Wireless and RF

Reply
New Contributor
Posts: 4
Registered: ‎12-07-2009

Laptops not connecting to the strongest/closest AP.

HI, I'm having an odd problem. I have several dozen Dell Latitude D620 with Intel 3945ABG wireless cards. The problem I'm having is that they are not connecting to their closest or strongest Access Point. Instead, they seem to connect randomly to other APs they can detect, even though the connection is slow/weak. I've updated to the latest available driver, and configured the cards to roam as aggressively as they can, to no avail. Can anyone give me some advice on what to do next; is there anything I can configure in the controller to encourage these machines to connect to the APs that are close by, or is it something that I will need to address on the laptops themselves? FWIW, my controller is running 3.4.0.5.

Thanks in advance,

Andrew
New Contributor
Posts: 3
Registered: ‎01-26-2010

Possible Intel Driver Issue

Andrew,
I know exactly what you are talking about. Let me see, you have Dell 620s with Intel 3945ABG cards and you are most likely running a 12.x series or the 13.0.0.x series driver? Intel had a problem with AP selection in these driver sets causing the same problem for me, however we are mainly a Dell 620 shop so it was pretty painful. I have been working directly with our Intel POC and he provided a 12.4.4.501 engineering build driver set which worked well but it will not be released publicly. The 13.1.1 driver had the fix rolled into it, but is not out yet for the 3945, due to issues they have been battling with power settings. I can however provide you with that driver, the work around on that issue is manually configuring power management settings to (CAM) Constantly Awake Mode to prevent the card being disabled randomly in Device Manager. Sent you a private message to hammer out driver delivery.
Contributor I
Posts: 31
Registered: ‎09-15-2009

Driver

ereece01,
I am having the same issue.
Could I possibly access the driver you spoke of as well?
Occasional Contributor II
Posts: 18
Registered: ‎11-23-2009

Re: Laptops not connecting to the strongest/closest AP.

I've seen the "sticky client" problem as well. Fortunately, we only have a handful.
New Contributor
Posts: 3
Registered: ‎01-26-2010

Intel 13.1.1

This is the 13.1.1 driver for the Intel 3945ABG card. I didn't know what OS or bit version you were running so I went with the safe bet of WinXP 32 bit. I can't post the whole thing to support all Win OS's it is massive. Let me know if this version works for you.

The way Dell works with Intel and power management it is a must that you set the Power Management accordingly, see below:

The Power Management setting is determined by the INF file (NETw5x32.inf) and the laptop manufacturer. Some manufacturers choose “default,” while others choose something else. Dell is one company that has power management enabled regardless of the power source. Here is a section from the INF file.


HKR,,BandType,0x10003,0x2
HKR,,DesiredSsid,0x00000002,"101"
HKR,,LedMode,0x10001,0x2
HKR,,PowerIndex,0x00000002,"3"
HKR,,RecommendedChannel24,2,"1"
HKR,,FeatureSet,0x10001,0x3390F001

The PowerIndex value determines the laptop behavior and the appearance of the PowerManagement setting in the NCPA. PowerIndex has a range of 0 to 6. 0 = no power savings. 5 = maximum power savings. A value of 6 translates to “default” behavior. Default behavior is to disable power savings mode when on AC power (i.e. level 0) and enable power savings when on battery (i.e. level 3. I’m not sure why level 5 was not chosen). If PowerIndex is hard coded to 3 (like it is in the data above), power savings mode is enabled regardless of the power source. Power savings mode enabled (i.e. PowerIndex = 3) is causing problems for the 3945. The workaround is to set the PowerIndex to 0 and disable power savings at all times. Setting the PowerIndex to 6 or “default” will disable power savings mode when using AC power, but there will be problems when the user is on battery.
Contributor I
Posts: 31
Registered: ‎09-15-2009

Re: Laptops not connecting to the strongest/closest AP.

Thanks!
Hopefully this helps.
Occasional Contributor II
Posts: 17
Registered: ‎05-08-2007

Re: Laptops not connecting to the strongest/closest AP.

FYI,
Which Intel utility are you using? Is it the one from Intel website or Dell's website. In my conversations with Intel, they will not support Dell's Intel utility since they do things in the background to support Dell's laptop hardware. I have been using the supplicant from Intel for the past three years with no issues (D620), but since our desktop support that creates laptop images decided to use Dell's Intel supplicant, he has been having issues. His requirement was to access the laptop and push Microsoft patches while the laptop is logged off. His solution was to create another userid in the profile to login to the domain, not the userid that is logging in, which bypass security. A battle that I'm fighting at the moment.
New Contributor
Posts: 3
Registered: ‎08-27-2010

Re: Laptops not connecting to the strongest/closest AP.

I was seeing this problem on both 802.11a and 802.11g on my D620. Thanks for the v13 driver, it fixed the problem on both bands.
Frequent Contributor I
Posts: 108
Registered: ‎09-26-2008

Re: Laptops not connecting to the strongest/closest AP.

I'm facing this "sticky client" issues on Compaq CQ42 series laptops as well.
Will updating the driver work?

Anyone faced this issues as well?

Thanks.

Michael
Occasional Contributor I
Posts: 8
Registered: ‎10-29-2010

Re: Laptops not connecting to the strongest/closest AP.

I have seen similar problem with Casio DT-X7m-30R handheld bar-code scanners. They are switching from nearest to lower signal APs, roam unexpectedly, but all this becomes much better when "power save" in WLAN configuration is enabled.
Which looks complitely opposite to what we have with Intel card...
Any ideas about this?
Thanks in advance,
Eizens
Search Airheads
Showing results for 
Search instead for 
Did you mean: