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© Copyright 2015 Hewlett Packard Enterprise Development LP.

Open Source Code

This product includes code licensed under the GNU General Public License, the GNU Lesser General Public
License, and/or certain other open source licenses. A complete machine-readable copy of the source code
corresponding to such code is available upon request. This offer is valid to anyone in receipt of this information
and shall expire three years following the date of the final distribution of this product version by Hewlett-
Packard Company. To obtain such source code, send a check or money order in the amount of US $10.00 to:

Hewlett-Packard Company
Attn: General Counsel
3000 Hanover Street
Palo Alto, CA 94304
USA

Please specify the product and version for which you are requesting source code. You may also request a copy
of this source code free of charge at dl-gplquery@arubanetworks.com.

http://dl-gplquery@arubanetworks.com/
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Chapter 1
About ClearPass 6.5.3

ClearPass 6.5.3 is a patch release that introduces new features and provides fixes to previously outstanding
issues. These release notes contain the following chapters:

l "System Requirements for ClearPass 6.5" on page 9—Provides important system requirements information
for this release.

l "Upgrade and Update Information" on page 17—Provides considerations and instructions for version
upgrades and patch updates.

l "What’s New in This Release" on page 23—Describes new features and issues introduced in this 6.5.3
release as well as issues fixed in this 6.5.3 release.

l "Enhancements in Previous 6.5.x Releases" on page 31—Describes new features introduced in earlier 6.5
releases.

l "Issues Fixed in Previous 6.5.x Releases" on page 53—Lists issues fixed in earlier 6.5 releases.

l "Known Issues Identified in Previous Releases" on page 71—Lists currently existing issues identified in
previous releases.

Related Documents
The following documents are part of the complete documentation set for the ClearPass 6.5.3 platform:

l ClearPass Policy Manager 6.5 User Guide

l ClearPass Guest 6.5 User Guide

l ClearPass Insight 6.5 User Guide

l ClearPass Policy Manager 6.5 Getting Started Guide

l ClearPass Policy Manager Configuration API Guide

l ClearPass Policy Model: An Introduction

l Tech Note: Installing or Upgrading ClearPass 6.5 on a Virtual Machine

l Tech Note: Upgrading to ClearPass 6.5

l Tech Note: Cluster Upgrade Tool, ClearPass 6.5

Use of Cookies
Cookies are small text files that are placed on a user’s computer by Web sites the user visits. They are widely
used in order to make Web sites work, or work more efficiently, as well as to provide information to the owners
of a site. Session cookies are temporary cookies that last only for the duration of one user session.

When a user registers or logs in via an Aruba captive portal, Aruba uses session cookies solely to remember
between clicks who a guest or operator is. Aruba uses this information in a way that does not identify any user-
specific information, and does not make any attempt to find out the identities of those using its ClearPass
products. Aruba does not associate any data gathered by the cookie with any personally identifiable
information (PII) from any source. Aruba uses session cookies only during the user’s active session and does
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not store any permanent cookies on a user’s computer. Session cookies are deleted when the user closes
his/her Web browser.

Contacting Support

Main Site arubanetworks.com

Support Site support.arubanetworks.com

Airheads Social Forums and
Knowledge Base

community.arubanetworks.com

North American Telephone 1-800-943-4526 (Toll Free)
1-408-754-1200

International Telephones arubanetworks.com/support-services/support-program/contact-support/

Software Licensing Site licensing.arubanetworks.com

End of Support information arubanetworks.com/support-services/end-of-life-products/end-of-life-
policy/

Security Incident
Response Team (SIRT)

arubanetworks.com/support-services/security-bulletins/

Support Email Addresses

Americas, APAC, and EMEA support@arubanetworks.com

Security Incident
Response Team (SIRT)

sirt@arubanetworks.com

http://www.arubanetworks.com/
https://support.arubanetworks.com/
http://community.arubanetworks.com/
http://www.arubanetworks.com/support-services/support-program/contact-support
https://licensing.arubanetworks.com/login.php
http://www.arubanetworks.com/support-services/end-of-life-products/end-of-life-policy/
http://www.arubanetworks.com/support-services/end-of-life-products/end-of-life-policy/
http://www.arubanetworks.com/support-services/security-bulletins/
mailto:support@arubanetworks.com
mailto:sirt@arubanetworks.com
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Chapter 2
System Requirements for ClearPass 6.5

This chapter provides important system requirements information specific to this release. It should be read
carefully before upgrading to ClearPass 6.5.

ClearPass Guest and ClearPass Onboard are part of the ClearPass Policy Manager platform. ClearPass comes
pre-installed when you purchase an appliance. ClearPass can also be installed on a virtual appliance.

This chapter provides the following information:

l "End of Support" on page 9

l "Virtual Appliance Requirements" on page 10, including:

n "Supported Hypervisors" on page 10

n "ESX/ESXi Requirements " on page 10

n "Hyper-V Requirements " on page 11

l "Supported Browsers" on page 12

l "ClearPass OnGuard Unified Agent Requirements" on page 12, including:

n "Supported Antivirus Versions, OnGuard" on page 12

n "ClearPass OnGuard Dissolvable Agent Requirements" on page 13

l "ClearPass Onboard Requirements" on page 16

The IP address to access the licensing server clearpass.arubanetworks.com changed from 199.127.104.89 to
104.36.248.89 on September 27th, 2014. If you have any firewall protections allowing access, please be sure to
update the IP address information accordingly.

End of Support
Please be aware that the following vendors have officially stopped supporting their respective operating
systems on the stated dates.

Aruba Networks will attempt to preserve compatibility with these legacy operating systems; however, recent
versions of software agents (such as the ClearPass OnGuard Unified Agent) might not be able to provide the
same level of functionality that they provide on newer operating systems.

We will not provide any further bug fixes or feature enhancements related to supporting these operating
systems. Our TAC organization will also not be able to service customer support requests related to clients
running these operating systems. Customers should consider these operating systems as unsupported with
ClearPass:

l Microsoft Corporation:

n Windows Server 2003 — July 14, 2015

n Windows XP — April 8, 2014

l Apple, Inc:

n Mac OS X 10.6 (Snow Leopard) — February 26, 2014
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Virtual Appliance Requirements
Please carefully review all VA requirements, including functional IOP ratings, and verify that your system meets
these requirements. These recommendations supersede earlier requirements that were published for
ClearPass Policy Manager 6.x installations.

Virtual appliance recommendations have been adjusted to align with the shipping ClearPass hardware
appliance specifications. If you do not have the VA resources to support a full workload, then you should
consider ordering the ClearPass Policy Manager hardware appliance.

For VMware ESX/ESXi system requirements, see "ESX/ESXi Requirements " on page 10. For Microsoft Hyper-V™
system requirements, see "Hyper-V Requirements " on page 11. For complete information on installing and
configuring either ESX or Hyper-V, see the Tech Note: Installing or Upgrading ClearPass 6.5 on a Virtual Machine.

Supported Hypervisors
The following hypervisors are supported. Hypervisors that run on a client computer such as VMware Player are
not supported.

l VMware ESX 4.0 (Recommended minimum version of software for CP-VA-500 and CP-VA-5K. It does not
support greater than 8 virtual CPUs required for the CP-VA-25K.)

l VMware ESXi 5.0

l VMware ESXi 5.1

l VMware ESXi 5.5

l VMware ESXi 6.0

l Microsoft Hyper-V Server 2012 R2

l Hyper-V on Microsoft Windows Server 2012 R2

ESX/ESXi Requirements

CP-VA-500 (500 Virtual Appliance OVF)
l 2 Virtual CPUs

l 500 GB disk space

l 4 GB RAM

l 2 Gigabit virtual switched ports

l Functional IOP rating for a 40-60 read/write profile for 4K random read/write = 75

CP-VA-5K (5K Virtual Appliance OVF)
l 8 Virtual CPUs

l Disk space:

n 500 GB disk space required for existing deployments (upgrading from 6.2.6, 6.3.6, or 6.4.x)

n 1000 GB disk space recommended for new deployments

l 8 GB RAM

l 2 Gigabit virtual switched ports

l Functional IOP rating for a 40-60 read/write profile for 4K random read/write = 105



CP-VA-25K (25K Virtual Appliance OVF)
l 24 Virtual CPUs

l Disk space:

n 1000 GB disk space required for existing deployments (upgrading from 6.2.6, 6.3.6, or 6.4.x)

n 1800 GB disk space recommended for new deployments

l 64 GB RAM

l 2 Gigabit virtual switched ports

l Functional IOP rating for a 40-60 read/write profile for 4K random read/write = 350

CP-SW-EVAL (Evaluation OVF)
l 2 Virtual CPUs

l 80 GB disk space

l 4 GB RAM

l 2 Gigabit virtual switched ports

An evaluation version can be upgraded to a later evaluation version in a manner similar to a production
upgrade.

Hyper-V Requirements

CP-VA-500 (500 Virtual Appliance VHDX)
l 2 Virtual CPUs

l 500 GB disk space required

l 4 GB RAM

l 2 Gigabit virtual switched ports

l Functional IOP rating for a 40-60 read/write profile for 4K random read/write = 75

CP-VA-5K (5K Virtual Appliance VHDX)
l 8 Virtual CPUs

l 1000 GB disk space required

l 8 GB RAM

l 2 Gigabit virtual switched ports

l Functional IOP rating for a 40-60 read/write profile for 4K random read/write = 105

CP-VA-25K (25K Virtual Appliance VHDX)
l 24 Virtual CPUs

l 1800 GB disk space required

l 64 GB RAM

l 2 Gigabit virtual switched ports

l Functional IOP rating for a 40-60 read/write profile for 4K random read/write = 350

ClearPass 6.5.3 | Release Notes System Requirements for ClearPass 6.5 | 11
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CP-SW-EVAL (Evaluation VHDX)
l 2 Virtual CPUs

l 80 GB disk space required

l 4 GB RAM

l 2 Gigabit virtual switched ports

An evaluation version can be upgraded to a later evaluation version in a manner similar to a production
upgrade.

Supported Browsers
For the best user experience, we recommend you update your browser to the latest version available.
Supported browsers for ClearPass are:

l Mozilla Firefox on Windows Vista, Windows 7, Windows 8.x, Windows 10, and Mac OS X

l Google Chrome for Mac OS X and Windows

l Apple Safari 3.x and later on Mac OS X

l Mobile Safari 5.x on iOS

l Microsoft Internet Explorer 10 and later on Windows 7 and Windows 8.x

l Microsoft Edge on Windows 10

ClearPass OnGuard Unified Agent Requirements
Be sure that your client system meets the following requirements before installing the ClearPass OnGuard
Unified Agent:

l 1 GB RAM recommended, 512 MB RAM minimum

l 200 MB Disk Space

l Mac OS X: Version 10.6 or higher (64-bit only)

l Windows XP: Service Pack 3 or higher

l Windows 2003: Service Pack 2 or higher

l Ubuntu: 12.04 LTS and 14.04 LTS

Windows Vista, Windows 7, Windows 8.x Pro, Windows 10, and Windows Server 2008 are all supported with no
service pack requirements. OnGuard does not support Windows 8.x RT or Windows 8.x Phone.

Installing the Unified Agent will remove an existing VIA installation. To continue using VPN functionality, log in to
CPPM as the administrator, go to Administration > Agents and Software Updates > OnGuard Settings, and
select Install and enable Aruba VPN component from the Installer Mode drop-down list.

Supported Antivirus Versions, OnGuard
For OnGuard to work properly, please whitelist the following executable files and installation folders in your antivirus
products:
ClearPassOnGuard.exe
ClearPassAgentController.exe



C:\Program Files (x86)\Aruba Networks\ClearPassOnGuard\
C:\Program Files\Aruba Networks\ClearPassOnGuard\

In the lab, we use the following antivirus software for our validations. Due to the large number of products
available, this list may change at any time:

l Avast

l AVG

l COMODO

l Kaspersky: IS-11 and above

l MacAfee

l Microsoft Forefront Endpoint Protection-2008

l Microsoft Security Essentials

l Microsoft Windows Firewall

l Sophos: 9 and above

l Trend Micro

l Windows Defender Firewall

Some third-party anti-malware products are not supported by ClearPass OnGuard. For a complete list of supported
third-party products, in CPPM go to Administration > Agents and Software Updates > OnGuard Settings, click
the Help link, and then click the OnGuard Agent Support Charts link.

ClearPass OnGuard Dissolvable Agent Requirements
This section provides version information for both the Native Dissolvable Agent and the Java-based Dissolvable
Agent. For more information on the Dissolvable Agent, refer to the ClearPass Policy Manager online help.

ClearPass OnGuard Native Agent Version Information

In current laboratory tests for ClearPass 6.5.3, the browser versions shown in Native Agent Latest Supported
Browser Versions for This Release were verified for the ClearPass OnGuard Native Dissolvable Agents. There
are considerations to be aware of with some browser versions. For more information, click the ID number next
to the browser’s name.

Operating System Browser

Windows 10 64-bit Chrome 44.x (#24518, #24986)

Firefox 40.x

Internet Explorer 11.x

Edge 20.x

Windows 10 32-bit Chrome 44.x (#24518, #24986)

Firefox 39.x

Table 1: Native Agent Latest Supported Browser Versions for This Release

ClearPass 6.5.3 | Release Notes System Requirements for ClearPass 6.5 | 13
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Operating System Browser

Internet Explorer 8.x (#25827)

Edge 20.x

Windows 8.1 64-bit Chrome 44.x (#24986)

Firefox 39.x

Internet Explorer 11.x

Windows 8 64-bit Chrome 44.x (#24986)

Firefox 40.x

Internet Explorer 10.x

Windows 8 32-bit Chrome 44.x (#24986)

Firefox 40.x

Internet Explorer 10.x

Windows 7 64-bit Chrome 44.x (#24518, #24986)

Firefox 39.x

Internet Explorer 8.x (#25827)

Windows 7 32-bit Chrome 44.x (#24518, #24986)

Firefox 40.x

Internet Explorer 11.x

Windows 2008 64-bit Chrome 44.x (#24986)

Firefox 40.x

Internet Explorer 9.x (#24766)

Windows Vista Chrome 44.x (#24986)

Firefox 39.x (#29186)

Internet Explorer 7.x (#29186)

Mac OS X 10.10 Safari 9.x

Firefox 40.x

Chrome 44.x (#24518, #24986)

Table 1: Native Agent Latest Supported Browser Versions for This Release(Continued)



Operating System Browser

Mac OS X 10.9 Safari 7.x

Firefox 40.x (#28398)

Chrome 44.x (#24518, #24986)

Mac OS X 10.8 Safari 6.x (#28398)

Firefox 40.x

Chrome 44.x (#24986, #29143)

Mac OS X 10.7.5 Safari 6.x

Firefox 40.x

Chrome 44.x (#24986)

Ubuntu 12.04 64-bit LTS Firefox 34.x

Ubuntu 12.04 32-bit LTS Firefox 38.x

Ubuntu 14.04 64-bit LTS Firefox 36.x

Ubuntu 14.04 32-bit LTS Firefox 38.x (#28398)

Table 1: Native Agent Latest Supported Browser Versions for This Release(Continued)

ClearPass OnGuard Java-Based Agent Version Information
In current laboratory tests for ClearPass 6.5.3, the browser and Java versions shown in Supported Browser and
Java Versions were verified for the ClearPass OnGuard Java-based dissolvable agents. There are considerations
to be aware of with some browser versions. For information, click the ID number next to the browser’s name.

The latest Java version is required in order to perform client health checks.

There is an issue with the Chrome browser in this release. Please see #28737 in "New Known Issues in the 6.5.3
Release" on page 28 for a description and workaround.

Operating System Browser Java Version

Windows 10 64-bit Firefox 40.x (#7165) JRE 1.8 Update 51

Internet Explorer 11.x (#7165) JRE 1.8 Update 51

Windows 10 32-bit Firefox 40.x (#7165) JRE 1.8 Update 51

Internet Explorer 11.x (#7165) JRE 1.8 Update 51

Windows 8.1 64-bit Firefox 40.x JRE 1.8 Update 51

Internet Explorer 11.x JRE 1.8 Update 51

Windows 8 64-bit Firefox 37.x (#7165) JRE 1.8 Update 51

Table 2: Supported Browser and Java Versions

ClearPass 6.5.3 | Release Notes System Requirements for ClearPass 6.5 | 15



16 | System Requirements for ClearPass 6.5 ClearPass 6.5.3 | Release Notes

Operating System Browser Java Version

Internet Explorer 10.x (#7165) JRE 1.8 Update 51

Windows 8 32-bit Firefox 40.x JRE 1.8 Update 51

Internet Explorer 10.x JRE 1.8 Update 51

Windows 7 64-bit Firefox 40.x (#7165) JRE 1.8 Update 51

Internet Explorer 11.x JRE 1.8 Update 51

Windows 7 32-bit Firefox 40.x JRE 1.8 Update 51

Internet Explorer 11.x JRE 1.8 Update 51

Windows 2008 64-bit Firefox 36.x (#7165) JRE 1.8 Update 51

Internet Explorer 9.x (#7165) JRE 1.8 Update 51

Windows Vista Firefox 36.x (#7165) JRE 1.8 Update 51

Internet Explorer 9.x (#7165) JRE 1.8 Update 51

Mac OS X 10.10 Safari 9.x (#20191) JRE 1.8 Update 51

Firefox 40.x (#27871) JRE 1.8 Update 51

Mac OS X 10.9 Safari 7.x (#20191) JRE 1.8 Update 51

Firefox 40.x JRE 1.8 Update 51

Mac OS X 10.8 Safari 6.x JRE 1.8 Update 51

Firefox 40.x (#20191) JRE 1.8 Update 51

Mac OS X 10.7.5 Safari 6.x (#20191) JRE 1.8 Update 51

Firefox 40.x (#23340) JRE 1.8 Update 51

Table 2: Supported Browser and Java Versions(Continued)

ClearPass Onboard Requirements
Onboard does not support Windows 8.x RT or Windows 8.x Phone.
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Chapter 3
Upgrade and Update Information

This chapter provides considerations and instructions for upgrading or updating your ClearPass application:.

l The term “upgrade” refers to moving from one major release version to another—for example, from 6.4.x
to 6.5. For information on upgrading from a version prior to 6.5, see "Upgrading to ClearPass 6.5 from
6.2.6, 6.3.6, or 6.4.x" on page 17.

l The term “update” refers to applying a patch release within the same major version—for example, from
6.4.3 to 6.4.4, or from 6.5.2 to 6.5.3. For information on updating from an earlier 6.5.x release to 6.5.3,
see "Updating Within the Same Major Version" on page 20.

Upgrading to ClearPass 6.5 from 6.2.6, 6.3.6, or 6.4.x
An upgrade is the process of moving from one major release version to another—for example, from 6.4.x to
6.5. This section describes accessing upgrade images, considerations to be aware of, and instructions for
restoring the log database after the upgrade (optional).

You can upgrade to ClearPass 6.5 from ClearPass 6.2.6, 6.3.6, or 6.4.x. Before you proceed with the upgrade,
we recommend that you apply the latest available patch updates to your current release. For information on
the patch update procedure, see "Updating Within the Same Major Version" on page 20.

Upgrading to 6.5 from prior releases is not applicable to Hyper-V, since support for Hyper-V was introduced in 6.5.

l For 6.4.x upgrades through the Software Updates portal in the Policy Manager user interface, or through
the Web service, upgrade is supported for any 6.4.x version.

l For 6.4.x upgrades through the CLI, there are two options:

n If you are on 6.4.2 or later, you can upgrade directly to 6.5 through the CLI.

n If you are on 6.4.0 or 6.4.1, you must first download and install the 6.4.0 CLI updates patch. At
support.arubanetworks.com, go to Download Software > ClearPass > Policy Manager > Current
Release and select CPPM-x86_64-20140919-cli-der-support-patch. After you have installed the
patch, update to 6.4.2 or higher. You can then upgrade to 6.5 through the CLI.

l For 6.3.x, upgrade is only supported from the latest cumulative patch. You must update to 6.3.6 before
upgrading to 6.5.

l For 6.2.x, upgrade is only supported from the latest cumulative patch. You must update to 6.2.6 before
upgrading to 6.5.

l For 6.1.x, direct upgrades are not supported. Customers on 6.1.x must intermediately upgrade to 6.2.6,
6.3.6, or 6.4.x first before upgrading to 6.5.

l For appliance upgrades from 5.2.0, you must upgrade to 6.2.6, 6.3.6, or 6.4.x before upgrading to 6.5.

l Upgrade images are available within ClearPass Policy Manager from the Software Updates portal at
Administration > Agents and Software Updates > Software Updates.

l Upgrade images are also available for download on the Support site under ClearPass > Policy Manager >
Archives.
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If you are upgrading from 6.4.0, the Software Updates portal incorrectly shows a warning during upgrade asking for
two hard drives. This message can be ignored. (#27736)

MySQL is supported in CPPM 6.0.x and greater. Aruba does not ship drivers for MySQL by default. Customers who
require MySQL can contact Aruba support to get the required patch. Users should be aware that this patch does not
persist across upgrades, so customers using MySQL should contact support before they upgrade.

Before You Upgrade
Before you begin the upgrade process, please review the following important items:

l Plan downtime accordingly. Upgrades can take longer (several hours) depending on the size of your
configuration database. A large number of audit records (hundreds of thousands) due to MDM integration
can significantly increase upgrade times. Refer to the sample times shown in Sample Times Required for
Upgrade in "Sample Times Required for Upgrade" on page 18.

l Review the ESX/ESXi disk requirements. These are described in "Virtual Appliance Requirements" on page 10
of the “System Requirements for ClearPass 6.5” chapter.

l Any log settings that were modified prior to the upgrade are not retained, and are reset to the default. The
administrator should configure any custom log settings again after the upgrade.

Log Database and Access Tracker records are not restored as part of the upgrade. If required, you can manually
restore them after the upgrade. For more information, please review "After You Upgrade" on page 19.

l Before initiating the Upgrade process in CPPM, we recommend you set theAuto Backup Configuration
Options to Off (if it was set to other values such as Config or Config|Session). The reason for disabling this
setting is to avoid interference between the Auto Backup process and the Migration process.

To change this setting:

Navigate to Administration > Cluster Wide Parameters > General > Auto Backup Configuration
Options = Off.

l If you have a custom authentication source configured to use the session log database, additional steps are
required after upgrade. You have such an authentication source configured if you have a source of type
Generic SQL DB in ClearPass Policy Manager > Configuration > Sources with server name localhost
or 127.0.0.1 and with the database name tipsLogDb. In such cases, manually restoring the session log
database is required after the upgrade completes (see "After You Upgrade" on page 19). Please contact
Customer Support for configuration recommendations to move away from using the session log database
as an authentication source.

l VM only: If you have two disks already loaded with previous ClearPass versions—for example, 6.2 on SCSI
0:1 and 6.3 on SCSI 0:2—then drop the inactive disk before upgrading. You must then add a newer disk
based on the 6.5 disk requirements. Earlier releases used separate disks to store the current and previous
ClearPass release; newer releases use just a single drive to store both installations. For current
requirements, see "Virtual Appliance Requirements" on page 10.

Never remove SCSI 0:0

Sample Times Required for Upgrade

To help you estimate how much time the upgrade might take, Table 1 shows representative numbers for
upgrade times under test conditions. Remember that the figures here are only examples. The actual time



required for your upgrade depends on several factors:

l Your hardware or virtual appliance model. In the case of VM installations, upgrade times vary significantly
based on the IOPS performance of your VM infrastructure.

l The size of the configuration database to be migrated.

l For Insight nodes, the size of the Insight database.

l For subscriber nodes, the bandwidth and latency of the network link between the subscriber and the
publisher.

Hardware
Model

Config
DB Size

Insight
DB Size

Publisher
Upgrade
Time

Subscriber
Upgrade Time

Insight Restoration Time in
Publisher OR Subscriber

CP-500 100 MB 5 GB 50 minutes 50 minutes 20 minutes

200 MB 5 GB 60 minutes 60 minutes 20 minutes

CP-5K 100 MB 5 GB 50 minutes 50 minutes 15 minutes

200 MB 5 GB 60 minutes 60 minutes 15 minutes

CP-25K 200 MB 5 GB 30 minutes 30 minutes 15 minutes

500 MB 10 GB 40 minutes 40 minutes 20 minutes

Table 3: Sample Times Required for Upgrade

After You Upgrade
To reduce downtime, the default upgrade behavior will now back up Log Database and Access Tracker records
but will not restore them as part of the upgrade. If required, you can manually restore them after the upgrade
through either the application or the CLI. The session log database contains:

l Access Tracker and Accounting records

l Event Viewer

l ClearPass Guest Application Log

The Insight database is not part of the session log database, and will be migrated as part of the upgrade.

Restoring the Log DB Through the User Interface

To restore the Log DB after upgrade through the UI, restore from the auto-generated upgrade-backup.tar.gz
file (available at Administration > Server Manager > Local Shared Folders).

The restoration process could take several hours, depending on the size of your session log database. All
services are accessible and will handle requests during the restoration, but there will be a performance impact
while the restoration is in progress. We recommend that you perform this operation during a planned change
window.

The restoration process will continue in the background even if the UI is closed or the session times out. A
“Restore complete” event is logged in the Event Viewer when the restoration is complete.

This process needs to be repeated on each server in the cluster that should retain the session log database.
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1. Go to Administration > Server Manager > Server Configuration and click Restore for the server.

2. In theRestore Policy Manager Database window, select the File is on server option, and select the
upgrade-backup.tar.gz file.

3. Also select the following options:

l Restore CPPM session log data (if it exists on the backup)

l Ignore version mismatch and attempt data migration

l Do not back up the existing databases before this operation

4. Uncheck theRestore CPPM configuration data option.

5. Click Start.

Restoring the Log DB Through the CLI

To restore the Log Database after the upgrade process is complete, use the restore command. Go to
Administration > Server Manager > Local Shared Folders and download theupgrade-backup.tar.gz
file. Host the file at an scp or http location accessible from the ClearPass server and execute the command
restore <location/upgrade-backup.tar.gz> -l –i –b.

The restoration process could take several hours depending on the size of your session log database. All
services are accessible and handling requests during the restoration, but there will be a performance impact
while the restoration is in progress. We recommend that you perform this operation during a planned change
window.

The restoration process will abort if the CLI session is closed or times out. We recommend that you initiate the
restoration from the User Interface, especially if you have a large number of Access Tracker and Accounting records.

This process needs to be repeated on each server in the cluster that should retain the session log database.

The restore command syntax is as follows:
Usage:

restore user@hostname:/<backup-filename> [-l] [-i] [-b] [-c] [-r] [-n|-N] [-s]

restore http://hostname/<backup-filename>[-l] [-i] [-b] [-c] [-e] [-n|-N] [-s]

restore <backup-filename> [-l] [-i] [-b] [-c] [-r] [-n|-N] [-s]

-b -- do not backup current config before restore

-c -- restore CPPM configuration data

-l -- restore CPPM session log data as well if it exists in the backup

-r -- restore Insight data as well if it exists in the backup

-i -- ignore version mismatch and attempt data migration

-n -- retain local node config like certificates etc. after restore (default)

-N -- do not retain local node config after restore

-s -- restore cluster server/node entries from backup.

The node entries will be in disabled state on restore

Updating Within the Same Major Version
An update is the process of applying a minor patch release within the same major version—for example, from
6.5.2 to 6.5.3. Updates are available from the Software Updates page in ClearPass Policy Manager. This section
describes how to install a patch update either through the user interface or as an offline update.

When you install the patch on a cluster, update the publisher first before applying the update on subscriber
nodes.



During a patch update, the log database is retained. No extra steps are needed to retain the session log history
during a patch update.

Installation Instructions Through the User Interface
If access is allowed to the Web service, ClearPass servers will show the latest patch update on the Software
Updates portal:

1. In ClearPass Policy Manager, go to Administration > Agents and Software Updates > Software
Updates.

2. In the Firmware and Patch Updates area, find the latest patch update and click theDownload button in
its row.

3. After the patch is downloaded, click Install.

4. When the installation is complete, if the status on the Software Updates page is shown as Needs Restart ,
click theNeeds Restart button to restart ClearPass. The status for the patch is then shown as Installed.

Installation Instructions for an Offline Update
If you do not have access to the Web service and you need to do an offline update, you may download the
signed patch from the Support site, upload it to the CPPM server, and then install it through the user interface:

1. Download the appropriate patch update from the Support site (http://support.arubanetworks.com).

2. Open ClearPass Policy Manager and go to Administration > Agents and Software Updates > Software
Updates.

3. At the bottom of the Firmware and Patch Updates area, click Import Updates and browse to the
downloaded patch file.

4. Click Install. When the installation is complete, if the status on the Software Updates page is shown as
Needs Restart , click theNeeds Restart button to restart ClearPass. The status for the patch is then shown
as Installed.
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Chapter 4
What’s New in This Release

This chapter provides a summary of the new features and changes in the ClearPass 6.5.3 release.

This chapter contains the following sections:

l "Release Overview" on page 23

l "New Features and Enhancements in the 6.5.3 Release" on page 23

l "Issues Resolved in the 6.5.3 Release" on page 24

l "New Known Issues in the 6.5.3 Release" on page 28

Release Overview
ClearPass 6.5.3 is a patch release that introduces new features and provides fixes for known issues. The 6.5.3
cumulative patch update is available in ClearPass Policy Manager underAdministration > Agents and
Software Updates > Software Updates.

New Features and Enhancements in the 6.5.3 Release
The following new features were introduced in the ClearPass 6.5.3 release.

Endpoint Context Servers
l Additional attributes are now available for endpoint context servers. The machine-os and host-type

attributes can be used to indicate the device type and device family to use in the Check Point Login payload.
These attributes are not added by default, and must be configured by the administrator. To configure the
attributes, go to Administration > Dictionaries > Context Server Actions and click the row for the
Check Point Login action. In the Endpoint Context Server Details form, click theContent tab. Add the
machine-os and host-type attributes and their values. After these attributes are configured here, they
will be available for endpoint configuration. (#29363)

Guest
l A new API is enabled to support guest sponsor actions (/api/guest/:guest_id/sponsor). (#29147)

l In API Services, results returned by the Guest and Device queries are now sorted with the newest items at
the top of the list by default. (#29461)

OnGuard
l Support was added for the following products: (#29371, #30375)

n BitLocker Drive Encryption 10.x (Windows)

n Dr.Web for Mac 10.x (MacOSX)

n F-Secure Anti-Virus for Mac 1.x (MacOSX)

n Kaspersky Anti-Virus 15.x (MacOSX)

n Kaspersky Endpoint Security Encryption 10.x (Windows)

n Malwarebytes Anti-Malware 2.x (Windows)
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n Microsoft Windows Update Agent 10.x (Windows)

n Norton Internet Security 22.x (Windows)

n VMware Workstation 11.x (Windows)

Support was enhanced for the following products:

n AVG AntiVirus Free Edition 2015.x (Windows)

n Avira Free Antivirus 15.x (Windows)

n ESET Endpoint Antivirus 6.x (Windows)

n ESET NOD32 Antivirus 4.x (MacOSX)

n McAfee VirusScan Enterprise 8.8.x (Windows)

n System Center Configuration Manager 5.x (Windows)

n System Center Endpoint Protection 4.x (Windows)

l During automatic upgrade, the ClearPass OnGuard Unified Agent now uses HTTPS instead of HTTP to
download the new OnGuard version. (#29156)

l The ClearPass OnGuard Unified Agent now supports Windows 10. (#29159)

After the 6.5.3 release, an issue was identified with Windows 10 64-bit. Review the workaround instructions in
#30090 to obtain a hotfix patch to address it.

l A new option,Disconnect Network Connections, was added to theRemediation Action For Network
Connection Types Not Allowed drop-down list for Windows on theNetwork Connection Types form.
This remediation action applies only to wireless network interfaces. When this option is selected, OnGuard
will disconnect the wireless network interface. This provides an alternative to disabling the wireless interface
when a wired interface is connected. (#29536)

Issues Resolved in the 6.5.3 Release
The following issues have been fixed in the ClearPass 6.5.3 release.

This section includes the following:

l "Policy Manager" on page 25

l "Endpoint Context Servers" on page 26

l "Endpoint Context Servers" on page 26

l "Guest" on page 26

l "Insight" on page 26

l "Onboard " on page 27

l "OnGuard" on page 27



Policy Manager

Bug ID Description

#26475 The Computed Attributes list in the Access Tracker sometimes did not show MDM polled attributes.

#28813 When profiling was enabled and a subscriber was elected as the profile master, the subscriber made an
excessive number of DNS queries to the publisher.

#28979 When installing a 25K appliance, the VM disk space requirements now correctly display an alert based
upon 1800 GB instead of 2000 GB.

#29082 Active Policy Manager licenses were marked as expired if approximately 100 or more ClearPass API
requests were posted per second.

#29089 When endpoint details and attributes were fetched from Google Admin Console, Chromebook could not
be used in the role mapping policy. The Rules Editor displayed the message “The value entered is not
valid” if Google Chrome was selected as the value.

#29478 Corrected an issue that sometimes occurred in ClearPass when a proxy server was used to contact the
Webservices server to get the latest patches or fingerprint updates.
In scenarios where the username and password were not configured to access the proxy server,
ClearPass sent an empty authentication header, causing some proxy servers to return a “407
authentication required” error message. Now ClearPass will not send an empty authentication header
to the proxy server if it is not required.

#29548 The notifications displayed in Policy Manager for expired RADIUS or HTTPS server certificates were still
displayed even after the certificates were renewed.

#29607 On a cluster, the Event Viewer displayed a warning message that “The total number of authentication
requests is 31939 and the appliance capacity is 80”. The maximum appliance capacity values for both
hardware appliances and virtual machines are now updated to HCG mode values (tested for maximum
authentication request capacity).

#29641 The “cluster reset-database -f” command did not work and caused the login to fail with the
message “Error reading license information. Please retry.”

#29656
#29745

Attempting to send a Change of Authorization (CoA) for a user failed if the user was authenticated on
one node of a ClearPass cluster and the CoA was sent from a different node in the cluster. This had also
occurred if VIP was configured.

#29663 OpenSSL is now upgraded to version 1.0.1p. This includes fixes for CVE-2015-1793.

#29216
#29691

The Internet Explorer 11 browser (IE 11) would hang in ClearPass 6.5.1 Server Configuration pages,
and settings could not be changed or updated on any of the Administration > Server Manager
> Server Configuration pages.

#29818 ClearPass did not display attributes from the Accounting-Interim Request in the accounting record
details.

#29881 Apache httpd is now upgraded to version 2.4.16. This includes fixes for CVE-2015-0228, CVE-2015-0253,
CVE-2015-3183, and CVE-2015-3185.

#29920 ClearPass sent a logout message to the Palo Alto Networks server even if the user was still connected.

#29952 Changes that were made to the standard syslog format in 6.5.0 (inclusion of null values, order of key-
value pairs, timestampformat and source attribute) are now removed, and the behavior will be as it was
prior to the 6.5.0 release.

#30176 Corrected an issue where, in ClearPass 6.5.1 and 6.5.2, SNMP traps were not sent.

Table 4: Policy Manager Issues Fixed in 6.5.3
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Dissolvable Agent

Bug
ID Description

#29513 The native dissolvable agent did not work properly on Chrome 42.x or higher, and the guest page failed
to detect whether the ClearPass OnGuard Unified Agent was installed. The ClearPass OnGuard native
dissolvable agent (WebAgent) is now supported on Chrome Browser 42 and higher versions.

Table 5: Dissolvable Agent Issues Fixed in 6.5.3

Endpoint Context Servers

Bug ID Description

#29062 An incorrect endpoints count was shown for Google Admin Console.

#29079 The backslash character ( \ ) was not accepted in the Username field of the Endpoint Context Servers
configuration forms.

#29571 With JAMF MDM, ClearPass could not discover all the endpoints of devices with multiple MAC
addresses.

#29946
#29918

ClearPass showed the wrong serial numbers for endpoints pulled from JAMF.

Table 6: Endpoint Context Server Issues Fixed in 6.5.3

Guest

Bug ID Description

#29679
#29992

The PHP version is now updated to 5.5.28. This includes fixes for CVE-2015-3152.

#29837 Duplicate data sometimes caused a database query error when trying to view the list of devices on the
Guest > Manage Devices page or the list of guest accounts on the Guest > Manage Multiple
Accounts page.

#29900 If onboarding was configured to use sponsor confirmation, the sponsorship notifications sometimes
displayed a malformed username (the @ symbol was shown as %40).

#29951 The Guest > Manage Accounts page displayed a database query error.

#30013
#30017

Social logins using Facebook did not return the public profile if the app was created with the Facebook
API version 2.4.

Table 7: Guest Issues Fixed in 6.5.3

Insight

Bug ID Description

#29701 The Insight Dashboard did not load properly in ClearPass 6.5.2.

Table 8: Insight Issues Fixed in 6.5.3



Onboard

Bug ID Description

#29437 When onboarding Windows devices, server certificate validation was not disabled even if that was
specified in the configuration.

#29551 Corrected an issue where Onboard accepted Certificate Signing Requests (CSRs) with invalid
signatures.

#29784 Windows 10 devices were shown as Windows 8 devices in the Onboard device list.

Table 9: Onboard Issues Fixed in 6.5.3

OnGuard

Bug ID Description

#29092 The ClearPass OnGuard Unified Agent failed to enable Kaspersky Internet Security 15.x and antivirus
live updates. ClearPass OnGuard Unified Agent now supports updating virus definitions and enabling
firewall for Kaspersky Internet Security 2015.

#29101
#29655

The ClearPass OnGuard Unified Agent could not contact the server from the current zone.

#29155 OnGuard did not establish a control channel for a user if multiple instances of OnGuard were running.
The ClearPass OnGuard Unified Agent now supports the “switch user” use case on Windows and on
Mac OS X.

#29157 The ClearPass OnGuard Unified Agent caused high bandwidth usage when multiple users were logged
in to the same client using the “switch user” use case.

#29158
#29659

The ClearPass OnGuard Unified Agent would sometimes hang while performing health checks and had
to be manually restarted.

#29201 When a profile mapped to the IKEv2 policy used the SHA1-96 HASH algorithm in the controller’s
connection profile settings, VIA continually tried to connect and failed with the error message “ERR-
8949 FAILED TO ESTABLISH TUNNEL”. This issue was specific to controllers running ArubaOS 6.3.x or
earlier versions.

#29253 The ClearPass OnGuard Unified Agent for Mac OS X was not able to detect Microsoft System Center
2012 Endpoint protection for MAC.

#29487 The latest versions of some antivirus software products were not detected. Support is now added for
Dr. Web 10.0, F-Secure 1.0, and Kaspersky Anti-Virus 15.0 on Mac OS X.

#29501 The ClearPass OnGuard Unified Agent for Mac OS X did not detect ESET NOD32 Antivirus 4.x.

#29543 The VPN component of the ClearPass OnGuard Unified Agent is now updated to match the Aruba VIA
2.3 version. This includes Windows 10 support.

#29690 On Mac OS X, the Login and Retry buttons in OnGuard were sometimes disabled after the machine
woke up from sleep mode.

#29721 The ClearPass OnGuard Unified Agent now supports Aruba VIA functionality on Windows 10.

#30039 The ClearPass OnGuard Unified Agent for Windows could not read the DAT file time for AVG AntiVirus
Free Edition 2015.

Table 10: OnGuard Issues Fixed in 6.5.3
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New Known Issues in the 6.5.3 Release
The following known issues were identified in the ClearPass 6.5.3 release.

This section includes the following:

l "Policy Manager" on page 28

l "Dissolvable Agent" on page 28

l "OnGuard" on page 28

Policy Manager

Bug ID Description

#29995 Symptom: Installing the 6.5.3 update might fail if the boot partition does not meet the free space
requirements that are required by this update.
Workaround: If this occurs, please contact Support to resolve the issue and retry the update.

Table 11: Policy Manager Known Issues in 6.5.3

Dissolvable Agent

Bug ID Description

#30245 Symptom: The Java dissolvable agent is not supported in the Microsoft Edge browser.
Scenario: The Java dissolvable agent is not supported on the Edge browser on Windows 10, because the
Edge browser does not support plugins.
Workaround: Use Firefox or Internet Explorer 11 instead.

Table 12: Dissolvable Agent Known Issues in 6.5.3

OnGuard

Bug ID Description

#29598 Symptom: OnGuard does not stop or pause VM Player 7.x virtual machines.
Scenario: Users should be aware that the ClearPass OnGuard Unified Agent does not support auto-
remediation for Guest VMs running on VMware Player.

#30106 Symptom: On Mac OS X, the native and Java dissolvable agents do not get the RTP status of ESET
Cyber Security Antivirus 6.x.
Scenario: Users should be aware that the ClearPass OnGuard Native Dissolvable Agent for Mac OS X
does not support the RTP Status check for ESET CyberSecurity and ESET NOD32 Antivirus.

#30243
#30212

Symptom: The ClearPass OnGuard Unified Agent fails to load on Windows Server 2003, and does not
support VPN, Auto Upgrade, or SSO on Windows XP or Windows Server 2003.
Scenario: Users should be aware that Microsoft stopped supporting Windows Server 2003 on July 14,
2015, and stopped supporting Windows XP on April 8, 2014. Aruba will not provide further ClearPass
support for these operating systems.
Workaround: Windows 2003 server and XP machines are required to update the Microsoft root CA
certificate or missing trust certificates in order to load the OnGuard user interface properly.
The following Microsoft knowledgebase article provides information, as well as a link to the hotfix
download that needs to be installed in order to enable certificate support with SHA256 algorithm:
https://support.microsoft.com/en-us/kb/968730.

Table 13: OnGuard Known Issues in 6.5.3

https://support.microsoft.com/en-us/kb/968730


Bug ID Description

#30090 Symptom: On Windows systems, the ClearPass OnGuard Unified Agent exhibits the following two
symptoms:
l Health checks on Windows 10 64-bit systems might take longer than on Windows 10 32-bit or

earlier Windows releases.
l The “Windows Security Health Validator” plugin does not properly detect automatic and/or security

updates on Windows 10 64-bit systems.
Workaround: A hotfix patch to address this issue was originally released on September 11th. With the
release of OS X 10.11 (El Capitan), a new ClearPass 6.5.3 OnGuard for OS X 10.11 & Windows 10
64-bit Hotfix patch has replaced the previous Windows 10 64-bit only hotfix. This new hotfix is
available on the Support site and in the Software Updates portal for 6.5.3. This hotfix patch does not
require a reboot of the ClearPass appliance.

#30166 Symptom: The ClearPass OnGuard Unified Agent is unable to detect certain health classes when
running on Mac OS X 10.11 (El Capitan).
Workaround: Install the ClearPass 6.5.3 OnGuard for OS X 10.11 & Windows 10 64-bit Hotfix
patch, available on the Support site and in the Software Updates portal for 6.5.3. This replaces a
previously posted Windows 10 64-bit only hotfix. This hotfix patch does not require a reboot of the
ClearPass appliance.

#30375 Symptom: The ClearPass OnGuard Unified Agent does not properly detect Avast Security 2015
(version 11.x) on Mac OS X.
WorkAround: Install the ClearPass 6.5.3 OnGuard for OS X 10.11 & Windows 10 64-bit Hotfix
patch, available on the Support site and in the Software Updates portal for 6.5.3. This replaces a
previously posted Windows 10 64-bit only hotfix. This hotfix patch does not require a reboot of the
ClearPass appliance.

#30380 Symptom: On Mac OS X, the ClearPass OnGuard Unified Agent is not able to read the DAT file version
and Engine version of Norton AntiVirus 12.7.56.
WorkAround: Install the ClearPass 6.5.3 OnGuard for OS X 10.11 & Windows 10 64-bit Hotfix
patch, available on the Support site and in the Software Updates portal for 6.5.3. This replaces a
previously posted Windows 10 64-bit only hotfix. This hotfix patch does not require a reboot of the
ClearPass appliance.

#30381 Symptom: The ClearPass OnGuard Unified Agent might not be able to detect the installation of certain
Windows updates that are not visible in Control Panel > Programs and Features > View installed
updates.
Scenario: These are updates that might not use an installer or cannot be removed. Some examples
include the Windows Malicious Software Removal Tool, certain Windows Defender updates (but these
are validated through AntiVirus health class), and foreign language input method editor (IME) files.
Workaround: There is no workaround at this time.

#30572 Symptom: Encrypted Location checks for FileVault 10.11 on Mac OS X 10.11 are not available.
Workaround: There is no workaround at this time.

#30618 Symptom: The ClearPass user interface may become unavailable after installing ClearPass OnGuard
hotfix patches due to a service restart.
Workaround: Log in to the ClearPass CLI using the appadmin account, and restart cpass-admin-server
using the ‘service restart cpass-admin-server’ command. This will only affect the GUI and not the
availability of ClearPass services (for example, RADIUS).

Table 13: OnGuard Known Issues in 6.5.3(Continued)
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Chapter 5
Enhancements in Previous 6.5.x Releases

This chapter provides a brief summary of the features and enhancements introduced in previous ClearPass
6.5.x releases.

Features and Enhancements in Previous 6.5.x Releases
This section provides detailed information about changes to each functionality area. Issue tracking IDs are
included when available.

This section includes:

l "Policy Manager" on page 31

l "Dissolvable Agent" on page 40

l "Endpoint Context Servers" on page 41

l "Guest" on page 44

l "Insight" on page 46

l "Onboard" on page 47

l "OnGuard" on page 48

Policy Manager

Features Added in 6.5.2
l ClearPass now supports TLS version 1.2 in addition to 1.0 and 1.1 in TLS-based EAP methods. (#28012)

l A new configuration parameter,Authorize Attribute Status, was added in the TACACS+ based
enforcement profile. This parameter lets you change the “Auth Status” flag value in the TACACS+
authorization response. (#28619)

l The Java installers provided in the Help documentation of the Java-based WebAgent were updated to JRE
8u45. (#28755)

l ClearPass now supports iboss Post-Auth enforcement. (#28761)

l A new cluster-wide parameter, "Store Local User passwords using reversible encryption", was added. When
set to TRUE, local user passwords are stored using reversible encryption. This maintains backward
compatibility with 6.4 and older releases. If cleartext-password-based authentication against a local user
repository is required, the Authentication filter of the local user repository must be modified manually to
retrieve the cleartext password by adding the following to the SELECT query:
"user_credential(password) AS User_Password". (#28895)

Examples of the default SELECT query and of the required change to take advantage of this enhancement
are provided below.

Example of default query:

SELECT user_credential(password_hash) AS Password_Hash, user_credential

(password_ntlm_hash) AS Password_Ntlm_Hash, CASE WHEN enabled = FALSE THEN 225

WHEN ((expire_time is not null AND expire_time <= now()) OR

(passwordPolicy.expiry_days > 0 AND (PASSWORD_UPDATED_AT <= (now() - interval '1

days' * passwordPolicy.expiry_days))) ) THEN 226 ELSE 0 END AS Account_Status,
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tips_role.name as Role_Name, case when enabled=true then 'true' else 'false' end

as enabled FROM tips_auth_local_users JOIN tips_role ON (tips_auth_local_

users.user_role = tips_role.id), password_policy passwordPolicy WHERE

passwordPolicy.usertype='LOCAL_USERS' AND user_id = '%{Authentication:Username}'

Example with enhancement:

SELECT user_credential(password_hash) AS Password_Hash, user_credential

(password_ntlm_hash) AS Password_Ntlm_Hash, user_credential (password) AS User_

Password, CASE WHEN enabled = FALSE THEN 225 WHEN ((expire_time is not null AND

expire_time <= now()) OR (passwordPolicy.expiry_days > 0 AND (PASSWORD_UPDATED_

AT <= (now() - interval '1 days' * passwordPolicy.expiry_days))) ) THEN 226 ELSE

0 END AS Account_Status, tips_role.name as Role_Name, case when enabled=true

then 'true' else 'false' end as enabled FROM tips_auth_local_users JOIN tips_

role ON (tips_auth_local_users.user_role = tips_role.id), password_policy

passwordPolicy WHERE passwordPolicy.usertype='LOCAL_USERS' AND user_id = '%

{Authentication:Username}'

l A new RADIUS service parameter, “Disable TLS 1.2”, was added. This option lets you enable or disable TLS
1.2 support in TLS-based EAP methods. (#29052)

Features Added in 6.5.1
l ClearPass installations are now supported on Hyper-V platforms (Windows Server 2012 R2 and higher). If

you wish to use this feature, files are available on the Support site underDownload Software >
ClearPass > Policy Manager > Current Release > Hyper-V. After installing the 6.5.0 Hyper-V image,
apply this 6.5.1 patch update. For system requirements information, see the Hyper-V Requirements “ 
section under "Virtual Appliance Requirements" on page 10. For installation and configuration information,
see the Tech Note “Installing or Upgrading ClearPass 6.5 on a Virtual Machine”. (#9380)

l During PEAP authentication, ClearPass now always sends a TLS start with a flag value of 1 (PEAPv1), allowing
certain clients to negotiate from PEAPv2. (#27931)

l At Monitoring > Live Monitoring > Access Tracker, the Status Message that is logged when a
RADIUS CoA is sent to a network access device (NAD) is now more detailed. (#27951, #27359)

l ClearPass 6.5.1 supports TLS versions 1.0, and 1.1 in TLS-based EAP methods. (#28597)

l To improve performance, a new cluster-wide parameter,Multi Master Cache Durability, was added at
Administration > Server Manager > Server Configuration. The admin can use this parameter to
configure the durability of the BatteryDb, setting it to OFF, NORMAL, or FULL mode. The default setting is
OFF mode. (#28164, #28177)

Features Added in 6.5.0
l Support was added for terminating IPSec VPN tunnels. To use this feature, go to Administration > Server

Manager > Server Configuration and click the server in the list. On theNetwork tab, click theCreate
IPSec Tunnel button. Items that can be configured for an IPSec tunnel include: (#8378)

n Local Interface

n Remote IP Address

n IPSec Mode

n IKE Version

n IKE Phase1 Mode

n Encryption Algorithm

n Hash Algorithm



n Diffie Hellman Group

n Authentication Type

n IKE Shared Secret

l Support was added for broadcasting a RADIUS accounting request to proxy targets configured in the
service. A newAccounting Proxy option is available when you configure new or modify existing RADIUS
services, providing the ability to proxy RADIUS accounting events. (#15002, #25647)

To use this feature, go to Configuration > Services and select or add a RADIUS service. On its
configuration form, click the Service tab. Complete the fields as needed and, in theMore Options field,
select theAccounting Proxy check box. An Accounting Proxy tab is added to the form. Fields on this tab
let you configure a hierarchical list of proxy targets to which the RADIUS server should be forwarded, and
configure attributes to include in the accounting packet. Attribute values can be static or any parameterized
value.

l RADIUS is now supported as an authentication and authorization source, allowing ClearPass to query third-
party RADIUS servers. When you add a new authentication source, the new RADIUS Server source type is
available in the Type drop-down list at Configuration > Authentication > Sources > General tab. The
RADIUS Server source type can be used with any RADIUS-based authentication service. Extra
RADIUS attributes can be added before sending the RADIUS request to a RADIUS-based remote server, and
the response attributes can be used as role or authorization attributes. (#20550, #25646)

l Four service templates were enhanced to streamline workflows for some common ClearPass
configurations. To use these features, go to Configuration > Start Here and select the following service
template links: (#20659)

n 802.1X Wired — A Posture Settings tab was added. Options on this tab let you enable or disable
posture checks, specify host operating systems (Windows, Linux, or Mac OS X), and provide a quarantine
message.

n 802.1X Wireless — A Posture Settings tab was added. Options on this tab let you enable or disable
posture checks, specify host operating systems (Windows, Linux, or Mac OS X), and provide a quarantine
message.

n Guest Access - Web Login — The Service Rule tab now includes a link to open theClearPass Guest
> Configuration > Web Logins page, where you can create a new guest Web login page.

n Onboard — The Provisioning Wireless Network Settings tab now includes a link to open the
Onboard > Configuration > Network Settings page, where you can add new Onboard network
settings.

l Enhancements to the Access Tracker provide additional information. To see this feature, go to Monitoring
> Live Monitoring > Access Tracker and click a server in the list. TheRequest Details form opens.
Changes to this form include: (#20660, #26127)

n The Input tab now shows the category, family, and OS of the device, and the name of the vendor. This
tab also includes a new Show Configuration button, which adds a tab to the Request Details form.

n When you click the Show Configuration button on the Input tab, theConfiguration tab is added to
theRequest Details form. This tab provides Service Rule, Role Mapping Policy Details, and
Enforcement Policy Details information.

l Three new widgets were added to the Dashboard: (#20664)

n Endpoint Profiler Summary

n MDM Discovery Summary

n OnGuard Client Summary
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l Several enhancements were made related to Common Criteria Protection Profile and FIPS 140. Changes
were made in the areas of password complexity policies, idle session timeout configuration, admin
passwords, and performance monitor rendering. As part of this feature: (#20667, #23819, #24191,
#26272, #26273, #26274, #27208, #27475)

n Password security was strengthened.

n A new Password Policy Settings form was added for both local users and admin users. To use this
feature, go to eitherAdministration > Users and Privileges > Admin Users > Password Policy or
Configuration > Identity > Local Users > Password Policy. Options that can be configured for the
password include length, complexity, disallowed characters, disallowed words, disallowed user ID or
repeated characters, and the number of days to expiration.

n A new cluster-wide parameter,Admin Session Idle Timeout, allows administrators to configure the
maximum idle time permitted for a session before it times out. To use this feature, go to
Administration > Server Manager > Server Configuration > Cluster-Wide Parameters
> General tab. Scroll to theAdmin Session Idle Timeout row and enter the number of minutes to
allow before timeout. The default value is 30 minutes.

n A new cluster-wide parameter, Performance Monitor Rendering Port, controls performance metrics
rendering among the nodes in the cluster. The port can be altered depending on the firewall
requirements in deployments.

l Default values have changed for two items in the Administration module: (#25998)

n The default value of Old Audit records cleanup interval is changed from 30 days to 7 days under the
Administration > Server Manager > Server Configuration > Cluster-Wide Parameters >
Cleanup Intervals tab.

n The default value of the Limit each log file size parameter underAdministration > Log
Configuration > System Level is changed from 25 MB to 50 MB. 

l ClearPass now provides the ability to add a number of devices that have contiguous IP addresses. To use
this feature, go to Configuration > Network > Devices > Add Device. In the IP Address or Subnet
field, use a hyphen to indicate the range of device IP addresses, following the format a.b.c.d-e (for example,
192.168.1.1-20). (#20841, #26134)

l A new option lets you clear the machine authentication cache on all the nodes. This option is available at
Administration > Server Manager > Server Configuration > Clear Machine Authentication
Cache. (#20959)

l Information retrieved by API queries to the Endpoints table now includes endpoint profile information.
(#21004)

l A new RADIUS service parameter, Enable signing for OCSP Request, was added for specifying whether
ClearPass should sign an OCSP request with a RADIUS server certificate. To use this feature, go to
Administration > Server Manager > Server Configuration and click the server in the list. On the
Service Parameters tab, select RADIUS server in the Select Service drop-down list. Scroll to the Enable
signing for OCSP Request row and set the value to either TRUE or FALSE. The default value is FALSE to
disable the signing process. (#21677)

l Administrators and guest operators can now log in to ClearPass using smart cards and TLS certificates. To
use this feature: (#23050)

1. In ClearPass Policy Manager, go to Configuration > Start Here, click Certificate/Two-factor
Authentication for ClearPass Application Login, and configure the service template and add it. It
will then be available in the list at Configuration > Services.



2. In ClearPass Guest, go to Configuration > Pages > Web Logins to create a Web login page. In the
Vendor Settings drop-down list, select Single Sign-On - SAML Identity Provider. In the Login Form
area, select the appropriate values in theClient Certificate and Authentication fields to allow admins
and guests to log in via smart cards and TLS certificates.

l The following additional OIDs are now exposed for reporting CPU load averages for one minute, five
minutes, and fifteen minutes: (#24057)

n .1.3.6.1.4.1.2021.10.1.3.1

n .1.3.6.1.4.1.2021.10.1.3.2

n .1.3.6.1.4.1.2021.10.1.3.3

l A new attribute,Mac-Address-Upper-Hyphen, was added to the Connection namespace. This attribute
contains the client’s MAC address in uppercase with a hyphen delimiter. (#24074)

l Support was added for the EAP-PWD authentication method. To use this feature, go to Configuration
> Authentication > Methods and scroll to the [EAP PWD]method in the list. The EAP-pwd protocol
method uses a shared password for authentication. For more information, see http://www.rfc-base.org/rfc-
5931.html. (#24149)

l The Cisco Adaptive Security Appliance (ASA) RADIUS dictionary was added. When you upgrade or restore
from a previous version, the Cisco ASA dictionary automatically replaces the Cisco VPN3000 RADIUS
dictionary. If you require the Cisco VPN3000 dictionary, you may import it. (#24337)

l A new service parameter, Include Nonce in OCSP request, was added for specifying whether an OCSP
request should contain a nonce or not. A nonce is a unique identifier for an OCSP request. To use this
feature, go to Administration > Server Manager > Server Configuration and click the server in the list.
On the Service Parameters tab, select RADIUS server in the Select Service drop-down list. Scroll to the
Include Nonce in OCSP request row and set the value to either TRUE or FALSE. The default value is TRUE.
If the OCSP server does not support nonce, set the value of this parameter to FALSE to avoid an EAP-TLS
authentication failure. (#24443)

l ClearPass now provides the ability to authenticate users belonging to trusted domains when the Global
Catalog server is configured as an authentication source and the username does not contain the domain
name. (#24731)

l ClearPass now displays information from the SNMP Management Information Base (MIB). On an SNMP
query, the information is exposed beginning one minute after changes are made to the configuration.
Details include: (#24850)

n System information

n Authentication counters

n Authorization counters

n Network traffic counters

n Traps for various system and application events

For more information, see
http://support.arubanetworks.com/DownloadSoftware/tabid/75/DMXModule/510/Default.aspx?EntryId=
16480.

l A new service template was added for to provide authentication sources for social logins. To see this
feature, go to Configuration > Start Here and select Guest Social Media Authentication. (#25183)

l Data about the various posture classes and their status for endpoints, as derived by the OnGuard agent,
can now be sent to Palo Alto Networks devices. To use this feature, when configuring a Palo Alto firewall or
panorama device as an external context server, go to Administration > Server Manager > Server
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Configuration, open the server’s configuration form, and click the Service Parameters tab. Set the Send
Posture Data option to TRUE, and enter a value higher than two minutes for the Eager handler polling
interval option. Because this feature can be resource-intensive, the eager handler-polling interval must be
two minutes or more. (#25217)

l A new option, Join Server Back to Cluster, was added to the Server Configuration page for nodes
whose replication status is DISABLED. This option is only available to users with the Admin role. The Join
Server Back to Cluster option lets administrators join a failed node back to the cluster. The node can also be
promoted to publisher. This option can only be triggered from a node that is currently active in the cluster.
To use this option, go to Administration > Server Manager > Server Configuration and click the node
whose replication status is DISABLED. (#25304)

l TheCertificate Trust List at Administration > Certificates > Trust List now includes DoD
(Department of Defense) certificates. These are disabled by default, and can be enabled as needed. A DoD
certificate allows a browser to trust Web sites whose secure communications are authenticated by a
Department of Defense agency. (#25329)

l For wired network profiling, MAC OUI (Organizationally Unique Identifier) information is now populated for
all endpoints even when no other profiling information is available for an endpoint. This feature is available
at Configuration > Identity > Endpoints > Edit Endpoint. (#25377)

l For wired network profiling, a list of multiple SNMP community strings can now be configured and used to
query static IP devices discovered by the Profiler. If a static IP device does not respond to queries from the
default public community string, the SNMP service can use the credentials from this custom list to query the
device. This feature is available at Configuration > Profile Settings > SNMP Configuration. (#25417,
#25837)

l For wired network profiling, a one-time scan can now be triggered to discover and profile devices in
specified network IP subnets. To use this feature, go to Configuration > Profile Settings > Subnet
Scans and click theOn-Demand Subnet Scan link. Enter the subnets to scan and click Submit. (#25418)

l Insight now records the last connected location for an endpoint when such information is available. This
information is determined from RADIUS authentication and accounting information, and from SNMP
queries of network devices that have been set up for SNMP read and trap notification. Insight reports
based on the Endpoints template can report on the following columns related to device location: (#25421)

n NadIp (switch or controller IP)

n NadPort (port information for wired devices)

n Access Point (AP for wireless devices)

n Ssid (SSID for wireless devices)

l For wired network profiling, an SNMP scan of an endpoint can now be triggered from itsAccess Tracker
authentication record or Endpoints configuration in order to profile the endpoint. The option for the
SNMP scan of the endpoint is only available if the client IP address is available. Only one endpoint can be
scanned at a time. (#25456, #25420)

n To use this feature fromMonitoring > Live Monitoring > Access Tracker, click the server in the list
to open theRequest Details form. On the Summary tab, click Change Status. On theAccess
Control Capabilities tab, select the Server Action radio button. Select SNMP Scan in the Server
Action drop-down list, and then click Submit.

n To use this feature from Configuration > Identity > Endpoints, mark the check box for the endpoint
in the list and click Trigger Server Action. In the Server Action drop-down list select SNMP Scan, and
then click Submit.



l A new cluster-wide service parameter, Replication Batch Interval, was added. This parameter can be used
to change the number of seconds for the minimum replication time. This parameter should only be
modified as instructed by Support. (#25461)

l The Policy Server now logs an alert message if an authentication source filter takes a long time (more than 6
to 10 seconds) or times out. The alert message can be viewed in the logs at Monitoring > Live
Monitoring > Access Tracker. (#25508)

l Ubuntu was added to the list of Linux Posture configuration settings at Configuration > Posture
> Posture Policies > Posture Plugins. (#25676)

l ClearPass now supports two new event type formats, CEF (Common Event Format) and LEEF (Log Event
Extended Format). On theAdministration > External Servers > Syslog Export Filters configuration
form, the Export Event Format Type field includes the LEEF and CEF options in addition to the Standard
option. (#25764)

l TheCertificate Trust List at Administration > Certificates > Trust List now includes Alcatel root
certificates. These are disabled by default, and can be enabled as needed. An Alcatel root certificate allows
Alcatel Lucent IP phones to authenticate via EAP-TLS. (#25782)

l The Linux Posture plugin was modified to simplify AV health class configuration under each Linux
distribution. (#25792)

l The following Graphite counters were added to the RADIUS server: (#25862)

n Kerberos Authentication Time

n Number of RADIUS Accounting Packets Processed

n Number of Timed Out Requests

n RADIUS Accounting Packets Processed

n RADIUS Duplicate Packets Received

n RADIUS Policy Evaluation Time

n RADIUS Service Evaluation Time

n Time Taken for a RADIUS Request Process

n Time Taken to Verify the Certificate Against OCSP Server

l A new MAC Caching service template was added. Instead of using Insight as the authorization source, this
service uses an endpoint attribute containing the MAC cache expiry date, and checks this attribute against
the authentication date. If the authentication date is earlier than the expiry date, access is granted. To see
this feature, go to Configuration > Start Here and select theUser Authentication with MAC Caching
template. (#25900)

l An Nmap scan of an endpoint can now be triggered from itsAccess Tracker authentication record or
Endpoints configuration in order to profile the endpoint. The option for the Nmap scan is only available if
the endpoint’s IP address is available. Only one endpoint can be scanned at a time. (#25943)

n To use this feature fromMonitoring > Live Monitoring > Access Tracker, click the server in the list
to open theRequest Details form. On the Summary tab, click Change Status. On theAccess
Control Capabilities tab, select the Server Action radio button. Select Nmap Scan in the Select
Action drop-down list, and then click Submit.

n To use this feature from Configuration > Identity > Endpoints, mark the check box for the endpoint
in the list and click Trigger Server Action. In the Server Action drop-down list select Nmap Scan, and
then click Submit.
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l An alert is now shown in the Access Tracker if an enforcement action fails with an error code returned from
the external context server. Alerts indicate the details of the HTTP request, and are shown on theAlerts tab
of theRequest Details form when you select a server in the list at Monitoring > Live Monitoring
> Access Tracker. (An example of an enforcement action would be an HTTP enforcement invoking a
GET/POST/PUT to an external context server such as a generic HTTP server or an MDM context server)
(#25972)

l ClearPass Profile can now determine device type using TCP OS Fingerprinting. It also uses ARP (Address
Resolution Protocol) packets to get the MAC:IP binding. To support TCP fingerprinting, theAdministration
> Server Manager > Server Configuration > System tab > Span Port field now includes an Enable
TCP fingerprinting check box. This option is disabled by default. When the check box is selected to enable
TCP fingerprinting, a warning message is displayed that advises the user of the potential impact on system
performance. TCP session-based fingerprinting is a CPU-intensive operation, and the server should not be
used for request processing while this option is enabled. (#25984, #26168)

l A new service template, Device MAC Authentication, was added. This service template can be used for plain
device accounts that do not have a user directly associated with them. (#26033)

l Support was added for notifications to registered subscribers when a device profile changes. (#26106)

l New UI options and CLI commands let users perform on-demand cleanup operations. In addition, the
system checks disk utilization every hour and purges data if the configured disk threshold is met: (#26121,
#24005)

n To use this feature in the UI, go to Administration > Server Manager > Server Configuration, select
the radio button in the rows of the servers you wish to clean up, and click theCleanup button. A pop-up
window lets you specify, in days, the age of the files to remove. File types that are removed include:

n System and application log files

n Past authentication records

n Audit records

n Expired guest accounts

n Past auto and manual backups

n Stored reports

n To use this feature in the CLI, the new system cleanup command performs on-demand cleanup. The
new system sysinfo command provides information on disk and memory utilization.

l New endpoint attributes capture information about endpoints that have generated threat events.
Administrators can create policies based on a threat’s category, risk, or severity level, or a combination
thereof. A device’s threat resolution status can also be captured for logging purposes. The attributes are
shown in New Endpoint Attributes for Threat Information, and are available in the Attributes dictionary
(Administration > Dictionaries > Attributes) (#26222)

Endpoint Attribute Data Type

[Threat Category] String

[Threat Detection Device IP] IPv4Address

[Threat Detection Device Name] String

Table 14: New Endpoint Attributes for Threat Information



Endpoint Attribute Data Type

[Threat Name] String

[Threat Risk] Integer32

[Threat Severity] List

[Threat Status] List

[Threat Timestamp] Date-Time

Table 14: New Endpoint Attributes for Threat Information(Continued)

l User passwords are now stored as password hashes instead of the reversible AES-256 encrypted form. This
feature also supports MSCHAPv2 authentication. As part of this feature: (#26288, #26310, #26324,
#26325, #26346)

n Support was added for password hash-based user authentication for SQL authentication sources.

n Async netd modifications were made to support hashed admin user passwords.

n PostAuth modifications were made to support hashed user passwords.

n API modifications were made to support exporting password hash fields.

n An option is provided to store password hashes in a format compatible with MSCHAP authentication.
This can be controlled from a cluster-wide parameter.

If you disable this feature, RADIUS MSCHAP authentications against the Local User and Admin User repositories are
not possible because NTLM hashes are reset for all local and admin users. To re-enable RADIUS MSCHAP
authentication against the user repositories, you must reset all the affected passwords in addition to enabling this
feature.

l The RADIUS server was modified to integrate with Vasco IdentiKey Authentication Server. The changes also
ensure that the State attribute does not contain any non-printable (non-ASCII) characters. (#26320,
#27103)

l New System Monitoring graphs are available. To view these graphs, go to Monitoring > Live Monitoring
> System Monitor and click theClearPass tab. Select the newAdvanced option, and then select the
Type. The following graph types were added: (#26362)

n RADIUS Accounting Packets processed

n RADIUS Duplicate Packets received

n Time taken to verify the certificate against OCSP server

n RADIUS Policy Evaluation Time

n RADIUS Service Evaluation Time

n Number of RADIUS timed out requests

l The following RADIUS counters are now logged at the INFO level instead of the DEBUG level: (#26419)

n Service Categorization Time

n User Lookup time in rlm_ldap and rlm_sql modules

n User authentication time in rlm_mschap module

n Policy Evaluation time
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n End-to-End request processing time

l A new Service Template,Guest Social Media Authentication, was added to provide a step-wise wizard
for easy setup of CPPM policies that allow social logins for Guest access.(#26434)

l The RADIUS dictionary was updated with the latest information for all CheckPoint platforms. (#26616)

l For users who connect to a Microsoft SQL server using Integrated Authentication, the login username in the
authentication source now allows the backslash ( \ ) and at-sign (@) characters in addition to the hyphen
and underscore characters. Only the DOMAIN\\Username format is supported for Integrated
Authentication (UPN format is not supported). To use this feature, go to Configuration > Authentication
> Sources > Add and create a new source of typeGeneric SQL DB. On the Primary tab, enter the
username in the format DOMAIN\\Username in the Login Username field, and select MSSQL in theODBC
Driver field. (#26670)

l A new Endpoint Details API can be used to query the endpoint attributes for a given IP address or
MAC address. The admin should always use this API on nodes where Insight is enabled, and make sure that
RADIUS accounting is enabled. The following endpoint attributes can be retrieved using this API: (#26778)

n mac

n ip

n user

n device_category

n device_family

n device_name

n is_online

n updated_at

l To improve the efficiency of error handling, ClearPass now excludes the following errors from the Active
Directory errors that are used for recovery actions: (#26946)

n 0xC000006D - STATUS_LOGON_FAILURE

n 0xC000006E - STATUS_ACCOUNT_RESTRICTION

n 0xC000006F - STATUS_INVALID_LOGON_HOURS

n 0xC0000071 - STATUS_PASSWORD_EXPIRED

n 0xC0000072 - STATUS_ACCOUNT_DISABLED

n 0xC0000064 - STATUS_NO_SUCH_USER

n 0xC000006C - STATUS_PASSWORD_RESTRICTION

n 0xC000006A - STATUS_WRONG_PASSWORD

n 0xC0000193 - STATUS_ACCOUNT_EXPIRED

n 0xC0000234 - STATUS_ACCOUNT_LOCKED_OUT

n 0xC0000224 - STATUS_PASSWORD_MUST_CHANGE

Dissolvable Agent

Features Added in 6.5.0
l The OnGuard Mac Health Checker.dmg file for the Mac OS X Native Dissolvable Agent now uses the

Native Agent Installer instead of the Native Agent App. This allows users to easily uninstall the agent.
(#25063)



l The Native Dissolvable Agent is now supported for the Ubuntu operating system with the Firefox browser
(it is not supported for the Chrome browser). The following Ubuntu OS versions are supported:

l 12.04 32-bit LTS

l 12.04 64-bit LTS

l 14.04 32-bit LTS

l 14.04 64-bit LTS

For more information, see #20656 under "Dissolvable Agent" on page 40. (#25271)

l To uninstall the Native Agent from Mac OS X, you can now run the following command: (#27163)

open ~/Library/Application\ Support/ClearPassWebAgent/Uninstaller.app/

Endpoint Context Servers

Features Added in 6.5.0
l ClearPass now provides the ability to turn off HTTP Basic authentication for context server actions, and to

specify user credentials as Action Attributes. To see this feature, go to Administration > Dictionaries
> Context Server Actions and either click a server type in the list or click Add to add a new server. The
Endpoint Context Server Details window opens. (#18919)

n To use the HTTP Basic authentication option, on theAction tab, use the check box in the Skip HTTP
Auth field to enable or disable HTTP Basic authentication.

n To use the Action Attributes option, on theAttributes tab, add the attributes in the following formats:

Attribute Name Attribute Value

Server Name %{Server.Name}

User Name %{Server.UserName}

Password %{Server.Password}

Table 15: Options for HTTP Basic Authentication and User Credentials as Action Attributes

l The Event Viewer at Administration > External Servers > Endpoint Context Servers now includes a
Poll Status tab for MDM polling information. This tab is available when editing the context server if MDM is
enabled for polling and if at least one poll has been completed. (#24225)

Information shown on the Poll Status tab for a successful poll includes:

n Last poll status

n Last successful poll time

n Total elapsed time for polling MDM and posting endpoints to ClearPass

n Number of endpoints (fetched from MDM)

n Number of invalid endpoints (invalid MAC addresses or duplicates)

n Number of endpoints updated to ClearPass

n Number of incomplete device profiles (missing category or family information, or device model not
present in dictionary)

n Number of device profiles updated in ClearPass
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Information shown on the Poll Status tab if the poll fails includes:

n Last poll status

n Last successful poll time

n URL that MDM was trying to access

n HTTP status code

n Reason for failure

l ClearPass now supports the Google Administration Console as an MDM External Context Server. To use this
feature, a project must first be created in the Google Developer Console, and then the Google Admin
Console can be added as a context server in ClearPass Policy Manager. The procedures are described below.
(#24499)

Steps in the Google Developer Console:

1. Make sure to enableAdmin SDK API.

2. Create a new Client ID and Client Secret (select Web Application as theApplication Type).

3. Create a Consent Screen with the desired logo and text (This screen is seen by the ClearPass
administrator when authorizing ClearPass Policy Manager - more below).

4. Add Redirect URIs. This is of the format https://<clearpass-server>/async_
netd/mdm/oauth/google, where “clearpass-server” should be a fully qualified domain name (FQDN)
and not an IP address. This server should be reachable by that FQDN by the device the administrator is
using to access the ClearPass Admin UI over a Web browser.

5. Configure the domain's security setting to allow API access.

Steps in ClearPass Policy Manager:

1. Go to Administration > External Servers > Endpoint Context Servers > Add. On the Server tab,
select Google Admin Console in the Select Server Type drop-down list.

2. Enter the valid Client ID and Client Secret that were configured in the Google Developer Console.

3. Click Save to save the Client ID and Client Secret. This also enables the Authorize ClearPass button.

4. Click Authorize ClearPass. The Google page for entering the username and password for the Google
domain (account) opens in a new tab or window.

5. Enter the credentials. A consent screen (the one that was set up in the Google Console steps) is
displayed, where you will be given the choice to authorize ClearPass to communicate with the Google
Admin Console to fetch the MDM data for the Google Chrome Devices registered with the domain.

6. After the approval, the status of the operation is displayed — either that a “Refresh Token has been
fetched and saved”, or an error message.

7. You can return to the main ClearPass Admin UI window and make additional selections (such as enabling
ClearPass to poll for MDM data) before you click Save to save the settings.

When all configuration is complete in the Google Developers Console and in CPPM, subsequent MDM
polling cycles will fetch the MDM data for the Google Chrome Devices and add that to the endpoints,
profiling data to use with functionality of ClearPass Policy Manager, such as in creating and configuring
policies and services. The details of the devices fetched can be seen from several places in the UI. The
figures below show details of a Google Chrome Device whose MDM data was fetched by ClearPass from the
Google Admin Console. This information is displayed when an endpoint row is clicked at Configuration >
Identity > Endpoints. The list of devices (rows) on can be filtered by using the filter attribute Source >
contains > Google Admin Console.



l A new enforcement profile, Session Notification Enforcement, is introduced in 6.5.0. Notification of a
change in IP address can now be sent to any external context server (such as a firewall) by configuring that
server as a generic HTTP server and adding the appropriate generic HTTP context server actions. The
content of the payload to be posted by CPPM to the external server is based on the REST API defined by the
external server for communication. (#24508, #24509)

Prior to 6.5, session restrictions enforcement allowed a Palo Alto Firewall device to be added as a value for
an attribute of type “Session-Check” and name “IP-Change-Notify”. When used as part of a policy and
service, that profile let CPPM notify the firewall when users logged in or out of the network. In the 6.5.0
release, the new enforcement profile type, Session Notification Enforcement, provides the same
functionality not only for Palo Alto firewalls but also for firewalls for other vendors. It replaces the IP-
Change-Notify attribute, which will no longer be supported. Any pre-6.5.0 configuration will be migrated to
the new enforcement type during upgrade to 6.5. Three different configuration options are described in the
tables below.

Field Configuration

Session-Notify Server Type Palo Alto Networks Firewall

Session-Notify Server IP <IP ADDRESS>

Table 16: Session Notification Enforcement Configuration: PANW Integration

Field Configuration

Session-Notify Server Type Palo Alto Networks Firewall

Session-Notify Server IP <IP ADDRESS>

Session-Check Username %{Endpoint:Username}

Table 17: Session Notification Enforcement Configuration: PANW Integration Extended to Guest MAC Caching

Field Configuration

Session-Notify Server Type Generic HTTP

Session-Notify Server IP <IP ADDRESS>

Session-Notify Login Action Check Point Login

Session-Notify Logout Action Check Point Logout

Table 18: Session Notification Enforcement Configuration: Generic HTTP Servers (Check Point)

To use this new enforcement profile type, go to Configuration > Enforcement > Profiles > Add. On the
Profile tab, select Session Notification Enforcement in the Template drop-down list. On the
Attributes tab, select the Session-Notify type.

l MobileIron MDM integration was updated to the 5.5 VSP release API specification, improving the device
discovery logic for large deployments (tens of thousands of managed devices). Device discovery is now
much faster and timeout issues are eliminated. (#24690)

l The server configuration form at Administration > External Servers > Endpoint Context Servers now
includes aBypass Proxy option. An administrator can select this option to specify that the endpoint
context server should not use the configured proxy settings (if a proxy is used). ClearPass would then
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bypass the proxy for functions such MDM API, Endpoint Context Server Actions, or Generic HTTP outbound
enforcement. (#25686)

l ClearPass now lets you configure multiple endpoint context servers of the same server type. To use this
feature, go to Administration > External Servers > Endpoint Context Server > Add and select the
Server Type. A new attribute to identify the server from which the endpoints are fetched was added to the
dictionary at Administration > Dictionaries > Attributes. This attribute, Context Server, is populated
with the Server Name value of the endpoint context server the endpoint is fetched from.(#25826)

l New generic HTTP context server actions are available. They can be used in conjunction with CheckPoint
and Fortinet firewalls that are configured as external context servers in order to communicate end user
logins and logouts in the form of session notification enforcement. To use this feature, go to
Administration > Dictionaries > Context Server Actions. In the Filter drop-down lists, select Action
Name > contains > Log and click Go. The following server actions were added: (#26682)

n Check Point Login

n Check Point Logout

n Fortinet Login

n Fortinet Logout

Guest

Features Added in 6.5.2
l The /api/guest/:guest_id/sponsor action was added to the API. (#29465)

l In the API, the lists returned by the Guest and Device queries are now sorted with the newest items at the
top by default. (#29466)

Features Added in 6.5.1

ClearPass Guest now provides the ability to whitelist User-Agents from the meta-refresh redirect behavior in
the captive portal (they will be shown the captive portal without any redirects), and to blacklist them from
receiving the captive portal. Whitelists and blacklists for captive portals can be configured in at
Administration > Plugin Manager > Platform Services > Configuration. (#27990)

Features Added in 6.5.0
l Support was added to Transaction Services for the following Property Management Systems (PMS):

(#19271, #23108, #25239)

n Agilysys hotel PMS

n Protel PMS

l A new Web Analytics plugin was added. This plugin can be used to inject a Web analytics tracking code into
guest-facing application pages. This functionality does not collect any user information. (#20552)

l The sponsor can now confirm or reject a guest account or device account directly from theGuest >
Manage Accounts orGuest > Manage Devices page, respectively, instead of by email. To configure this
option, go to Configuration > Pages > Guest Self-Registrations and click the Edit link for a Guest Self-
Registration (GSR). In the diagram, click the Sponsor Confirmation link. Select the Enabled check box for
sponsorship confirmation and save your changes. Register the guest account. On theGuest > Manage
Accounts list, the account’s row will include the Sponsor link. (#20633)

l The PHP opcode cache was updated to OPcache 7. (#21188)



l Web Pages was added to Configuration > Pages. You can manage your list of custom Web pages and
create simple new custom pages. The Web Pages list also provides four page templates: Browser
Unsupported, Jailbroken Device, Posture Check, and Service Unavailable. (#24439)

If you have configured Bulk SMS as your SMS provider, the outgoing port has changed from TCP port 5567 to TCP
port 80. Please review any firewall settings you may have configured. An override is available in the Configuration
> SMS Services > Gateways configuration form to override the default port. (#24453)

l The Self-Service Portal summary page now displays the NAT IP if it is available in the authentication
session of the user. (#25165)

l Transaction processors using the FIAS protocol will now adhere to the No Post NP flag and deny access.
Previously guests were still able to attempt a charge or otherwise be granted access. (#25240)

l Support was added for the Media4u SMS gateway (Japan). (#25551)

l TheAdministration > API Services > API Clients page includes a new link,API Explorer, that provides
access to the various APIs used for configurations in Guest and Onboard. (#25556)

l TheGuest > Active Sessions > Show Details window now includes the ClearPass Policy Manager service
and the session ID of the user’s connection. The Service Type and SSID fields can be added to theGuest >
Active Sessions list as a custom view. To add these columns, click theMore Options link above the table,
click Choose Columns, click the field name you want to add, and then click Enable Field. (#25633)

l Two new skins have been added to the list of available skins at Administration > Plugin Manager. The
Galleria Skin and Galleria Skin 2 provide a customizable and dynamic full-screen user experience for
guests. (#25672)

l In Transaction Processor configuration, for matching names against Property Management Systems (PMS)
you can now configure how many characters of the name require matching. To use this feature, go to
Configuration > Hotspot Manager > Transaction Processors and open the configuration form for a
new or existing processor. In the Processing Gateway drop-down list, select one of the PMS providers. In
theName Match field, you can specify either an exact name match or matching just the first 3, 4, 5, 6, or 7
letters of the last name. (#25783)

l The performance of captive portal pages was improved. (#25965)

l When you configure a guest self-registration to use a Facebook Wi-Fi social login, a new option lets you
enable a RADIUS Change of Authorization (CoA) when the guest’s session expiration time is reached. To use
this feature, go to Configuration > Pages > Guest Self-Registrations > Advanced Editor link. In the
Customize Guest Registration page, scroll to the Social Logins area and select the check box in the
Social Login row, and then select the Advanced check box. The newDisconnect Action drop-down list
specifies the action to take when a disconnect is requested by Facebook. If a CoA Enforcement Profile is
selected, it must be compatible with the NAD the guests are connecting to. (#26001)

l When Single Sign-On _ SAML Identity Provider is selected in theVendor Settings field at
Configuration > Pages > Web Logins, a new configuration option, Client Certificate, lets you request a
client certificate from the user to be used for authentication. (#26046)

l Access control lists in Guest and Onboard now support IPv6 addresses in addition to IPv4. These access
control lists include any “allow access”, “deny access”, or “enable access” fields , found on forms such asWeb
Logins,Guest Self Registration, Provisioning Settings, or the SCEP server settings in Certificate
Authority Settings. (#26079)

l Significant performance enhancements were made to guest-facing pages such as Web Logins and Guest
Self-Registration pages, improving performance by 32% to 166% more requests per second. (#26119)

ClearPass 6.5.3 | Release Notes Enhancements in Previous 6.5.x Releases | 45



46 | Enhancements in Previous 6.5.x Releases ClearPass 6.5.3 | Release Notes

l Support was added for specifying security options for Cross-Origin Resource Sharing (CORS). This applies to
API requests made from Web applications. The default is to not permit any cross-origin requests. To
configure this behavior, you can specify a list of hostnames, optionally including wildcards, at
Administration > Plugin Manager > API Framework > Configuration > Allowed Origins. (#26179)

Insight

Features Added in 6.5.0
l Support was added for WYSIWYG graphical report design in Insight. This feature includes the following

changes: (#20541)

n On the Insight Dashboard, aReport button was added. You can click this button to open theAdd
Reports form and generate a report of the currently-displayed Dashboard widgets.

n On theAdd Reports form, you can add a Dashboard report by selecting the newDashboard template.
The report uses the current Dashboard widgets in the configuration. To change the widgets in the report,
first change them in the Dashboard and then return to the report configuration.

n TheAdd Reports form also includes a newDesign tab. You can click theHeader, Title, or Footer row
to edit the HTML, or the Image row to add a file.

l Insight reports now support OnGuard Agent Type and Version fields in WebAuth reports. (#22689)

l A new template, Endpoint Latest, was added to Insight report configuration to allow reporting on location
attributes. (#23219, #24079)

l A new template,MAB, is now supported in Insight report configuration for MACAUTH BYPASS reports.
(#23421)

l A new widget, Insight Disk Usage, was added to the Insight Dashboard. It displays Insight resource
consumption statistics such as disk usage of the Insight DB and the Reports Directory. (#23620)

l A sample report can now be viewed for each of the template types within a template group. In the Select
Template field on Insight’s Reports > Configuration tab, the Sample Report link downloads an example
of the selected report in PDF format. (#25123)

l Support was added for including endpoint connection information such as Switch Port/Controller and
Access Point in Insight reports. (#25422)

l Insight report configuration now displays uploaded images in the Design Tab. Support was also added for
uppercase image file extensions for JPEG and PNG. GIF images are not supported. (#25514)

l Insight reports now include the following new Posture fields for the File Check Health class: (#25575)

n Files Missing

n Files Not Allowed

n Invalid MD5 Sum Files

l Enhancements to Insight’s Search tab provide additional information. Changes to this form include:
(#26125, #26126, #20660)

n A Summary View button was added to the Search Type options. You can configure the Summary View
for and endpoint, a network device, or a user and specify the widgets to include. When you select
columns and click Save, the details are correlated across cluster nodes in the displayed information.



Onboard

Features Added in 6.5.0
l The guest self-registration page can now be configured to initiate Onboard device enrollment as an

alternative to NAS login, allowing the guest to log in and proceed to Onboard enrollment in one step. To use
this feature, go to Configuration > Pages > Guest Self-Registrations and click the link to either create
or edit a page. In the diagram, you can either: (#9859, #25652)

n Click Advanced Editor, scroll to Login > Enabled, and select the Enable Onboard device enrollment
option.

n UnderReceipt Page > Submit, click either Title, Login Message, Login Delay, orNAS Vendor
Settings. In the Enabled field at the top of the form, select the Enable Onboard device enrollment
option.

l Onboard now provides the ability to require a sponsor to approve a new device that is being provisioned for
the network. A field for the sponsor’s email address will be added to the guest’s login form below the
username and password fields. When the user logs in to register their device, an email is sent to the sponsor
requesting approval, and a message is displayed on the user’s screen advising them that it is in process. To
set up the email to the sponsor, first go to Onboard > Deployment and Provisioning > Provisioning
Settings > Web Login tab, click in theCustom Fields text box, and select Sponsor’s Email: (sponsor_
email) from the drop-down list. Next, click the new Sponsorship Confirmation tab and then click the
Enabled check box. Options on this tab let you specify provisioning settings related to sponsorship
confirmation and UI overrides. (#11912)

l The list of available settings you can configure for an iOS device at Onboard > Configuration > iOS
Settings now includesDevice Restrictions Settings. (#12402)

l Automatic cleanup options were added for Onboard certificates. In theActions area of theOnboard
> Deployment and Provisioning > Provisioning Settings form, options let you: (#14424)

n Revoke certificates for inactive devices, specifying the period of inactivity

n Delete duplicate certificates, specifying the number of days to wait after re-enrollment before deletion

l The default algorithm to use for the certificate authority in Onboard is now changed to SHA-512 from SHA-
1 because SHA-1 digest algorithm is no longer considered fully trustworthy by many browsers. Additionally,
attempting to create a certificate authority with SHA-1 results in the following warning message in the UI: (#
25671)

The SHA-1 digest algorithm is no longer considered fully trustworthy by many browsers and, if
used, may result in security warnings being displayed.

l When a device is disabled or deleted through the Onboard BYOD self-service portal, active sessions for the
device are now terminated. (#15599)

The {php} Smarty tag is now deprecated. Please be aware that PHP is no longer allowed in editable templates. A
warning message will be displayed if you attempt to save a template that contains the {php} tag. Existing templates
that include this tag will not work. (#16900)

l An error message is now displayed if a user tries to onboard an Android or iOS device with a browser that is
not supported for that operating system (for example, iOS with Chrome, Dolphin, or Opera Mini). The
Onboard > Deployment and Provisioning > Provisioning Settings > Supported Devices tab
includes options to enable the browser check for Android and for iOS. For new installations, these options
are enabled by default. For existing installations, these options are disabled by default. (#17164)

l In the 6.5 release, a switchip is no longer necessary in order to reconnect a device after onboarding. The
device’s MAC address is all that is required. (#18599)
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l Onboard now provides the ability to specify different instructions for iOS and OS X provisioning. (#21007)

l Onboard now provides the ability to customize the iOS and OS X enrollment wizard’s post-login instructions.
(#21008)

l You can now filter devices by MDM enrollment status. AManaged By column was added to theOnboard
> Management and Control > View by Device list, and the Show Details link for the device displays all
endpoint attributes, MDM and otherwise. (#23877)

l Onboard now provides the ability to create certificates suitable for use as HTTPS server certificates. At
Onboard > Management and Control > View by Certificate, theHTTPS option is available as a
certificate type when importing or creating a code-signing certificate and can be used to filter the certificate
list. (#25301)

l Onboard can now use the same code-signing certificate for signing Windows applications and iOS and OS X
profiles. Profile-signing certificates are no longer needed and have been removed. (#25648)

l Certificates that are currently valid can now be deleted. This has the same effect as revoking them or
disabling the device. TheDelete Certificate option is available in the certificate’s row at Onboard
> Management and Control > View by Certificate. (#25741)

l Onboard certificates can now be provisioned in a browser for manual installation on devices that do not
have an Onboard client. To use this feature, go to Onboard > Deployment and Provisioning
> Provisioning Settings. The Supported Devices tab now includes aWeb-Based Provisioning section,
and the Instructions & Messages tab includes aWeb-Based Instructions section. (#25752)

l Onboard now provides the ability to onboard devices via social login. To use this feature, go to Onboard >
Deployment and Provisioning > Provisioning Settings > Web Login and scroll to the Social Logins
section. (#25754)

l The trusted servers configuration at Onboard > Configuration > Network Settings now defaults to the
automatic setting of only trusting the common names of servers in the ClearPass cluster. (#25767)

l Onboard now provides the ability to manually override device detection for scenarios where the device
cannot be accurately detected from the browser user agent. To use this feature, go to Onboard
> Deployment and Provisioning > Provisioning Settings. Both the Supported Devices tab and the
Instructions & Messages tab now include an Override Device Type Detection field. (#25815)

l A new page,Usage, was added underOnboard > Management and Control. This page displays usage
statistics for Onboard. Information shown here includes: (#25869)

n License Usage: Count representing a 30-day rolling average of the number of devices with valid
certificates

n Devices: For each device type, the number enrolled, not enrolled, and denied

n Certificates: For each CA, the number valid, expired, and revoked

l Support was added for the Chromebook System TPM Token certificate store. To use this feature, go to
Onboard > Deployment and Provisioning > Provisioning Settings > Supported Devices tab and
scroll to Chromebook Provisioning > Chromebook Token. (#26570)

OnGuard
l Support was added for the following products: (#26283, #26515, #28184, #28707)

n Altiris Agent 6.x (Windows)

n Avast Internet Security 10.x (Windows)

n Avast Security 2015 on Mac OS X

n Avira Antivirus Pro 15.x (Windows)



n uTorrent 3.x (Windows)

n Casper Suite 9.x (MacOSX)

n DELL Kace Agent 6.x (Windows)

n FileVault 10.10 (Mac)

n Kaspersky Internet Security 15.x (Windows)

n McAfee VirusScan Enterprise 8.8.x (Windows)

n Oracle VM VirtualBox 4.x (Windows)

n Sophos SafeGuard 7.x (Windows)

n Symantec Hosted Endpoint Protection 2.x (Windows)

n System Center Configuration Manager 5.x (Windows)

n VMware Player 5.x, 6.x, 7.x (Windows)

Support was enhanced for the following products:

n Avira Free Antivirus 15.x (Windows)

n Avira Mac Security 3.x (MacOSX)

n Bitdefender Antivirus Essential 1.x (Windows)

n ESET Endpoint Antivirus 6.x (Windows)

n FileVault 10.7.x (Mac)

n Kaspersky Total Security 15.x (Windows)

n McAfee VirusScan 18.x (Windows)

n Symantec Hosted Endpoint Protection 2.x (Windows)

Features Added in 6.5.2
l The VPN component of the ClearPass OnGuard Unified Agent was updated to match VIA 2.1.1.8. Some

important enhancements are: (#29017)

n Multiple DNS suffix support

n Split tunnel works in driver mode

For more details, refer the Aruba VIA 2.1.1.8 Release Notes on the Support site.

l For “Allow Only One Network Connection” and “Allow One Network Connection with VPN” configurations, if
more than one network connection type is selected and the ClearPass OnGuard Unified Agent detects more
than one network connection type, then OnGuard gives priority to network connections in the order they
were added to the list of allowed network connections. The first network connection that was added has
the highest priority and is retained, and all other connections are disabled or disconnected. (#29034,
#29488)

Features Added in 6.5.1
l The ClearPass OnGuard Unified Agent can now automatically upgrade without requesting the user’s

permission. It updates automatically if theUpgrade Action is set to Download and Install on the
OnGuard Settings page. (#27675, #27676)

l A new parameter, DESKTOPSHORTCUT, was added to the ClearPass OnGuard Unified Agent installer for
Windows. This parameter controls whether to create a desktop shortcut or not. A value of 1 will create a
desktop shortcut when OnGuard is installed; a value of 0 will not create the desktop shortcut. The default
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value is 1 (creates shortcut). To use this parameter to install OnGuard without creating a desktop shortcut
for it, use one of the following commands: (#27677)

n ClearPassOnGuardInstall.eye /DESKTOPSHORTCUT=0

n msiexec /i ClearPassOnGuardInstall.msi DESKTOPSHORTCUT=0

l TheOverride Server IPs field in OnGuard Settings now allows FQDN as well as IP addresses. This feature is
available in Policy Manager at Administration > Agents and Software Updates > OnGuard Settings
> Policy Manager Zones > Override Server IPs. (#27811, #27818)

Features Added in 6.5.0
l A new health class, File Check, was added for both Mac OS X and Windows OS to check for the presence or

absence of files. Auto-Remediation is not supported for the File Check health class. (#14032, #14034)

l The ClearPass OnGuard Unified Agent is now supported on Ubuntu OS. The ClearPass OnGuard Unified
Agent Installer for the Ubuntu OS can be downloaded fromAdministration > Agents and Software
Updates > OnGuard Settings. As part of support for the Ubuntu OS, the ClearPass OnGuard Unified
Agent user interface now has an OnGuard tab and a Common tab, and theDiagnostics tab now includes
Health Logs. Currently, only two health classes are supported for Ubuntu: Services and AntiVirus. Support
for the Persistent Agent for Ubuntu was added in the Beta 1 release. In the Beta 2 release, support was
added for the Dissolvable Agent, with Firefox supported on the Native Agent and Chrome supported on the
Java-based Agent. (#20656, #25267, #26493)

The system requirements, procedures, and rpm dependencies for OnGuard installation on Ubuntu are
shown below:

Supported Operating Systems

All Ubuntu flavors based on version 12.04 or above are supported.

Installing the ClearPass OnGuard Persistent Agent

(1) Ensure the system is up to date. Run the sudo apt-get update and then sudo apt-get

upgrade command.

(2) Make sure all rpm dependencies are installed (gksudo, gdebi library dependency) prior to OnGuard
installation.

(3) Download the Ubuntu ClearPassOnGuardInstall.tar.gz file and extract it.

(4) Select the binary installer provided for the target platform. For Ubuntu, use clearpass-onguard-
installer-< versionnumber>-ubuntu-i386 for 32 bit machines. Use clearpass-onguard-
installer-<version number>-ubuntu-x86_64 for 64 bit machines.

(5) Run the selected binary installer either by mouse click or from the terminal.

(6) When the installer starts, it asks for permissions for system changes with a password prompt.
Accept the End-user license agreement (EULA) and continue. The native installation mechanism
(debi) begins the actual installation.

(7) When the installation is complete, the installer closes and the ClearPass OnGuard Agent starts
automatically. If the installation fails, the installer displays installation logs for troubleshooting.

Uninstalling the ClearPass OnGuard Persistent Agent

To uninstall the application, run the sudo apt-get purge clearpass-onguard command from the
terminal.



Dependencies

The binary Installer and the application require the following packages:

n libc6 (>= 2.15)

n libdbus-1-3 (>= 1.0.2)

n libdbus-glib-1-2 (>= 0.78)

n libgcc1 (>= 1:4.1.1)

n libglib2.0-0 (>= 2.14.0)

n libgnome-keyring0 (>= 2.22.2)

n libnm-glib-vpn1 (>= 0.7.999)

n libnm-glib4 (>= 0.7.999)

n libnm-util2 (>= 0.7.0)

n libproxy1 (>= 0.4.7),

n libqtcore4 (>= 4:4.7.0~beta1)

n libqtgui4 (>= 4:4.6.1)

n libstdc++6 (>= 4.6)

n libtdb1 (>= 1.2.7+git20101214)

n libxml2 (>= 2.7.4)

n zlib1g (>= 1:1.2.0)

n gdebi

n gksu

l Two new fields were added in Patch Management configuration for Windows OS. TheGrace Period field
lets you specify a time interval during which the client will be treated as Healthy even if some patches are
missing. The Scan Interval field lets you specify the time interval after which the OnGuard Agent should
check for missing patches. (#24125)

l Authentication server IP addresses used by OnGuard persistent agents can now be manually configured. At
Administration > Agents and Software Updates > OnGuard Settings > Policy Manager Zones, the
user can configure an ordered list of authentication server IPs per zone. (#25836)
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Chapter 6
Issues Fixed in Previous 6.5.x Releases

The following issues were fixed in previous 6.5.x releases. For a list of issues resolved in the 6.5.3 release, see
"What’s New in This Release" on page 23.

Fixed in 6.5.2
The following issues were fixed in the 6.5.2 release.

Policy Manager

Bug
ID Description

#20004 A String data type for the GuestUser Role ID produced the database query error “Invalid input syntax for
integer”. The data type for the GuestUser Role ID is now Integer instead of String. After upgrade, the
admin should manually update the value for this tag in enforcement profiles with the appropriate integer
values.

#27850
#27967
#27969
#27971
#28026
#29183
#29209

This release includes fixes for CVE-2015-3653, CVE-2015-3654, CVE-2015-3655, CVE-2015-3656,
CVE-2015-3657, and CVE-2015-4649. For more information, refer to the Aruba Security Advisory
ARUBA-PSA-2015-009.

#27889 The user interface could not be launched if the certificate chain was built incorrectly (for example, if the
incorrect SUBCA was included in the chain). A new CLI command provides the option to reset the
HTTPS Server certificate and the RADIUS Server certificate. The user must provide confirmation in order
to reset the server certificate, since a restart of services is required after the certificate reset.
Usage:#system reset-server-certificate

#27977 Adding a role as a string caused the user’s role to be incorrect. In the TACACS Enforcement Profile, the
Auth-Status can now be set to either PASS_ADD or PASS_REPL in the TACACS+ Authorization response.

#28247 Corrected an issue where 0.0.0.0/1 was not allowed as a netmask length for device IP configuration.

#28360 The Apache httpd version is now upgraded to 2.4.12.

#28433 A start/stop operation or an IP address change could be executed in Server Configuration by a user with
insufficient privileges.

#28591 Policy Manager’s online help could be accessed even if the user did not have permissions to access the
user interface.

#28599 The RADIUS server crashed if the value of the NetBIOS Domain Name attribute was not set in the Active
Directory authentication source.

#28625 Change of authorization (CoA) did not work for a Juniper VPN client. ClearPass now uses the Access-
Request without Calling-Station-Id and with User-Name in order to send the CoA for the session.

Table 19: Policy Manager Issues Fixed in 6.5.2
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Bug
ID Description

#28634 Corrected issues with RADIUS server and policy server memory leaks. For more information, see #29125
and #29212.

#28663 New-line characters (<br>) were displayed in the login banner.

#28665 The Syslog LEEF (Log Event Extended Format) message format fields were updated to send additional IDs
and categories in LEEF messages.

#28686 More than 21 Palo Alto Firewall serial numbers could not be added in the Endpoint Context Server
configuration for the Palo Alto Networks Panorama server type.

#28714 The PostgreSQL version is now updated to 9.1.15. This includes fixes for CVE-2014-0067, CVE-2014-8161,
CVE-2015-0241, CVE-2015-0242, CVE-2015-0243, and CVE-2015-0244.

#28751 In server configuration, trying to drop a subscriber node failed if the file backup servers configuration
included the server that was to be dropped. A fix is also included for an issue that occurred when
restoring a backup taken with file backup servers that included ClearPass nodes that were not in the
cluster.

#28846 This release includes fixes for the Leap Second vulnerability. Insertion of the leap second is scheduled for
June 30th, 2015 at 23:59:60 UTC. For more information, refer to the Aruba Leap Second Field Bulletin at
https://support.arubanetworks.com/Documentation/tabid/77/DMXModule/512/Default.aspx?EntryId=519
2.

#28881 Static-IP-based profiling using NADClient configuration failed if the number of IP addresses to be scanned
was more than 100.

#28955 ClearPass 6.5.1 required the HTTP CONNECT method for certificate revocation list updates via proxy. The
Administration > Certificates > Revocation Lists form now includes an option to bypass the proxy
server.

#29080 The CP-HW-500 appliance could not be reached on the network. To avoid interface lockups, PCIE_
ASPM=off is now included in the grub configuration if it is missing.

#29125 A RADIUS server memory leak occurred while processing the Accounting-Request without the Calling-
Station-ID attribute in the accounting packets.

#29212 In a Switch User use case, WebAuthAHealth Requests from the OnGuard Agent caused memory leaks in
the Policy Server.

#29234 Corrected an issue that sometimes caused TLS tunnel failures between the client and ClearPass, leading
to authentication failures.

#29239 The default value for the cluster-wide service parameter “Free memory threshold value” has been
changed from 30% to 20% in this release. This was done to avoid false out-of-memory alarms that could
be generated, especially on CP-VA-500 and CP-HW-500 where 4GB RAM is available and some of the
processes pre-allocate around 2.5+ GB.

#29375 OpenSSL is now upgraded to version 1.0.1o-111. This includes fixes for CVE-2014-8176, CVE-2015-1788,
CVE-2015-1789, CVE-2015-1790, CVE-2015-1791, and CVE-2015-1792.

Table 19: Policy Manager Issues Fixed in 6.5.2 (Continued)
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CLI

Bug ID Description

#27841
#28578
#28612

Corrected an issue where, if a static route was deleted, the same route could not be added again.

Table 20: CLI Issues Fixed in 6.5.2

Endpoint Context Servers

Bug ID Description

#28609 The Event Viewer did not display the count of endpoint details for some servers. As part of the fix, new
Event Viewer messages were added.

#28610 If MobileIron MDM endpoints were deleted from the endpoint repository, ClearPass did not fetch their
device details at subsequent polling intervals.

#28729 An SSH handshake sometimes failed for a certificate with a DHE cipher.

#28748 ClearPass did not fetch attributes from Aruba Activate if the device details included any Unicode or non-
ASCII characters.

Table 21: Endpoint Context Server Issues Fixed in 6.5.2

Guest

Bug ID Description

#28656
#28988
#29379

The PHP version is now updated to 5.5.26. This includes fixes for CVE-2015-1351, CVE-2015-1352,
CVE-2015-2325, CVE-2015-2326, CVE-2015-3414, CVE-2015-3415, and CVE-2015-3416.

#28679 Corrected some issues with performance when there is a large number of accounts. Tag lookup
performance is now greatly improved in guest management queries.

#28690 Data migration failed during upgrade from 6.3.6 to 6.5.0 if there were outstanding certificate signing
requests in Onboard.

#28872 Twilio SMS did not work for international numbers. Please re-save any Twilio gateway you might have
configured.

#28899 ClearPass Guest did not honor the expiry_timezone field, and if timezone selection was enabled on a
form with the Expire After field, the timezone adjustment was made twice.

#28900 Corrected an issue where a timing problem could cause a social login on a subscriber node to fail.

#28905 The SMS gateway for EZ Texting did not work and returned a 404 error message. The API URL for the
EZ Texting SMS gateway has been updated.

Table 22: Guest Issues Fixed in 6.5.2
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Bug ID Description

#28947 Anonymous logins failed on a subscriber node if the publisher was not accessible.

#28973 The “Password matching complexity requirements” password generator did not check the list for
disallowed symbols.

#29030 Corrected an issue that caused a spurious warning to be logged in the Application Log when browsing
to a Web login page.

Table 22: Guest Issues Fixed in 6.5.2 (Continued)

Insight

Bug ID Description

#28317 Insight search drop-down lists were not populated if the search query took a long time.

#29226 This release includes fixes for CVE-2015-4650. For more information, refer to the Aruba Security
Advisory ARUBA-PSA-2015-009.

Table 23: Insight Issues Fixed in 6.5.2

Onboard

Bug ID Description

#28845 HTTP proxy settings were not provisioned correctly for iOS 8.3 devices.

#29105 Corrected an issue that prevented iOS reconnect when using a Cisco controller.

Table 24: Onboard Issues Fixed in 6.5.2

OnGuard

Bug ID Description

#28550 The ClearPass OnGuard Unified Agent for Windows caused high CPU usage when WmiPrvSE.exe was
launched.

#28552 The ClearPass OnGuard Unified Agent’s Controller Service crashed on the Windows OS.

#28705 The ClearPass OnGuard Unified Agent could not identify the latest disk encryption software version. As
part of the fix, the ClearPass OnGuard Unified Agent for Windows now supports Sophos SafeGuard 7.x.

#28817 In rare situations, the ClearPass OnGuard Unified Agent wrote an empty server IP in agent.conf,
causing OnGuard to crash.

#28981 The ClearPass OnGuard Unified Agent incorrectly reported the status of the System Center
Configuration Manager 5.x agent.

Table 25: OnGuard Issues Fixed in 6.5.2#



QuickConnect

Bug
ID Description

#28600 Onboarding failed on non-English Windows 8 systems.

#29437 When onboarding Windows devices, server certificate validation was not disabled even if the Validate
Certificate option was disabled at Onboard > Configuration > Network Settings > Trust.

Table 26: QuickConnect Issues Fixed in 6.5.2

Fixed in 6.5.1
The following issues were fixed in the 6.5.1 release.

Policy Manager

Bug ID Description

#20185 Routing could not be provided to VLANs that were created and attached to an MGMT or DATA
interface. The “network ip add” command now supports adding custom routes via a VLAN interface.

#22963 Corrected an issue where a cluster split-brain occurred during recovery of a failed publisher.

#26614 The Policy Manager user interface showed an incorrect license usage count. This occurred in a specific
deployment where CPPM was behind the load balancer and authentication requests did not include the
MAC address.

#26939 The error message “Guest application has exceeded recommended capacity...” was displayed in the
Event Viewer.

#27428
#28033

In the Service Rule area on the Configuration > Services > Edit page, the mouse cursor changed to
a pointer and none of the options were clickable.

#27445
#28032

On the Monitoring > Live Monitoring > Access Tracker page, the text in the Service column was
truncated if the service name was longer than 20 characters.

#27454 In some situations (for example, VIA authentication), the controller set the value of the Calling-Station-
Id attribute to 000000000000 and ClearPass treated it as a valid MAC address, which caused VIA +
Healthcheck to not work. Now if the client’s MAC address is all zeros, it is condidered an invalid
address, and the RADIUS server does not add any computed attributes for the MAC address. The
authentication should succeed. Instead of the MAC address, the username must be treated as a
session entry in the battery.

#27551 Validation for IP addresses is enhanced, correcting an issue where RADIUS services stopped if the
wrong IP address was added in Network Devices

#27586 When a network administrator changed the value of the cluster-wide parameter "Store Password Hash
for MSCHAP" to "false," ClearPass did not display a warning that the NTLM hashes for local and admin
users would be permanently removed.

#27615
#28037

Importing and exporting Google MDM type endpoint context servers did not work and, for the Google
MDM type, the Add Endpoint Context Server form had to be used to add the configuration manually
instead of using Import or Export. Importing and exporting endpoint context servers of the Google
MDM type is now fully supported.

Table 27: Policy Manager Issues Fixed in 6.5.1
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Bug ID Description

#27658 The Event Viewer gave false alerts if the authentication count exceeded the license capacity of the
CPPM node. The Event Viewer now displays the correct authentication count.

#27692 In a test scenario, the number of application licenses was doubled after a failover of the standby
publisher.

#27783 The user could not complete onboarding when the pre-auth type was configured as Application
Authentication. AppAuth now escapes the backslash character during deserialization of the Policy
Server response object so that the Access Tracker is populated with the request details.

#27787 Corrected an issue where Show Sysinfo showed incorrect values for the percentage of disk and
memory utilization.

#27870
#26964

If the Default (x servers) value of the set of subscribers in a cluster was selected in the Select
Server/Domain field at Monitoring > Live Monitoring > Access Tracker > Edit, the selection would
revert to the publisher if the date range was changed or if the user navigated to another page.

#27933
#27880

ClearPass sent an Access-Reject packet when the NAD retransmitted the RADIUS packet, even though
the Drop enforcement profile was configured.

#28009
#27937

Corrected an issue where, if the publisher and the standby publisher were in different subnets, the
standby publisher was not promoted to publisher during a failover.

#28030
#27630

The value in the FQDN field on the Administration > Server Manager > Server Configuration page
was not retained after restoring a backup.

#28079 If the Dashboard’s default layout was changed to a new layout, a widget that was used in the default
layout could not also be used in the new layout until it was removed from the default layout.

#28113 Users should be aware that ClearPass no longer supports uploading custom Nessus plugins at
Administration > Server Manager > Server Configuration, because the option was not used and
common practice is to use an external Nessus server instead.

#28135
#28130

Corrected an issue where the standby publisher would not take over from the primary publisher if
static routes were added.

#28155 ClearPass periodically rejected users if the LDAP connection was passively closed in “User Bind” mode.
ClearPass will now try again to establish a new connection to LDAP/AD after a bind fails due to a TCP
idle connection being passively closed by remote-end (AD/LDAP/Firewall).

#28205
#26652

Logs were inconsistent in the Access Tracker. The selected column list is now used to query the table
data.

#28288 Corrected an issue with performance regression in guest account lookups, where a steady decrease
was observed in the number of requests being processed.

#28319 If a ClearPass Evaluation license was expired, the login screen advised that it was expired but did not
provide an option to update it. An option to update the license is now provided at login.

#28406 OpenSSL is now upgraded to version 1.0.1m. This includes fixes for CVE-2015-0204, CVE-2015-0207,
CVE-2015-0208, CVE-2015-0209, CVE-2015-0285, CVE-2015-0286, CVE-2015-0287, CVE-2015-0288,
CVE-2015-0289, CVE-2015-0290, CVE-2015-0291, CVE-2015-0292, CVE-2015-0293, CVE-2015-1787.

#28573 Export for an authentication source of the RADIUS Server type failed with a Javascript alert at
Configuration > Authentication > Sources.

Table 27: Policy Manager Issues Fixed in 6.5.1 (Continued)



Dissolvable Agent

Bug ID Description

#27663
#27661

Users had to install a point patch to restore JRE after each update. The JRE installers are included in
ClearPass 6.5.1, and can be downloaded from the Java Dissolvable Agent help page after 6.5.1 is
installed.

Table 28: Dissolvable Agent Issues Fixed in 6.5.1

Endpoint Context Servers

Bug ID Description

#27666 Users could not create more than one Google Admin Console type context server. Users can now add
multiple context servers of the Google Admin Console type at Administration > External Servers
> Endpoint Context Servers.

#27815 Endpoint attribute information was not deleted when a device was reset in Aruba Activate. Endpoint
attribute are now deleted from CPPM when the corresponding attributes are deleted in the MDM
Context Server.

#28169
#28441

Endpoints could not be retrieved from the Google Admin Console. The “osVersion” attribute is now
changed to the “optional response” attribute in the MDM Connector.

Table 29: Endpoint Context Server Issues Fixed in 6.5.1

Guest

Bug ID Description

#27981 Operator profile permissions were not applied correctly to the Guest > Manage Accounts page
(report_users).

#27999 The PHP version is now upgraded to 5.5.22. This includes fixes for CVE-2015-0231, CVE-2015-0235,
CVE-2015-0273, CVE-2015-2305, and CVE-2015-2331.

#28200 Viewing an operator profile on a subscriber node would display an error instead of the expected list of
roles.

#28356 Corrected an issue with performance regression in guest account lookup.

Table 30: Guest Issues Fixed in 6.5.1

Insight

Bug ID Description

#27245
#28045

When a CPPM session was active, idle session timeout for Insight did not take effect.

#27597
#28028

The Insight search utility did not correctly display an error message if a user searched for a device by
username, but no username data existed.

#27741 Insight did not send email notifications for reports if the SMTP auth-method was CRAM-MD5.

Table 31: Insight Issues Fixed in 6.5.1
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Onboard

Bug ID Description

#27985 Corrected an issue with double-escaping in certain Onboard list views.

#28171 Corrected an issue that produced a SQL error in the Onboard > Management and Control > View
by Device page when a device without a MAC address was present in the database.

#28194 Corrected a creation error for the QuickConnect package that sometimes occurred while a
background cluster operation was running.

Table 32: Onboard Issues Fixed in 6.5.1

OnGuard

Bug ID Description

#27668 OnGuard did not select the correct patch management application on a system where two patch
management applications were installed.

#28075 The ClearPass OnGuard Unified Agent for Windows could not perform health checks if the hostname
included Chinese characters.

#28210 Certificate store access failed after updating the certificate. VIA now displays a certificate selection
window if a previously-selected certificate is either expired or deleted.

Table 33: OnGuard Issues Fixed in 6.5.1

Fixed in 6.5.0
The following issues were fixed in the 6.5.0 release.

Policy Manager

Bug ID Description

#20280 CPPM license usage counters in Graphite were not available on ClearPass 6.3.x.

#20639 The “Guest Access - Web Login PreAuth” and “Onboard Authorization - RADIUS” service
templates were removed. These two templates were replaced by the Onboard template.

#20788 Corrected a RADIUS server issue where rlm_device_sensor crashed if a burst of accounting
requests was sent that included device sensor information.

#21874 The Event Viewer page displayed an incorrect authentication count when the node authentication
capacity exceeded the licensing limit. The error was in the authentication count which was same as the
license capacity instead of the actual authentication count.

#22057 A device could not be disconnected after an AirGroup authorization request was received from the
client.

#22910 The Access Tracker on the publisher would hang if one of the subscribers was down. An error
message is now shown to let the user know if the nodes selected in the Access Tracker are
unreachable, so the user can remove the node and execute it again.

Table 34: Policy Manager Issues Fixed in 6.5.0



Bug ID Description

#23851 The Active Sessions data filter query that is used to get authentication details is now optimized to
retrieve information more quickly.

#24141 CentOS is now updated to version 6.6. This provides fixes for the kernel vulnerability CVE-2014-2523.

#24397 Using certificate namespace attributes in authentication source filters caused AD lookups to fail.

#24423 Mobile devices could not be polled from JAMF. The JAMF connector configuration is now reset after
each poll.

#24484 ClearPass could not be accessed through the CLI because logs used too much disk space. To fix this
issue:
l The new 'system cleanup' command performs on-demand cleanup.
l The 'system sysinfo' command provides information on the disk and memory utilization.
l The system checks the disk utilization every hour and purges data if the configured disk threshold

is met.

#24674 Incorrect error messages were shown after OCSP responses without nonce were rejected. The
appropriate messages are logged now when OCSP checks fail.

#24783 The CURL library is now updated to 7.19.7-37.3. This includes fixes for CVE-2013-4545.

#25112 ClearPass 6.5.0 now supports extended network traffic counters for database traffic (port 5432) and
HTTP and HTTPS web traffic (ports 80 and 443) between the nodes in the cluster. These counters also
increment during cluster operations that add or drop a subscriber, or promote a subscriber to a
publisher.

#25191 The event viewer failed to show an accurate SMTP delivery status for an email sent using the Send
Test Email action on the Administration > External Servers > Messaging Setup page.

#25197 This release includes fixes for a vulnerability issue where the CPPM version was displayed during the
launch of an SSH session in CPPM before authentication completed.

#25202 A space after a comma in a comma-separated whitelist host header configuration sometimes caused
the HTTPD service to stop.

#25305 Users were not able to filter the endpoint repository using an attribute name with '_' .

#25714 Users were not assigned the correct user role after a subscriber in a multi-node cluster was promoted
to a publisher.

#25732 Endpoint cache entries did not update correctly when endpoints were manually deleted in bulk.

#25733 Some of the guest accounts did not authenticate after CPPM was upgraded to the latest version.

#25737 The event viewer now logs start and end events for subnet scans for static IP device discovery,
providing enhanced visibility into the subnet scan process.

#25744 Corrected an issue where the error message “Can’t contact LDAP server” was shown intermittently.
CPPM will now reconnect once to the LDAP/AD server if the bind fails with the error code LDAP_
SERVER_DOWN during authentication.

#25860 The Policy Server service parameter "Authentication Cache Timeout" is removed in this release,
because Policy Manager does not use this parameter anymore.

#25878 Corrected an intermittent issue where users could not update the management/data port gateway IP

Table 34: Policy Manager Issues Fixed in 6.5.0 (Continued)
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Bug ID Description

address.

#25916 In the CPU Load screen, the Y-axis was labeled incorrectly. The CPU Load Y-axis now displays "Load
Average" instead of "Percentage."

#25983 The “Use Full Username” option is now supported for Palo Alto Networks UID updates.

#26048
#25196

OpenSSL is now upgraded to the latest version available. This includes fixes for CVE-2014-3511, CVE-
2014-3566, CVE-2014-3567, and CVE-2014-3568.

#26057 A warning message was not displayed when the RADIUS certificate expiration would occur within 30
days. The warning is now correctly displayed when the RADIUS certificate is about to expire.

#26112 The Dashboard’s Quick Links widget pointed to an incorrect link if Configuration > Network >
Devices or Administration > Server Manager > Server Configuration was selected.

#26178 The administrator was unable to insert a service in the OnGuard Posture Plugin configuration if the
service name included special characters.

#26182 The Analysis & Trending page showed an incorrect correlation of authentication count and time. This
occurred only if the user changed the time duration scale.

#26279 Authentications sometimes failed against an AD/LDAP server if the length of the user DN exceeded
255 characters.

#26370 Mobile devices were not updated from JAMF. The JAMF MDM connector configuration is now reset
after each poll.

#26377 Reject requests were not shown in red in the Access Tracker.

#26412 CLI-based enforcement failed on extreme switches.

#26499 Any changes made to the cluster password caused the syslog queries to the database to fail.

#26519 If a disabled node was part of a VIP configuration and it is in Enabled status during a “join back to
cluster” operation, then VIP service will be started automatically after the node joins back to the
cluster. The VIP service will be started after the node is made a subscriber and before it is promoted to
publisher (if that is selected).

#26660 Corrected a spacing issue between the application name and text in the Clearpass UI.

#26717 When configuring an SMTP mail server for email notifications with SSL enabled, server certificates
were not validated. Server certificate validation is now added for SMTP configuration with Connection
Security set to SSL.
To fetch Server Certificates, use the following configuration:
1. Go to Administration > External Servers > Endpoint Context Servers > Add.
2. On the Server tab, use the following values:

n Select Server Type = Generic HTTP
n Server Name = smtp.gmail.com
n Server Base URL = https://smtp.gmail.com:465
n Validate Server = Mark the Enable check box to validate the server certificate.
This fetches the server certificate, and a Certificates tab is added to the form, where you can see
the certificate listed.

3. Click Save.

#26723 Downloading skins from the Administration > Agents and Software Updates > Software Updates

Table 34: Policy Manager Issues Fixed in 6.5.0 (Continued)



Bug ID Description

page failed with a Download Stuck error.

#26745 The error message that was displayed at Monitoring > Event Viewer did not provide enough
information when a RADIUS server failed to start due to an expired server certificate.

#26850 This release includes fixes for CVE-2015-1389, a cross-site scripting vulnerability that could permit an
unauthenticated user to inject script code that could be executed by a ClearPass administrator while
inside an administrative session.

#26891 Corrected an issue with server certificate validation by retrieving the Certificate Extension Values like
Subject Key Identifier and Authority Key Identifier while the Certificate Chain for Radius Server
Certificate and Https Server Certificate were being built.

#26933 Users should be aware that, during upgrade to 6.5, the AntiVirus check in the Linux Posture Policy will
not be restored by default. The administrator must manually reconfigure AntiVirus checks for Linux
systems if they are required. A message is now displayed in the UI advising the user of this.

#26946 Performance is now improved for Active Directory error handling. Now the Domain Service is not
restarted when authentication fails with the following error codes:
l 0xC000006D - STATUS_LOGON_FAILURE
l 0xC000006E - STATUS_ACCOUNT_RESTRICTION
l 0xC000006F - STATUS_INVALID_LOGON_HOURS
l 0xC0000071 - STATUS_PASSWORD_EXPIRED
l 0xC0000072 - STATUS_ACCOUNT_DISABLED
l 0xC0000064 STATUS_NO_SUCH_USER
l 0xC000006E STATUS_ACCOUNT_RESTRICTION
l 0xC000006C STATUS_PASSWORD_RESTRICTION
l 0xC000006A STATUS_WRONG_PASSWORD
l 0xC0000193 STATUS_ACCOUNT_EXPIRED
l 0xC000006F STATUS_INVALID_LOGON_HOURS
l 0xC0000234 STATUS_ACCOUNT_LOCKED_OUT
l 0xC0000224 STATUS_PASSWORD_MUST_CHANGE

#27103 Attempting to integrate a Vasco Identikey Authentication server with Clearpass 6.5.0 using Vasco as a
Radius Authentication source failed. The RADIUS server is now modified to integrate with the Vasco
IdentiKey Authentication Server.

#27171
#27112

CPPM updates to PANW did not update the NETBIOS name for users.

#27298 This release includes fixes for multiple cross-site scripting vulnerabilities that existed within ClearPass
and that could be used by one authenticated administrative user to inject script code into the session
of another administrative user.

#27336 The IPSec tunnel was not reestablished when configuration parameters such as the IKE version or
hash algorithm were modified.

#27342 Usage of port 4231 in the External Netevent Target URL is removed in 6.5. To specify an external
Insight server, use http://<CPPM-IP-Address>/netwatch/netevents in the Target URL.

Table 34: Policy Manager Issues Fixed in 6.5.0 (Continued)
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Bug ID Description

#27497 If the default “admin” or “apiadmin” account’s name or user ID was changed, it reverted to the default
after upgrade. ClearPass now gives a validation error in such cases.
Users should be aware that ClearPass 6.5.0 does not support any changes to the name or ID of the
default admin user (admin, apiadmin). If these values were changed in previous versions of ClearPass,
they will be reset to their original default values upon upgrading to ClearPass 6.5.0. (The password will
be carried forward as in the previous version.)

#27532 The glibc package was updated. This includes fixes for CVE-2015-0235.

#27857 Users should be aware that, to enable upgrade from 6.2 or 6.3 now that the 6.5 upgrade image is DER-
signed, the CPPM-x86_64-20140919-cli-der-support patch update is now required before upgrading
from ClearPass 6.2.6 or 6.3.6 to 6.5.0. The patch is available in the Software Updates portal and the
support site.

Table 34: Policy Manager Issues Fixed in 6.5.0 (Continued)

AirGroup

Bug ID Description

#26361 Corrected an issue where a dot (".") character was not permitted in an AP-Name used for AirGroup
sharing rules.

Table 35: AirGroup Issues Fixed in 6.5.0

CLI

Bug ID Description

#25669 Users should be aware that the 'network app' command is now deprecated in the CLI as it is no
longer needed.

Table 36: CLI Issues Fixed in 6.5.0

Dissolvable Agent

Bug ID Description

#25871 Users should be aware that the Java-based OnGuard Dissolvable Agent does not display remediation
results unless the latest version of Java is installed on the client. This is the expected behavior, and
reflects ever-changing Java security policies. The latest Java version is always required in order to
perform client health checks.

#27239 The Native Dissolvable Agent for Mac OS X displayed the warning “ Identity of the developer
cannot be confirmed” during launch.

Table 37: Dissolvable Agent Issues Fixed in 6.5.0



Endpoint Context Servers

Bug ID Description

#24170 CPPM was unable to fetch Endpoints from Maas360. This issue was observed only for endpoints that
had wired interfaces.

#25470 Improvements to the requests library resolved an issue where the Clearpass server was unable to
retrieve information from an MDM simulated server when proxy was configured on the CPPM Server.

#25498 All endpoint types were downloaded from Aruba Activate, even though a filter for Aruba Active MDM
was configured in Administration > External Servers > Endpoint Context Servers that limited the
download to remote and instant APs.

#26996 Corrected an issue that occurred while configuring Administration > External Servers > Endpoint
Context Servers.The ClearPass Cloudy Proxy option listed in the Server Type drop-down list is now
disabled.

#27005 An issue with multiple occurrences of TCP connections while polling MDM Servers from MDM
Connector was resolved by upgrading the library.

27640 Additional ContextServers could not be added if the same ServerName was used for both and the
base URL was different. The ServerName can now be configured as the proper HostName or IP
address for MDM ContextServers.

Table 38: Endpoint Context Server Issues Fixed in 6.5.0

Guest

Bug ID Description

#14368 Page action links were not displayed correctly if a custom skin was used as the non-default skin.

#19568 Database errors occurred when RADIUS accounting data was sent to a server that did not process the
RADIUS authorization (access-request). This issue was triggered when a session had RADIUS accounting
data but did not match any authentication records.

#22011 Firefox could not save or auto-complete passwords. This prevented the username and password of the
operator be auto-filled in various configuration forms, such as the Edit Account form.

#25135 Guest sponsorship approval could be incorrectly configured to allow role override when operator
authentication was disabled.

#25327 Unwanted JavaScript appeared in emails when certain skins were used.

#25339 Messages sent using the SMS Global SMS gateway were not encoded according to the gateway’s
requirements.

#25343 This release includes fixes for CVE-2014-6628, a vulnerability issue that permitted an authenticated
administrative user to execute arbitrary uploaded code on the underlying operating system with the
privilege level of the Web server.
As part of this fix, the ability to run PHP within Guest's custom pages has been removed. If you
previously ran PHP from Content Manager or within a login or registration page, you should contact
Aruba Support for assistance.

The ability to run PHP within the custom pages for ClearPass Guest has been removed.

#25639 The contents of folders under CPGuest > Config > Content Manager > Public could not be deleted.

Table 39: Guest Issues Fixed in 6.5.0
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Bug ID Description

#26103 The initial state of the account was incorrect if a role override for sponsored registrations was set to
[Prompt].

#26258 The value for the IdP-Cookie-Timeout-Mins attribute was applied as seconds instead of minutes.

#26327 To improve performance of Web login pages, Advertising Services can now be selectively enabled or
disabled from either Configuration > Pages > Web Logins or Configuration > Pages > Guest Self-
Registrations > Master Enable.

#26371 Operating as a SAML Identity Provider (IdP) failed due to browser redirection issues.

#26400 Changing a guest account role on the Guest > Manage Accounts > Edit Account form did not trigger
an appropriate CoA request for active sessions. To configure CoA requests to handle changes in guest
roles, the admin must create CoA profiles in the correct format:
1. At Policy Manager > Configuration > Enforcement > Profiles > Add, on the Profile tab, select

RADIUS Change of Authorization (CoA) in the Template drop-down list.
2. In the Name field, the name entered for the profile must include the exact role name in square

brackets. For example, for the role “[Guest]”, the profile name might be “My Company [Guest] CoA”.
3. On the Attributes tab, select Aruba - Change-User-Role in the Select RADIUS CoA Template

drop-down list.
4. Click a row and add an attribute with the Type as Radius:IETF, and for the Value enter the role

name, but without the square brackets this time.

#26401 On Guest > Manage Devices, disabling or deleting an account did not disconnect an active session for
the device. Disabling or deleting a device account now triggers a session disconnect for all active
sessions associated with the account.

#26444 Enabling a Web login security hash did not work for Apple devices. Devices are now verified and
authenticated successfully when the same hash is present in the Web login and the controller.

#26489 A RADIUS CoA from Active Sessions did not work due to proxy settings being used incorrectly by internal
communications.

#26889 On the Active Sessions list, if the Role column was added, it was not populated with the authenticated
devices. The Role column now shows the device’s role for authenticated devices. If there is a CoA,
however, this column is not updated.

#26941 This release includes fixes for CVE-2015-1551, a vulnerability that permitted an authenticated
administrative user to read information which he or she may not be authorized to read by uploading
content which exploits a bug that fails to enforce proper file path restrictions.

#27273 Device accounts that are paired with guest accounts that require sponsorship are now updated when
sponsorship confirmation is received.

#25368
#26073
#26393
#27050
#27478

The PHP version is now updated to 5.5.21. This includes fixes for CVE-2014-2497, CVE-2014-3538, CVE-
2014-3587, CVE-2014-3597, CVE-2014-3668, CVE-2014-3669, CVE-2014-3670, CVE-2014-3710, CVE-
2014-4698, CVE-2014-4670, CVE-2014-5120, CVE-2014-8142, CVE-2014-9427, CVE-2015-0231, and CVE-
2015-0232.

#27506 The active session was not disconnected for the user if the expiration time was set to "now". For an
active session, a role-change CoA attempt will be made if there is an applicable profile, and no CoA will
be sent if the user expiration time is extended.

Table 39: Guest Issues Fixed in 6.5.0 (Continued)



Bug ID Description

#27595 The bypass CNA configuration sometimes failed on the subscriber.

#27606
#27607

If a proxy was configured, ClearPass Guest used it incorrectly when contacting the publisher. ClearPass
requires direct access to all other servers in the cluster.

#27628 The random password generator allowed some inappropriate words.

Table 39: Guest Issues Fixed in 6.5.0 (Continued)

Insight

Bug ID Description

#20096 Authentication records could not be updated in the auth table of the Insight DB. To fix this issue, the 20-
character limit for the field has been removed and the data type of the “ip” column is changed to Text.

#25306 Headers on a PDF report were not displayed correctly. Column headers are now displayed only at the
beginning of the table.

#25476 Uploaded Images were not correctly displayed in Insight reports in PDF and HTML formats.

#26157 Corrected an issue where including special characters (such as the '=') in a cluster password caused
upgrades to fail.

#26988 This release includes fixes for CVE-2015-1550, a vulnerability that permitted an authenticated
administrative user to execute arbitrary uploaded code on the underlying operating system with the
privilege level of the Web server.
As part of this fix, report names now cannot contain characters such as a slash ( / ) or two sequential
periods ( .. ).

#27300 This release includes fixes for CVE-2015-1392, multiple SQL injection vulnerabilities that existed within
ClearPass. An administrative user with a lower privilege level could have leveraged these
vulnerabilities to read information that should only be available at a higher privilege level.

Table 40: Insight Issues Fixed in 6.5.0

Onboard

Bug ID Description

#21010 Auto-reconnect is not supported for Mac OS X, and the Provisioning Settings forms are updated to
reflect this.

#24553 When you connect to ADCS to issue an Onboard certificate, the server certificate is verified against the
CPPM Trust list.

#24879 The ClearPass Endpoint profile now correctly displays the device family for Ubuntu and Chromebook
devices.

#25132 The iOS Settings > Settings Type > Create and Cancel buttons both initiated the Create function.
The Cancel button now works correctly.

#25291 To address an issue where Mac OS X systems with no airport card failed onboarding with a “Profile
installation failed” error, the console application now displays the error message "mdmclient: No
wireless interface was found."

Table 41: Onboard Issues Fixed in 6.5.0
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Bug ID Description

Users should be aware that configuring wired networks with Mac OS X is only supported when the Mac
has a Wi-Fi adapter (AirPort card or similar), otherwise the profile installation will fail with the message
"Profile installation failed. The 'Wi-Fi Network' payload could not be installed. The Wi-Fi network either
could not be found, or could not be connected. You may need to try to reconnect at a later time." This
is due to system limitations of Apple’s device provisioning process.

#25364 Corrected an issue that prevented the generation of EC keys in Onboard.

#25484 The requirement to have a network configured to enroll Chromebook devices in Onboard has been
removed, since there is no network configuration done on Chromebook.

#25667 An incorrect signature algorithm was used with certificates using the SHA-2 family of signature
algorithms.

#25671 The default configuration for a newly installed or created Onboard Certificate Authority (CA) is
updated to use the SHA-512 digest algorithm. The SHA-1 cryptographic hash algorithm is not
recommended for SSL or code-signing certificates. Its use is being deprecated by major providers, and
it will soon be untrusted for code-signing certificates. More information is available at sites such as
http://googleonlinesecurity.blogspot.com/2014/09/gradually-sunsetting-sha-1.html and
http://blogs.technet.com/b/pki/archive/2013/11/12/sha1-deprecation-policy.aspx.

#25812 The Onboard device incorrectly displayed the marketing model names of iOS devices instead of the
internal product numbers of the device.

#25909 A Windows client failed to sign the Aruba QuickConnect application in FIPS mode.

#26350 Options to control reconnect behavior are no longer included in the Provisioning Settings form. For
iOS, reconnect behavior is now automatic when Insight is enabled and the same SSID provisioning is
used, and is disabled otherwise.

#26558 The UI navigation to Onboard > Deployment and Provisioning > Provisioning Settings did not
work correctly when the Aruba ClearPass skin was used.

#26601 Onboard incorrectly displayed a warning message about RADIUS server certificates missing the id-kp-
eapOverLAN key usage even when the server certificate specified “Any Extended Key Usage”.

#27349 Onboard enrollment failed against the latest version of ADCS on Windows 2008.

#27365 For non-Apple devices, the device type was displayed as “None” if ADCS was used for issuing client
certificates. When signing a client certificate with ADCS, Onboard now records the device information
against the certificate, even when the certificate itself does not embed this information.

#27369 Duplicate device entries sometimes caused re-enrollment to fail.

#27455 When SSO was configured for Onboard, the “Unsupported Device” informational text was not
displayed correctly. Error messages are now correctly displayed when SSO is configured.

#27746 QuickConnect.exe could not be downloaded successfully on legacy versions of Internet Explorer.
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OnGuard

Bug ID Description

#6012 The ClearPass OnGuard Unified Agent for Windows now categorizes virtual Interfaces such as
VMware Network Adapter VMnet8 as Other instead of Wired.

#20279 On Mac OS X, the ClearPass OnGuard Unified Agent’s Quit and Force Quit options sometimes did not
work and the machine would not restart.

#25081 The Access Tracker showed a status of Service even after the Service was removed from the Posture
Policy configuration.

#25843 A disk encryption check failed due to a trailing backslash character (\) in the location path.

#25848 Network administrators were unable to uninstall OnGuard silently (without startup confirmation or
uninstall status messages) using an MSI package.

#25906 The ClearPass OnGuard Unified Agent failed Disk Encryption Checks for PGP on Mac OS X.

#26275 On Mac OS X 10.10, after changing the mode on the CPPM server the ClearPass OnGuard Unified
Agent would not relaunch.

#26300 The ClearPass OnGuard Agent now performs health checks every time system wakes up from
hibernation/sleep mode.

#26369 The ClearPass OnGuard Unified Agent caused delays in loading the desktop after rebooting the
Windows OS.

#26513 The Native Dissolvable Agent for Windows did not send health for Windows Security Health Validator.

#26613 The following method has been added for mass deployment environments that need MSI based
solution to uninstall. (msiexec /i ClearPassOnGuardInstall.msi CLEANUP=1 /q)

#26669 The ClearPass OnGuard Unified Agent was unable to detect Casper Suite Patch Agent.

#26808 The ClearPass OnGuard Unified Agent was unable to detect Korean applications for the Installed
Applications Health Class in the Korean Windows OS.

#26844 The ClearPass OnGuard Unified Agent in the OnGuard Activity > Bounce Agent option displayed an
incorrect message in the Korean language.

#27011 The ClearPass OnGuard Unified Agent displayed an incorrect disk encryption state while using
FileVault.

#27183 The ClearPass OnGuard Unified Agent for Mac OS X was not able to launch processes while
performing auto-remediation of the Processes health class on Mac OS X 10.10.

#27207 A user could not log in to ClearPass using a client certificate with a chain length of more than one. The
depth of the client certificate chain validation has now been increased.

#27374 During installation of the ClearPass OnGuard Unified Agent, the message “Windows cannot verify the
publisher of this software” was displayed.

Table 42: OnGuard Issues Fixed in 6.5.0
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QuickConnect

Bug ID Description

#21736 The ClearPass QuickConnect application on an Android device no longer displays errors when a user
manually launches the application and selects a configured network.

#25216 Corrected an issue where Onboarding failed for Mac OS X 10.6.8.

#25323 Onboarding failed on a Korean Windows system when virtual interfaces were present.

Table 43: QuickConnect Issues Fixed in 6.5.0
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Chapter 7
Known Issues Identified in Previous Releases

The following known issues for this release were identified in previous releases. Workarounds are included
when possible. For a list of known issues identified in the ClearPass 6.5.3 release, see the What’s New in This
Release chapter.

Policy Manager

Bug ID Description

#10881 Entity updates with PostAuth enforcement fail if the publisher is down.

#11744 Symptom: Upgrading from 5.2 to 6.x fails if CPPM is joined to the domain.
Scenario: The issue will not be seen if the latest cumulative patch is installed before performing the
upgrade.

#11906 Symptom: The Aruba dictionary becomes disabled by default after upgrading from Policy Manager
4.x to 6.0.1.
Workaround: Customers who run into this issue must enable the Aruba dictionary manually from the
Administration > Dictionaries page.

#12316 Syslog Filters and Data Filters configuration will be removed after an upgrade. Policy Manager does
not carry forward Syslog Filters and Data Filters configuration. Only default data is migrated.

#13645 Authorization attributes are not cached for the Okta authentication source.

#13781 Symptom/Scenario: In the 6.1 release, the default unit for the CRL update interval was changed to
“hours” from an earlier default unit of “days”. Restoring a 5.x backup on CPPM 6.x causes the update
interval to be “hours”. For example, “2 days” in 5.2.0 becomes “2 hours” in 6.1.0.
Workaround: Manually change the value in days to the value in hours. In the above example, that
would be 48 hours.

#13999
#13975

In order to add or update a PostAuth profile configuration, the admin must first delete old profiles from
CPPM, and then add the new/updated profiles.

#14186 Symptom: Post auth doesn’t work properly for UNKNOWN endpoints in a MAC Authentication Bypass
(MAB) flow.
Scenario: This has been observed if the user tries to connect using an endpoint that is unknown to
CPPM.

#14190 Symptom: Blacklisted MAC Authentication Bypass (MAB) users cannot be blocked using the Blacklist
User Repository.
Workaround: In order for post auth to work in a MAB flow, a new blacklist repository must be added
with a custom filter.

#17232 Symptom/Scenario: The error and warning messages returned by the Web service are displayed in
English instead of the localized language.

#18064 Symptom: AirWatch custom HTTP actions needs content even though it’s not required.
Scenario: For AirWatch MDM, custom-defined HTTP actions such as Lock Device or Clear Passcode
fail with error messages. This is due to a bug in AirWatch.
Workaround: Do either of the following:
l Add a header Content-Length:0 in the Context Server Action.

Table 44: Known Issues in Policy Manager
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Bug ID Description

l Add a dummy JSON data {“a”:”b”}.

#18701 Symptom/Scenario: Performing an AddNote operation using AirWatch as the MDM connector fails in
CPPM. This is due to a bug in AirWatch.

#19176 CPPM does not currently support posting of Palo Alto Networks (PANW) user ID information when the
PAN OS uses Vsys.

#19826 Palo Alto Networks (PANW) devices will only accept the backslash character ( \ ) as a separator
between the domain name and the username.

#20292 Symptom/Scenario: On the Monitoring > Live Monitoring > System Monitor page, the Last
updated at field displays time based on the time zone of the ClearPass node where the user is
viewing the page.

#20383 The system posture status may still be maintained after Post Auth agent disconnect action. This is
likely to happen when Posture result cache timeout service parameter is higher than the Lazy handler
polling frequency.

#20416 Symptom: The Palo Alto Networks (PANW) operating system firewall rejects user ID updates from
CPPM when the user ID limit is reached on the firewall. When this happens, user ID updates are
rejected with errors.
Scenario: This occurs when the PANW firewall exceeds its supported limit advertised for user ID
registration.
Workaround: There is no workaround at this time.

#20453 In order for CPPM to have complete data to post to Palo Alto Networks devices in HIP reports, profiling
must be turned on. This is the expected behavior.

#20455 Symptom/Scenario: When doing an SSO & ASO flow in Safari browsers, the certificate needs to be
added in the trust list of the browser.
Workaround: Please follow these steps:
1. Open the Safari browser and enter the SP URL.
2. After you enter the SSO application in the browser, the Show Certificate option is provided in a

popup window.
3. Click Show Certificate and select the “Always trust ‘FQDN of SP machine’ when connecting

to IPaddress” check box, and then click the Continue button.

#20456 Symptom: SNMP bounce fails.
Scenario: When only the SNMP bounce in the SNMP Enforcement profile of a Web auth service is
configured, SNMP bounce functionality does not work.
Workaround: Also configure a VLAN ID along with the SNMP bounce in the SNMP enforcement profile.

#20484 Symptom: Dropping the Subscriber and then adding it back to the cluster may fail at times.
Scenario: CPPM system time might not have been synchronized with an NTP source.
Workaround: Configure an NTP server. CPPM will synchronize its time with the NTP source. Attempt
the cluster operation.

#20489 Symptom/Scenario: CPPM 6.3 does not allow a server certificate with a Key Length of 512 bits as
seen in the Self-Signed Certificate and Certificate Signing Request UIs. Earlier CPPM versions did not
have this restriction, hence their server certificate may use one with a 512 bit Public Key. After
upgrade, these servers will not work properly.
Workaround: The admin must manually fix the server certificate to allow a minimum of 1024 bits long
Public Key prior to upgrade.

#20943 Symptom/Scenario: After upgrading from 6.2.0 to 6.3.0, the WorkSpace Attributes under Service
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Rules, Role Mapping, and Enforcement Policy Rules are not updated. In 6.2, under Enforcement Policy
> Rules, the WorkSpace Dictionary Items are used with Application:WorkSpace:<Attribute>. In 6.3 this
is changed to Application:ClearPass:<Attributes>.

#21334 Symptom: CPPM does not launch.
Scenario: The ClearPass user interface will not launch from Firefox or from older versions of Internet
Explorer (IE) browsers if an EC-based HTTPS server certificate is used. On Firefox, the error message
“Secure Connection Failed. An error occurred during a connection to <server>. Certificate type not
approved for application” is displayed. On older versions of IE, the error message “Internet Explorer
cannot display the Web page” is displayed.
Workaround: Use the latest version of IE, or the Chrome browser instead.

#22023 Symptom/Scenario: Launching the customer's ClearPass user interface through a proxy does not
work on the Internet Explorer or Safari browsers.
Workaround: Use the Chrome or Firefox browser instead.

#23581 Symptom: A database connection error occurs in the Access Tracker UI when it is updated to 6.3.2
with MD2 server certificates.
Scenario: This is a database connection problem because of the MD2 certificate available for
PostgreSQL. MD2 is not supported.
Workaround: After updating to 6.3.2 (patch installation from 6.3.0), if Access Tracker or Analysis &
Trending show errors relating to database query errors, it can be due to an invalid Server Certificate.
1. Go to Server Certificate and select the certificate for the server and RADIUS service.
2. Click View Details for each certificate in the chain.
3. Look for the Signature Algorithm and check to see if it uses MD2.
4. Download the certificate that is MD5 or SHA1-based algorithm to replace the MD2 algorithm from

the corresponding Certificate Authority site.
5. From the Support shell, restart the cpass-postgresql service.

#23625 Symptom: Restoring the log DB in 6.3.2 overwrites existing event viewer entries.
Scenario: In 6.3.2, restoring the log database alone (without configuration database restoration) from
a backup results in the Event Viewer entries being overwritten with the ones from the backup. This has
occurred in cases where the log database is restored manually after the upgrade.
Workaround: There is no workaround at this time.

#23848 Symptom: The ClearPass server’s time setting might sometimes be off by as much as eight hours.
Scenario: This is due to a known issue with VMware tools, which periodically checks and synchronizes
time between the host and the guest operating systems. This issue is documented by VMware at
http://pubs.vmware.com/vSphere-50/index.jsp?topic=%2Fcom.vmware.vmtools.install.doc%2FGUID-
C0D8326A-B6E7-4E61-8470-6C173FDDF656.html.
Workaround: There is no workaround at this time.

#24646
#24919
#26698
#27379
#27568

Symptom/Scenario: There are some issues on Internet Explorer 9 (IE 9), including:
l The login banner is not centered and the footer is not placed at the bottom of the page.
l The IE browser fails to display an error message if connectivity is lost with the ClearPass Policy

Manager server.
l The scroll function does not work in the pop-up that opens from the Monitoring > Audit Viewer

page.
l ClearPass Policy Manager and Insight do not work properly on IE 9.
l The Save operation gets stuck when you try to save the server configuration changes using the IE

browser.
Workaround: Use IE 10 or IE 11 or the Firefox or Chrome browsers instead. Users should be aware
that ClearPass supports IE 10 and later on Windows 7 and Windows 8.x.

#24781 Palo Alto Networks (PANW) devices accept only the backslash ( \ ) character as a separator between
the domain name and the username. If the update uses an “at” sign ( @ ) between the domain name
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Bug ID Description

and the username, the HIP report will not be shown in PANW.

#25211 Symptom/Scenario: When messages are sent using the Send Message option, messages are not
received on the end points enrolled with SAP Afaria MDM Server.

#25720 Symptom/Scenario: The Dashboard shows the server as being down if an HTTPS server certificate is
signed by OnBoard CA using SHA-256.
WorkAround: Be aware that SHA1 RSA is not recommended for security reasons. You must update
your certificates to use stronger keys, such as RSA with > 1024 bits length.

#27306 Whenever IPSec configuration is changed on either end of the tunnel (Wireless Controller or
ClearPass), after the changes, the ClearPass IPSec service should be restarted in ClearPass from
Services Control to establish the IPsec tunnels reliably. After restart, verify the status of the IPsec
tunnel from the Network tab at Administration > Server Manager > Server Configuration.

#27592 Symptom: SAML-SSO using TLS certificate does not work in Firefox or Safari browser.
Workaround: Use alternate browsers such as Google Chrome or IE.

#27621 Symptom: The number of authentications per second for non-MSCHAPv2 methods is reduced when
the Local User or Admin User authentication sources are used.
Scenario: Local and admin user passwords are now stored as non-reversible PBKDF2 based hashes. A
side-effect of this change is reduced performance in password-based authentications (for example,
PAP, GTC, WebAuth, or TACACS+) against the Local User and Admin User authentication sources.
Refer to product documentation for the latest performance numbers.
Authentications against external authentication sources such as AD or external SQL are not affected
by this change.

#27737 Symptom/Scenario: Session Restriction Enforcement is not converted to Session Notification if
Session check User name is configured.
Workaround: Configure a new Session Notification Enforcement as shown below and associate it with
the service:
l Session-Notify Server Type = Palo Alto Networks Firewall
l Session-Notify Server IP = <IP ADDRESS>
l Session-Check Username = %{Endpoint:Username}

#27745 Symptom: Some CPPM Dashboard widgets do not work properly.
Scenario: On the CPPM Dashboard, some widgets (for example, All Requests) do not display
information correctly when dragged onto the Dashboard windows. This happens with the Internet
Explorer 9 browser.
Workaround: Use the Firefox or Chrome browser instead.

#27895 Users should be aware that, because of schema changes now that ClearPass supports storing
irreversible passwords, any import of old authentication sources using XML files will break the
required SQL filters. Avoid any import of old authentication source configuration as this causes
authentication failures for guest users and admin users.

#27903 Symptom/Scenario: Trying to upgrade from 6.2.6 to 6.5.0 using the Import Updates option on the Soft-
ware Updates portal does not work, and the error message “Uploaded file is invalid...” is displayed.
Workaround: Use either the CLI or Web server option instead to perform the upgrade.

#27908 If you will be upgrading through the CLI and are upgrading from 6.4.0 or 6.4.1, you must update to
6.4.2 or later before upgrading to 6.5. This is due to the changes in the signing mechanism of the
updates and upgrade images. Prior to updating to 6.4.2, you must first download and install the 6.4.0
CLI updates patch. At support.arubanetworks.com, go to Download Software > ClearPass > Policy
Manager > Current Release and select CPPM-x86_64-20140919-cli-der-support-patch.
If you are upgrading through the Software Updates portal in the Policy Manager user interface, or
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through the Web service, upgrade is supported for any 6.4.x version.

#27922 Symptom: TACACS/WebAuth authentication fails and shows an internal error.
Scenario: In some upgrade cases the services might not come up properly on subscriber nodes,
resulting in Webauth/TACACS Authentication Failures. The Access Tracker > Session Details form
shows the internal error message “Failed to authenticate user”,
Workaround: Manually restart the corresponding services that cause the failures.

#28417 Symptom: Updating the DNS settings through the UI causes the application to hang and the error
message “Error processing request. Please retry” is displayed.
Scenario: If the DNS settings are updated at Administration > Server Manager > Server
Configuration, all services are restarted and the UI session is lost.
Workaround: Wait a moment to let the Admin server restart, and then refresh the UI and log in again.

#28575 Symptom: The Edit and Delete actions in service templates might not work.
Scenario: This happens only for services created in 6.4.x and after upgrade to 6.5.0.
Workaround: Service and related entities should be edited or deleted manually.

#28991 Symptom/Scenario: Endpoint context server updates fail after Palo Alto Networks firewall is
upgraded to PAN-OS 7.0.
Workaround: Downgrade back to PAN-OS 6.x.

Table 44: Known Issues in Policy Manager (Continued)

Dissolvable Agent

Bug ID Description

#7165 To have health data collection work correctly in 64-bit Windows 7, please use the JRE version provided by
CPPM. It can be downloaded from the following URL:
https://<CPPM-IP-Address>/agent/html/help.html

#18031 Symptom: The OnGuard Web Agent does not work with Chrome on Mac OS X with Java 7 or 8 installed.
Workaround: The Java plugin is now deprecated in Chrome 42.x and above. This is an issue with
Chrome, not with ClearPass.
Use the Firefox, Internet Explorer, or Safari browser.

#18035 Symptom: The OnGuard Web Agent applet fails to launch on Mac OS X 10.9.
Scenario: New security restrictions in Mac OS X 10.9 and Safari 7 prevent the launch of the OnGuard
Web Agent.
Workaround: Go to Safari menu > Preferences > Security > Allow. Allow plugins should already be
selected. Click Manage Website Settings, look for your portal Web site IP/name, and select Run in
Unsafe Mode.

#18230 Symptom/Scenario: The ClearPass OnGuard Dissolvable Agent might not work properly if the client
machine runs two different Java versions—for example, Java 6 and Java 7.
Workaround: Uninstall the old Java component if it exists and keep the latest Java version.

#20191 The OnGuard applet needs to run in Safari's “Unsafe mode” to perform health checks. To enable this, go
to Safari > Preferences > Security > Manage Website Settings > Java > [Select IP/hostname of
ClearPass server], and select “Run in Unsafe Mode” in the drop-down list.

#20514 Client health checks might not work if the client is not running the latest Java version.

#23253 Symptom/Scenario: Launching the Web Agent applet using some Java versions (7u55 and above)

Table 45: Known Issues in the Dissolvable Agent
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displays the security warning “This web site is requesting access and control of the Java application
shown above. Allow access only if you trust the web site...”
Workaround: Click Allow to let the health checks proceed.

#23340 Symptom: The OnGuard Agent does not display remediation messages.
Scenario: This happens on Mac OS X using Firefox 27 and JRE 1.7 update 55. It is not an issue on later
versions of Firefox.
Workaround: Reload the page and log in again.

#24518 Symptom: The first time a run or scan operation is initiated in the Native Dissolvable Agent flow, an
“External protocol request” message is displayed, and if the user clicks the “Do Nothing” option, the
message stays on the screen.
Scenario: This occurs on the Chrome browser on both Windows and Mac OS X.
Workaround: This message is produced by the Chrome browser and can be ignored. Click Launch
Application in the External protocol request message.

#24762 Symptom: When launching the OnGuard Dissolvable Agent, Mac OS X displays the message “You are
opening the application ‘ClearPass OnGuard WebAgent’ for the first time. Are you sure you want to open
this application?”
Scenario: This is the normal, default behavior of Mac OS X, and is not an issue in OnGuard.

#24766 Symptom/Scenario: The Native Dissolvable Agent fails to download from IE on Windows 2008/XP if the
“Do not save encrypted pages to disk” check box is enabled.
Workaround: Go to Internet Options > Advanced. Uncheck (disable) the check box for the “Do not
save encrypted pages to disk” option.

#24768 Symptom: The Native Dissolvable Agent does not work well in Internet Explorer on Windows XP.
Scenario: The agent works after downloading it and allowing pop-ups, but no remediation results are
displayed and, after clicking Launch ClearPass Application, a series of messages is displayed in a loop.
Workaround: Windows XP is an unsupported operating system. Use a later Windows version or the
Chrome or Firefox browser instead.

#24792 Symptom/Scenario: The Native Dissolvable Agent flow will not work properly on IE if ActiveX Filtering is
enabled on IE settings.
Workaround: For Native Dissolvable Agent to work properly on Internet Explorer, ActiveX Filter should
be disabled.

#24862 Symptom/Scenario: The Native Dissolvable Agent uses ActiveX on IE on Windows OS. Based on IE
Security Settings, the browser may ask the user to run or allow “ClearPass OnGuard Web Agent Control”.
Workaround: For the Native Dissolvable Agent to work properly on Internet Explorer, the user should
allow “ClearPass OnGuard Web Agent Control” ActiveX Control to run.

#27117 Symptom: On Mac OS X, the Native Dissolvable Agent might not work properly on Google Chrome or
Firefox if Avast Mac Security 2015 Antivirus is installed.

#27756 Symptom/Scenario: The Native Dissolvable Agent can not be installed on Mac OS X 10.6.
Workaround: On Mac OS X 10.6, admin/root permission is required to install the Native Dissolvable
Agent. After installation, the admin user should execute the following command:
sudo chmod –R 777 ~/Library/Application\

Support/ClearPassOnGuardWebAgent/

#28398 Symptom: The native dissolvable agent does not automatically relaunch the applet.
Scenario: This can occur on Mac OS or on Ubuntu after upgrading from 6.5.0 to 6.5.1.

#28737 Symptom: The native dissolvable agent does not work properly on Chrome 42.x or higher. The guest
page fails to detect whether the ClearPass OnGuard Unified Agent is installed or not.
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Scenario: On Chrome 42 and higher versions, the guest page keeps asking the user to download the
ClearPass OnGuard Unified Agent even if the agent is already installed. This happens on both Windows
and MacOSX, and for both the native agent and the Java-based agent. ClearPass normally installs the
NPAPI plugin while installing the native agent. The guest page uses this plugin to detect whether the
native agent is installed or not. However, in Chrome 42, NPAPI plugins are disabled by default.
Workaround: Enable NPAPI plugins manually or by using Enterprise Policy via
chrome://flags/#enablenpapi.

#29127 Symptom: The OnGuard Java-based Dissolvable Agent is not supported on the Chrome 42.x or higher
browser.
Scenario: The Java plugin is now deprecated in Chrome. This is an issue with Chrome, not with
ClearPass.
Workaround: Use the Firefox, Internet Explorer, or Safari browser.

#29143 Symptom: The native dissolvable agent does not work on Chrome 43.x even after the NAPI plugin is
enabled.
Scenario: This occurs on Mac OS X.

#29186 Symptom/Scenario: The Native Dissolvable Agent sometimes does not run on Windows Vista, Windows
2008r2, or Windows 8.
Workaround: Right-click the OnGuard application to open Properties, and then unblock the .exe file.

Table 45: Known Issues in the Dissolvable Agent (Continued)

Guest

Bug ID Description

#9967 Symptom/Scenario: Unicode SMS messages (UTF-16 encoded) are limited to 70 Unicode characters.
The ClearPass Guest user interface still displays 160 characters as the limit. Sending a Unicode SMS
message over 70 characters may fail if the SMS service provider does not support multi-part SMS
messages.
Workaround: If you plan to use Unicode SMS messages, check your SMS receipt carefully to ensure it
is not over 70 characters in length.

#25137 Please review your operator privileges for new features that may need to be enabled.

#27363 Symptom/Scenario: If the default role-mapping policy [Guest Roles] is renamed, the guest roles in
ClearPass Guest are not populated.

Table 46: Known Issues in Guest

Insight

Bug ID Description

#11827 Symptom/Scenario: Insight is not supported in Internet Explorer 8 (IE8).

#12096 Symptom/Scenario: Editing a report to select some columns for analytics overwrites/replaces the
chosen columns for the corresponding report.

#12159 Symptom/Scenario: Insight reports do not show license changes immediately. The changes might
take up to 24 hours, depending on when the changes are made.

Table 47: Known Issues in Insight
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#19507 Symptom/Scenario: PDF and HTML Data Tables are not created if the CSV file size is larger than
1MB, although the generated PDF and HTML reports include analytics if configured in the report.

#20601 Insight custom templates used in report configurations of 6.3.x versions are not supported in 6.4.x.
Customers must contact Aruba TAC by providing logs from Insight > Administration > Collect logs
and a new set of custom templates for the 6.4.x version will be provided. Custom templates in 6.4.x
work fine with 6.5.x and are carried forward.

#26899 Symptom: Use of System Events and Audit Events via the Insight template is not recommended.
Workaround: Use the default System Events and Audit Events template from syslog filters instead.

#27529 Insight report generation for the Endpoint Latest template might take a long time or might not
complete if the number of endpoints is greater than 1,00,000.

Table 47: Known Issues in Insight (Continued)

Onboard

Bug ID Description

#9897 Symptom: ClearPass Onboard does not update the Policy Manager endpoints table with an endpoint
record when provisioning an iOS 5 device.
Scenario: This is because the iOS 5 device does not report its MAC address to ClearPass Onboard
during device provisioning.

#10667 Symptom/Scenario: When using Onboard to provision a OS X system with a system profile, an
administrator user must select the appropriate certificate when connecting to the provisioned network
for the first time. The administrator should also ensure that the system's network settings are
configured to automatically prefer connecting to the provisioned network, if the intent is for non-
administrator users to always use that network.
Workaround: The process to provision an OS X system with a system profile is:
1. The administrator should log in to the OS X system and connect to the provisioning SSID. Do not

select the “Remember this network” option.
2. Use Onboard to provision the device with an EAP-TLS profile, ignoring the username/password

prompt.
3. Connect to the provisioned network, selecting EAP-TLS as the mode and selecting the provisioned

certificate, but ignoring the username field.
4. When the system connects and authorizes to the network, use Network Preferences to place the

EAP-TLS network first in the priority list.
5. After the administrator logs out, users logging in are connected by EAP-TLS and cannot modify

those settings.

#20983 Symptom: HTC Android asks the user to enter a certificate name to be installed when onboarding.
Scenario: HTC Androids running Android version less than Android 4.3 and greater than Android
2.3 ask the user to enter a name for the certificate to be installed while onboarding.
Authentication will fail if the user does not enter the exact certificate name as QuickConnect
application instructs in a message prior to the certificate installation dialog.
Workaround: None. This issue is due to a limitation in the Android phone’s firmware.

#23287 Symptom: Embedding Admin credentials for onboarding does not work in Windows 8 and above. The
system hangs and there is no error message.
Scenario: When onboarding Windows systems with Windows 8 and above, if operations requiring
admin privileges are configured, then the end user doing the onboarding needs to have admin
privileges on the system. These operations include installing applications, configuring wired networks,
installing certificates in the machine certificate store, and so on. Embedding admin credentials along
with the QuickConnect wizard for this purpose does not work for Windows 8 and above.

Table 48: Known Issues in Onboard



Bug ID Description

Workaround: There is no workaround. This is a Windows system limitation.

#23699 Symptom: Mac OS X disconnects before it completes a certificate renewal.
Scenario: On Mac OS X, automatic certificate renewal through the “Update” option on Apple’s interface
does not work. This occurs on provisioned (wireless) networks.
Workaround: This is an issue with OS X limitations, and is not an Onboard issue. Users should be
aware that when their certificate is about to expire, they should renew the certificate through Onboard
instead of using Apple’s automatic certificate renewal.

#25711 iOS always displays SHA-1 for the signing algorithm regardless of the actual algorithm used. This is an
issue with iOS, not Onboard.

Table 48: Known Issues in Onboard (Continued)

OnGuard
Memory utilization for ClearPass OnGuard depends on the Health Classes configured and the type of Windows OS;
however, the minimum requirement for ClearPass OnGuard running on a Windows platform is 90 MB.

Bug ID Description

#12342 The OnGuard agent fails to collect health on Windows 8 if VMware Server 2.0.2.X is
installed.

#13164 Symptom: The hardware installation pop-up dialog appears to stop installing the ClearPass
OnGuard Unified Agent for VIA+OnGuard mode. A warning message similar to “The
software you are installing... has not passed Windows Logo testing” might be displayed
during installation.
Scenario: This might occur during the installation of the ClearPass OnGuard Unified Agent
on WinXP and Windows 2003 SP2.
Workaround: Users should click Continue Anyway to proceed.

#13363 Symptom: On Mac OS X, the current version of the ClearPass OnGuard Unified Agent VPN
component does not show some VPN-related information—for example, tunnel IP assigned
by the controller, packet count, or diagnostic details.
Scenario: This occurs on Mac OS X. It does not occur on Windows OS.

#13929 At times, OnGuard may fail to detect peer-to-peer applications, such as /uTorrent, on
Windows  2008  R2.

#13935 OnGuard does not support enabling/disabling the Windows Update Agent Patch
Management Application.

#13970 After anti-virus software is installed, the system must be rebooted before using ClearPass
OnGuard.

#14196 ClearPass OnGuard will not be able get the correct status of 'Software Update' PM
application on Mac OS X, if “Check for updates” and “Download updates automatically” are
not toggled at least once.

#14673 The OnGuard Agent for Mac OS X does not support bouncing of a VPN Interface other than
the Aruba VPN Interface (version 6.1).

#14760 In some cases, OnGuard fails to connect to the CPPM server from a wired interface if the
VPN is connected from a trusted network.

Table 49: Known Issues in OnGuard
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#14842 Installing the ClearPass OnGuard Unified Agent removes an existing VIA installation. To
continue to use VPN functionality, go to Administration > Agents and Software Updates
> OnGuard Settings and select Install and enable Aruba VPN component from the
drop-down list.

#14996 If McAfee VE is running on Windows XP, the ClearPass OnGuard Unified Agent VPN will not
work.

#15072 VIA connection profile details are not carried forward after upgrading from VIA 2.0 to
ClearPass OnGuard Unified Agent 6.1.1.

#15097 The ClearPass OnGuard Unified Agent does not support installation of a VPN component on
Mac OS X 10.6.

#15156 VPN configuration is not retained after upgrading to the ClearPass OnGuard Unified Agent
using MSI Installer on a 64-bit Windows system.

#15233 On Win 7 (64 Bit), upgrading an existing VIA 2.1.1.X to the ClearPass OnGuard Unified Agent
can lead to an inconsistent state. Users should first uninstall VIA and then proceed with the
ClearPass OnGuard Unified Agent installation.

#15351 Symptom: The state of the Real_Time Scanning button in the Trend Micro Titanium
Internet Security for Mac OS X is not updated.
Scenario: This is observed when the ClearPass Unified OnGuard Agent has Real Time
Protection (RTP).
Workaround: Close the UI using Command +Q and restart.

#15586 Symptom: The ClearPass OnGuard 6.2 dissolvable agent does not support the following
new health classes on Mac OS X: Processes, Patch Management, Peer-To-Peer, Services,
USB Devices, and Disk Encryption. The dissolvable agent (DA) does not display these health
classes as remediation messages in the user interface because java binary sdk support is
not included.
Scenario: The client will be unhealthy if any of the health classes listed above are
configured and performing a health scan via the DA.

#15986 ClearPass OnGuard returns the product name of “Microsoft Forefront Endpoint protection”
AntiVirus as “Microsoft Security Essential”.

#16181 Symptom: The command level process can be detected using the path “none” but the
application level process can't be detected by setting the path to ”none”.
Scenario: This applies to Mac OS X.
Workaround: The application-level process health should be configured with the path set to
Applications > Firefox.app.

#16550 Symptom/Scenario: The ClearPass OnGuard Unified Agent does not support checking of
disk encryption state using the MacKeeper (ZeoBIT LLC) Disk Encryption Product on Mac OS
X. This causes the client to be treated as healthy even if none of the disk is encrypted.
Workaround: There is no workaround at this time.

#18259 Symptom/Scenario: The ClearPass OnGuard Unified Agent does not support Stop or
Pause remediation actions for Oracle VM Box Guest virtual machines on Mac OS X.

#18281 The ClearPass OnGuard configured health quiet period is supported in Health only mode. It
doesn’t work in Auth+Health mode.

#18341 Symptom/Scenario: OnGuard cannot start a process on Mac OS X for non-administrative

Table 49: Known Issues in OnGuard (Continued)
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users.
Workaround: The user must have root privileges to start process-level health checks by
OnGuard on Mac OS X.

#19019 The network interface will be bounced twice (once immediately, and once after the
configured interval) when the log-out/bounce delay parameter is configured. This is
expected behavior; the first bounce is required to end the existing session.

#19685 Symptom: After upgrading OnGuard to 6.3, the backend service fails to start and is unable
to collect logs.
Scenario: This rarely occurs. It has been observed on the Mac OS X 10.6, 10.8, or 10.9 OS
after upgrading OnGuard from 6.2.4 or 6.3 to 6.3.
Workaround: If the backend service fails to communicate with the plugin, reboot the
system after the OnGuard upgrade is complete.

#20316 OnGuard’s Health Check Quiet Period is applicable per network interface. If a machine has
more than one network interface, then each interface will have its own Health Check Quiet
Period duration.

#21152 Symptom: The ClearPass OnGuard Unified Agent fails to establish a control channel on
Windows or Mac OS X if more than one instance of the OnGuard Agent is running.
Scenario: This occurs if multiple instances of OnGuard are running due to multiple users
having logged in using Switch User.

#23470 Symptom/Scenario: On a Japanese OS, when upgrading from VIA 2.1.1.3 to the ClearPass
OnGuard Unified Agent, a known issue with uninstalling VIA displays a message asking the
user to select the VIA driver. This does not occur on an English OS.

#23636 Symptom: The value of the Posture:Applied Policy attribute is not correctly displayed in the
Access Tracker for posture policies carried over from releases earlier than 6.3.0.
Scenario: This has been observed when upgrading from 6.2.6 to 6.3.2.
Workaround: This can be corrected by manually saving the affected posture policy once
after upgrade.

#23861 Symptom/Scenario: On Mac OS X, the ClearPass OnGuard Unified Agent sometimes fails
to download a VIA connection profile after the application mode is changed.
Workaround: None.

#24986 Symptom: The Native Dissolvable Agent is not automatically launched after downloading
and running the agent the first time on the Chrome browser.
Scenario: This occurs on Windows and on Mac OS X.
Workaround: The first time you launch the Dissolvable Agent, click Launch ClearPass
OnGuard Agent.

#25827 Symptom/Scenario: On Internet Explorer 8, when the security warning message asks
whether you want to view only the content delivered through a secure HTTPS connection,
the behavior is not as expected.
Workaround: For the Native Agent flow to work correctly, click No in the pop-up dialog.

#26224 Symptom/Scenario: Some combined products that include both antivirus and antispyware
(for example, McAfee VirusScan Enterprise + AntiSpyware Enterprise) are not shown in the
AntiSpyware Posture configuration.
Workaround: Add products like this only in Antivirus. Both the AntiVirus and AntiSpyware
values are the same.

#26232 Symptom: When installing or running the Native Dissolvable Agent on Mac OS X 10.10, the

Table 49: Known Issues in OnGuard (Continued)
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message “’ClearPass OnGuard WebAgent’ can’t be opened because the identity of the
developer cannot be confirmed” is displayed.
Workaround: When opening the OnGuard WebAgent application for the first time after
installing, the user must open it manually. Right-click and select the Open option. The Web
browser will then be able to launch the OnGuard WebAgent.

#26276 Symptom/Scenario: On Mac OS X 10.10, the ClearPass OnGuard Unified Agent ‘s VIA
component fails to download the connection profile when the tunnel is established, and the
log window shows the error “Configuration download... failed”.

#27134 Symptom: OnGuard does not support dynamic switching between logged-in users on an
Ubuntu client.

#27572 Symptom: If the ClearPass OnGuard Unified Agent uses a VIA connection and is installed
on a Mac OS X client, and if the user is idle for five minutes, OnGuard automatically
disconnects the VIA tunnel.
Workaround: If VIA is disconnected, connect again manually.

#27599 Symptom: The OnGuard logo is not shown on the desktop on Ubuntu.
Scenario: On the Ubuntu OS, the OnGuard logo is not visible on the desktop at first. The
logo will be updated automatically after the desktop is refreshed.

#27602 Symptom: The OnGuard Unified Agent fails to return health-check data over a VPN tunnel
when the agent is installed on a client running MAC OSX 10.10 and using the Kaspersky
AntiVirus software.
Workaround: OnGuard services should be whitelisted on Kaspersky AntiVirus in order to
work over VPN.

#27871 Symptom The Java dissolvable agent does not detect AVG 2014.
Scenario: This occurs on Mac OS 10.10 with the Java dissolvable agent. The native
dissolvable agent is able to detect it.

#27876 Users should be aware that RADIUS CoA over VPN is not supported on Ubuntu.

#29243 Symptom: The Unified Agent fails to disable other types of network connections when
“Allow Only One Network Connection” is selected.
Scenario: Users should be aware that the ClearPass OnGuard Unified Agent for Windows
does not support disabling USB data card/modem type network interfaces.

Table 49: Known Issues in OnGuard (Continued)

QuickConnect

Bug ID Description

#20867 Symptom/Scenario: Android 4.3 and above fails to install a self-signed certificate for the CA
certificate.
Workaround: For onboarding Android version 4.3 and above, CPPM must have a RADIUS server
certificate issued by a proper Certificate Authority and not a self-signed certificate. This is a
requirement of Android’s API for Wi-Fi management. In Onboard > Configuration > Network
Settings, the CA certificate that issued the server's certificate has to be selected as the trusted root
certificate to be installed on Android.

#25521 Symptom/Scenario: Embedding admin credentials is not supported on Windows 8+.
Workaround: Provide the admin credentials manually during Onboard provisioning.

Table 50: Known Issues in QuickConnect
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