OC20 Unable To Activate Network

By esupport posted Mar 31, 2020 11:12 AM

  
Problem:

Device: HPE OC20 802.11ac (RW) Access Point. 

Issue: Unable to activate the network. 



Diagnostics:

When configuring the  AP using the Mobile APP (HPE OfficeConnect WiFi Portal), after providing the email and password, when clicking on Activate, it fails to ACTIVATE. 

 

 



Solution
  • The Aruba Instant Certificate Expiry Issue impacts the Office Connect OC20 Access Point.
  • One of the certificates used on OC20 expired on February 7, 2020. The new firmware version 1.2.1 comes with a new certificate that fixes the issue.
  • All OC20 upgraded to version 1.2.1 before Saturday Feb 8th 12am UTC won’t be affected by the problem.
  • OC20 with no network access or that could not be upgraded to the new firmware will be impacted and will need to be manually upgraded to version 1.2.1

 

Procedure for Linux and Mac

Note: Please connect the AP in same subnet for the PC/Laptop where you are executing the Script.

 

1) Download the file: https://for-guy.s3.amazonaws.com/OC20Console_Unix.zip  (all files are included in the zip)

2) Unzip it and open a Terminal

3) Update permissions of the script: sudo chmod +x OC20_upgrade.sh

4) Execute the script: ./OC20_upgrade.sh  IP  Username  Password

 

Item

Value

IP

IP address of the OC20 Access Point

Username

Username of the Office Connect site or Admin if not set

Password

Password of the Office Connect site or Admin if not set

 

5) When the script completes the AP will reboot and will connect to the cloud

 

Procedure for Windows

1) Download the file: https://for-guy.s3.amazonaws.com/OC20Console.zip (all files are included in the zip)

2) Unzip it and open the OC20 Console folder

3) Launch ConsoleStarter.cmd

4) Execute the script: ./OC20_upgrade.sh  IP  Username  Password

Item

Value

IP

IP address of the OC20 Access Point

Username

Username of the Office Connect site or Admin if not set

Password

Password of the Office Connect site or Admin if not set

 

5) When the script completes the AP will reboot and will connect to the cloud

 

7 comments
4 views

Comments

Feb 13, 2021 01:39 PM

I tried the solution with no hope at all

Sep 18, 2020 02:43 AM

Hi IT_Luke,

 

update done. but after update also the problem is same. when i try to configure it and click on Activate It option in mobile app. its showing processing only. giving msg. (please allow some time for your network to become active. this usually take 30 second) 

but nothing hepped after waiting for 10 -15 min as well.

given below the updated script output. please help me

root@Bib12507-NB ~
$ ./OC20_upgrade.sh 192.168.43.40
USAGE: ./OC20_upgrade.sh IP Username Password
FORM_DATA=opcode=smb&sid=ivuqjV5u0znzYqNUPWzr&&restResource=openSshSesame&restMethod=GET
{"restStatus":200,"restBody":{"kind":"openSshSesame","ssh status":"enabled (publickey)"}}spawn ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null -i OfficeConnectAP_Apr2017_rsa.dat 192.168.43.40
Warning: Permanently added '192.168.43.40' (RSA) to the list of known hosts.
Switching to Full Access
~ # /usr/sbin/wget https://hpe-officeconnect-firmwares.s3.amazonaws.com/OfficeConnectPortal_OC20_1.2.1_74212
--06:07:43-- https://hpe-officeconnect-firmwares.s3.amazonaws.com/OfficeConnectPortal_OC20_1.2.1_74212
=> `OfficeConnectPortal_OC20_1.2.1_74212'
Resolving hpe-officeconnect-firmwares.s3.amazonaws.com... 52.216.185.155
Connecting to hpe-officeconnect-firmwares.s3.amazonaws.com|52.216.185.155|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 12,805,460 (12M) [binary/octet-stream]

21% [========================> ] 2,766,429 11.79K/s ETA 17:36mv OfficeConnectPortal_OC20_1.2.1_74212 /tmp/mips.ari.flash
60% [======================================================================> ] 7,797,341 12.45K/s ETA 06:19write_flash 2
92% [==========================================================================================================> ] 11,801,181 10.12K/s ETA 01:15write_flash 1
100%[====================================================================================================================>] 12,805,460 15.29K/s ETA 00:00

06:23:51 (13.00 KB/s) - `OfficeConnectPortal_OC20_1.2.1_74212' saved [12805460/12805460]

~ # mv OfficeConnectPortal_OC20_1.2.1_74212 /tmp/mips.ari.flash
~ # write_flash 2

root@Bib12507-NB ~
$

Sep 15, 2020 09:33 AM

Hi Bibesh, try to launch the script while in the cmd prompt/shell. Open the cmd prompt and go to where you unzipped the script then launch it without username and password - the script itself contains already the default credentials. At least you can see what the error is.

Sep 15, 2020 04:36 AM

hi team,

 

i am also facing same issue.

when i process step 4 or step 3 (4) Execute the script: ./OC20_upgrade.sh  IP  Username  Password)

nothing is happening.

 

when we run Launch ConsoleStarter.cmd command prompt just open and close.

 

May 08, 2020 07:01 PM

@sacosta try launching the upgrade script with just the IP and nothing else. You should do this with a fixed green LED (indicating ready state) after reboot (usually after a couple of minutes after power on). I've done this on 2 devices which were never updated and installed before Feb 7 2020 and they both updated *without* any username or password (the script adds "admin/admin" as user and pass if nothing is written and BTW it's admin ALL LOWER CASE. The instructions appear to be incorrect if you've never set your device up and connected it to the hp provisioning cloud - hence you should OMIT any username or password (or use admin/admin NOT Admin/Admin).

Apr 23, 2020 03:26 AM

Hi.

 

I've downloaded both files:

 

On Mac it says:

-bash: ./OC20_upgrade.sh: /bin/bash^M: bad interpreter: No such file or directory

 

On Windows:

USAGE: ./OC20_upgrade.sh IP Username Password

Unable to establish session with AP at 192.168.100.44

 

192.168.100.44 is the address that the AP obtains from my Home Router.

Is there something that I'm missing?

Is there other way to update the firmware? Now my AP is just a brick with green/amber blinking LEDs

 

Thanks.

 

 

EDIT: I've seen that the error on Mac is maybe due to CR-LF character non-unix on the file, i used vim and established the format with ':set formatfile=unix'

And i've been using in the command line, the user and password Admin, when none is required (i made a factory reset).

 

Then the update was smooth...

 

I've consulted this doc also:

https://techlibrary.hpe.com/OfficeConnect/?PRE=OC20#firmwareProcedure

 

But is practically the same as this...

Apr 14, 2020 10:19 AM

Hello, i have the same problem, but the AP not use my dhcp range but release address 172.31.98 .xx (this ip address is'n pingable, open only web page where download app)

i can't confugre and i can't upgrade the firmware...

how can i do??

thanks