IAP on Juniper EX switch

By Shyam_Moolayilkalarikkal posted Jul 11, 2014 07:00 PM

  
Question Why does Aruba Instant APs connected to Juniper EX switch don't form a cluster?
Environment Aruba Instant APs connected to Juniper EX switch.

 

With Juniper EX switches; if the native vlan is included in the member vlan; it would be tagged. This would result in APs not able to communicate to each other consequently not join the cluster.

 

Example ::

 

family ethernet-switching {

                    port-mode trunk;

                    vlan {

                        members [ VLAN5 VLAN200 VLAN100];    <-- Native VLAN Included

                    }

                    native-vlan-id VLAN100;

                }

 

 

 

rtaImage.jpg

 

 

To have the native vlan untagged; it should only be defined under native-vlan-id.

 

 

Example ::

 

family ethernet-switching {

                    port-mode trunk;

                    vlan {

                        members [ VLAN5 VLAN200];    <-- Native VLAN NOT Included

                    }

                    native-vlan-id VLAN100;

                }

 

 

 

Juniper KB Article :: https://kb.juniper.net/InfoCenter/index?page=content&id=KB17419

1 comment
0 views

Comments

Nov 29, 2017 03:47 AM

I can confirm horribly intermittent IAP operation, intermittent AP to AP pings, intermittent lack of ARP responses, and various other maladies when this is the case.  Removing the native VLAN from the members resolves it all.   Thank you!