Cannot stream videos on iphones or ipads using IAPs

By JuliaOstrowski posted Jun 01, 2014 11:17 PM

  

Symptoms

Why are we unable to stream youtube vidoes that have a preluding commercial on iPhones/iPads?

Diagnosis

Any Aruba OS
Any Aruba IAP
iPhones/iPads
 
We observe that any youtube video that has a commercial in front of it will NOT play, but videos without the leading commercials WILL.  
 
HBO Go – will stream
Vimeo – will stream
Amazon Instant Video – will stream
Apple Trailers – will not stream
Netflix – will not stream
Trailer-Addict – will not stream
Crackle – will not stream
YouTube – will only show me commercials that precede the videos I wish to watch.  At that point, YouTube will not stream

When the video has a commercial before it, video playback stops as soon as the main video would begin to play (right after the commercial).  Here is a screenshot of the error message on the iphone:  
 
Image A.jpg

Solution

Settings on the firewall block certain HTTP traffic.
 
We have seen a couple of such settings on a Dell SonicWall that block selective videos.  Adjusting the settings as below resolved the issue in this case:

#1 – Enabled “Enable HTTP Byte-Range requests with Gateway AV” under Security Services – Gateway Anti-virus – Gateway AV Settings
 
Image b.jpg
 
 
#2 – Unchecked / Disabled “Low Danger Level Spyware” detection under Security Settings – Anti-Spyware – Signature Groups.
 
Image c.jpg
 
 
 
 
After the above changes, we were able to stream YouTube, NetFlix etc.  The precise details of these settings might need a reference with Dell documentation and why these 2 settings were causing trouble for iPhone / iPad users only.  However we are sure that the issue is on the firewall and not with the IAPs.  This was established by various tests with IAPs on a network without such firewall restrictions.
 
This issue can either be related to the youtube App or login cache on the iPhone/iPad.  Once that is ruled out then the only possibility is some firewall settings on the Network, because other videos work fine using the same client.  We have seen a couple of such settings for a Dell SonicWall that were found to be selectively blocking http traffic for youtube videos on iPhones/iPads.
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
1 comment
0 views

Comments

Oct 16, 2015 12:48 PM

This has nothing to do with firewall outside the Aruba.

 

The aruba is the issue. I have the same issue. This happened once the aruba was put into place. The Cisco do not have this issue?

 

Please fix it soon.