Resetting MAC OSX Leopard Wireless

By ozerdo posted Nov 13, 2011 09:47 PM


MACs had the title for being the easiest to join wireless networks: just click on wireless network and it will automatically tell you need to join it; no problems. Unfortunately there are a number of situations where MACs will get into a state where wireless networks that it has been connecting to for the longest, it will NO Longer connect to reliably. The only thing to do is to entirely reset your wireless.


When you have tried everything in MAC Client "Nuances" ( and it is only that client with problems, this is the procedure for you:

Network preferences are stored in the 'System' file space (/Library) and the 'User' file space (~/Library) in the following files:
System files (network and wireless): /Library/Preferences/SystemConfiguration/
System Files (General configurations) /Library/Preferences/SystemConfiguration/preferences.plist
802.1x Profiles: ~/Library/Preferences/

To reset default network settings, remove (or make copy and remove) ALL of the above files. You need to be in UNIX mode to do that: Launch 'Terminal': Finder -> Applications -> Utilities -> Terminal From the UNIX Shell, create a directory to store old preferences:

cd ~
mkdir saved-preferences

Then, move all network preferences files to this backup folder:

mv ~/Library/Preferences/ ~/saved-preferences
cd /Library/Preferences/SystemConfiguration

sudo mv * ~/saved-preferences

The "sudo" command WILL ask you for the root password to proceed. Reboot Computer to get back in business! Big shout out to the engineer in Asia who I copied this from Verbatim.


Additional Comment #1

Great info to share. One minor note, the sudo command will prompt you for YOUR password not the root password. By default the root account on Mac OSX is disabled and users with the Administrator role are allowed to use the sudo command to run commands with root privs.


Additional Comment #2

We were experiencing the same issue where a Mac client would refuse to connect. The fix that you provided above did not always resolve the issue. It got bad enough that we ended up getting into a conference call with one of Apple's CE's.

This issue is caused by the user either not having a login keychain and/or system keychain for the SSID it is attempting to authenticate to. This can happen when you image a Mac that has been built with the admin account, the Network Preferences' Preferred network has been entered from that account. This populates the system keychain and the login keychain for the original admin account, but does not place the SSID in the login keychain for the user's account. The user's account looks to the login keychain when the user first logs in or turns off/on the wireless NIC with the Airport icon. Waking from sleep is the only time during a normal user account's activity where the system keychain will be used to authenticate the network.

Complicating this issue further is that if the date/time is not set and produces an error stating that the clock is set before 2001, as a security measure, the OS will not save any additions to the system keychain. So if you have a laptop that is offline because it can't connect and your date/time is not set and you perform the fix above, you will not be able to add the network and have it successfully authenticate under the user past the first restart, when the system keychain will blank itself again.

The first thing you have to do in that situation is fix the date/time preferences by setting it manually, log in as root or admin and save the network under Network Preferences > Advanced> Preferred Networks, then log in as the user and, if necessary, authenticate to the network through the Airport icon. This last step saves the authenticated network in the user's login keychain.

So really, you don't have to delete all of the plists you mention above and you might want to avoid it since deleting the system preferences plist actually sets ALL of your system preferences to default.