Controllerless Networks

last person joined: 4 hours ago 

Aruba Instant Wi-Fi: Meet the controllerless Wi-Fi solution that's easy to set-up, is loaded with security and smarts, and won't break your budget.
Expand all | Collapse all

Aruba IAP-325 WIFI disappear

  • 1.  Aruba IAP-325 WIFI disappear

    Posted Oct 21, 2020 11:14 AM
      |   view attached

    Hello. Sorry but I am new to Aruba.  I have a following issue with the IAP-325.  It landed from ~ 1 m on floor - no signs on chassis, I have checked also inside of the AP if there are no loose cables etc. No visible sign of harm.  The IPA started never-ending booting loop. I had restored firmware to 6.5.4.11-6.5.4.11 and cleared to factory setting via serial console, then IAP stopped power cycling and web GUI appeared, how ever no wifi signal.  I had issued debugging commands ...  

    Is there any way how to detect faulty hw or misconfiguration?

    Here is boot log from serial console.

    APBoot 1.5.5.8 (build 57191)
    Built: 2016-11-04 at 17:53:10

    Model: AP-32x
    DRAM: 491 MB
    SF: Detected MX25U3235F with page size 64 kB, total 4 MB
    Flash: 4 MB
    NAND: 132 MiB
    PCIE0: link down
    PCIE1: link up
    dev fn venID devID class rev MBAR0 MBAR1 MBAR2 MBAR3
    00 00 168c 0040 00002 00 00000004 00000000 00000000 00000000
    Power: 802.3at POE
    In: serial
    Out: serial
    Err: serial
    Net: eth0, eth1
    Radio: qca9990#0
    Reset: cold
    FIPS: passed

    Hit <Enter> to stop autoboot: 2 1 0
    Booting OS partition 0
    Checking image @ 0x0
    Copying image from 0x44000000

    Image is signed; verifying checksum... passed
    SHA2 Signature available
    Signer Cert OK
    Policy Cert OK
    RSA signature verified using SHA2.
    [ 0.000000]
    [ 0.000000] Aruba Networks
    [ 0.000000] ArubaOS Version 6.5.4.11-6.5.4.11 (build 68542 / label #68542)
    [ 0.000000] Built by p4build@pr-hpn-build09 on 2019-01-10 at 06:29:30 UTC (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) )
    [ 0.000000] CPU: ARMv7 Processor [512f04d0] revision 0 (ARMv7), cr=10c5387d
    [ 0.000000] CPU: PIPT / VIPT nonaliasing data cache, PIPT instruction cache
    [ 0.000000] Machine: IPQ806X wave-2 board
    [ 0.000000] Flash variant: default
    [ 0.000000] msm_reserve_memory: 0x44600000, 0x200000
    [ 0.000000] Memory policy: ECC disabled, Data cache writealloc
    [ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 123178
    [ 0.075538] CPU1: Booted secondary processor
    [ 0.102530] clk_tbl_nss - loaded
    [ 0.243923] msm_pcie_setup: link initialization failed
    [ 0.282911] PCI: enabling device 0000:00:00.0 (0140 -> 0143)
    [ 8.537394] m25p80 spi5.0: found mx25u3235f, expected s25fl512s
    [ 10.866385] Found AT97SC3203 on i2c-gpio0
    [ 10.924929] no pmic restart interrupt specified
    [ 11.564167]
    [ 11.564198] Starting Kernel SHA1 KAT ...
    [ 11.616307] Completed Kernel SHA1 KAT
    [ 11.661105] Starting Kernel HMAC-SHA1 KAT ...Starting Kernel DES KAT ...Completed Kernel DES KAT
    [ 11.767353] Starting Kernel AES KAT ...Completed Kernel AES KAT
    [ 11.811121]
    [ 11.856982] Starting Kernel AESGCM KAT ...Completed Kernel HMAC-SHA1[ 11.946641] Completed Kernel AESGCM KAT
    Thu Jan 1 00:00:00 PST 1970
    Domain Name: SetMeUp.arubanetworks.com
    Current OEM Name : Aruba Networks
    Disabling ipv6 for devices by default
    AP-type has_ble_support: ONBOARD.
    IPv6 capability is supported for devices
    The APBoot version: 57191
    APBoot is up to date
    Done.
    No panic info available
    Writing /dev/ttyHSL2 into /tmp/ble_port
    Enabling ble_daemon and ble_relay via nanny
    apfcutil: sector CACHE: Cache uninitialized
    apfcutil: sector RAP: Cache uninitialized
    apfcutil: sector FAT: Cache uninitialized
    apfcutil: sector SCRATCH: Cache uninitialized
    Backup ENV.
    apfcutil: sector MESH Prov: Cache uninitialized
    [ 16.584536] nss_driver - fw of size 391744 bytes copied to load addr: 40000000, nss_id : 0
    [ 16.693783] nss_driver - Turbo Support 1
    [ 16.728272] Supported Frequencies - 110Mhz 550Mhz 733Mhz
    [ 16.798281] nss_driver - fw of size 190016 bytes copied to load addr: 40800000, nss_id : 1
    [ 16.932833] nss_crypto_module_init[273]:module loaded (platform - IPQ806x, build - Jan 10 2019:06:16:05)
    Enter non-FIPS mode
    Cfg len is 0
    Configuration file is empty, turning on default services...
    extended ssid activate due to no AP config ...
    Ethernet port 1 mode: active-standby
    [ 18.197563] bonding: Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)
    [ 18.299031] bonding: MII link monitoring set to 400 ms

    [ 18.372758] ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 18.428397] ADDRCONF(NETDEV_UP): bond0: link is not ready
    [ 18.496844] bonding: bond0: enslaving eth0 as a backup interface with a down link.
    Info: use bonding and enslave eth1[ 18.592283] ADDRCONF(NETDEV_UP): eth1: link is not ready

    Starting watchdog process...
    [ 19.359169] Kernel watchdog refresh ended on core 0.
    [ 19.459137] Kernel watchdog refresh ended on core 1.
    [ 20.653983] nss_crypto_process_event[388]:engine(0) opened successfully
    [ 20.720805] nss_crypto_process_event[388]:engine(1) opened successfully
    [ 20.799843] nss_crypto_process_event[388]:engine(2) opened successfully
    [ 20.879006] nss_crypto_process_event[388]:engine(3) opened successfully
    [ 22.605185] eth0: 1000 Mbps Full Duplex
    [ 22.957169] bonding: bond0: link status definitely up for interface eth0, 1000 Mbps full duplex.
    [ 23.049953] bonding: bond0: making interface eth0 the new active one.
    [ 23.128053] bonding: bond0: first active interface up!
    [ 23.188815] ADDRCONF(NETDEV_CHANGE): bond0: link becomes ready
    [ 23.651171] Settng Jumbo MRU 2000
    training packets on interface:
    eth0 eth1
    Index for interface eth0 is 2
    MAC address for interface eth0 is 44:48:c1:c0:3b:c6
    Index for interface eth1 is 3
    MAC address for interface eth1 is 44:48:c1:c0:3b:c7
    send training from interface eth0
    send training from interface eth1
    received Aruba Instant Training packet on eth0, sender eth0, status 0.
    subtype: 4, interface 2, sender-name: eth0, reserved: Aruba Instant Training
    No reply within 1 seconds.
    send training from interface eth0
    send training from interface eth1
    received Aruba Instant Training packet on eth0, sender eth0, status 11.
    subtype: 4, interface 2, sender-name: eth0, reserved: Aruba Instant Training
    [ 27.659950] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
    [ 27.716526] eth1: 1000 Mbps Full Duplex
    No reply within 1 seconds.
    send training from interface eth0
    send training from interface eth1
    received Aruba Instant Training packet on eth0, sender eth0, status 11.
    subtype: 4, interface 2, sender-name: eth0, reserved: Aruba Instant Training
    received Aruba Instant Training packet on eth1, sender eth1, status 11.
    subtype: 4, interface 3, sender-name: eth1, reserved: Aruba Instant Training
    [ 28.775195] Settng Jumbo MRU 2000
    training timeout
    touching file /tmp/ip_mode_0
    eth1 admin down
    init usb modem ...
    insmod: cannot insert `/lib/slhc.ko': File exists (-1): File exists
    insmod: cannot insert `/lib/ppp_generic.ko': File exists (-[ 34.724742] usbcore: registered new interface driver usbserial
    [ 34.813714] usbcore: registered new interface driver usbserial_generic
    [ 34.892033] USB Serial support registered for generic
    [ 34.951983] usbserial: USB Serial Driver core
    1): File exists
    [ 35.028647] SCSI subsystem initialized
    [ 35.154326] Initializing USB Mass Storage driver...
    [ 35.200656] usbcore: registered new interface driver usb-storage
    [ 35.272258] USB Mass Storage support registered.
    No USB Plugged in
    [ 55.413589] usbcore: deregistering interface driver usb-storage
    [ 55.490409] cdrom: Uniform CD-ROM driver unloaded
    [ 55.545267] USB Serial deregistering driver generic
    [ 55.598562] usbcore: deregistering interface driver usbserial_generic
    [ 55.675570] usbcore: deregistering interface driver usbserial
    Checking country code.
    Ethernet uplink active. Becoming Mesh Portal
    [ 59.938081] bonding: bond0: enslaving eth1 as a backup interface with a down link.
    Mesh is DISABLED on this device.
    extended ssid is activated o[ 60.050234] drvlog_mod: module license 'Proprietary' taints kernel.
    [ 60.178850] Disabling lock debugging due to kernel taint
    n the platform ...
    copying bootuplog ...
    [ 60.264917] AP xml model 89, num_radios 2 (jiffies 30129)
    [ 60.352796] apType 89 hw_opmode 0
    [ 60.392908] radio 0: band 1 ant 0 max_ssid 16
    [ 60.444486] radio 1: band 0 ant 0 max_ssid 16
    [ 60.500062] init_asap_mod: installation:0
    [ 60.544642] election init: rand=15 HZ=500
    [ 60.592408] IAP client match init
    [ 60.632489] ethernet_device_event: dev eth0 is up
    [ 60.688691] ethernet_device_event: dev eth1 is up
    allow PAPI
    set device anul0 mtu to 2000
    notify asap_mod 3g no present...
    Starting update SBL2 ...
    Prepare update SBL2 ...
    The expected MD5: e337c2ee110ce85a0e5d69059fc774b6
    The SBL file size: 105484
    The /aruba/bin/nor_sbl2.mbn MD5: e337c2ee110ce85a0e5d69059fc774b6
    The MD5 of /aruba/bin/nor_sbl2.mbn is correct
    [ 63.910652] ethernet_device_event: dev eth1 is changed, carrier: 1
    [ 63.972164] eth1: 1000 Mbps Full Duplex
    [ 64.287191] bonding: bond0: link status definitely up for interface eth1, 1000 Mbps full duplex.
    105484+0 records in
    105484+0 records out
    The original SBL2 MD5: e337c2ee110ce85a0e5d69059fc774b6
    CMDLINE_WRITE_ENVIRONMENT arg {NEW_SBL2=1}
    The SBL2 in flash is same to /aruba/bin/nor_sbl2.mbn
    Done.
    apdot1x authentication is not enabled
    Starting DHCP
    Getting an IP address...
    Jan 1 00:01:01 udhcpc[3300]: udhcpc (v0.9.9-pre) started
    Jan 1 00:01:01 udhcpc[3300]: send_discover: pkt num 0, secs 0
    Jan 1 00:01:01 udhcpc[3300]: Sending discover...
    Jan 1 00:01:01 udhcpc[3300]: send_selecting: pkt num 0, secs 0
    Jan 1 00:01:01 udhcpc[3300]: Sending select for 192.168.0.99...
    Jan 1 00:01:01 udhcpc[3300]: Lease of 192.168.0.99 obtained, lease time 86400
    [ 73.621180] ip_time_handler: Got ip and packets on bond0 Started master election 3-0, rand 28
    [ 94.490378] bonding: bond0: releasing backup interface eth1
    [ 94.544892] ethernet_device_event: dev eth1 others: 9
    [ 94.606404] ethernet_device_event: dev eth1 is down
    [ 94.663573] ethernet_device_event: dev eth1 others: 8
    [ 94.727241] ethernet_device_event: dev eth1 others: 13
    [ 94.785848] ADDRCONF(NETDEV_UP): eth1: link is not ready
    [ 94.848797] ethernet_device_event: dev eth1 is up
    192.168.0.99 255.255.255.0 192.168.0.1
    Compressing all files in the /etc/httpd directory...
    Done.
    Starting Webserver
    bind: Transport endpoint is not connected
    bind: Transport endpoint is not connected
    bind: Transport endpoint is not connected
    [ 99.090909] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
    [ 99.147516] ethernet_device_event: dev eth1 is changed, carrier: 1
    [ 99.221493] eth1: 1000 Mbps Full Duplex
    Put ntpclient to the first of nannylist.
    [ 99.490378] ath_hal: 0.9.17.1 (AR5416, AR9380, WRITE_EEPROM, 11D)
    [ 99.566354] ath_rate_atheros: Copyright (c) 2001-2005 Atheros Communications, Inc, All Rights Reserved
    [ 99.678194] ath_dfs: Version 2.0.0
    [ 99.678194] Copyright (c) 2005-2006 Atheros Communications, Inc. All Rights Reserved
    [ 99.815838] ath_dev: Copyright (c) 2001-2007 Atheros Communications, Inc, All Rights Reserved
    [ 99.929428] ath_pci: (Atheros/multi-bss)
    [ 99.965198] PCI: enabling device 0000:01:00.0 (0140 -> 0142)
    [ 100.033052] ath_pci 0000:01:00.0: ath DEBUG: sc=0xd746b000
    [ 101.297063] Startup Mode-0 set
    [ 101.321524] htt_peer_map_timer_init Enter pdev db43c000 hrtimer db43e9b0
    [ 101.401280] htt_alloc_peer_map_mem : Alloc Success : host q vaddr ddf13000 paddr 5f413000
    [ 101.518400] htt_alloc_peer_map_mem : Flush Interval Configured to 256 pkts
    [ 101.620930] ol_txrx_pdev_attach: 2500 tx desc's allocated ; range starts from d57c0000
    [ 101.715057] SERIAL NUMBER: NHQGH10000A3X01 : wifi0
    [ 101.806497] wmi_service_ready_event_rx: WMI UNIFIED SERVICE READY event
    [ 101.958419] wmi_ready_event_rx: WMI UNIFIED READY event
    [ 102.010840] target uses HTT version 2.2; host uses 2.2
    [ 102.112152] ol_ath_smart_ant_attach: Firmware doest not support Smart Antenna.
    [ 102.186160] ol_ath_smart_ant_attach: Hardware doest not support Smart Antenna.
    [ 102.273289] dfs_attach: event log disabled by default
    [ 102.336207] aruba_mods_radio_attach: dev:<wifi0> ic:d5700540 osdev:d746b010 phy:2
    [ 102.422992] wifi0: Base BSSID 44:48:c1:83:bc:70, 16 available BSSID(s) processor ID: 0
    [ 102.517432] eth0 address=44:48:c1:c0:3b:c6
    [ 102.566791] br0 address=44:48:c1:c0:3b:c6
    [ 102.614276] wifi0: AP type AP-325, radio 0, max_bssids 16
    [ 102.679256] aruba_mods_radio_attach() INT setting antenna polarization to 0 radio 0
    [ 102.771946] Resetting spectral chainmask to Rx chainmask
    [ 102.938206] Enabling eth1 due to power change [power profile 1]
    [ 102.997375] Resetting spectral chainmask to Rx chainmask
    [ 103.060481] Init the PCAP for radio0 offload 1.
    [ 103.114901] aruba_mods_radio_attach: radio: 0, init txq work cpu: core-0
    [ 103.199812] pktlog_init: Initializing Pktlog for AR900B, pktlog_hdr_size = 16
    AP rebooted caused by cold HW reset(power loss)
    shutting down watchdog process (nanny will restart it)...

    <<<<< Welcome to the Access Point >>>>>

    Completed SW FIPS KAT test
    User: [ 106.094314] Starting Kernel HMAC SHA1 FIPS KAT ...
    [ 106.137800] Completed Kernel HMAC SHA1 FIPS KAT
    [ 106.701124] Kernel watchdog refresh ended on core 0.
    [ 106.701155] Kernel watchdog refresh ended on core 1.
    [ 108.093158] Starting Kernel HMAC SHA256 FIPS KAT ...
    [ 108.146735] Completed Kernel HMAC SHA256 FIPS KAT
    [ 110.101155] Starting Kernel HMAC SHA384 FIPS KAT ...
    [ 110.149765] Completed Kernel HMAC SHA384 FIPS KAT
    [ 112.101155] Starting Kernel HMAC SHA512 FIPS KAT ...
    [ 112.149609] Completed Kernel HMAC SHA512 FIPS KAT
    [ 125.767104] i am master now
    [ 125.788003] (13:48:38) !!! Init ---> Master
    [ 125.838019] asap_send_elected_master: sent successfully
    [ 125.921399] asap_send_elected_master: sent successfully

    I collected also some tech support data 
    I will be thankful for any help. 

    Attachment(s)

    txt
    show-tech.txt   99K 1 version


  • 2.  RE: Aruba IAP-325 WIFI disappear

    Posted Oct 22, 2020 04:53 AM

    Do I understand correctly that you can after the resets/re-image connect to the WebUI, configure the SSID, SSID showing up in the configuration but not in the air?

     

    Please check with the command on the CLI (or WebUI support section): show ap bss-table. If the output there shows active channels and power, but you don't see anything in the air, I'm quite confident that the AP has a hardware defect.

    AP303H-xx:68# show ap bss-table
    
    Aruba AP BSS Table
    ------------------
    bss                ess           port  ip              phy    type  ch/EIRP/max-EIRP  cur-cl  ap name       in-t(s)  tot-t            flags
    ---                ---           ----  --              ---    ----  ----------------  ------  -------       -------  -----            -----
    24:f2:xx:xx:xx:f1  SSID01        ?/?   192.168.33.160  a-VHT  ap    153-/14.0/14.0    0       AP303H-xx:68  0        33d:16h:55m:17s
    24:f2:xx:xx:xx:e0  SSID02        ?/?   192.168.33.160  g-HT   ap    1/9.0/19.9        0       AP303H-xx:68  0        33d:16h:55m:33s
    24:f2:xx:xx:xx:e1  SSID01        ?/?   192.168.33.160  g-HT   ap    1/9.0/19.9        0       AP303H-xx:68  0        33d:16h:55m:16s
    24:f2:xx:xx:xx:f0  SSID02        ?/?   192.168.33.160  a-VHT  ap    153-/14.0/14.0    1       AP303H-xx:68  0        33d:16h:55m:49s
    

     

    Before requesting an RMA, if you are 'first owner', make sure you communicate the fact that the AP has dropped (and you opened it) and get a confirmation that there is a free-of-charge replacement in this case. That to avoid that when the returned AP is analyzed and physical damage is detected that you will need to return the AP again.



  • 3.  RE: Aruba IAP-325 WIFI disappear

    Posted Oct 22, 2020 02:04 PM

    Thank you for the answer.  The bss-table command output was in enclosed file of the original message.

    1 Access Point
    --------------
    Name IP Address Mode Spectrum Clients Type IPv6 Address Mesh Role Zone Serial # 2.4 Channel 2.4 Power (dB) 2.4 Utilization (%) 2.4 Noise Floor (dBm) 5.0 Channel 5.0 Power (dB) 5.0 Utilization (%) 5.0 Noise Floor (dBm) Need Antenna Config From Port Config Id Config Csum Ext SSID Active Age Link Local IP Address
    ---- ---------- ---- -------- ------- ---- ------------ --------- ---- -------- ----------- -------------- ------------------- --------------------- ----------- -------------- ------------------- --------------------- ------------------- --------- --------- ----------- --------------- --- ---------------------
    44:48:c1:c0:3b:c6 192.168.0.99* access disable 0 325(indoor) -- N/A - SN - - - - - - - - No none 2 12222 enable 44s --
    44:48:c1:c0:3b:c6# show ap bss-table

     

    Aruba AP BSS Table
    ------------------
    bss ess port ip phy type ch/EIRP/max-EIRP cur-cl ap name in-t(s) tot-t flags
    --- --- ---- -- --- ---- ---------------- ------ ------- ------- ----- -----
    Also I  noticed that  "PCIE1: link up" but "PCIE0: link down" while both WIFI modules are present. I am not first owner and I am totally aware that damage was done by mishandling, thus opened and inspected. 
    Thank you for your assistance and best regards.