Controllerless Networks

last person joined: 2 hours ago 

Aruba Instant Wi-Fi: Meet the controllerless Wi-Fi solution that's easy to set-up, is loaded with security and smarts, and won't break your budget.

ArubaOS 8.7.1.1 Mobility Controller XML-API issue

  • 1.  ArubaOS 8.7.1.1 Mobility Controller XML-API issue

    Posted 7 days ago
    Hello,

    I am trying to use XML-API to integrate our external captive portal and I found an odd behavior.
    When I send message that should generate an error in response I am getting anyway OK.
    For example

    xml=<aruba command="user_authenticate">
    <ipaddr>127.0.0.1</ipaddr>
    <version>1.0</version>
    <key>123123</key>
    <authentication>cleartext</authentication>
    </aruba>

    Response:

    <aruba>
    <status>Ok</status>
    <code>0</code>
    </aruba>

    In controller log i see the correct error
    Feb 22 22:27:32, authmgr[3792]: <124030> <3792> <INFO> |authmgr| Received XML API cmd=user_authenticate, agent=192.168.1.110 IP=127.0.0.1
    Feb 22 22:27:32, authmgr[3792]: <124004> <3792> <DBUG> |authmgr| IP=127.0.0.1, MAC=00:00:00:00:00:00, name=''
    Feb 22 22:27:32, authmgr[3792]: <124004> <3792> <DBUG> |authmgr| auth='cleartext', role='', tout=0, vers='1.0'
    Feb 22 22:27:32, authmgr[3792]: <199802> <3792> <ERRS> |authmgr| ecp.c, ecp_api:357: ecp_api: validate_client failed for mac 00:00:00:00:00:00 ip 127.0.0.1
    Feb 22 22:27:32, authmgr[3792]: <124827> <3792> <WARN> |authmgr| XML command=user_authenticate (0) from agent 192.168.1.110 IP=127.0.0.1 result=Error, error=''

    Any idea why is it?

    Thanks

    ------------------------------
    Alexander Shulgin
    ------------------------------