Controllerless Networks

last person joined: 2 days ago 

Aruba Instant Wi-Fi: Meet the controllerless Wi-Fi solution that's easy to set-up, is loaded with security and smarts, and won't break your budget.
Expand all | Collapse all

IAP - Certificate config page Blank after uploading new certificate.

This thread has been viewed 36 times
  • 1.  IAP - Certificate config page Blank after uploading new certificate.

    Posted Oct 15, 2021 09:46 AM
      |   view attached
    Hello.

    I been using Let's Encrypt certificates in IAP UI and in the last update, after uploading new cert, i've ended in a blank page.
    Now everytime i try to enter the Certificate config page, i've got a blank page.

    The UI certificate did not change but i can see in shell (show cert all) that the cert was uploaded.
    In shell I managed to set the new cert as the new UI cert, but even like that, i can't enter in certificate config page.

    How can I solve that? Because soon the cert will expire and I have no way to change it.

    Thank you.



  • 2.  RE: IAP - Certificate config page Blank after uploading new certificate.

    Posted Oct 20, 2021 07:44 AM
    What Instant version? What format did you use to import the certificate?

    I once had an issue with Instant 8.6 (if I remember correct) where it could not upload the certificate with encrypted key in PEM, but with an unencrypted key in PEM it worked. ... well I could upload, but the certificate could not be used. This may be the same. You can try to upgrade to 8.8+ or so, or decrypt the key and try with an unencrypted PEM to upload the certificate. My use-case was for a radsec client certificate, so different use-case, but you can try. Or reach out to Aruba TAC.

    ------------------------------
    Herman Robers
    ------------------------
    If you have urgent issues, always contact your Aruba partner, distributor, or Aruba TAC Support. Check https://www.arubanetworks.com/support-services/contact-support/ for how to contact Aruba TAC. Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba Networks.

    In case your problem is solved, please invest the time to post a follow-up with the information on how you solved it. Others can benefit from that.
    ------------------------------



  • 3.  RE: IAP - Certificate config page Blank after uploading new certificate.

    Posted Oct 20, 2021 12:11 PM
    I was on 8.8.0.1 when that happen, update it to 8.8.0.2 and did not solve the problem, now I'm on 8.9.0.0 and it's the same.

    I know that it only work with unencrypted key, as you can see in print screen, the certificate is valid now.
    I can walk around every option in the WebUI with no problem, but I can't enter in the certificates page... it appears for a millisecond and the all I can see is a blank page.

    ------------------------------
    dio33
    ------------------------------



  • 4.  RE: IAP - Certificate config page Blank after uploading new certificate.

    Posted Oct 21, 2021 03:37 AM
    My experience is that there is something wrong with the formatting of the PEM file. If you have not done this before, it may be best to reach out to TAC and let them figure out what is wrong; they can turn on debugging and better see what is going on.

    ------------------------------
    Herman Robers
    ------------------------
    If you have urgent issues, always contact your Aruba partner, distributor, or Aruba TAC Support. Check https://www.arubanetworks.com/support-services/contact-support/ for how to contact Aruba TAC. Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba Networks.

    In case your problem is solved, please invest the time to post a follow-up with the information on how you solved it. Others can benefit from that.
    ------------------------------



  • 5.  RE: IAP - Certificate config page Blank after uploading new certificate.

    Posted 17 days ago
    Did you get this resolved? I am in the same situation as of a few days ago. The entire UI works, but the certificates page draws for a millisecond and then goes blank.





  • 6.  RE: IAP - Certificate config page Blank after uploading new certificate.

    Posted 11 days ago
    Hello,

    Yes, with help from TAC.

    The procedure was:

    Isolate one AP
    Reset its config and move it to a diferent VLAN
    Upload saved config without certificate information (at the end of cfg file)
    Check if you can access certificate config page
    Unpromote the Preferred conductor
    Promote the isolated AP to Preferred conductor and move it to the right VLAN
    Reboot all other APs and they should join the cluster.

    Hope it helps.

    ------------------------------
    dio33
    ------------------------------



  • 7.  RE: IAP - Certificate config page Blank after uploading new certificate.

    Posted 11 days ago
    Yay! thanks for this, had trouble with this for ages
    Rgds
    Alex

    ------------------------------
    Alex Sharaz
    ------------------------------