Wired Intelligent Edge

last person joined: 9 hours ago 

Bring performance and reliability to your network with the Aruba Core, Aggregation, and Access layer switches. Discuss the latest features and functionality of the ArubaOS-Switch and ArubaOS-CX devices, and find ways to improve security across your network to bring together a mobile first solution.
Expand all | Collapse all

Aruba Switch -2920 Port Flapping - Aruba AP's Connected

This thread has been viewed 10 times
  • 1.  Aruba Switch -2920 Port Flapping - Aruba AP's Connected

    Posted Sep 15, 2019 02:48 PM

    Hi All,

    One of my customer is facing issue with port flapping on the Switch when I checked the Switch logs its saying due to STP (The Port is Blocked by STP)  after 2 seconds the ports come up and the issue reoccurs after 30 mins. The other end of the Switch is connected to Aruba 207 Access Points. So, due to this port flapping the access points are going up & down. Please find the attachment of the Screenshot. I don't understand why it's happening. Can I disable the STP on those ports? or put them in ADMIN-EDGE ports ?
    Please suggest. 

    Thank you.!!!



  • 2.  RE: Aruba Switch -2920 Port Flapping - Aruba AP's Connected

    Posted Sep 15, 2019 06:35 PM
    Port flapping has many causes...what devices are connected on flapping ports (I see many ports actually flapping)?

    What is the output of show power brief ethernet x (where x is the port's number) related to flapping port?

    What software version is running your Aruba 2920?

    Admin edge generally would be set on any port connected to access device (such as an host) with the command spanning-tree ethernet x admin-edge-port but, nevertheless, you should investigate first why a port flaps while another doesn't...that's because the admin edge option just sets the involved port into immediate forwarding state (shortening the typical Blocking -> Listening -> Learning -> Forwarding spanning tree phases).

    Eventually you would provide sanitized running configuration to help diagnosing what is going on...


  • 3.  RE: Aruba Switch -2920 Port Flapping - Aruba AP's Connected

    Posted Sep 16, 2019 02:23 AM
      |   view attached

    What are the causes for port flapping? 

    devices connected to those ports are Aurba Access points 205 /215

     

    Software Version is 16.01.0006

     

    Find the attachment for the "show power brief ethernet all"

    So on those ports  can I  use Admin-edge command as access points are connected on to it. 

    RUNNING CONFIGURATION :

    HP-2920-24G-Floor-1-POE# show run

    Running configuration:

    interface 4
    ; Ver #0c:00.34.59.14.29.eb.8f.fc.f3.ff.37.2d:d2

    hostname "HP-2920-24G-Floor-1-POE"
    module 1 type j9727a
    no timesync
    sntp unicast
    ip default-gateway 192.168.220.1
    interface 1
    poe-allocate-by value
    poe-value 15
    exit
    interface 2
    poe-allocate-by value
    poe-value 15
    exit
    interface 3
    poe-allocate-by value
    poe-value 15
    exit
    poe-allocate-by value
    poe-value 15
    exit
    interface 5
    poe-allocate-by value
    poe-value 15
    exit
    interface 6
    poe-allocate-by value
    poe-value 15
    exit
    interface 7
    poe-allocate-by value
    poe-value 15
    exit
    interface 8
    poe-allocate-by value
    poe-value 15
    exit
    interface 9
    poe-allocate-by value
    poe-value 15
    exit
    interface 10
    poe-allocate-by value
    poe-value 15
    exit
    interface 11
    poe-allocate-by value
    poe-value 15
    exit
    interface 12
    poe-allocate-by value
    poe-value 15
    exit
    interface 13
    poe-allocate-by value
    poe-value 15
    exit
    interface 14
    poe-allocate-by value
    poe-value 15
    exit
    interface 15
    poe-allocate-by value
    poe-value 15
    exit
    interface 16
    poe-allocate-by value
    poe-value 15
    exit
    interface 17
    poe-allocate-by value
    poe-value 15
    exit
    interface 18
    poe-allocate-by value
    poe-value 15
    exit
    interface 19
    poe-allocate-by value
    poe-value 15
    exit
    interface 20
    poe-allocate-by value
    poe-value 15
    exit
    interface 21
    poe-allocate-by value
    poe-value 15
    exit
    interface 22
    poe-allocate-by value
    poe-value 15
    exit
    interface 23
    poe-allocate-by value
    poe-value 15
    exit
    snmp-server community "public" unrestricted
    oobm
    ip address dhcp-bootp
    exit
    vlan 1
    name "DEFAULT_VLAN"
    no untagged 2-23
    tagged 1,24
    no ip address
    exit
    vlan 7
    name "VLAN7"
    no ip address
    exit
    vlan 21
    name "VLAN21"
    tagged 1-24
    no ip address
    jumbo
    exit
    vlan 22
    name "VLAN22"
    no ip address
    exit
    vlan 101
    name "Events"
    tagged 1-24
    no ip address
    exit
    vlan 103
    name "VLAN103"
    tagged 1-22,24
    no ip address
    exit
    vlan 104
    name "EVENTS1"
    tagged 1-24
    no ip address
    exit
    vlan 107
    name "VLAN107"
    tagged 1-24
    no ip address
    jumbo
    exit
    vlan 210
    name "VLAN210"
    untagged 2-20
    tagged 24
    no ip address
    jumbo
    exit
    vlan 211
    name "VLAN211"
    tagged 24
    no ip address
    exit
    vlan 212
    name "VLAN212"
    tagged 24
    no ip address
    exit
    vlan 213
    name "VLAN213"
    tagged 24
    no ip address
    exit
    vlan 214
    name "VLAN214"
    no ip address
    exit
    vlan 215
    name "VLAN215"
    no ip address
    exit
    vlan 216
    name "VLAN216"
    tagged 24
    no ip address
    exit
    vlan 220
    name "VLAN220"
    tagged 24
    ip address 192.168.220.10 255.255.255.0
    exit
    spanning-tree
    no tftp server
    no autorun
    no dhcp config-file-update
    no dhcp image-file-update
    password manager
    password operator

    HP-2920-24G-Floor-1-POE#




    Thank You..!!



  • 4.  RE: Aruba Switch -2920 Port Flapping - Aruba AP's Connected

    Posted 12 days ago
    Hello sir ,
    I am having the same issue ,port which is connected to energy meter are getting disabled .
    IT was working before properly but when we applied port security ,mac binding, bpdu protection it's started getting disabled so we removed the Port security and bpdu protection but still problem is not solved

    ------------------------------
    Shivam Ojha
    ------------------------------



  • 5.  RE: Aruba Switch -2920 Port Flapping - Aruba AP's Connected

    Posted 12 days ago
    This is a response to an old thread. Please create a new one, and include more details like configuration, type of devices, type and version of switches, logging information.

    Also, this sounds possibly urgent. In that case, open a case with your Aruba partner or Aruba support to get proper attention. It is hard to impossible with this little information to do anything useful.

    ------------------------------
    Herman Robers
    ------------------------
    If you have urgent issues, always contact your Aruba partner, distributor, or Aruba TAC Support. Check https://www.arubanetworks.com/support-services/contact-support/ for how to contact Aruba TAC. Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba Networks.

    In case your problem is solved, please invest the time to post a follow-up with the information on how you solved it. Others can benefit from that.
    ------------------------------