Wired

last person joined: 17 hours ago 

Bring performance and reliability to your network with the Aruba Core, Aggregation, and Access layer switches. Discuss the latest features and functionality of the ArubaOS-Switch and ArubaOS-CX devices, and find ways to improve security across your network to bring together a mobile first solution.
Expand all | Collapse all

AOS-CX (8320) checkpoint auto "minutes" <<< failure after admin disconnect

Jump to Best Answer
This thread has been viewed 13 times
  • 1.  AOS-CX (8320) checkpoint auto "minutes" <<< failure after admin disconnect

    Posted Nov 18, 2019 06:57 AM

    Re: AOS-CX (8320, 10.04.0001) checkpoint auto "minutes"

     

    Big picture:  The checkpoint auto "minutes" and auto recover feature does not seem to work if the admin disconnects from the aos-cx-8320 before the timer expires.

     

    See one question at the end of this original post.

     

    Specific Issue:

    Step#1: I logged into the 8320.  Then set the checkpoint timer for 3 minutes.  Next, changed the hostname to "...3". Final, logged out of the 8320 before the 3 minute timer expired.

    Step#2: I re-logged into the 8320 after 5 minutes. The hostname was still "...3".  Also discovered the checkpoint timer was still "stuck on".

     

    ....LOG IN >>>>> SSH >>> 10.10.10.6......

    HPE-AOSCX8320-TEMP2# check auto 3

    Auto checkpoint mode expires in 3 minute(s)

    HPE-AOSCX8320-TEMP2#conf

    HPE-AOSCX8320-TEMP2(config)# hostname HPE-AOSCX8320-TEMP3

    HPE-AOSCX8320-TEMP3(config)#exit

    HPE-AOSCX8320-TEMP3# exit

    Attempting username/password authentication...

    The SSH connection closed: Connection closed by host.

    after 5 minutes....LOG IN >>>>> SSH >>> 10.10.10.6......

    HPE-AOSCX8320-TEMP3# check auto 3

    Auto checkpoint mode expires in 3 minute(s)

    Error: Checkpoint auto timer is already ON

    HPE-AOSCX8320-TEMP3#

     

    Question#1:  Should the checkpoint auto timer expire automatically and then recover even if the admin is disconnected???

     

    EDITED: 20191118-0627 (CST)

    I rebooted the 8320 and did not save the RUNN config.

    Logged back into the 8320 with the following results:

     

    HPE-AOSCX8320-TEMP2# check auto 3

    Auto checkpoint mode expires in 3 minute(s)

    Error: Checkpoint auto timer is already ON  <<<<<

     

    -----
    # Thanks # Gracias # Merci # ありがとう # Danke # Spasiba # 감사합니다 # Toda # Cheers # Dhanyawaad # Ahsante # Xièxiè # shukran #


    #8320


  • 2.  RE: AOS-CX (8320) checkpoint auto "minutes" <<< failure after admin disconnect

    Posted Nov 18, 2019 10:06 AM

    Hello,

    I've just checked on 10.04.0001 as you reported, with 1 minute instead of 3 minutes and it perfectly works as expected.

     

    Try without logout and see if the switch is able to restore the configuration.  you should see:

    8325-3# WARNING: Restoring configuration. Do NOT add any new configuration.
    Configuration changes will take time to process, please be patient.
    Restoration successful

     

    Regards,

    Vincent



  • 3.  RE: AOS-CX (8320) checkpoint auto "minutes" <<< failure after admin disconnect

    Posted Nov 18, 2019 10:58 AM

    Thanks for your extra effort.  I should have clarified my point.  Yes, as long as I stay logged into the aos-cx (8320) the check auto "minutes" feature works perfectly for me.

    My problem:  I have remote sites that if I am disconnected due to my ignorant configuration, I need the 8320 to revert back to the original RUNN config which in theory should allow me to remotely re-attach to the 8320 a an admin.  My log-off steps are similating a bad config that disconnects me feature set.



  • 4.  RE: AOS-CX (8320) checkpoint auto "minutes" <<< failure after admin disconnect

    Posted Nov 18, 2019 11:04 AM

    Understood, and this is what I tested (by disconnected my ssh session and connecting after 2 minutes). I confirm it worked as expected on my switch.



  • 5.  RE: AOS-CX (8320) checkpoint auto "minutes" <<< failure after admin disconnect

    Posted Nov 18, 2019 11:10 AM

    vincent.giles wrote:

    Understood, and this is what I tested (by disconnected my ssh session and connecting after 2 minutes). I confirm it worked as expected on my switch.


     

    Thanks for the clarification.  I will try the test re-attaching via ssh before the "checkp auto" timeout.  All my tests were after the timeout.



  • 6.  RE: AOS-CX (8320) checkpoint auto "minutes" <<< failure after admin disconnect

    Posted Nov 19, 2019 04:15 AM

    vincent.giles wrote:

    Understood, and this is what I tested (by disconnected my ssh session and connecting after 2 minutes). I confirm it worked as expected on my switch.


     

    Used the checkpoint 5 command…then exited the 8320….after 36 hours:

     

    HPE-AOSCX8320# check auto 3

    Auto checkpoint mode expires in 3 minute(s)

    Error: Checkpoint auto timer is already ON   <<<<  ???

     

    HPE-AOSCX8320# no check auto conf

    WARNING: Restoring configuration. Do NOT add any new configuration.

    Configuration changes will take time to process, please be patient.

    Restoration successful

     

    I tried:

    logged in via ssh

    check auto 5

    changed hostname

    exited the 8320

    logged in via ssh   (within 1 minute...pre- 5 minute timer)

    NO aos-cx notification to checkpoint auto confirm

    5 minutes expired...still notification but then tried:

     

    HPE-AOSCX8320# check auto 3

    Auto checkpoint mode expires in 3 minute(s)

    Error: Checkpoint auto timer is already ON   <<<<< ON ???

     

    HPE-AOSCX8320# no check auto conf

    WARNING: Restoring configuration. Do NOT add any new configuration.

    Configuration changes will take time to process, please be patient.

    Restoration successful

     

    Thanks again for trying to help !!!

     

     

     



  • 7.  RE: AOS-CX (8320) checkpoint auto "minutes" <<< failure after admin disconnect
    Best Answer

    Posted Nov 19, 2019 04:33 AM

    Can you log a case ?



  • 8.  RE: AOS-CX (8320) checkpoint auto "minutes" <<< failure after admin disconnect
    Best Answer

    Posted Nov 19, 2019 12:52 PM

    This is acknowledged as a bug.



  • 9.  RE: AOS-CX (8320) checkpoint auto "minutes" <<< failure after admin disconnect

    Posted Jan 29, 2021 09:18 AM

    CX 10.06.0010:  appears fixed


    ------------------------------
    R-Air
    ------------------------------