Wired

last person joined: 10 hours ago 

Bring performance and reliability to your network with the Aruba Core, Aggregation, and Access layer switches. Discuss the latest features and functionality of the ArubaOS-Switch and ArubaOS-CX devices, and find ways to improve security across your network to bring together a mobile first solution.
Expand all | Collapse all

Alcatel VOIP to Aruba

This thread has been viewed 18 times
  • 1.  Alcatel VOIP to Aruba

    Posted 26 days ago
    Hello, we are encountering an issue by moving alcatel phone from Alcatel switches to Aruba .

    Equipments are 
    - Alcatel-Lucent OS6850-P48
    - Alcatel Iphone 8028/8018
    - Alcatel OmniPCX
    - Aruba 2540 48G POE

    Alcatel switch config is 
    ! File: /flash/working/boot.cfg !
    !========================================!
    ! Stack Manager :
    ! Chassis :
    system name SwL2-AT4-2
    system location AT4
    system timezone CET
    system daylight savings time enable
    ! Configuration:
    ! VLAN :
    vlan 1 enable name "Server"
    vlan 2 enable name "Computer"
    vlan 2 port default 1/3
    vlan 2 port default 1/6
    vlan 2 port default 1/9
    vlan 2 port default 1/11
    vlan 2 port default 1/17
    vlan 2 port default 1/18
    vlan 2 port default 1/19
    vlan 2 port default 1/23
    vlan 2 port default 1/25
    vlan 2 port default 1/26
    vlan 2 port default 1/31
    vlan 2 port default 1/34
    vlan 2 port default 1/39
    vlan 2 port default 1/40
    vlan 3 enable name "Toip"
    vlan 3 mobile-tag enable
    vlan port mobile 1/2 bpdu ignore enable
    vlan port mobile 1/3 bpdu ignore enable
    vlan port mobile 1/4 bpdu ignore enable
    vlan port mobile 1/5 bpdu ignore enable
    vlan port mobile 1/6 bpdu ignore enable
    vlan port mobile 1/7 bpdu ignore enable
    vlan port mobile 1/8 bpdu ignore enable
    vlan port mobile 1/9 bpdu ignore enable
    vlan port mobile 1/10 bpdu ignore enable
    vlan port mobile 1/11 bpdu ignore enable
    vlan port mobile 1/12 bpdu ignore enable
    vlan port mobile 1/13 bpdu ignore enable
    vlan port mobile 1/14 bpdu ignore enable
    vlan port mobile 1/15 bpdu ignore enable
    vlan port mobile 1/16 bpdu ignore enable
    vlan port mobile 1/17 bpdu ignore enable
    vlan port mobile 1/18 bpdu ignore enable
    vlan port mobile 1/19 bpdu ignore enable
    vlan port mobile 1/20 bpdu ignore enable
    vlan port mobile 1/21 bpdu ignore enable
    vlan port mobile 1/22 bpdu ignore enable
    vlan port mobile 1/23 bpdu ignore enable
    vlan port mobile 1/24 bpdu ignore enable
    vlan port mobile 1/25 bpdu ignore enable
    vlan port mobile 1/26 bpdu ignore enable
    vlan port mobile 1/27 bpdu ignore enable
    vlan port mobile 1/28 bpdu ignore enable
    vlan port mobile 1/29 bpdu ignore enable
    vlan port mobile 1/30 bpdu ignore enable
    vlan port mobile 1/31 bpdu ignore enable
    vlan port mobile 1/32 bpdu ignore enable
    vlan port mobile 1/33 bpdu ignore enable
    vlan port mobile 1/34 bpdu ignore enable
    vlan port mobile 1/35 bpdu ignore enable
    vlan port mobile 1/36 bpdu ignore enable
    vlan port mobile 1/37 bpdu ignore enable
    vlan port mobile 1/38 bpdu ignore enable
    vlan port mobile 1/39 bpdu ignore enable
    vlan port mobile 1/40 bpdu ignore enable
    vlan port mobile 1/41 bpdu ignore enable
    vlan port mobile 1/42 bpdu ignore enable
    vlan port mobile 1/43 bpdu ignore enable
    vlan port mobile 1/44 bpdu ignore enable
    vlan port mobile 1/45 bpdu ignore enable
    vlan port mobile 1/46 bpdu ignore enable
    vlan port mobile 1/47 bpdu ignore enable
    vlan port mobile 1/48 bpdu ignore enable
    ! VLAN SL:
    ! IP :
    ip service all
    ip interface dhcp-client vlan 1 ifindex 1
    ip interface "vlan_1" address xxx.xxx.xxx.xxx mask 255.255.254.0 vlan 1 ifindex 2
    ip interface "vlan_2" address xxx.xxx.xxx.xxx mask 255.255.255.0 vlan 1 ifindex 3
    ! IPX :
    ! IPMS :
    ip multicast status enable
    ip multicast querying enable
    ip multicast zapping enable
    ip multicast version 3
    ip multicast querier-forwarding enable
    ! AAA :
    aaa authentication default "local"
    aaa authentication console "local"
    aaa authentication http "local"
    aaa authentication ssh "local"
    ! PARTM :
    ! AVLAN :
    ! 802.1x :
    ! QOS :
    qos trust ports default servicing mode drr 8 2 9 4 9 0 0 0 no user-port filter user-port shutdown bpdu bgp ospf rip vrrp dhcp-server pim dvmrp isis dns-reply
    policy port group UserPorts 1/2 1/3 1/4 1/5 1/6
    policy port group UserPorts 1/7 1/8 1/10 1/11 1/12
    policy port group UserPorts 1/13 1/14 1/15 1/16 1/17
    policy port group UserPorts 1/18 1/19 1/20 1/21 1/22
    policy port group UserPorts 1/23 1/24 1/25 1/26 1/27
    policy port group UserPorts 1/28 1/29 1/30 1/31 1/32
    policy port group UserPorts 1/33 1/34 1/35 1/36 1/37
    policy port group UserPorts 1/38 1/39 1/40 1/41 1/42
    policy port group UserPorts 1/43 1/44 1/45 1/46 1/47
    policy port group UserPorts 1/48
    qos apply
    ! Policy manager :
    ! Session manager :
    session timeout cli 120
    session prompt default "SwL2-AT4-2 -> "
    session login-timeout 120
    command-log enable
    ! SNMP :
    ! RIP :
    ! OSPF :
    ! BFD-STD :
    ! ISIS :
    ! IPv6 :
    ! IPSec :
    ! IP multicast :
    ! RIPng :
    ! OSPF3 :
    ! BGP :
    ! Health monitor :
    ! Interface :
    interfaces 1/1 flood broadcast rate percentage 5
    interfaces 1/2 flood broadcast rate percentage 5
    interfaces 1/3 flood broadcast rate percentage 5
    interfaces 1/4 flood broadcast rate percentage 5
    interfaces 1/5 flood broadcast rate percentage 5
    interfaces 1/6 flood broadcast rate percentage 5
    interfaces 1/7 flood broadcast rate percentage 5
    interfaces 1/8 flood broadcast rate percentage 5
    interfaces 1/9 flood broadcast rate percentage 5
    interfaces 1/10 flood broadcast rate percentage 5
    interfaces 1/11 flood broadcast rate percentage 5
    interfaces 1/12 flood broadcast rate percentage 5
    interfaces 1/13 flood broadcast rate percentage 5
    interfaces 1/14 flood broadcast rate percentage 5
    interfaces 1/15 flood broadcast rate percentage 5
    interfaces 1/16 flood broadcast rate percentage 5
    interfaces 1/17 flood broadcast rate percentage 5
    interfaces 1/18 flood broadcast rate percentage 5
    interfaces 1/19 flood broadcast rate percentage 5
    interfaces 1/20 flood broadcast rate percentage 5
    interfaces 1/21 flood broadcast rate percentage 5
    interfaces 1/22 flood broadcast rate percentage 5
    interfaces 1/23 flood broadcast rate percentage 5
    interfaces 1/24 flood broadcast rate percentage 5
    interfaces 1/25 flood broadcast rate percentage 5
    interfaces 1/26 flood broadcast rate percentage 5
    interfaces 1/27 flood broadcast rate percentage 5
    interfaces 1/28 flood broadcast rate percentage 5
    interfaces 1/29 flood broadcast rate percentage 5
    interfaces 1/30 flood broadcast rate percentage 5
    interfaces 1/31 flood broadcast rate percentage 5
    interfaces 1/32 flood broadcast rate percentage 5
    interfaces 1/33 flood broadcast rate percentage 5
    interfaces 1/34 flood broadcast rate percentage 5
    interfaces 1/35 flood broadcast rate percentage 5
    interfaces 1/36 flood broadcast rate percentage 5
    interfaces 1/37 flood broadcast rate percentage 5
    interfaces 1/38 flood broadcast rate percentage 5
    interfaces 1/39 flood broadcast rate percentage 5
    interfaces 1/40 flood broadcast rate percentage 5
    interfaces 1/41 flood broadcast rate percentage 5
    interfaces 1/42 flood broadcast rate percentage 5
    interfaces 1/43 flood broadcast rate percentage 5
    interfaces 1/44 flood broadcast rate percentage 5
    interfaces 1/45 flood broadcast rate percentage 5
    interfaces 1/46 flood broadcast rate percentage 5
    interfaces 1/47 flood broadcast rate percentage 5
    interfaces 1/48 flood broadcast rate percentage 5
    interfaces 1/1 violation-recovery-time 300
    interfaces 1/2 violation-recovery-time 300
    interfaces 1/3 violation-recovery-time 300
    interfaces 1/4 violation-recovery-time 300
    interfaces 1/5 violation-recovery-time 300
    interfaces 1/6 violation-recovery-time 300
    interfaces 1/7 violation-recovery-time 300
    interfaces 1/8 violation-recovery-time 300
    interfaces 1/9 violation-recovery-time 300
    interfaces 1/10 violation-recovery-time 300
    interfaces 1/11 violation-recovery-time 300
    interfaces 1/12 violation-recovery-time 300
    interfaces 1/13 violation-recovery-time 300
    interfaces 1/14 violation-recovery-time 300
    interfaces 1/15 violation-recovery-time 300
    interfaces 1/16 violation-recovery-time 300
    interfaces 1/17 violation-recovery-time 300
    interfaces 1/18 violation-recovery-time 300
    interfaces 1/19 violation-recovery-time 300
    interfaces 1/20 violation-recovery-time 300
    interfaces 1/21 violation-recovery-time 300
    interfaces 1/22 violation-recovery-time 300
    interfaces 1/23 violation-recovery-time 300
    interfaces 1/24 violation-recovery-time 300
    interfaces 1/25 violation-recovery-time 300
    interfaces 1/26 violation-recovery-time 300
    interfaces 1/27 violation-recovery-time 300
    interfaces 1/28 violation-recovery-time 300
    interfaces 1/29 violation-recovery-time 300
    interfaces 1/30 violation-recovery-time 300
    interfaces 1/31 violation-recovery-time 300
    interfaces 1/32 violation-recovery-time 300
    interfaces 1/33 violation-recovery-time 300
    interfaces 1/34 violation-recovery-time 300
    interfaces 1/35 violation-recovery-time 300
    interfaces 1/36 violation-recovery-time 300
    interfaces 1/37 violation-recovery-time 300
    interfaces 1/38 violation-recovery-time 300
    interfaces 1/39 violation-recovery-time 300
    interfaces 1/40 violation-recovery-time 300
    interfaces 1/41 violation-recovery-time 300
    interfaces 1/42 violation-recovery-time 300
    interfaces 1/43 violation-recovery-time 300
    interfaces 1/44 violation-recovery-time 300
    interfaces 1/45 violation-recovery-time 300
    interfaces 1/46 violation-recovery-time 300
    interfaces 1/47 violation-recovery-time 300
    interfaces 1/48 violation-recovery-time 300
    interfaces 1/1 violation-recovery-maximum 0
    interfaces 1/2 violation-recovery-maximum 0
    interfaces 1/3 violation-recovery-maximum 0
    interfaces 1/4 violation-recovery-maximum 0
    interfaces 1/5 violation-recovery-maximum 0
    interfaces 1/6 violation-recovery-maximum 0
    interfaces 1/7 violation-recovery-maximum 0
    interfaces 1/8 violation-recovery-maximum 0
    interfaces 1/9 violation-recovery-maximum 0
    interfaces 1/10 violation-recovery-maximum 0
    interfaces 1/11 violation-recovery-maximum 0
    interfaces 1/12 violation-recovery-maximum 0
    interfaces 1/13 violation-recovery-maximum 0
    interfaces 1/14 violation-recovery-maximum 0
    interfaces 1/15 violation-recovery-maximum 0
    interfaces 1/16 violation-recovery-maximum 0
    interfaces 1/17 violation-recovery-maximum 0
    interfaces 1/18 violation-recovery-maximum 0
    interfaces 1/19 violation-recovery-maximum 0
    interfaces 1/20 violation-recovery-maximum 0
    interfaces 1/21 violation-recovery-maximum 0
    interfaces 1/22 violation-recovery-maximum 0
    interfaces 1/23 violation-recovery-maximum 0
    interfaces 1/24 violation-recovery-maximum 0
    interfaces 1/25 violation-recovery-maximum 0
    interfaces 1/26 violation-recovery-maximum 0
    interfaces 1/27 violation-recovery-maximum 0
    interfaces 1/28 violation-recovery-maximum 0
    interfaces 1/29 violation-recovery-maximum 0
    interfaces 1/30 violation-recovery-maximum 0
    interfaces 1/31 violation-recovery-maximum 0
    interfaces 1/32 violation-recovery-maximum 0
    interfaces 1/33 violation-recovery-maximum 0
    interfaces 1/34 violation-recovery-maximum 0
    interfaces 1/35 violation-recovery-maximum 0
    interfaces 1/36 violation-recovery-maximum 0
    interfaces 1/37 violation-recovery-maximum 0
    interfaces 1/38 violation-recovery-maximum 0
    interfaces 1/39 violation-recovery-maximum 0
    interfaces 1/40 violation-recovery-maximum 0
    interfaces 1/41 violation-recovery-maximum 0
    interfaces 1/42 violation-recovery-maximum 0
    interfaces 1/43 violation-recovery-maximum 0
    interfaces 1/44 violation-recovery-maximum 0
    interfaces 1/45 violation-recovery-maximum 0
    interfaces 1/46 violation-recovery-maximum 0
    interfaces 1/47 violation-recovery-maximum 0
    interfaces 1/48 violation-recovery-maximum 0
    interfaces violation-recovery-trap enable
    ! Udld :
    ! Netsec :
    ! Link Aggregate :
    ! Port Mapping :
    ! VLAN AGG:
    ! 802.1Q :
    vlan 2 802.1q 1/1 "TAG PORT 1/1 VLAN 2"
    vlan 3 802.1q 1/1 "TAG PORT 1/1 VLAN 3"
    ! Spanning tree :
    bridge mode 1x1
    ! Bridging :
    ! Bridging :
    ! Port mirroring :
    ! UDP Relay :
    ! Server load balance :
    ! System service :
    swlog syslog-facility-id local2
    swlog console level info
    ! SSH :
    ! VRRP :
    ! Web :
    ! AMAP :
    ! Lan Power :
    lanpower 1 capacitor-detection enable
    lanpower start 1
    ! NTP :
    ntp server xxx.xxx.xxx.xxx
    ntp client enable
    ! RDP :
    ! VLAN STACKING:
    ! Ethernet-OAM :
    ! EFM-OAM :
    ! ERP :
    ! SAA :
    ! DHCP Server :
    ! WCCP :
    ip wccp admin-state enable
    ! LLDP :
    lldp network-policy 1 application voice vlan 3 l2-priority 5 dscp 46
    lldp chassis notification enable
    lldp chassis tlv management port-description enable system-name enable system-description enable
    lldp chassis tlv management management-address enable
    lldp chassis tlv med network-policy enable power enable
    lldp chassis med network-policy 1
    ! Link-fault-propagation :
    ! DHL :


    Aruba switch config is 

    Running configuration:

    ; JL357A Configuration Editor; Created on release #YC.16.08.0001
    ; Ver #14:07.44.38.04.99.03.b3.b8.ef.74.61.fc.68.f3.8c.fc.e3.ff.37.2f:13

    hostname "........."
    module 1 type jl357a
    console idle-timeout 3600
    console idle-timeout serial-usb 3600
    password minimum-length 8
    timesync ntp
    ntp unicast
    ntp server xxx.xxx.xxx.xxx
    ntp enable
    no telnet-server
    time timezone 10
    ip default-gateway xxx.xxx.xxx.xxx
    interface 47
    no power-over-ethernet
    exit
    interface 48
    no power-over-ethernet
    exit
    snmp-server community ......
    vlan 1
    name "Server"
    untagged 1-52
    ip address xxx.xxx.xxx.xxx 255.255.255.0
    exit
    vlan 2
    name "Computer"
    no ip address
    exit
    vlan 3
    name "Toip"
    no ip address
    voice
    exit
    spanning-tree
    no tftp server
    no autorun
    no dhcp config-file-update
    no dhcp image-file-update
    password manager
    password operator

    We found a solution to get it working by adding tag on port and removing Voice option on the VLAN 3 as below however phone traffic is not stable 


    vlan 1
    name "Server"
    untagged 1-52
    ip address 159.217.232.234 255.255.255.0
    exit
    vlan 2
    name "Computer"
    tagged 1-52
    no ip address
    exit
    vlan 3
    name "Toip"
    tagged 1-52
    no ip address
    exit


    We suspect some LLDP policy that is causing this issue but after tried adding policy results were the same 

    Any advice ?

    Thanks


  • 2.  RE: Alcatel VOIP to Aruba

    Posted 25 days ago
    Hi,

    do you have check the qos trust dscp ?

    ------------------------------
    PowerArubaSW : Powershell Module to use Aruba Switch API for Vlan, VlanPorts, LACP, LLDP...

    PowerArubaCP: Powershell Module to use ClearPass API (create NAD, Guest...)

    PowerArubaCX: Powershell Module to use ArubaCX API (get interface/vlan/ports info)..

    ACEP / ACMX #107 / ACDX #1281
    ------------------------------



  • 3.  RE: Alcatel VOIP to Aruba

    Posted 25 days ago
    I didn't check yet these settings, I 'll go deeper on it to do some test and understand better how to set and let you know.

    Many thanks


  • 4.  RE: Alcatel VOIP to Aruba

    Posted 25 days ago
    Have you seen this document VoIP Deployment on ArubaOS-Switch?

    What do you mean by 'not stable'? Link flapping? No IP address? Choppy audio? Complete loss of service?


    ------------------------------
    Herman Robers
    ------------------------
    If you have urgent issues, always contact your Aruba partner, distributor, or Aruba TAC Support. Check https://www.arubanetworks.com/support-services/contact-support/ for how to contact Aruba TAC. Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba Networks.
    ------------------------------



  • 5.  RE: Alcatel VOIP to Aruba

    Posted 25 days ago
    Many thanks, with the first settings applied on the Aruba switch ( only Voice option without tags) some phone attached to the VLAN and some other stuck on network discovery and we were not able to get computer behind phone.

    With the current config the latest without Voice option and port tagged phone link is flapping and computer can take between 1-5 min to get an IP distributed, after that performance are normal on computers.

    I tried to set a policy like below without any success , which is the same as your link describe

    switch(config)# device-identity name "VoIP-Phone"
    switch(identity-VoIP-Phone)# lldp oui 00-80-c2 sub-type 1
    switch(identity-VoIP-Phone)# exit
    Next, create the device profile with settings to be applied to provisioned ports:
    switch(config)# device-profile name "Phone-Profile"
    switch(device-profile)# tagged-vlan 3
    switch(device-profile)# untagged-vlan 1
    switch(device-profile)# untagged-vlan 2
    switch(device-profile)# allow-jumbo frames
    switch(device-profile)# exit
    Lastly, associate the device identity with the new profile, and enable the profile for that device type:
    switch(config)# device-profile device-type "VoIP-Phone"
    switch(device-VoIP-Phone)# associate "Phone-Profile"
    switch(device-VoIP-Phone)# enable
    switch(device-VoIP-Phone)# exit


  • 6.  RE: Alcatel VOIP to Aruba

    Posted 25 days ago
    Hi @hbrsc, well...the dual untagged part of:

    switch(device-profile)# tagged-vlan 3
    switch(device-profile)# untagged-vlan 1
    switch(device-profile)# untagged-vlan 2​
    ​on ArubaOS-Switch has no sense.

    An interface (physical or logical) can be untagged on only one VLAN (in your case VLAN 1 - which is default - or VLAN 2, not both). The very same port can be also tagged on various other VLAN IDs. An interface can be also only a tagged member of a VLAN (without necessarily being untagged member of a VLAN too -> this case appears as the interface to be marked as "no untagged" on VLAN 1).

    So I can understand that an interface is a tagged member of VLAN 3 and also an untagged member of VLAN 1 or a tagged member of VLAN 3 and an untagged member of VLAN 2 but not a tagged member of VLAN 3 and being an untagged member of VLAN 1 and concurrently an untagged member of VLAN 2.

    My 2 cents: triple check what are the VLAN/Interface membership settings on your Alcatel to see if you can reproduce those settings on your ArubaOS-Switch.

    ------------------------------
    Davide Poletto
    ------------------------------



  • 7.  RE: Alcatel VOIP to Aruba

    Posted 25 days ago
    Hi Davide,

    Many thanks for these remarks, we reviewed all tagging for our VLAN and it seems that network is more stable after removing the VLAN2 from tagged network. We are keeping things under monitoring as soon we'll be sure that things are fine I'll post the config we set to get it shared on the discussion.

    We also have had to remove the 802.1x settings on the phone itself and forced the VLAN 3.

    KR