Wired Intelligent Edge

last person joined: 2 hours ago 

Bring performance and reliability to your network with the Aruba Core, Aggregation, and Access layer switches. Discuss the latest features and functionality of the ArubaOS-Switch and ArubaOS-CX devices, and find ways to improve security across your network to bring together a mobile first solution.
Expand all | Collapse all

Default Gateway on VLAN (Aruba 6100 12G CL4 - Layer 2)

Jump to Best Answer
This thread has been viewed 59 times
  • 1.  Default Gateway on VLAN (Aruba 6100 12G CL4 - Layer 2)

    Posted Apr 21, 2021 11:04 AM
    Hey Airheads,

    hopefully this is the right community to ask that question.

    I'm curently trying to configure a new edge switch (Aruba 6100 12G CL4 - Layer 2) in our environment.
    All our edge switches are managened in a seperate vlan, where only admins can access.
    So I added a vlan (vlan20) on the switch and gave it an ip address (#conf, #interface vlan 20, #ip address 172.21.16.240/24). The problem now is that the switch has no connection to Aruba Central anymore because it can't access the internet without the gateway 172.21.16.254.
    So my question is if there is any posibility to change the managament vlan from vlan1 to my vlan20 and set up a default gateway? We never use the default vlan1 and always manage them through vlan20.

    I already tried to turn dhcp on on vlan20 to check if that would word but it seems its only possible for defaut vlan.

    Many many thanks for your help!
    Cheers,
    Yannik

    ------------------------------
    Yannik Piwowarski
    ------------------------------


  • 2.  RE: Default Gateway on VLAN (Aruba 6100 12G CL4 - Layer 2)
    Best Answer

    Posted Apr 21, 2021 02:28 PM
    simply use the 

    ip route 0.0.0.0/0 172.21.16.254  

    The above will give you a default gateway to your host on VLAN 20

    Note to use 6100 in central you will need 10.07 software release  which is now available on ASP as of today.
    Also only template group will be supported in current central version (2.5.3)  

    dhcp only supported on default vlan 1 on 6100

    I hope this helps

    basic config

    vlan 20
    !

    int X/Y/Z
    no shut
    vlan access 20
    !
    int vlan 20
    ip address 172.21.16.X/24
    ip route 0.0.0.0/0 172.21.16.254
    !
    ip dns server-address A.D.C.D


    ------------------------------
    Kamal Takodra
    If my post was useful accept solution and/or give kudos
    ------------------------------



  • 3.  RE: Default Gateway on VLAN (Aruba 6100 12G CL4 - Layer 2)

    Posted Apr 22, 2021 03:32 AM
    That was is. So simple that I didn't think of it.

    Many thanks for your help!

    Cheers,
    Yannik

    ------------------------------
    Yannik Piwowarski
    ------------------------------



  • 4.  RE: Default Gateway on VLAN (Aruba 6100 12G CL4 - Layer 2)

    Posted Jul 13, 2021 09:50 AM
    Hi,

    I got a a Aruba 6100 (same as above)

    i only have one VLAN = vLAN 1 (Default)

    I have been trying to connect the switch to Aruba Central

    but I haven't had any luck

    I get the following error


    From the switch, I can ping the Default Gateway, no problems


    but if I try to ping something beyond the gateway, I get an error (pinging from the switch again)



    But if i try pinging 8.8.8.8 from my laptop (which is connected to the switch in question)


    i don't understand why it would ping from my laptop but not from the switch.

    any ideas would be greatly appreciated

    cheers

    Ian


    ------------------------------
    Ian Salgado
    ------------------------------



  • 5.  RE: Default Gateway on VLAN (Aruba 6100 12G CL4 - Layer 2)

    Posted Jul 13, 2021 08:30 PM
    Have you tried to ping a non-Google address? For example, CloudFlare DNS @ 1.1.1.1?

    For the central connection, make sure your time is set correctly and you have DNS configured.​

    ------------------------------
    Justin Noonan
    ------------------------------



  • 6.  RE: Default Gateway on VLAN (Aruba 6100 12G CL4 - Layer 2)

    Posted Jul 14, 2021 06:02 AM
    Hi,

    time is correct on the switch
    I can now ping 1.1.1.1

    added ip route 0.0.0.0/0 x.x.x.x (default gateway)

    cheers


    ------------------------------
    Ian Salgado
    ------------------------------



  • 7.  RE: Default Gateway on VLAN (Aruba 6100 12G CL4 - Layer 2)

    Posted Jul 17, 2021 01:50 AM
    Hi,

    I found there was an issue with the Time & Time Zone

    so I fixed them both by adding an ntp server & setting the correct time zone

    but still have issue.

    It just refuses to connect to aruba central

    any ideas ?

    cheers

    ------------------------------
    Ian Salgado
    ------------------------------



  • 8.  RE: Default Gateway on VLAN (Aruba 6100 12G CL4 - Layer 2)

    Posted Jul 14, 2021 05:57 AM
    I added a couple of additional entries to the switch config

    ip route 0.0.0.0/0 x.x.x.x (default gateway

    ip dns server-address 8.8.8.8

    now I can ping pass the gateway

    I can resolve dns by name, ie: www.google.com

    but still can' t connect the switch to Aruba Central.


    cheers

    ------------------------------
    Ian Salgado
    ------------------------------