Wired

last person joined: 22 hours ago 

Vrf in a gretunnel interface

This thread has been viewed 8 times
  • 1.  Vrf in a gretunnel interface

    Posted Jul 29, 2021 11:53 AM
    Hi Guys

    I am having an issue with a new Aruba CX 6300 and tunnel with a vrf, that won't work.
    It used to be a cisco 3560, but it has been swapped with a cx 6300M

    Hardware:
    HPE Comware Software, Version 7.1.070, Release 7557P01
    Copyright (c) 2010-2017 Hewlett Packard Enterprise Development LP
    HP 10508 uptime is 181 weeks, 6 days, 14 hours, 13 minutes
    Boot image: flash:/10500-CMW710-BOOT-R7557P01.bin

    Aruba CX6300M
    Vendor : Aruba
    Product Name : JL659A 6300M 48SR5 CL6 PoE 4SFP56 Swch
    ArubaOS-CX Version : FL.10.06.0101

    Configuraution:
    HPE:
    interface Tunnel64 mode gre
    description GuestNet
    ip binding vpn-instance GuestNet
    ip address 10.74.0.29 255.255.255.252
    source 10.68.0.4
    destination 10.30.2.94

    #dis int Tunnel 64
    Tunnel64
    Current state: UP
    Line protocol state: UP
    Description: GuestNet
    Bandwidth: 64 kbps
    Maximum transmission unit: 1476
    Internet address: 10.74.0.29/30 (primary)
    Tunnel source 10.68.0.4, destination 10.30.2.94
    Tunnel keepalive disabled
    Tunnel TTL 255
    Tunnel protocol/transport GRE/IP
    GRE key disabled
    Checksumming of GRE packets disabled
    Last clearing of counters: Never
    Last 300 seconds input rate: 0 bytes/sec, 0 bits/sec, 0 packets/sec
    Last 300 seconds output rate: 0 bytes/sec, 0 bits/sec, 0 packets/sec
    Input: 2435 packets, 148416 bytes, 0 drops
    Output: 2333 packets, 133368 bytes, 0 drops

    ArubaOS-CX:
    interface tunnel 64 mode gre ipv4
    description Tunnel
    source ip 10.30.2.94
    destination ip 10.68.0.4
    no shutdown

    #sh int tunnel
    Interface tunnel64 is up
    Admin state is up
    tunnel type GRE IPv4
    tunnel source IPv4 address 10.30.2.94
    tunnel destination IPv4 address 10.68.0.4
    tunnel ttl 255
    Description: Tunnel
    L3 Counters: Rx Disabled, Tx Disabled
    Rx
    L3:
    0 packets, 0 bytes
    Tx
    L3:
    0 packets, 0 bytes

    # sh int brief | i tunn
    tunnel64 -- routed -- yes up -- Tunnel


    Next step is that i wan't to attach a vrf to the tunnel interface so i do the following
    interface tunnel 64 mode gre ipv4
    vrf attach GuestNet
    description Tunnel
    source ip 10.30.2.94
    destination ip 10.68.0.4
    no shutdown
    ttl 255

    Then the tunnel interface goes down, also when i add ip adresses ip address 10.74.0.30/30
    #sh int tunnel 64

    Interface tunnel64 is down
    Admin state is up
    State information:
    Description: Tunnel
    tunnel type GRE IPv4
    tunnel source IPv4 address 10.30.2.94
    tunnel destination IPv4 address 10.68.0.4
    tunnel ttl 255
    L3 Counters: Rx Disabled, Tx Disabled
    Rx
    L3:
    0 packets, 0 bytes
    Tx
    L3:
    0 packets, 0 bytes

    It appears that when i add layer3 to the tunnelinterface it goes down.
    Anyone having the same issue or even some great advice, it worked previously when it was a cisco
    MTU size is 1476 on both sides.

    From HPE the route is known and it can be pinged
    #dis ip routing-table 10.30.2.94

    Summary count : 3

    Destination/Mask Proto Pre Cost NextHop Interface
    0.0.0.0/0 O_ASE2 150 250 10.30.1.57 Vlan3114
    10.30.2.92/30 O_INTRA 66 15 10.30.1.57 Vlan3114
    <Coreswitch>ping 10.30.2.94
    Ping 10.30.2.94 (10.30.2.94): 56 data bytes, press CTRL_C to break
    56 bytes from 10.30.2.94: icmp_seq=0 ttl=62 time=4.959 ms
    56 bytes from 10.30.2.94: icmp_seq=1 ttl=62 time=4.768 ms
    56 bytes from 10.30.2.94: icmp_seq=2 ttl=62 time=4.670 ms
    56 bytes from 10.30.2.94: icmp_seq=3 ttl=62 time=4.663 ms
    56 bytes from 10.30.2.94: icmp_seq=4 ttl=62 time=4.906 ms

    --- Ping statistics for 10.30.2.94 ---
    5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss
    round-trip min/avg/max/std-dev = 4.663/4.793/4.959/0.121 ms

    From Aruba the route is known and it can be pinged
    # sh ip route 10.68.0.4

    Displaying ipv4 routes selected for forwarding

    '[x/y]' denotes [distance/metric]

    0.0.0.0/0, vrf default
    via 10.30.2.93, [1/0], static
    10.68.0.0/16, vrf default, tag 0
    via 10.30.2.93, [110/116], ospf
    # ping 10.68.0.4
    PING 10.68.0.4 (10.68.0.4) 100(128) bytes of data.
    108 bytes from 10.68.0.4: icmp_seq=1 ttl=253 time=4.67 ms
    108 bytes from 10.68.0.4: icmp_seq=2 ttl=253 time=5.33 ms
    108 bytes from 10.68.0.4: icmp_seq=3 ttl=253 time=4.56 ms
    108 bytes from 10.68.0.4: icmp_seq=4 ttl=253 time=4.64 ms
    108 bytes from 10.68.0.4: icmp_seq=5 ttl=253 time=5.21 ms

    --- 10.68.0.4 ping statistics ---
    5 packets transmitted, 5 received, 0% packet loss, time 4006ms
    rtt min/avg/max/mdev = 4.566/4.886/5.338/0.334 ms

    Regards Kenneth

    ------------------------------
    Kenneth Jensen
    ------------------------------