Developer

last person joined: yesterday 

AOS-CX Ansible Collection & Role now using pyaoscx v2!

This thread has been viewed 33 times
  • 1.  AOS-CX Ansible Collection & Role now using pyaoscx v2!

    Posted Jun 10, 2021 08:13 PM
    Updates have been pushed to both the AOS-CX Ansible Collection and Role that include dependency on the Python3 package pyaoscx v2 .

    All modules that use REST API will utilize the pyaoscx v2 library to execute REST API calls and validate device configuration allowing for even more efficient execution!

    Our previous implementation will continue to function but will not be supported for future modules. That means you need to update your Ansible Inventory variables to specify the following:  
    • ansible_network_os=arubanetworks.aoscx.aoscx when using the AOS-CX Ansible Collection or ansible_network_os=aoscx when using the AOS-CX Ansible Role 
    • ansible_aoscx_validate_certs: Set to True or False depending if Ansible should bypass validating certificates to connect to AOS-CX. Only required when ansible_connection is set to aoscx
    • ansible_aoscx_use_proxy: Set to True or False depending if Ansible should bypass environment proxies to connect to AOS-CX. Only required when ansible_connection is set to aoscx.

    Refer below for the command to update to the latest collection or role:
    ansible-galaxy install arubanetworks.aoscx_role -f 
    ansible-galaxy collection install arubanetworks.aoscx -f


    ------------------------------
    Tiffany Chiapuzio-Wong
    ------------------------------