Developer

last person joined: yesterday 

Expand all | Collapse all

IoT development server - telemetry and relay

This thread has been viewed 30 times
  • 1.  IoT development server - telemetry and relay

    Posted May 11, 2021 01:11 PM

    For development purposes only, is it OK if I use http rather than http?  And what is the format of serverURL: is it "http://" or "ws://" ?

    Is it OK to specify the port as part of the URL?

    I can't quite seem to come up with something that works.  I was hoping to avoid  having to have an actual certificate for development.

    ---------------------------Profile[frogpond]---------------------------
    
    serverURL                               : ws://192.168.0.227:8080/
    serverType                              : Telemetry Websocket
    deviceClassFilter                       : All
    reportingInterval                       : 10 second
    ageFilter                               : 120 second
    accessToken                             : abcdefgh
    clientID                                : DAZZLE
    username                                : chrisp
    password                                : *****
    rssiReporting                           : Average
    environmentType                         : office
    ble_on_controller                       : TRUE
    include_ap_group                        : default
    Server Connection State
    --------------------------
    TransportContext                        : Connection Started
    Fail Reason                             : Invalid host:192.168.0.227:8080. path:.
    
    Last Data Update                        : 2021-05-11 13:04:54
    Last Send Time                          : 1969-12-31 19:00:00
    TransType                               : Websocket
    




    ------------------------------
    Christopher Piggott
    ------------------------------


  • 2.  RE: IoT development server - telemetry and relay

    Posted May 12, 2021 04:53 AM
    Hi Christopher,

    For Telemetry-websocket only "ws://" for unencrypted websocket or "wss://" for secure websocket is supported, even if we recommend to use secure websocket only. Specifying a port is supported but you should have at least some path like this "ws://<ip>:<port>/test".

    Please find some config examples here:
    https://iot-utilities.arubademo.de/docs/aruba/aruba_iot_configuration_guide.html#ibeacon--eddystone-asset-tracking

    I assume you use a controller based setup. Try to get more details about the issue by using the following command:
    show ble_relay ws-log​


    ------------------------------
    Jens Fluegel
    ------------------------------



  • 3.  RE: IoT development server - telemetry and relay

    Posted May 12, 2021 10:06 AM
    you can use ws URLS in AOS 8.x. The format should be ws://hostname:port/path.

    in your output, it says
    Invalid host:192.168.0.227:8080. path:.​

    indicating that the path portion of the URL is missing.



    ------------------------------
    Ankur Kamthe
    ------------------------------



  • 4.  RE: IoT development server - telemetry and relay

    Posted May 12, 2021 10:39 AM
    Thank you, Ankur.  It was unfortunate that when I made my development server i docked the websocket at the root.  I placed it lower in the resource path and now it works.

    ------------------------------
    Christopher Piggott
    ------------------------------