Security

last person joined: 11 hours ago 

Enterprise security using ClearPass Policy Management, ClearPass Security Exchange, IntroSpect, VIA, 360 Security Exchange, Extensions and Policy Enforcement Firewall (PEF).
Expand all | Collapse all

CleasPass Azure installation - Update failed after clean install

Jump to Best Answer
This thread has been viewed 11 times
  • 1.  CleasPass Azure installation - Update failed after clean install

    Posted Jun 04, 2021 06:56 PM
    Hi Airheads,

    Iám testing to install ClearPass in the cloud on the MS Azure platform. I follow the ClearPass Guidelines and deploy a fresh server from the Marketplace.
    The version in the marketplace is 6.9.0 and after deployment i try to patch to the latest 6.9.6 version, any update i tried from the GUI or CLI fails. Also try to automatic download from the software update GUI and manually, upload succeed but installation fails any time on three clean installs.

    Somebody have experience with this situation? See below the CLI output.

    [appadmin@cppm01]# system update -i wlanpi@172.16.200.100:/home/wlanpi/CPPM-x86_64-20200522-clearpass-6.9-updates-2-aruba-69-patch.signed.tar

    The authenticity of host '172.16.200.100 (172.16.200.100)' can't be established.
    ECDSA key fingerprint is SHA256:ttSCSu0GmtsYmtYHNfcm0FjW0i2iz1/hq9OBptgxFkk.
    ECDSA key fingerprint is MD5:2b:00:b1:c2:b4:15:8f:28:fc:c9:02:2d:9c:88:7e:20.
    Are you sure you want to continue connecting (yes/no)? yes
    wlanpi@172.16.200.100's password:
    CPPM-x86_64-20200522-clearpass-6.9-updates-2- 100% 1339MB 1.2MB/s 18:23

    Installing patch from=CPPM-x86_64-20200522-clearpass-6.9-updates-2-aruba-69-patch.signed.tar
    Extracting patch...
    INFO - CPPM-x86_64-20200522-clearpass-6.9-updates-2-aruba-69-patch.signed.tar is signed
    ERROR - Extracting patch file failed

    The image is valid but for some reason the Azure appliance won't let my update, while this is supported in the documentation.

    ------------------------------
    Marcel Koedijk | MVP Guru 2021 | ACMP | ACCP | ACDA | Ekahau ECSE | Not an HPE Employee | Opionions are my own
    ------------------------------


  • 2.  RE: CleasPass Azure installation - Update failed after clean install

    Posted Jun 05, 2021 04:58 AM
    Marcel,

    If you are absolutely sure the image is correct, and you have enough free disk space on the appliance (appliance is deployed according to system requirements), this should work without an issue. If it is an issue, like in your case, work with Aruba Support as they can collect some more information and find what is causing this. The WebUI upgrade has my preference, over CLI. Unless you have many appliances to upgrade and want to download once, and update many appliances from a local copy.

    BTW, the image you try to use for upgrade is 6.9.2, not 6.9.6. You may try with the actual 6.9.6 upgrade. Also, for some versions there are hotfixes, like I think with 6.9.0 there was one for TACACS and there was a license activation hotfix around May last year. Do you see other hotfixes?

    ------------------------------
    Herman Robers
    ------------------------
    If you have urgent issues, always contact your Aruba partner, distributor, or Aruba TAC Support. Check https://www.arubanetworks.com/support-services/contact-support/ for how to contact Aruba TAC. Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba Networks.

    In case your problem is solved, please invest the time to post a follow-up with the information on how you solved it. Others can benefit from that.
    ------------------------------



  • 3.  RE: CleasPass Azure installation - Update failed after clean install
    Best Answer

    Posted Jun 05, 2021 05:14 AM
    Thanks Herman!

    I solved the issue. This is my first experience with the installation in Azure. During the pre-installation i add an 1TB disk but i was not aware that i need to morphing it into production from CLABV to Cx000 before it will use the 1TB disk. So diskspace was probably the main issue and 20GB free space of the 40GB installation disk was to less or not supported.

    Indeed i tried different releases to figure out what the problem was, and agree that updating/upgrading from the WebGui is preffererd. Anyway my Aruba ClearPass appliance in Azure works now as expected. Thanks again for sharing your knowledge :).

    ------------------------------
    Marcel Koedijk | MVP Guru 2021 | ACMP | ACCP | ACDA | Ekahau ECSE | Not an HPE Employee | Opionions are my own
    ------------------------------