Security

last person joined: yesterday 

Enterprise security using ClearPass Policy Management, ClearPass Security Exchange, IntroSpect, VIA, 360 Security Exchange, Extensions and Policy Enforcement Firewall (PEF).
Expand all | Collapse all

Insight report exporting via SCP

  • 1.  Insight report exporting via SCP

    Posted Dec 04, 2020 01:56 PM
    Racking my brain and cannot figure out the syntax that InSight wants for the remote directory. The remote windows server I am trying to copy to is running OpenSSH.

    Under Administration I enter the proper File Transfer Settings...
    -->A test while leaving the remote directory field blank is successful as shown below
    -->The test tgz file gets copied to C:/Users/myuser/
    ---->In the above mentioned directory, the test creates a folder named "test", inside of which is the test tgz file
    ---->It also creates a folder named "-p" (what is this for?) in addition to the "test" folder


    Now if I try to specify a specific remote directory, it fails...
    --> assume my username is myuser
    --> assume myuser's home folder is found in C:/Users (like normal users)
    --> assume I created a new folder called newfolder inside myuser's home dir (this is where we want the report going)
    --> when specifying this remote directory, the test fails
    ----> I have tried various combos and variations of dir paths, /'s and \'s, etc... and cannot get a test to work. I want the test to place the tgz into C:/Users/myuser/newfolder


    I have reports exporting from Airwaves via SCP to this same windows server just fine. In airwaves I am even using the same user. In airwaves when I specify the remote dir as /Users/myuser/myfolder the copy works just fine. Even mimicking that syntax is not working for me over in InSight.

    Any ideas? I'm going to feel like an idiot if I am glazing over something simple.



    ------------------------------
    Cody Ensanian
    ------------------------------


  • 2.  RE: Insight report exporting via SCP

    Posted Dec 22, 2020 08:55 AM

    Following up in case this helps someone else down the road. After reaching out to support it appears this is a known bug in 6.9.

    This issue is supposed to be resolved in version 6.10. (TAC had no ETA for release of 6.10)

    Workaround to allow a report to SCP to your remote server:
    - in the InSight settings, set the remote directory path to just "/" (without the quotes)
    - on your remote server at the root of c:, you must create a folder with a name that matches your report's name



    ------------------------------
    Cody Ensanian
    ------------------------------



  • 3.  RE: Insight report exporting via SCP

    Posted Jan 03, 2021 11:00 PM

    Have you tried manually creating a test folder under the desired directory? Also, what's the version of the CPPM on 6.9.x?

    Below is the snippet from CPPM running 6.9.4, tested against Windows server 2012 R2 running OpenSSH

    CPPM Version: 6.9.4

    Root Dir: C:/

    Manually create a 'test' folder under Insight_Reports

      



    ------------------------------
    SANDEEP YADAV
    Global Escalation Center, ACCP | Aruba Software
    ------------------------------



  • 4.  RE: Insight report exporting via SCP

    Posted Jan 03, 2021 11:01 PM

    Have you tried creating a folder named test under your desired directory? And what's the version of 6.9.x you are trying on?

    Below is the snippet from 6.9.4, with Openssh running Windows Server:

    Root Dir: C:/

    Manually created a folder named 'test' under Insight_Reports

    ------------

    Sandeep



    ------------------------------
    Sandeep Yadav
    ------------------------------