Network Management

last person joined: 23 hours ago 

Keep an informative eye on your network with IMC and AirWave network management solutions.
Expand all | Collapse all

ArubaOS-CX routing issue

This thread has been viewed 27 times
  • 1.  ArubaOS-CX routing issue

    Posted Aug 27, 2021 10:00 AM
    Hi,

    I have an issue with routing on a ArubaOS-CX switch. I have only one static route defined which is the default, but the switch has 'learned' some host 'routes' and now tries to use one of these as its default route.

    In the config:

    ip route 0.0.0.0/0 10.44.12.254

    show ip route:

    Displaying ipv4 routes selected for forwarding

    '[x/y]' denotes [distance/metric]

    0.0.0.0/0, vrf default
    via 10.44.12.254, [1/0], static
    10.44.12.0/23, vrf default
    via vlan10, [0/0], connected
    10.44.12.229/32, vrf default
    via vlan10, [0/0], local
    10.200.12.0/23, vrf default
    via vlan1, [0/0], connected
    10.200.13.180/32, vrf default
    via vlan1, [0/0], local

    traceroute 10.44.112.225:

    traceroute to 10.44.112.225 (10.44.112.225), 1 hops min, 30 hops max, 3 sec. timeout, 3 probes
    1 * 10.200.13.180 62.427ms !H 0.015ms !H

    It tries to route via the host 10.200.13.180. Can't figure out why that would be. I have just put "no ip icmp redirect" on the config but can't work out how to clear any learned routes via this, although I don't know if this is how it learned them.

    Anyone have any ideas on this? Its affected 2 out of 7 deployed switches.

    Thanks,

    ------------------------------
    Neil Behagg
    ------------------------------


  • 2.  RE: ArubaOS-CX routing issue

    Posted Aug 27, 2021 04:15 PM
    Hi! could you post the outputs of show ip route static all-vrfs, show ip route connected all-vrfs and show ip route 0.0.0.0 commands? Which Aruba CX Switch series and AOS-CX software version are you exactly using?

    ------------------------------
    Davide Poletto
    ------------------------------



  • 3.  RE: ArubaOS-CX routing issue

    Posted Aug 31, 2021 06:10 AM
    Hi Davide,

    It is v 10.06.0001 on a 6100 JL677A.

    sh ip route static

    Displaying ipv4 routes selected for forwarding

    '[x/y]' denotes [distance/metric]

    0.0.0.0/0, vrf default
    via 10.44.12.254, [1/0], static


    show ip route connected

    Displaying ipv4 routes selected for forwarding

    '[x/y]' denotes [distance/metric]

    10.44.12.0/23, vrf default
    via vlan10, [0/0], connected
    10.200.12.0/23, vrf default
    via vlan1, [0/0], connected


    show ip route 0.0.0.0

    Displaying ipv4 routes selected for forwarding

    '[x/y]' denotes [distance/metric]

    0.0.0.0/0, vrf default, tag 0
    via 10.44.12.254, [1/0], static


    This is baffling me. To be honest I don't need IP routing on these switches but don't know the arubaos-cx enough to know if I can switch off IP routing and just have a default gateway for the VLAN interface for management.

    Thanks for any assistance!


    ------------------------------
    Neil Behagg
    ------------------------------



  • 4.  RE: ArubaOS-CX routing issue

    Posted Aug 31, 2021 06:59 AM
    Hi Neil, probably not the best answer actually but why not update to ArubaOS-CX 10.06.0140 first (the 10.06.0001 software version was the first 10.06 build) and then perform the routing test again? eventually sharing the sanitized running configuration would be of help.

    ------------------------------
    Davide Poletto
    ------------------------------



  • 5.  RE: ArubaOS-CX routing issue

    Posted Aug 31, 2021 07:47 AM
    Unfortunately a firmware upgrade at this point isn't an option for me. I have just discovered that if I put a static route in for the 10.0.0.0/8 network to go via the default gateway address, the routing engine does honour this and sends traffic the correct way. Relying on the default route however it doesn't. I'll go with this as a workaround for now.

    ------------------------------
    Neil Behagg
    ------------------------------