Cloud Managed Networks

last person joined: 7 days ago 

Forum to discuss all things Aruba Central and UXI Network Management, this includes Aruba Central managed networks, Central configuration, best practices, Central APIs, Cloud Guest, AIOps, Presence Analytics and Other Central Applications

template config 2530 series switches issues with _sys_template_header variable

This thread has been viewed 3 times
  • 1.  template config 2530 series switches issues with _sys_template_header variable

    Posted Nov 21, 2019 06:57 PM

    Greetings all. Am having issues with the _sys_template_header variable and i belive formating it within my JSON variable file.

     

    My current variable entry in my JSON file for this is as follows

     

    "_sys_template_header": "; J9774A Configuration Editor; Created on release #YA.16.09.0001
    ; Ver #14:01.44.00.04.19.02.13.98.82.34.61.18.28.f3.84.9c.63.ff.37.27:45
    "

     

    with my config file in part looking like this

     

    %_sys_template_header%
    hostname %_sys_hostname%"
    %_sys_module_command%
    qos type-of-service diff-services
    no cwmp enable
    dhcp-snooping
    dhcp-snooping authorized-server 123.123.123.123
    dhcp-snooping authorized-server 123.123.123.124
    trunk 9-10 trk1 lacp
    include-credentials

     

    When the system attempts to push this to the switch, i get a corrupted configuration file error message. When i look at configuration audit logs for the push i see things like this

     

    Recent log events from the device (20)<12>Nov 21 15:28:05 - 00158 update: line 175. Invalid input: activate
    <12>Nov 21 15:28:05 - 00158 update: line 174. Invalid input: dhcp
    <12>Nov 21 15:28:05 - 00158 update: line 173. Invalid input: dhcp

    and get the following from the audit trail

     

    <12>Nov 21 15:28:05 - 00158 update: line 175. Invalid input: activate
    <12>Nov 21 15:28:05 - 00158 update: line 174. Invalid input: dhcp
    <12>Nov 21 15:28:05 - 00158 update: line 173. Invalid input: dhcp
    <12>Nov 21 15:28:05 - 00158 update: line 172. Invalid input: tftp
     
     
    I remove the %_sys_template_header% and replace it with the valid header data for the switch, things work properly.
     
    I've clearly missed somthing with my variable here. Can someone offer a suggestion as to what that is, as well, if there's a location to see where the config as pushed from central ends up on the device so i can perhaps look and see what the switch is getting, which may further help.
     
     

     

     


    #2530