Wireless Access

last person joined: an hour ago 

Access network design for branch, remote, outdoor and campus locations with Aruba access points, and mobility controllers.
Expand all | Collapse all

AP Image Preload not possible

  • 1.  AP Image Preload not possible

    Posted Oct 02, 2018 02:31 AM

    Hi,

    we have a controller which runs 6.4er Version and i want to upgrade to 6.5. On t he comtroller there are 1500 accesspoints connected so i want to preload the image.

    I tested with just one ap. It worked perfectly.

    But no i want to do the preloading on all aps but i got the errormessage:

     

    An AP image preload has already been executed. You must reload the controller before executing another one.

     

    That does not make sense at all i cannot reboot the controller now. I wanted to reduce downtime with preloading and now I should have more downtime?

     

    Is there a way to get it working again?



  • 2.  RE: AP Image Preload not possible

    Posted Oct 02, 2018 06:30 AM
    What were the two commands that you executed? You can execute the image preload only once for the same access point or once for the same set of access points (by ap-group). I suspect it is because the image preload procedure is very resource intensive.


    In reality, Aruba has always had the fastest image upgrade in the industry and using image preload does not save a significant amount of time.


  • 3.  RE: AP Image Preload not possible

    Posted Oct 02, 2018 08:16 AM

    I executed the preload for one specific ap for testing like you can see in the attachement.

     

    For my opinion ap preloaded the image correctly as you can see in the attachement "preload result".

    So after testing i tried to activate preload for all my aps.

    But this is not working.

     



  • 4.  RE: AP Image Preload not possible

    Posted 14 days ago

    I realize this is an old thread but wanted to reply as I just ran into the same thing on 8.7.1.0 when attempting to preload 8.7.1.1.   In short, if you are receiving this message via the GUI, run "show ap image-preload status all" via CLI.

    Via the controller's GUI I had preloaded the image onto one AP group to test, upon trying to do additional groups I received the same message as the original poster.

    This message shown in the GUI (at least in 8.7.x) is misleading, when logging in via CLI and running "show ap image-preload status all" the first group of APs I preloaded showed as "No preload needed" and the other AP groups I had picked when I tried the second time showed that they were in the process of preloading.

    Just wanted to post here in case others were looking because this was the first (and only one of two) thread(s) I could find on the forums referencing this message.  Possibly a bug/issue in GUI of particular firmware(s)?

    ------------------------------
    Steve Pollock
    ------------------------------



  • 5.  RE: AP Image Preload not possible

    Posted 8 days ago
    Hi,

    Yes, it does not make sense to reboot the controller to do AP image-preload.
    It maybe bug of your current software version.
    Please try to use CLI "#ap image-preload add AP-Group OR AP-name and activate"

    ------------------------------
    Ratchapas Shatsa-Nga
    ------------------------------



  • 6.  RE: AP Image Preload not possible

    Posted 7 days ago
    I don't agree with it but that is expected behaviour.  Once you trigger an ap-preload for a particular ap-group, you cannot choose any other groups, unless you go ahead and reboot the controller first.
    The lesson here is to preload all APs.  To be honest it doesn't make a lot of sense only preloading a subset of them.

    ------------------------------
    Michael Clarke (Aruba)
    ------------------------------



  • 7.  RE: AP Image Preload not possible

    Posted 7 days ago
    Hi Michael,

    It seems that after selecting and triggering one group of APs for pre-load, you can actually select a second (third, fourth, etc.) group and trigger pre-load even though the GUI displays a message saying a reboot is required in order to trigger pre-load for more APs.  If you log in to CLI, the second (third, fourth, etc.) AP group chosen will in fact be preloading and the process works without a reboot despite the GUI message. 

    I do agree with you that it really doesn't make sense to be preloading only a subset of APs, but if someone clicks something by mistake or is unfamiliar with the pre-load process, this GUI message can be misleading to them.  I only commented on the thread since the original poster was on 6.4.x / 6.5.x and I had the same message on 8.7.x. (it is also nice for others who may be searching this error message to get some closure).  The clarification that this is expected behavior is appreciated.

    ------------------------------
    Steve Pollock
    ------------------------------