Wireless Access

last person joined: 36 minutes ago 

Access network design for branch, remote, outdoor and campus locations with Aruba access points, and mobility controllers.
Expand all | Collapse all

Raspberry PI issues

This thread has been viewed 34 times
  • 1.  Raspberry PI issues

    Posted Mar 20, 2020 11:44 AM
      |   view attached

    Hi all,


    Has anyone had issues with raspberry Pis dropping off WLAN's managed by a physical controller running version 6.5.x. I have tried 304 and 225 AP's with the same results.


    My particular issue is that the PI's (in my testing 3B and 3B+) connect on 2.4GHz (usually an open WLAN but tried a PSK enabled one with the same results) for a while then seem to stop sending responding to packets.

     

    A "show user" shows their sessions are active and the only way to get them going again is to issue a "aaa user delete" (which as we know sends a deauth frame to the station/stations) and after a few seconds they are start to access the network again. So I guess the PIs must be “listening” for packets. For reference sake all data rates are enabled/the default.

     

    I don't know if this is necessarily a PI hardware or software issue as I have tried different vendors AP's (Cisco Aironet and WLC based and Meraki) and have not been able to replicate the issue, its possible I didn't wait long enough for the issue to manifest itself on the Non Aruba APs but on the Aruba AP's the issue usually occurs within an hour or two but somethings quite often (like every few minutes) and I left it running on the Cisco AP's for at least 3 hours without issue.


    Any ideas or pointers would be appreciated.

     



  • 2.  RE: Raspberry PI issues

    Posted Mar 20, 2020 12:51 PM

    I have not had problems with Raspberry Pis dropping off the network, whether it may be 2, or 3s.  I will let others comment.



  • 3.  RE: Raspberry PI issues

    Posted Jan 19, 2021 10:31 AM
    Hi alow, 

    We appeat to have the same issue with Pi's disconnecting. It appears to be worse when the avahi daemon is running. 
    Also we do not see  this issue with Version 6.5.4.3 but mainly with Version 8.6.x

    ------------------------------
    Athanasios Karapatis
    Embedded Engineer
    Abel Sensors
    ------------------------------



  • 4.  RE: Raspberry PI issues

    Posted Jan 20, 2021 04:16 AM
    We eventually show that disabling fast roaming options 802.11k and 802.11v, appears to solve the issue. 

    Maybe you can try this as well

    ------------------------------
    Athanasios Karapatis
    Embedded Engineer
    Abel Sensors
    ------------------------------



  • 5.  RE: Raspberry PI issues

    Posted Jan 20, 2021 04:59 AM
    Can you please open a TAC support case for this observation? It would make sense to have investigated if the issue is in the Raspberry Pi implementation or in the controller version.

    ------------------------------
    Herman Robers
    ------------------------
    If you have urgent issues, always contact your Aruba partner, distributor, or Aruba TAC Support. Check https://www.arubanetworks.com/support-services/contact-support/ for how to contact Aruba TAC. Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba Networks.
    ------------------------------



  • 6.  RE: Raspberry PI issues

    Posted 16 days ago
    I've noticed exactly the same behavior. After upgrading from Firmware 8.5.0.9_75467 to 8.7.1.2_79305, all Raspberry Pi computers started experiencing severe WiFi connectivity issues. They'll remain associated to the AP, but become unreachable within 10 minutes of initial connection. Forcing a disconnect causes them to reconnect, and be reachable for another 10 minutes before they stop responding again.

    Turning off 802.11k and 802.11v immediately fixes the problem, and allows all of my Raspberry Pi's to stay connected.

    ------------------------------
    Allison Creely
    ------------------------------