Wireless Access

last person joined: an hour ago 

Access network design for branch, remote, outdoor and campus locations with Aruba access points, and mobility controllers.
Expand all | Collapse all

LACP on Aruba 7240XM

This thread has been viewed 27 times
  • 1.  LACP on Aruba 7240XM

    Posted 19 days ago
    I am configuring Aruba 7240XM.
    As I know, its gi0/0/2 and gi0/0/3 capable support 10Gb/s, so I am trying to enable LACP ethechannel:

    interface port-channel 0
    trusted
    trusted vlan 1-4094
    switchport mode trunk
    switchport trunk allowed vlan 1-1000

    but it does not allow to assign gi0/0/2 and gi0/0/3 to lacp group 0 :

    (DR-Mode) [mm] (config) #interface gigabitethernet 0/0/2

    (DR-Mode) [mm] (config-submode)#lacp group 0 mode active
    Illegal Operation: Interface belongs to lacp group

    Such message seems not right, Interface does not have related settings:

    interface gigabitethernet 0/0/2
    description "GE0/0/2"
    no poe
    lldp transmit
    lldp receive
    !

    interface gigabitethernet 0/0/3
    description "GE0/0/3"
    no poe
    lldp transmit
    lldp receive
    !

    Could you suggest what is wrong.

    ------------------------------
    A Y
    ------------------------------


  • 2.  RE: LACP on Aruba 7240XM

    Posted 19 days ago
    Looks like your in disaster recovery mode, so I assume this is managed by a Mobility Master/Conductor? If so are you getting the interface config above from a show run or show config while logged into the controller? Or is it from the MM at the controller level? If the latter, a show config effective would give you the correct output.

    I have seen issues before as well where you need to configure the individual interface as a trunk (switchport mode trunk) first before adding it to a port-channel. Maybe give that a shot?

    ------------------------------
    Dustin Burns
    ------------------------------



  • 3.  RE: LACP on Aruba 7240XM

    Posted 15 days ago
    Its anchor expected to be managed by mobility master (not connected to MM yet, so I configuring it in recovery mode),
    it looks like a bug in a code, I've finally achieved which is needed:

    interface gigabitethernet 0/0/2
    description "GE0/0/2"
    no poe
    lacp group 0 mode active
    lldp transmit
    lldp receive
    !

    interface gigabitethernet 0/0/3
    description "GE0/0/3"
    no poe
    lacp group 0 mode active
    lldp transmit
    lldp receive


    (DR-Mode) [mm] #show lacp 0 internal

    Flags: S - Device is requesting slow LACPDUs
    F - Device is requesting fast LACPDUs
    A - Device is in Active mode P - Device is in Passive mode
    LACP Internal Table
    -------------------
    Port Flags Pri AdminKey OperKey State Num Status
    ---- ----- --- -------- ------- ----- --- ------
    GE 0/0/2 SA 255 0x1 0x1 0x45 0x3 down
    GE 0/0/3 SA 255 0x1 0x1 0x45 0x4 down

    ------------------------------
    Andrii Yefremov
    ------------------------------



  • 4.  RE: LACP on Aruba 7240XM

    Posted 15 days ago
    What did you do to fix this? Also, make sure you are keeping track of your changes in disaster recovery mode as you will need to make the changes on the MM as well to get them to match once you connect them. Disaster recovery isn't really meant for pre-configuration, but for emergency changes when the MM is not available due to an outage.

    ------------------------------
    Dustin Burns
    ------------------------------



  • 5.  RE: LACP on Aruba 7240XM

    Posted 12 days ago
    I removed lacp group 0 from gi0/0/0 and gi0/0/1, so gi0/0/2 & gi0/0/3 start to show explicitly that they already belong to lacp group 0.

    Thanks for hint: I've joined Aruba 7240XM to MM, will continue with other settings from MM to push towards Aruba 7240XM.

    ------------------------------
    Andrii Yefremov
    ------------------------------