Wireless Access

last person joined: an hour ago 

Access network design for branch, remote, outdoor and campus locations with Aruba access points, and mobility controllers.
Expand all | Collapse all

VMM on KVM stuck after boot before initial setup dialog

This thread has been viewed 8 times
  • 1.  VMM on KVM stuck after boot before initial setup dialog

    Posted May 28, 2021 11:08 AM
      |   view attached
    I've tried to set up a VMM with KVM from ArubaOS_MM_8.6.0.9_79813.iso.
    After the initial installation from the image, the system boots from the disk. However, the expected initial setup dialog does not appear.  See attachment for last output of console. After this, the console echos characters but is otherwise unresponsive. The serial port get some boot messages and is otherwise unresponsive, too.

    Two of the 6 virtual cpu threads seem to be in a busy loop.

    qemu Command-Line is:  qemu-system-x86_64 --enable-kvm -name aruba-mm -cpu host -m 8G -smp 6,sockets=1 -drive file=aruba-mm-d1.001.disk,discard=on,if=virtio -drive file=aruba-mm-d2.001.disk,discard=on,if=virtio -netdev tap,id=netdev1,ifname=tap.aruba-mm-1,script=no,downscript=no -netdev tap,id=netdev2,ifname=tap.aruba-mm-2,script=no,downscript=no -netdev tap,id=netdev3,ifname=tap.aruba-mm-3,script=no,downscript=no -device virtio-net-pci,netdev=netdev1 -device virtio-net-pci,netdev=netdev2 -device virtio-net-pci,netdev=netdev3 -vnc :61 -chardev socket,id=s1,path=serial1.socket,server,nowait -serial chardev:s1 -chardev socket,id=mon1,path=mon.socket,server,nowait -mon chardev=mon1,mode=readline -chardev socket,id=mon2,path=qmp.socket,server,nowait -mon chardev=mon2,mode=control -cdrom ArubaOS_MM_8.6.0.9_79813.iso

    qemu version is 5.1.0.
    Host Kernel is 4.19.19
    Host is not using a distro.
    host cpu: Intel(R) Xeon(R) CPU E5-2687W v3 @ 3.10GHz
    cpu flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic movbe popcnt aes xsave avx f16c rdrand lahf_lm abm cpuid_fault epb invpcid_single pti tpr_shadow vnmi flexpriority ept vpid ept_ad fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid cqm xsaveopt cqm_llc cqm_occup_llc dtherm ida arat pln pts
     
    Tried a few other kvm versions, another (amd based) host, a few other MM versions with the same result
    Several other VMs run on this host without problems.
    I didn't enable nested virtualization (regarding the other VMs).  Is this required?

    Any ideas?

    ------------------------------
    Donald Buczek
    ------------------------------


  • 2.  RE: VMM on KVM stuck after boot before initial setup dialog

    Posted Jun 04, 2021 08:43 AM
    For the records if somebody gets here with a similar problem:

    I think, I've adapted all configuration aspects of the virtual machine configuration of my KVM hypervisor, in which the MM fails,  to that of a CentOS 7 KVM hypervisor, in which the MM works. But still the problem persisted. The KVM in CentOS 7 is very old and contains a *lot* of  Red Hat specific patches, both of which might be a source of remaining differences visible to the guest.

    Because I didn't want to dedicate hardware on this, I've switched to nested virtualization as a workaround.  It works to run the vMM as a virtual machine inside CentOS 7 as documented and with the CentOS system itself being a virtual machine in acurrent KVM hypervisor.

    ------------------------------
    Donald Buczek
    ------------------------------