Controllerless Networks

last person joined: yesterday 

Aruba Instant Wi-Fi: Meet the controllerless Wi-Fi solution that's easy to set-up, is loaded with security and smarts, and won't break your budget.
Expand all | Collapse all

Time not correct, NTP looks like it's not working

Jump to Best Answer
This thread has been viewed 5 times
  • 1.  Time not correct, NTP looks like it's not working

    Posted Apr 25, 2016 02:54 PM

    Hello,

    After setting the NTP server either in the GUI and CLI and rebooting the IAP 205 the time reverts back to 1970-01-01 00:12:00. How can I test NTP or verify?

     

    Also when setting the time using the clock set command I enter in the time as 11 20 00 and when I show the clock it states 04 20 00.

     

    ArubaOS (MODEL: 205), Version 6.4.4.3-4.2.2.0

     

    Any ideas?

     

    Thx,

    D

     



  • 2.  RE: Time not correct, NTP looks like it's not working

    Posted Apr 25, 2016 03:31 PM

    The IAP needs to be able to reach the ntp server, but you also have to set the Timezone for the correct time.



  • 3.  RE: Time not correct, NTP looks like it's not working

    Posted Apr 25, 2016 03:59 PM

    Yep, done all that but still have issues.

     

    D



  • 4.  RE: Time not correct, NTP looks like it's not working

    Posted Apr 25, 2016 04:40 PM

    Do you have a firewall that blocks outgoing traffic?  Are you trying to set the NTP server to something internal?  Did the Timezone at least change?

     



  • 5.  RE: Time not correct, NTP looks like it's not working

    Posted Apr 25, 2016 05:28 PM

    Yes, I have a firewall and yes NTP traffic flow has been verified to PC but not IAP 205:

    Tracking us.pool.ntp.org [45.79.10.228:123].
    Collecting 5 samples.
    The current time is 4/25/2016 2:26:16 PM.
    14:26:16, -02.3353142s
    14:26:18, -02.3432984s
    14:26:20, -02.3376330s
    14:26:22, -02.3387669s
    14:26:24, -02.3429400s



  • 6.  RE: Time not correct, NTP looks like it's not working

    Posted Apr 25, 2016 08:10 PM

    Are you saying that your clock is 2 seconds off?



  • 7.  RE: Time not correct, NTP looks like it's not working
    Best Answer

    Posted Apr 26, 2016 10:42 PM

    can u check for the following log?

     

    show log iap-bootup | i NTP

     

    basically this shows what happened to NTP while IAP bootsup. Here are samples from lab using 4.2.3

     

    1. default ntp.pool.org

     

    IAP5# show log iap-bootup | i NTP
    Launching NTP Client on pool.ntp.org

     

    2. setting ntp via option 42 from DHCP server

     

    f0:5c:19:ca:13:1a# show log iap-bootup | i NTP
    NTP server 10.70.100.6 received via DHCP option.
    Launching NTP Client on 10.70.100.6

     

     

    another important thing, which has caused issues in my lab is DNS server setting. IAP should be able to resolve pool.ntp.org. At times one forgets to set DNS server on infrastrucutre devices via DHCP.

     

     



  • 8.  RE: Time not correct, NTP looks like it's not working

    Posted Apr 27, 2016 11:05 PM

    OK, that was it, DNS! When I use the IP for pool.ntp.org the time was correct.

    DNS was added under the Static settings but pool.ntp.org was still not resloving.

     

    Current Time     :2016-04-27 20:01:41

     

    Thx

    D



  • 9.  RE: Time not correct, NTP looks like it's not working

    Posted Apr 26, 2016 01:30 AM

    Just showing that NTP can pass my firewall.... But when I reboot the IAP it sets the time to 

     

    sh clock = Current Time     :1970-01-01 00:21:46