Controllerless Networks

last person joined: 25 minutes ago 

Aruba Instant Wi-Fi: Meet the controllerless Wi-Fi solution that's easy to set-up, is loaded with security and smarts, and won't break your budget.
Expand all | Collapse all

IAP not honoring a-channels arm setting?

Jump to Best Answer
  • 1.  IAP not honoring a-channels arm setting?

    Posted Apr 12, 2017 01:35 PM
      |   view attached

      I am reconfiguring an IAP-105 I picked up for use with surveying to use for a one off event coming up in a few weeks and I thought the process was fairly straightforward to configure a static channel on an IAP, basically just the configuration:

     

    arm
    a-channels 165

     

      The intent that arm would have only channel 165 to pick from and thus never stray from 165.  In practice, this configuration has the IAP start up on channel 44 and never go to 165.  Additionally if I add in other channels (but removing channel 44):

     

    arm

    a-channels 36,40,48,52,56,60,64,100,165

     

    it ignores them as well.  Running an rf-summary shows:

    Survey IAP-105# show ap arm rf-summary

    Channel Summary
    ---------------
    channel retry phy-err mac-err noise util(Qual) cov-idx(Total) intf_idx(Total)
    ------- ----- ------- ------- ----- ---------- -------------- ---------------
    36 0 0 0 91 0/0/0/0/91 0/0(0) 0/0//0/0(0)
    40 0 0 0 90 9/0/0/0/91 0/0(0) 0/0//0/0(0)
    48 0 0 0 91 9/0/0/0/91 0/0(0) 0/0//0/0(0)
    52 0 0 0 93 0/0/0/0/91 0/0(0) 0/0//0/0(0)
    56 0 0 0 93 9/0/0/0/91 0/0(0) 0/11//0/0(11)
    60 0 0 0 93 0/0/0/0/90 0/0(0) 33/0//0/0(33)
    64 0 0 0 93 9/0/0/0/91 0/0(0) 16/11//0/0(27)
    100 0 0 0 93 0/0/0/0/91 0/0(0) 0/0//0/0(0)
    165 0 0 0 96 10/0/0/0/90 0/0(0) 0/3//0/0(3)
    11 0 0 0 0 0/0/0/0/0 0/0(0) 0/0//0/0(0)

    Columns:util(Qual): ch-util/rx/tx/ext-ch-util/quality

    HT Channel Summary
    ------------------
    channel_pair Pairwise_intf_index
    ------------ -------------------

    Interface Name :wifi0
    Current ARM Assignment :44/17
    Covered channels a/g :0/0
    Free channels a/g :9/0
    ARM Edge State :disable
    Last check channel/pwr :53m:49s/53m:49s
    Last change channel/pwr :53m:49s/53m:49s
    Next Check channel/pwr :0s/0s
    Assignment Mode :Maintain

    Interface Name :wifi1
    Current ARM Assignment :1/17
    Covered channels a/g :0/0
    Free channels a/g :0/1
    ARM Edge State :disable
    Last check channel/pwr :53m:49s/53m:49s
    Last change channel/pwr :53m:49s/53m:49s
    Next Check channel/pwr :0s/0s
    Assignment Mode :Maintain

    Channel quality history:wifi0
    36:Q: 91 91 91 91 0 0
    :c: 0 0 0 0 0 0
    :N: 91 91 91 91 0 0
    :s: 0 0 0 0 100 100
    :U: 9 9 9 9 0 0
    40:Q: 91 91 91 91 91 91 91
    :c: 0 0 0 0 0 0 0
    :N: 90 90 90 90 90 90 90
    :s: 0 0 0 0 0 0 0
    :U: 9 9 9 9 9 9 9
    48:Q: 91 91 91 91 91 0 0
    :c: 0 0 0 0 0 0 0
    :N: 91 91 91 91 91 0 0
    :s: 0 0 0 0 0 100 100
    :U: 9 9 9 9 9 0 0
    52:Q: 91 91 91 100 91 91 0
    :c: 0 0 0 0 0 0 0
    :N: 93 93 93 93 93 93 0
    :s: 0 0 0 0 0 0 100
    :U: 9 9 9 0 9 9 0
    56:Q: 91 91 91 91 91 91 0
    :c: 0 0 0 0 0 0 0
    :N: 93 93 93 92 93 93 0
    :s: 0 0 0 0 0 0 100
    :U: 9 9 9 9 9 9 0
    60:Q: 90 90 90 100 90 90 0
    :c: 0 0 0 0 0 0 0
    :N: 93 93 93 93 93 93 0
    :s: 0 0 0 0 0 0 100
    :U: 10 10 10 0 10 10 0
    64:Q: 91 91 91 91 91 91 0
    :c: 0 0 0 0 0 0 0
    :N: 93 93 93 93 93 93 0
    :s: 0 0 0 0 0 0 100
    :U: 9 9 9 9 9 9 0
    100:Q: 91 91 91 90 90 0
    :c: 0 0 0 0 0 0
    :N: 93 93 93 93 93 0
    :s: 0 0 0 0 0 100
    :U: 9 9 9 10 10 0
    165:Q: 90 90 90 90 0 0
    :c: 0 0 0 0 0 0
    :N: 96 96 96 96 0 0
    :s: 0 0 0 0 100 100
    :U: 10 10 10 10 0 0

    Channel quality history:wifi1
    11:Q: 0 0 0 0 0 0 0 0
    :c: 0 0 0 0 0 0 0 0
    :N: 0 0 0 0 0 0 0 0
    :s: 100 100 100 100 100 100 100 100
    :U: 0 0 0 0 0 0 0 0

     

      I was able to override arm via the 'a-channel 165 18' command but I clearly missed something in the arm setup.  Can someone give me a hint as to where I went wrong?  Thanks!

     

    - Kurtis

     

    Attachment(s)

    txt
    iap-techsupport.txt   201K 1 version


  • 2.  RE: IAP not honoring a-channels arm setting?

    Posted Apr 12, 2017 01:51 PM

    If you can, please get the tech support when you only have a single channel selected.  Your tech support says this:

     

    arm
     wide-bands none
     a-channels 36,40,48,52,56,60,64,100,165
     g-channels 11
     min-tx-power 18
     max-tx-power 18
     band-steering-mode disable
     air-time-fairness-mode fair-access
     scanning

     

    and your access point is on channel 165, which is what it should be doing:

     

    Survey IAP-105# show aps
    
    
    
    1 Access Point
    --------------
    Name            IP Address     Mode    Spectrum  Clients  Type         Mesh Role  Zone  Serial #   2.4 Channel  2.4 Power (dB)  2.4 Utilization (%)  2.4 Noise Floor (dBm)  5.0 Channel  5.0 Power (dB)  5.0 Utilization (%)  5.0 Noise Floor (dBm)  Need Antenna Config  From Port  Config Id  Config Csum  Ext SSID Active  Age     
    ----            ----------     ----    --------  -------  ----         ---------  ----  --------   -----------  --------------  -------------------  ---------------------  -----------  --------------  -------------------  ---------------------  -------------------  ---------  ---------  -----------  ---------------  ---     
    Survey IAP-105  192.168.1.10*  access  disable   0        105(indoor)  N/A        -     BT0489915  -            -               -                    -                      165          18              0(good)              -96(good)              No                   none       3          22671        disable          31m:7s  
    Survey IAP-105# show ap bss-table
    

     



  • 3.  RE: IAP not honoring a-channels arm setting?

    Posted Apr 12, 2017 02:19 PM
      |   view attached

    Colin,

     

      Ah yes I forgot to change it back after mucking with it a bit - I changed it back to just channel 165 and rebooted and it stayed at 165!  Which is great, but I am a bit greedy and wanted to test it further so I changed the arm configuration to:

     

    arm
    a-channels 36

     

     and wrote memory and also did a 'commit apply' then watched to see if arm would move off 165 to 36 - and so far it hasn't moved. The only real difference is that I issued the 'a-channel 165 18' command before and that worked - it moved it immediately to 165 previously and I would imagine if I issued the same command for channel 36, it would work again but then that isn't really arm doing it.

     

      There doesn't appear to be a configuration directive for the 'a-channel' command nor a 'no' version of it to negate it.  Perhaps that is all this is - the IAP remembering the last manually set channel?  Just a thought.

     

    - Kurtis

     

    Attachment(s)



  • 4.  RE: IAP not honoring a-channels arm setting?
    Best Answer

    Posted Apr 12, 2017 02:53 PM

    When you change the channel range, I believe you have to reboot for it to be fully in effect.  If you just want to set the channels and power on an access point statically, you would simply edit the access point from the GUI, go to radio and do below:

    static-channels.png



  • 5.  RE: IAP not honoring a-channels arm setting?

    Posted Apr 12, 2017 03:14 PM

    Colin,

     

      Ah, that makes sense.  Sure enough when I change it there and hit Ok, the change is near instant.

     

      I also changed it to ARM controlled and it followed the arm config as I originally expected it to.  Changing the channel there caused ARM to reflect the channel change very quickly as well.

     

      Where do the changes live for these settings (administrator set / ARM managed channels)?  I don't see them in 'show running-config', is there some other location they get stored?

     

      In any case, thanks for the help!

     

    - Kurtis