Wireless Access

last person joined: an hour ago 

Access network design for branch, remote, outdoor and campus locations with Aruba access points, and mobility controllers.
Expand all | Collapse all

Change VLAN that APs connect to

  • 1.  Change VLAN that APs connect to

    Posted Dec 22, 2014 03:17 PM

    Hello,

    We have two 6000/M3 controllers running 6.2.1.5 in a backup master configuration with about 350 AP/AMs.

    There are two VLANs configured on our controller - VLAN 152 ( admin, internal ) and VLAN 116 ( GUEST, external ).  There is NO routing between these VLANS.  Both VLANS are configured for redundancy via VRRP.  

    Right now all of the APs are on VLAN 116.  I would like to change the APs so they are on VLAN 152.  I would like to verify how to do this but here are my thoughts.  

    --Update LMS IP from VLAN 116 VRRP IP to VLAN 52 VRRP IP
    --Change switchports of all AP/AMs from VLAN 116 to VLAN 152

    How do I change the controller so it is “listening” for the APs on VLAN 152 and not on VL 116?

    I believe this would require me changing the “controller IP” on both controllers?  Right now the Controller IP is set to the loopback IP which is on VLAN 116.  If this is the correct setting  to change, would I change the Controller IP to be the IP of the interface on VLAN 152?  I could also change the loopback IP from VLAN 116 to VLAN 152, then leave the controller IP set to the new loopback?

    Lastly, the Master Redundancy VLAN is VLAN 116 -- there's no need to change this, is there?


    Thanks,
    Bryan



  • 2.  RE: Change VLAN that APs connect to

    Posted Dec 22, 2014 03:30 PM

    Setting the Loopback ip automatically changes the Controller IP that that ip address.

     

    If there is no loopback ip, the management or controller ip was historically set as  the lowest numbered VLAN number's ip address.  That can be overridden with the controller-ip command, so that you do not need a loopback address.  Please see the history of the loopback, controller ip and VLAN here:  http://community.arubanetworks.com/t5/Controller-Based-WLANs/What-is-the-quot-controller-ip-quot-command-used-for/ta-p/183448

     

    You can find out what the controller thinks is the switch ip address by typing "show switch ip"

     

    The way it works, if an access point attempt to contact a controller on an ip address that is NOT the switch ip, it will redirect the access point to contact it on the switch ip address.  So theoretically if the access points can still reach the controller, it will be redirected to the true switchip immediately.

     

     

    Changing the switchip by changing the loopback or the switch ip command, unfortunately requires a reboot of the controller.  In your situation, you can just change the loopback address on both controllers to an ip address on the target VLAN subnet..

     

     

     



  • 3.  RE: Change VLAN that APs connect to

    Posted Dec 23, 2014 07:16 AM

    HI Friend,

     

    Couple of questions,

     

    Which method you are using for the master discovery ? DHCP or DNS or static

    do you have Master-Local setup ? if not. we need not worry about LMS, changing the LMS IP will not help here.

     

    if you look at the AP boot sequence, first AP will discover the master and update the Image and downlods the provisioned AP-group then it will terminate on the LMS.

     

    To achieve this you need not change the switch IP ( Controller-IP vlan <>) let it be as loopback IP.

     

    The idle solution should be ,

    1. Move all your AP to VLAN 115

    2. Change the master-redundancy VLAN to VLAN 115

    3. Change the master IP of your APs to the Virtual IP of VRRP running on VLAN 115.

     

    Hope got some more clarity,

     

    Please feel free for any further clarity on this.



  • 4.  RE: Change VLAN that APs connect to

    Posted Dec 23, 2014 03:20 PM

    Thanks for the quick responses -- I have a clear idea of what needs to be done now.  I have some downtime scheduled so a couple reboots isn't a problem.

     

    Thanks,

    Bryan