Wired

last person joined: an hour ago 

Bring performance and reliability to your network with the Aruba Core, Aggregation, and Access layer switches. Discuss the latest features and functionality of the ArubaOS-Switch and ArubaOS-CX devices, and find ways to improve security across your network to bring together a mobile first solution.
Expand all | Collapse all

Aruba switches 2930F weird putty output

Jump to Best Answer
  • 1.  Aruba switches 2930F weird putty output

    Posted Jan 25, 2018 11:00 AM
      |   view attached

    Hi guys,

     

    I always use putty to connect to switches and save the session logs with no problem. Now I am using putty to connect to my new switches 2930F but when I save the session log the file has a somewhat encrypted parts. Attached the putty file when I issued the commands "show flash", "show version" and "show running-config".

    I have tried with both ssh and telnet in to the switch, but both log files are the same.

    Do I have to configure anything special on the switches?

     

    Regards,

    Julián

    Attachment(s)



  • 2.  RE: Aruba switches 2930F weird putty output
    Best Answer

    Posted Jan 26, 2018 03:00 AM

    Those weird outputs are terminal control commands, which are a remainder from the old (VT100) terminals. These codes move the cursor around, change text colors, and are used for some kind of formatting as good as it can get on the old terminals.

     

    If you want to get rid of these codes, you can select in Putty to only log printable commands:

    2018-01-26 08_53_47-PuTTY Reconfiguration.png

    For most purposes that is easier. If you log to files and have large outputs, I think that you already found the command: "no page" which disables the pagination (-- MORE --, next page: Space, next line: Enter, quit: Control-C) thus need to press space all the time.

     

     



  • 3.  RE: Aruba switches 2930F weird putty output

    Posted Jan 26, 2018 10:28 AM
      |   view attached

    Hi Herman,

     

    Thank you very much. I have tried by choosing Printable Output and the output is more readable, however, the commands output appear after the command and not in the next line, like this:

     

    SW-CORE# SW-CORE# show flashImage Size (bytes) Date Version
    ----------------- ------------ -------- --------------
    Primary Image : 25480797 09/12/16 KB.16.02.0013
    Secondary Image : 25480797 09/12/16 KB.16.02.0013

    .

    .

    .

    SW-CORE# show versionImage stamp: /ws/swbuildm/rel_spokane_qaoff/code/build/bom(swbuildm_rel_spokane_qaoff_rel_spokane)
    Sep 12 2016 11:47:57
    KB.16.02.0013
    528
    Boot Image: Primary

     

    I guess there is no other solution. What do you think?

     

    Regards,

    Julián

    Attachment(s)



  • 4.  RE: Aruba switches 2930F weird putty output

    Posted Jul 31, 2018 08:12 AM

    Are you saving the output to a drive mapped on the network?

     

    Try saving it on c:\temp

     

    I had also a strange output issue, and doing above worked.

     

    EDIT: i see a solution is already there :)