Wireless Access

last person joined: 10 hours ago 

Access network design for branch, remote, outdoor and campus locations with Aruba access points, and mobility controllers.
Expand all | Collapse all

Re: Intel AX-201 drops connection on bandsteer/roam events

Jump to Best Answer
  • 1.  Re: Intel AX-201 drops connection on bandsteer/roam events

    Posted Oct 20, 2020 05:46 AM

    Just for reference.

     

    I have an AX200 with laster driver, run 2x9004 controllers in a L2 cluster with 2x AP-505. I test roaming a couple of times last month with ArubaOS 8.6.0.6, 8.7.0.0 and 8.7.10. I have 802.11r/k disabled and 802.11v enabled. I don't have any roaming issues as you described.

     

    I know that for the ax200/201 are very regular driver updates available that have often bug fixes.

     

    I got another issue sometimes where a client comes from sleep mode/hibernation, get 801.11 auth/association succeed, get 4-way handshake succeed, but not get an IP until it roams to another AP and then gets DHCP and is connected as normal.

     

    Questions;

    • do you have just one controller or two in a cluster?
    • Did you try to set the HE (High efficiency) SSID disabled ?

     



  • 2.  RE: Re: Intel AX-201 drops connection on bandsteer/roam events

    Posted Oct 20, 2020 06:34 AM

    @AndreyP wrote:

    It didn't make much difference, unfortunately

    while going from one AP to another connection drops, and controller (8.7.0.0) seem to think that this is disconnect + connect, as it resets all client graphs (like connection quality) and resets "association time" to zero

     

    thanks!


    What  changes have you made to the default setup?  There are a number of things that could have been turned off that could affect that, but let's start with any changes you made to the defaults, first.



  • 3.  RE: Re: Intel AX-201 drops connection on bandsteer/roam events

    Posted Oct 20, 2020 07:12 AM

    On second thought, to get to the bottom of this, execute this on the commandline of the controller:

     

    show ap client trail-info <mac address of client>

    That should give you an idea of why the client is disconnecting.  Show ap association client-mac will reset connection time on a roam, and that counter depicts association time to an AP.  If the client time is getting reset in the output of "show user-table" on every roam, that is an issue.



  • 4.  RE: Re: Intel AX-201 drops connection on bandsteer/roam events

    Posted Oct 20, 2020 12:23 PM

    thanks for responses!

    1) I run controller in standalone config

    2) I did not try disabling HE, but will give it a try. (I am quite sure at least one 802.11ax phone roams successfully)

    3) Changes I did are: enable create 5 SSIDs (some bridged, others tunneled), enable wmm, enable mesh, enable v/k/r (now disabled as per suggestion k/r on this particular SSID). I'll be happy to provide config diffs, but don't know how to generate list of changes from defaults.

    4) just tried roaming AP-555 -> AP-345(mesh) -> AP-555(garage) and back. going forward roaming was seamless and worked fine. on a way back connection got dropped and show user-table age was reset to 0. here's client-trail

     

    (Aruba7210) [mynode] #show ap client trail-info  PROBLEM_MAC

     

    Client Trail Info

    -----------------

    MAC                BSSID              ESSID        AP-name        VLAN  Deauth Reason                                                   Alert

    ---                -----              -----        -------        ----  -------------                                                   -----

    PROBLEM_MAC  38:17:c3:82:e3:b3  home-net-1x  AP-345 (mesh)  1     Disassociated; Auth frame from STA that was already associated  STA has roamed to another AP

     

    Deauth Reason

    -------------

    Reason                                                          Timestamp

    ------                                                          ---------

    Disassociated; Auth frame from STA that was already associated  Oct 20 00:10:25

    Ptk Challenge Failed                                            Oct 19 23:57:11

    Disassociated; Auth frame from STA that was already associated  Oct 19 23:57:09

    Num Deauths:3

     

    Alerts

    ------

    Reason                        Timestamp

    ------                        ---------

    STA has roamed to another AP  Oct 20 09:14:58

    STA has roamed to another AP  Oct 20 09:13:57

    STA has roamed to another AP  Oct 20 09:13:48

    STA has roamed to another AP  Oct 20 08:40:59

    STA has roamed to another AP  Oct 20 02:55:10

    STA has roamed to another AP  Oct 20 00:26:40

    STA has roamed to another AP  Oct 20 00:11:45

    STA has roamed to another AP  Oct 19 22:58:21

    STA has roamed to another AP  Oct 19 22:27:47

    Num Alerts:9

     

    Mobility Trail

    --------------

    BSSID              ESSID        AP-name         VLAN  Timestamp

    -----              -----        -------         ----  ---------

    38:17:c3:82:e3:b3  home-net-1x  AP-345 (mesh)   1     Oct 20 09:14:58

    80:8d:b7:81:76:d3  home-net-1x  AP-555(Garage)  1     Oct 20 09:14:58

    38:17:c3:82:e3:b3  home-net-1x  AP-345 (mesh)   1     Oct 20 09:14:58

    80:8d:b7:81:76:d3  home-net-1x  AP-555(Garage)  1     Oct 20 09:13:57

    38:17:c3:82:e3:b3  home-net-1x  AP-345 (mesh)   1     Oct 20 09:13:57

    80:8d:b7:81:76:d3  home-net-1x  AP-555(Garage)  1     Oct 20 09:13:57

    38:17:c3:82:e3:b3  home-net-1x  AP-345 (mesh)   1     Oct 20 09:13:48

    80:8d:b7:81:67:43  home-net-1x  AP-555          1     Oct 20 09:13:48

    38:17:c3:82:e3:b3  home-net-1x  AP-345 (mesh)   1     Oct 20 09:13:48

    80:8d:b7:81:67:43  home-net-1x  AP-555          1     Oct 20 08:40:59

    Num Mobility Trails:10

    (Aruba7210) [mynode] #

     

     

    thanks for help!



  • 5.  RE: Re: Intel AX-201 drops connection on bandsteer/roam events

    Posted Oct 20, 2020 12:39 PM

    Update.

    did another walkaround.

    this time connection didn't drop (I guess it switched quick enough) but user-table age got reset anyway

     

    (Aruba7210) [mynode] #show ap client trail-info cc:d9:ac:de:be:0d

    Client Trail Info
    -----------------
    MAC BSSID ESSID AP-name VLAN Deauth Reason Alert
    --- ----- ----- ------- ---- ------------- -----
    cc:d9:ac:de:be:0d 80:8d:b7:81:67:43 home-net-1x AP-555 1 Response to EAP Challenge Failed STA has roamed to another AP

    Deauth Reason
    -------------
    Reason Timestamp
    ------ ---------
    Response to EAP Challenge Failed Oct 20 09:35:36
    Disassociated; Auth frame from STA that was already associated Oct 20 00:10:25
    Ptk Challenge Failed Oct 19 23:57:11
    Disassociated; Auth frame from STA that was already associated Oct 19 23:57:09
    Num Deauths:4

    Alerts
    ------
    Reason Timestamp
    ------ ---------
    STA has roamed to another AP Oct 20 09:35:12
    STA has roamed to another AP Oct 20 09:15:53
    STA has roamed to another AP Oct 20 09:14:58
    STA has roamed to another AP Oct 20 09:13:57
    STA has roamed to another AP Oct 20 09:13:48
    STA has roamed to another AP Oct 20 08:40:59
    STA has roamed to another AP Oct 20 02:55:10
    STA has roamed to another AP Oct 20 00:26:40
    STA has roamed to another AP Oct 20 00:11:45
    STA has roamed to another AP Oct 19 22:58:21
    Num Alerts:10

    Mobility Trail
    --------------
    BSSID ESSID AP-name VLAN Timestamp
    ----- ----- ------- ---- ---------
    80:8d:b7:81:67:43 home-net-1x AP-555 1 Oct 20 09:35:36
    80:8d:b7:81:67:43 home-net-1x AP-555 1 Oct 20 09:35:36
    80:8d:b7:81:76:d3 home-net-1x AP-555(Garage) 1 Oct 20 09:35:36
    80:8d:b7:81:76:d3 home-net-1x AP-555(Garage) 1 Oct 20 09:35:12
    80:8d:b7:81:67:43 home-net-1x AP-555 1 Oct 20 09:35:12
    80:8d:b7:81:76:d3 home-net-1x AP-555(Garage) 1 Oct 20 09:35:12
    80:8d:b7:81:67:43 home-net-1x AP-555 1 Oct 20 09:15:53
    38:17:c3:82:e3:b3 home-net-1x AP-345 (mesh) 1 Oct 20 09:15:53
    80:8d:b7:81:67:43 home-net-1x AP-555 1 Oct 20 09:15:53
    38:17:c3:82:e3:b3 home-net-1x AP-345 (mesh) 1 Oct 20 09:14:58
    Num Mobility Trails:10

     

    Edit. Just now for short period of time (like 5 mins?) I had client connected, it had entry in show ap client association remote, but not in show user-table.



  • 6.  RE: Re: Intel AX-201 drops connection on bandsteer/roam events

    Posted Oct 20, 2020 05:10 PM

    Hi AndreyP,

     

    From your trial-info i can see that the EAP challenge failed.

     

    "Response to EAP Challenge Failed STA has roamed to another AP

    Deauth Reason. Reason: Timestamp"

     

    Just for a test, try to setup an SSID without radius (just wpa2-personal) and test again.

     



  • 7.  RE: Re: Intel AX-201 drops connection on bandsteer/roam events
    Best Answer

    Posted Oct 20, 2020 05:15 PM

    Is there a reason why you have 5 SSIDs?  Can you create as few as possible and only test on a single tunneled SSID, please?



  • 8.  RE: Re: Intel AX-201 drops connection on bandsteer/roam events

    Posted Oct 20, 2020 05:39 PM

    Agree with Colin. 

     

    Design rule is don't create more than 4 SSID's because each SSID will have is own management traffic that can occupied the available airtime when creat to many SSID's.

     

    Preferred forwarding mode is Tunnel Mode. Bridge Mode forwarding layer 2 traffic to the edgeswitch instead of the controller. In Bridge Mode the switch is  responsible for update the mac-table when a client roams, what can have a negative effect on your client roaming. 

     



  • 9.  RE: Re: Intel AX-201 drops connection on bandsteer/roam events

    Posted Oct 20, 2020 07:17 PM

    thanks for suggestions!

    answers

    1) multiple SSIDs since they'll have different VLANs (management, regular, IOT) and 2 more for testing: 1 for 802.1x and another one to verify roaming on tunneled connection

    2) I use 802.1x since according to windows 10 docs it supports 802.11r only for 802.11 auth connections

     

    here's what I'll try

    1) Reduce number of networks to bare minimum

    2) use wpa2-psk wlan

    3) use tunnel.

     

    will get back to you with update!

    thanks again!

    Andrey



  • 10.  RE: Re: Intel AX-201 drops connection on bandsteer/roam events

    Posted Oct 21, 2020 01:24 PM

    short update:

    I've switched to wpa2-psk wlan with tunnel and didn't have similar problems since then.  802.11r/k/v are all on.

    so I guess the point about switches NOT updating arp table while in bridge mode can be a reason. 

    I was pretty surre controller must "pre-heat" arp on switches before roaming the client.

     

    thanks for help!!

     

    Andrey



  • 11.  RE: Re: Intel AX-201 drops connection on bandsteer/roam events

    Posted Oct 21, 2020 12:22 PM

    New driver released yesterday for ax200/ax201

    https://downloadmirror.intel.com/29902/eng/ReleaseNotes_WiFi_22.0.0.pdf

     

    Fixes:

    "When connected to a Wi-Fi 6 network with 802.11r Fast Roaming is enable, random disconnections occur in enterprise environments".

     

    Maybe it helps.