Network Management

last person joined: 13 hours ago 

Keep an informative eye on your network with IMC and Airwave network management solutions.
Expand all | Collapse all

User ampadmin/amprecovery error - Airwave 8.2.7.1

Jump to Best Answer
  • 1.  User ampadmin/amprecovery error - Airwave 8.2.7.1

    Posted Jan 22, 2019 02:35 PM

    Good afternoon to all of you.

     

    I've implemented over ESXi Airwave 8.2.7.1 from ISO file.

    During the process, I changed user "amprecovery" to "recovery" since with .ova implementation the users amprecovery and ampadmin didn't worked with any password (it didn't asked ampadmin password in the process of installation and neither it asked amprecovery password).

    My problem is, when I try to access to CLI with user ampadmin or, in this case, recovery, it drops the message "Login incorrect". I've repeated the process of installation with .ova file and .iso file at least 5 times with "Installation Guide" but without success.

    I've tried different solutions like one that cdelarosa recommended (https://community.arubanetworks.com/t5/Network-Management/Tutorial-Airwave-Root-password-recovery-Jan14-Tutorial/m-p/307190) but in this case it shows no 'e' option in booting process, it shows 'p' option which is protected by password.

    CLI is very important to me since i'm learning AirWave to deploy on customers, confronting implementation issues like this one and exploring its features. For example, VisualRF is not working and, founding a possible solution (https://community.arubanetworks.com/t5/AirWave-and-Network-Management/Stop-and-Start-Visual-RF-From-CLI/td-p/6972) requires CLI access.

    How can I access to CLI? Is there a way to recover ampadmin password? 

    Thanks to all in advance.

     

    Best regards.

    Gonzalo.User_CLI_airwave.PNGUserAMPCLI.png



  • 2.  RE: User ampadmin/amprecovery error - Airwave 8.2.7.1

    Posted Jan 22, 2019 10:58 PM

    During the install process, there's 2 username prompts and 1 password prompt.

     

    The 1st username prompt is the username that by default is amprecovery.  The default password for this account is 'recovery' - and this account is only accessible from console -> so if you're trying to access over SSH, it will not work (this is as designed, assumption is physical access means you have admin rights to the machine).  In VMware, you can access from the remote console.  The password can be changed by the ampadmin user.  Once in, you have 3 actions available as amprecovery: 1) generate new pw [result is a pw hash key], 2) scp the new pw hash so that you can send to support, 3) activate the new pw [with pw translation from support]

     

    The 2nd username prompt is the username for the AMPCLI admin, default is ampadmin.  This user has no default password - so password is what you set during install.

     

    You still won't be able to start/stop VisualRF from the AMPCLI, the only route to perform that operation is from the VisualRF Setup page (disable the process, wait 5-10 min, re-enable the process).  Otherwise a support case can be made if there's continued VRF issues.



  • 3.  RE: User ampadmin/amprecovery error - Airwave 8.2.7.1

    Posted Jan 23, 2019 08:10 AM

    Hi rgin. Thanks for your response.

    During the process of installation it only prompted one username, recovery one. No ampadmin or password prompted.

    On the other hand, when I changed recovery username, it didn't asked for password. "recovery" didn't worked, blank didn't worked so i'm without any other option.

    These access were attempted from console over ESXi.

    Thanks in advance.

    Gonzalo



  • 4.  RE: User ampadmin/amprecovery error - Airwave 8.2.7.1

    Posted Jan 23, 2019 12:45 AM

    Did the installation get aborted in between at some point? if so we have to create the ampadmin user using the script. 
    In this case if you are not able to login as the ampadmin user and also the amprecovery is not working, i would suggest to open a TAC as they can help you using the live iso and recover/create the ampadmin user again.

     



  • 5.  RE: User ampadmin/amprecovery error - Airwave 8.2.7.1

    Posted Jan 23, 2019 08:16 AM

    Hello Vishnu.

    I don't think so, I monitored the installation and didn't failed but the problem is what you described.

    We are partners and distributors of hpe/aruba but we don't have support contracts so I can't open a TAC case.

    Thanks in advance.

    Best regards.

    Gonzalo



  • 6.  RE: User ampadmin/amprecovery error - Airwave 8.2.7.1

    Posted Jan 23, 2019 08:29 AM

    Please open TAC tikcet! Try reach customer care they may give one time support on request but not sure though!



  • 7.  RE: User ampadmin/amprecovery error - Airwave 8.2.7.1

    Posted Jan 23, 2019 08:53 AM

    Hello Pavan, how are you?

     

    First of all thanks for the tutorial. I saved the hashed password.

    When I reached the step where I have to press 'e' at boot screen, it doesn't show 'e' option. Only 'p' option as you can see over screenshot attached and it requires a password.

     

    Any idea? 

     

    Thanks mate!

     

    Best regards.

    Gonzaloboot_password.PNG



  • 8.  RE: User ampadmin/amprecovery error - Airwave 8.2.7.1

    Posted Jan 23, 2019 11:35 AM

    When installing, are you switching the console view to tail the log with the ctrl+alt+f9?  Because you'd be missing the AMPCLI setup prompts if you are, switching back to the main screen with ctrl+alt+f1 should get you to where you see both user prompts and password input.  It's not worth it to watch the log unless you have an install that has been failing repeatedly.  Instead, switch tasks while install is running, the amp install step takes about 20-30 minutes before it gets to any prompt related actions - and a lot of the logging during the install is just echoes for copying of files into place.  When you come back, the terminal may have fallen asleep, hitting shift or ctrl can wake it back up.



  • 9.  RE: User ampadmin/amprecovery error - Airwave 8.2.7.1

    Posted Jan 30, 2019 07:17 AM

    Hello rgin.

     

    The two times I did this procedure, one I pressed ctrl alt f9 and the other I didn't.

    The second time (when I didn't), I saw the prompt of recovery password but never for ampadmin password.

    I will try as soon as I can to install again without pressing ctrl alt f9 to see if ampadmin prompts this time.

    Thank you.

    Best regards.

    Gonzalo



  • 10.  RE: User ampadmin/amprecovery error - Airwave 8.2.7.1
    Best Answer

    Posted Jan 30, 2019 02:41 PM

    here's a capture from when i just re-tested the 8.2.8.0 OVA:prompts.png

     

    I tested twice, but the capture is from when I didn't change the usernames at all, but even when I did, the prompts should still happen.  The ampadmin prompt happened immediately after amprecovery username prompt (less than a second from when I hit enter)

     

    You might also want to doublecheck the md5sum verification of the OVA you're using against what's on the support site.



  • 11.  RE: User ampadmin/amprecovery error - Airwave 8.2.7.1

    Posted Jan 30, 2019 03:06 PM

    Thanks for investing your time proving this.

    I will test it and let you know.

     

    Best regards.

    Gonzalo



  • 12.  RE: User ampadmin/amprecovery error - Airwave 8.2.7.1

    Posted Jan 30, 2019 03:33 PM

    Ok, I've tried again with 8.2.7.1 but it happens the same (see attached ss) Airwave testing.PNG

    It didn't prompted Step 5 where I have to configure password.

    I will download amp 8.2.8.0 and give it a try.

    I will update this as soon as possible.

    Thanks!



  • 13.  RE: User ampadmin/amprecovery error - Airwave 8.2.7.1

    Posted Jan 31, 2019 11:58 AM

    Hello rgin.

     

    With AMP 8.2.8.0 the installation process was successful. I appreciate your concern and support. Thanks to all who tried to help me.

    Best regards.

     

    Gonzalo