Wireless Access

last person joined: 2 hours ago 

Access network design for branch, remote, outdoor and campus locations with Aruba access points, and mobility controllers.
Expand all | Collapse all

AOS 8.4 cluster / an internal system error

This thread has been viewed 0 times
  • 1.  AOS 8.4 cluster / an internal system error

    Posted Apr 05, 2019 01:16 PM
    Hi Airheads.
    I encouted a strange issue with aos 8 classic cluster

    Cluster is up but client cant get ips
    I disabled the cluster , and everything working.

    When checking the errorlog im getting this strange output:
    Apr 5 16:55:04 311020> |AP 48:4a:e9:c1:b9:ec@10.107.50.102 sapd| An internal system error has occurred at file sapd_cluster.c function sapd_cluster_standby_hello_cb line 749 error sapd_cluster_standby_hello_cb: Unexpected result code NOT_SUPPORTED_AP_TYPE, node state:init.

    Apr 5 16:55:07 311020> |AP 48:4a:e9:c1:b9:ec@10.107.50.102 sapd| An internal system error has occurred at file sapd_cluster.c function sapd_cluster_standby_hello_cb line 749 error sapd_cluster_standby_hello_cb: Unexpected result code NOT_SUPPORTED_AP_TYPE, node state:init.

    Apr 5 16:55:09 311020> |AP 48:4a:e9:c1:b9:ec@10.107.50.102 sapd| An internal system error has occurred at file sapd_cluster.c function sapd_cluster_standby_hello_cb line 749 error sapd_cluster_standby_hello_cb: Unexpected result code NOT_SUPPORTED_AP_TYPE, node state:init.

    Apr 5 16:55:11 311020> |AP 48:4a:e9:c1:b9:ec@10.107.50.102 sapd| An internal system error has occurred at file sapd_cluster.c function sapd_cluster_standby_hello_cb line 749 error sapd_cluster_standby_hello_cb: Unexpected result code NOT_SUPPORTED_AP_TYPE


    Any idea ?
    Whats causing the error ?


  • 2.  RE: AOS 8.4 cluster / an internal system error

    Posted Apr 05, 2019 01:29 PM
    What type of AP are you using ?



    Thank you

    Victor Fabian

    Pardon typos sent from Mobile


  • 3.  RE: AOS 8.4 cluster / an internal system error

    Posted Apr 05, 2019 01:41 PM

    AP-345


  • 4.  RE: AOS 8.4 cluster / an internal system error

    Posted Apr 05, 2019 01:59 PM
    I recommend you downgrade to AOS8.3.0.6 (most stable version)
    Unless you are looking to use a particular feature in AOS8.4





    Thank you

    Victor Fabian

    Pardon typos sent from Mobile


  • 5.  RE: AOS 8.4 cluster / an internal system error

    Posted Apr 05, 2019 02:11 PM
    But i have on the same mm other group that working wonderful as a cluster with AP-345

    8.4 GUI is much baked than 8.3.0.x

    Any idea what causing this issue ?


  • 6.  RE: AOS 8.4 cluster / an internal system error

    Posted Apr 05, 2019 02:15 PM

    Are you sure that the client VLAN is trunked to the controller?  The AP messages might have nothing to do with the client issue.



  • 7.  RE: AOS 8.4 cluster / an internal system error

    Posted Apr 05, 2019 02:20 PM
    Yes..
    Triple time checked and verified it.
    Tagged ab eth port on the controller with the needed vlan an got it..so the needed vlan arriving and functional but not when cluster is enabled.

    BTW:
    When cluster is disable its working


  • 8.  RE: AOS 8.4 cluster / an internal system error

    Posted May 12, 2019 10:44 AM

     

     

     



  • 9.  RE: AOS 8.4 cluster / an internal system error

    Posted May 12, 2019 10:54 AM

    I'm running with same AOS 8.4 and cluster is wokring fine.

    can you rechek below another configration points:

    1. Cluster profile and Exclude vlans list.

    2.And allowed vlans and native vlan id list under interfaces of MC's

    3. did you see any output like

     

    >show lc-cluster group-membership if its not connected then there is issue with version/limitation/physcial connectivity issue/IPSec tunnel setup issue.



  • 10.  RE: AOS 8.4 cluster / an internal system error

    Posted May 13, 2019 03:37 AM
    Issue solved couple weeks ago.

    (Wrong Vlan was in the cluster)

    found out by using the following command , what the wrong VLAN was,
    show lc-cluster vlan-probe status