Wired

last person joined: 12 hours ago 

Bring performance and reliability to your network with the Aruba Core, Aggregation, and Access layer switches. Discuss the latest features and functionality of the ArubaOS-Switch and ArubaOS-CX devices, and find ways to improve security across your network to bring together a mobile first solution.
Expand all | Collapse all

Aruba-2930F-24G-4SFP ( Layer 3)

Jump to Best Answer
  • 1.  Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Jul 22, 2019 01:08 PM

     have a switch Aruba-2930F-24G-4SFP ( Layer 3)  But i have a problem about configuration CLI in HP

     

    1) i know this commande  in Ciscobut i don't know in Aruba-2930F-24G-4SFP ( Layer 3) 

    interface  ethernet  1===> link with switch layer 2 ( DLINK)

    switch trunk enpasulation dot1Q

    switchport mode trunk

     

    how i can configure this CLI  in switch layer 3  HP 2930F:  traduction to HP 

     

    thanks in advance i a answer ASAB



  • 2.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Jul 22, 2019 03:18 PM

    int X untag vlan Y

     

    where X is the interface identifier in the Aruba switch, Y is the vlan or list of VLANs you want tagged in 802.1q to traverse that port.



  • 3.  RE: Aruba-2930F-24G-4SFP ( Layer 3)
    Best Answer

    Posted Jul 22, 2019 03:45 PM
      |   view attached

    Hi,

     

    see the file in attachment, CLI reference Guide. (equivalance between aruba and cisco)



  • 4.  RE: Aruba-2930F-24G-4SFP ( Layer 3)
    Best Answer

    Posted Jul 22, 2019 04:31 PM

    Personally, given your Cisco versus ArubaOS-Switch commands translation doubts (especially against VLAN tagging and Link Aggregation),...I think this is always illuminating.



  • 5.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 06:17 AM

    Hello

     

    i have a problem that switch Aruba-2930F-24G-4SFP don't give any address dhcp to PC : i have two vlan 10 and vlan 20 

     

    this switch is link to switch DLINK1210-28p

     

    so i need a help why pc don't recive any address from pool vlan 10 ?,

     

    i give scrpit about HP layer 3 and i need answer ASAB 

     



  • 6.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 06:37 AM

    PLease some one can access with team viwer to have idea about problem swith as preffer 

     

    please i nees answer urgent about switch layer 3 don't give any pool to desktop 

    thanks in advance



  • 7.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 06:55 AM

    Aruba-2930F-24G-4SFP# show dhcp-server

    Configuration and Status - DHCP Server

    DHCP Server Enabled : Yes
    DHCPv4 Operational Status : Enabled
    Traps Enabled : Yes
    Persistent Lease Database : No
    Conflict Logging Enabled : No
    DHCP VLAN Interfaces :



  • 8.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 07:09 AM

    seems that u don't have configured properly the dhcp configuration... missed some configuration

     

    Please follow these steps and let me know

     

    https://www.networktasks.co.uk/environments/hp/provision/dhcp-server-on-hpe-aruba-switch

     

     

    Thanks



  • 9.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 07:16 AM

    help me and give me commands missing that allow DHCP switch to give desktop 

    i wait to answer urgent 

     

    thanks in advance



  • 10.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 07:19 AM

    you have to create your vlan and assign that vlan the dhcp-server enable

     

     

    but before that, your config of the dhcp-server should look like that

     

    dhcp-server pool "VLAN-NAME"
    authoritative
    default-router "192.168.0.1"
    dns-server "8.8.8.8,8.8.4.4"
    domain-name "test.local"
    lease 00:01:00
    network 192.168.0.0 255.255.254.0
    range 192.168.0.21 192.168.1.149



  • 11.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 07:26 AM

     changed configuration so 

     

    Aruba-2930F-24G-4SFP# show dhcp-server

    Configuration and Status - DHCP Server

    DHCP Server Enabled : Yes
    DHCPv4 Operational Status : Enabled
    Traps Enabled : Yes
    Persistent Lease Database : No
    Conflict Logging Enabled : No
    DHCP VLAN Interfaces : 10,20

     

    BUt

     

    desktop don't recive any pool from vlan 10 !!??

     

    what i can check other hardware !!

     

     



  • 12.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 07:28 AM

    Aruba-2930F-24G-4SFP# show running-config

    Running configuration:

    ; JL259A Configuration Editor; Created on release #WC.16.09.0001
    ; Ver #14:27.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:04
    hostname "Aruba-2930F-24G-4SFP"
    module 1 type jl259a
    trunk 1 trk1 trunk
    ip routing
    interface 1
    flow-control
    exit
    snmp-server community "public" unrestricted
    vlan 1
    name "DEFAULT_VLAN"
    untagged 2-28,Trk1
    ip address dhcp-bootp
    ipv6 enable
    ipv6 address dhcp full
    exit
    vlan 10
    name "RH"
    ip address 10.10.10.1 255.255.255.0
    dhcp-server
    exit
    vlan 20
    name "office"
    ip address 20.20.20.1 255.255.255.0
    dhcp-server
    exit
    spanning-tree Trk1 priority 4
    dhcp-server pool "RH"
    authoritative
    default-router "10.10.10.1"
    network 10.10.10.0 255.255.255.0
    range 10.10.10.2 10.10.10.254
    exit
    dhcp-server pool "security"
    authoritative
    default-router "20.20.20.1"
    network 20.20.20.0 255.255.255.0
    range 20.20.20.2 20.20.20.254
    exit
    dhcp-server enable

    Aruba-2930F-24G-4SFP#

     

    this edit for configuration so what other check that i can edit !!??

     

    please i wait your help and answers !!

     



  • 13.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 07:33 AM

    It seems that you don't have any ports in your vlans....
    try to connect a PC to port 3 and do this command
    #vlan 10
    #untagged 3
    And see if you are receiving an ip address



  • 14.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 07:46 AM

    mon desktop don't recive any pool  with port 3from vlan 10 !!??????,

     

    so what is the problem !!

     

    the switch layer 3 or switch layer 2 !!!

     

    please i need e help from ingenieer and undetersand this problem about dhcp !!

     i wait the answer urgent



  • 15.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 07:54 AM

    nothing work 

     

    please can you access with team viewer to check

     

    please i need your help

     

     



  • 16.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 08:03 AM
      |   view attached

    some  one help me about dhcp from switch layer3

    Aruba-2930F-24G-4SFP# show run

    Running configuration:

    ; JL259A Configuration Editor; Created on release #WC.16.09.0001
    ; Ver #14:27.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:04
    hostname "Aruba-2930F-24G-4SFP"
    module 1 type jl259a
    trunk 1 trk1 trunk
    ip routing
    interface 1
    flow-control
    exit
    snmp-server community "public" unrestricted
    vlan 1
    name "DEFAULT_VLAN"
    untagged 2-28,Trk1
    ip address dhcp-bootp
    ipv6 enable
    ipv6 address dhcp full
    exit
    vlan 10
    name "RH"
    ip address 10.10.10.1 255.255.255.0
    dhcp-server
    exit
    vlan 20
    name "office"
    ip address 20.20.20.1 255.255.255.0
    dhcp-server
    exit
    spanning-tree Trk1 priority 4
    dhcp-server pool "RH"
    authoritative
    default-router "10.10.10.1"
    network 10.10.10.0 255.255.255.0
    range 10.10.10.2 10.10.10.254
    exit
    dhcp-server pool "security"
    authoritative
    default-router "20.20.20.1"
    network 20.20.20.0 255.255.255.0
    range 20.20.20.2 20.20.20.254
    exit
    dhcp-server enable

     

    ////////////////////////////

     

    screen shot switch layer 2

     

    //

    whay pc don't recive any ip address from dhcp vlan 10 !!??

     

    i need answer that help me urgent

     

    thanks

     

     

     



  • 17.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 08:07 AM

    Hi,

     

     

    i will not be able to connectr via teamviewer sorry

     

    but you don't have any ports assign to vlan 10.......

     

    All your ports are untagged in the defaukt vlan (vlan1)

     

    see bellow:

     

    vlan 1
    name "DEFAULT_VLAN"
    untagged 2-28,Trk1
    ip address dhcp-bootp
    ipv6 enable
    ipv6 address dhcp full
    exit

     

    Then all your port from 2-28 and TRK1 are in the vlan1 by default



  • 18.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 09:54 AM

    this switch linked with switch layer 2: d-link with port 1 trunk (switch layer 3) with port 1 ( switch layer 2 ) port 1: switch layer 3 HP: trunk port1 : switch layer 2 D-link : trunk allwed vlan 10 20 =======>

     

    So i need how i can configure that in switch layer 3 port 1 linked with switch layer2 !!??

     

    only port 1 : trunk

    other port : normal access

     

     

    thanks in advance 



  • 19.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 10:35 AM

    this switch linked with switch layer 2: d-link with port 1 trunk (switch layer 3) with port 1 ( switch layer 2 ) port 1: switch layer 3 HP: trunk port1 : switch layer 2 D-link : trunk allwed vlan 10 20 =======>

     

    So i need how i can configure that in switch layer 3 port 1 linked with switch layer2 !!??

     

    only port 1 : trunk

    other port : normal access

     

     

    thanks in advance 



  • 20.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 11:44 AM

    i wait your answer about my explain architechture link abou two switch

     

    please it urgent for my work in company

     

    please  you can access about 10 minute by team viewer that i can undertstand and i give information about solution 

     

     



  • 21.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 11:47 AM

    Sorry about that but i'm on training right now, 

     

    please tagged you interfaces in the Aruba switch side... your dlink switches seems to be fine...

     

    if that is not working i suggest you to contact de TAC

     

    https://www.arubanetworks.com/fr/service-technique/contactez-le-support/

     

    Thanks

     

     



  • 22.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 11:51 AM

    in the switch Aruba-2930F-24G-4SFP ( Layer 3) 

     

    what is command  that allow in port 1 is trunk  (switch layer 3)  to switch layer 2 !!

     

    only that command my be dhcp work 

    thanks in advance 



  • 23.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 12:00 PM

    what is cammand can check if port 1 switch layer 3 is trunk in  Aruba-2930F-24G-4SFP ( Layer 3)

     

     

     

    please i thanks very much to answer me 

     



  • 24.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 12:35 PM

    please can you reply !!

     

    thanks



  • 25.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 12:38 PM

    You look like in big trouble...but every time you received an help (someone told you to untag at least one port on a specific VLAN on the Aruba to test if DHCP is OK or not) you didn't.

     

    So:

    1. Untag one or more ports on VLAN 10 or 20 (the command is: vlan 10 -> Enter -> untagged 4 then exit to exit the VLAN 10 context you entered <-- this series of commands will cause port 4 to became untagged member of VLAN 10)...at that point a PC connected to port 4 with its NIC port set to DHCP will receive an IP Address from the Aruba in VLAN 10 or 20. To check the status of a port from the VLAN membership standpoint use the command show vlan port n detail where n is the physical or logical (trkX) port id. Remember to write memory to save your configuration running configuration to startup configuration on your Aruba.
    2. The port you use to interconnect your Aruba (Layer 3: doing IP Routing) and your D-Link (doing what?) is probably Port 1 on both the Aruba and the D-Link. OK...so you need to match VLAN tagging on both ends...you trunk 1 trk1 trunk is TOTALLY WRONG! you haven't a link aggregation (trunk trk1)...you said you have JUST one physical link between Aruba and D-Link so forget about trunk trk1...you must remove trk1 with no trunk trk1 and then Port 1 will be reset to be untagged member of VLAN 1...then you MUST tag others two VLAN id (10 and 20) you need for speaking with D-Link with the command: interface ethernet 1 vlan tagged 10,20...doing so if you perform a check with show vlan port 1 detail you will discover that Port 1 will be concurrently untagged member of VLAN 1 (like in D-Link Port 1) and tagged member of VLAN 10 and 20 (again, like in D-Link Port 1...as per your screenshot).
    3. If you're able to do that you should be OK, if not you need to contact anyone that will be able to help you directly (TAC, Distributor, Consultant)...I suspect nobody here have the time (nor will take the responsability) to perform a remote session to fix your issues in real time as you want <-- and that's because you didn't explain what was/is your scenario...you just throw an issue after the other waiting for help.


  • 26.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 12:51 PM

    I am a network engineer thanks very much about your  detail and tthat's what I want and  will feedback about result to morrow that is fine or not !

     

    thanks 



  • 27.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 06, 2019 03:10 AM
      |   view attached

    Hello

     

    i changed configuration but nothing work !!

     

    Aruba-2930F-24G-4SFP# show running-config

    Running configuration:

    ; JL259A Configuration Editor; Created on release #WC.16.09.0001
    ; Ver #14:27.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:04
    hostname "Aruba-2930F-24G-4SFP"
    module 1 type jl259a
    ip routing
    interface 1
    flow-control
    exit
    snmp-server community "public" unrestricted
    vlan 1
    name "DEFAULT_VLAN"
    untagged 1-28
    ip address dhcp-bootp
    ipv6 enable
    ipv6 address dhcp full
    exit
    vlan 10
    name "RH"
    tagged 1
    ip address 10.10.10.1 255.255.255.0
    dhcp-server
    exit
    vlan 20
    name "office"
    tagged 1
    ip address 20.20.20.1 255.255.255.0
    dhcp-server
    exit
    dhcp-server pool "RH"
    authoritative
    default-router "10.10.10.1"
    network 10.10.10.0 255.255.255.0
    range 10.10.10.2 10.10.10.254
    exit
    dhcp-server pool "security"
    authoritative
    default-router "20.20.20.1"
    network 20.20.20.0 255.255.255.0
    range 20.20.20.2 20.20.20.254
    exit
    dhcp-server enable

    Aruba-2930F-24G-4SFP# show vlans ports 1 detail

    Status and Counters - VLAN Information - for ports 1

    VLAN ID Name | Status Voice Jumbo Mode
    ------- -------------------- + ---------- ----- ----- --------
    1 DEFAULT_VLAN | Port-based No No Untagged
    10 RH | Port-based No No Tagged
    20 office | Port-based No No Tagged


    Aruba-2930F-24G-4SFP# ping 10.10.10.40
    Request timed out.
    Aruba-2930F-24G-4SFP# write memory
    Aruba-2930F-24G-4SFP# show RUNning-config

    Running configuration:

    ; JL259A Configuration Editor; Created on release #WC.16.09.0001
    ; Ver #14:27.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:04
    hostname "Aruba-2930F-24G-4SFP"
    module 1 type jl259a
    ip routing
    interface 1
    flow-control
    exit
    snmp-server community "public" unrestricted
    vlan 1
    name "DEFAULT_VLAN"
    untagged 1-28
    ip address dhcp-bootp
    ipv6 enable
    ipv6 address dhcp full
    exit
    vlan 10
    name "RH"
    tagged 1
    ip address 10.10.10.1 255.255.255.0
    dhcp-server
    exit
    vlan 20
    name "office"
    tagged 1
    ip address 20.20.20.1 255.255.255.0
    dhcp-server
    exit
    dhcp-server pool "RH"
    authoritative
    default-router "10.10.10.1"
    network 10.10.10.0 255.255.255.0
    range 10.10.10.2 10.10.10.254
    exit
    dhcp-server pool "security"
    authoritative
    default-router "20.20.20.1"
    network 20.20.20.0 255.255.255.0
    range 20.20.20.2 20.20.20.254
    exit
    dhcp-server enable

     

    ////////////////////////////////////////////////////////////////////////////////////

     

    i send screnn shot about ping from addres ip static vlan 20 to gateway 20.20.20.1

     

    but noting work !!

     

    so what i can do to check or to configure switch layer 3 !!

     

    please i need a help urgent 

     



  • 28.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 06, 2019 03:21 AM

    i changed configuration for switch layer 3 

     

    but noting work 

    please i need a reply what i can configure or check or edit this configuration

     

    pc don't get dhcp from vlan 10 !!!!!!!!!!!!!???????????????,,,

     

    ////////////////////////////////////////////////////////////////////////////////////////////

     

    Aruba-2930F-24G-4SFP# show running-config

    Running configuration:

    ; JL259A Configuration Editor; Created on release #WC.16.09.0001
    ; Ver #14:27.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:04
    hostname "Aruba-2930F-24G-4SFP"
    module 1 type jl259a
    ip routing
    interface 1
    flow-control
    exit
    snmp-server community "public" unrestricted
    vlan 1
    name "DEFAULT_VLAN"
    untagged 1-28
    ip address dhcp-bootp
    ipv6 enable
    ipv6 address dhcp full
    exit
    vlan 10
    name "RH"
    tagged 1
    ip address 10.10.10.1 255.255.255.0
    dhcp-server
    exit
    vlan 20
    name "office"
    tagged 1
    ip address 20.20.20.1 255.255.255.0
    dhcp-server
    exit
    dhcp-server pool "RH"
    authoritative
    default-router "10.10.10.1"
    network 10.10.10.0 255.255.255.0
    range 10.10.10.2 10.10.10.254
    exit
    dhcp-server pool "security"
    authoritative
    default-router "20.20.20.1"
    network 20.20.20.0 255.255.255.0
    range 20.20.20.2 20.20.20.254
    exit
    dhcp-server enable

    Aruba-2930F-24G-4SFP# show running-config

    Running configuration:

    ; JL259A Configuration Editor; Created on release #WC.16.09.0001
    ; Ver #14:27.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:04
    hostname "Aruba-2930F-24G-4SFP"
    module 1 type jl259a
    ip routing
    interface 1
    flow-control
    exit
    snmp-server community "public" unrestricted
    vlan 1
    name "DEFAULT_VLAN"
    untagged 1-28
    ip address dhcp-bootp
    ipv6 enable
    ipv6 address dhcp full
    exit
    vlan 10
    name "RH"
    tagged 1
    ip address 10.10.10.1 255.255.255.0
    dhcp-server
    exit
    vlan 20
    name "office"
    tagged 1
    ip address 20.20.20.1 255.255.255.0
    dhcp-server
    exit
    dhcp-server pool "RH"
    authoritative
    default-router "10.10.10.1"
    network 10.10.10.0 255.255.255.0
    range 10.10.10.2 10.10.10.254
    exit
    dhcp-server pool "security"
    authoritative
    default-router "20.20.20.1"
    network 20.20.20.0 255.255.255.0
    range 20.20.20.2 20.20.20.254
    exit
    dhcp-server enable



  • 29.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 06, 2019 03:22 AM

    You didn't untag ANY port on the relevant VLAN (10 or 20) you want to test...AGAIN...there aren't access port untagged member of VLAN 10 or VLAN 20...so what are you pretend to test if the configuration is missing a piece?

     

    Who is 10.10.10.40 you're trying to ping from the Switch console?

     

    Where is the host supposedly having that IP connected to (port)?

     

    Go to Step 1 and untag THAT port on VLAN 10 with the command we gave you before many times: enter VLAN 10 context with the vlan 10 commmand, execute the untagging with the command untagged port-number (where port-number is the Port where there is the host you are trying to ping on VLAN 10)...then exit the vlan context with exit, do a write memory...and finally do a show vlan port port-number detail to check that the configuration you did for that port is OK from the VLAN tagging/untagging standpoint.

     

    You wrote us you're a Network Engineer so you should have easy time doing such changes, it's not rocket science, really (clearly you need a basic understanding of CLI, configuration and VLANs...not necessarily Cisco biased).



  • 30.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 06, 2019 03:41 AM
      |   view attached

    my goal : principe switch layer 3 linked to switch layer 2 :

    not pc linked directly switch layer 3 because i try from switch layer  3 and  pc get ip  address from switch layer 3

     

    ==========> desktop linked directly to switch layer 2 ( D-link DES-1210 )  and get ip address from switch layer 3 linked to switch layer 2 

     

    /////////////////////////////////////////////////////////////////

     

    configuration switch layer 3:

     


    Aruba-2930F-24G-4SFP# show running-config

    Running configuration:

    ; JL259A Configuration Editor; Created on release #WC.16.09.0001
    ; Ver #14:27.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:04
    hostname "Aruba-2930F-24G-4SFP"
    module 1 type jl259a
    ip routing
    interface 1
    flow-control
    exit
    snmp-server community "public" unrestricted
    vlan 1
    name "DEFAULT_VLAN"
    untagged 1-28
    ip address dhcp-bootp
    ipv6 enable
    ipv6 address dhcp full
    exit
    vlan 10
    name "RH"
    tagged 1
    ip address 10.10.10.1 255.255.255.0
    dhcp-server
    exit
    vlan 20
    name "office"
    tagged 1
    ip address 20.20.20.1 255.255.255.0
    dhcp-server
    exit
    dhcp-server pool "RH"
    authoritative
    default-router "10.10.10.1"
    network 10.10.10.0 255.255.255.0
    range 10.10.10.2 10.10.10.254
    exit
    dhcp-server pool "security"
    authoritative
    default-router "20.20.20.1"
    network 20.20.20.0 255.255.255.0
    range 20.20.20.2 20.20.20.254
    exit
    dhcp-server enable

    Aruba-2930F-24G-4SFP#
    Aruba-2930F-24G-4SFP# conf terminal
    Aruba-2930F-24G-4SFP(config)# vlan 10
    Aruba-2930F-24G-4SFP(vlan-10)# untagged 3
    Aruba-2930F-24G-4SFP(vlan-10)# quit
    Aruba-2930F-24G-4SFP(config)# quit
    Aruba-2930F-24G-4SFP# write memory
    Aruba-2930F-24G-4SFP# show running-config

    Running configuration:

    ; JL259A Configuration Editor; Created on release #WC.16.09.0001
    ; Ver #14:27.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:04
    hostname "Aruba-2930F-24G-4SFP"
    module 1 type jl259a
    ip routing
    interface 1
    flow-control
    exit
    snmp-server community "public" unrestricted
    vlan 1
    name "DEFAULT_VLAN"
    no untagged 3
    untagged 1-2,4-28
    ip address dhcp-bootp
    ipv6 enable
    ipv6 address dhcp full
    exit
    vlan 10
    name "RH"
    untagged 3
    tagged 1
    ip address 10.10.10.1 255.255.255.0
    dhcp-server
    exit
    vlan 20
    name "office"
    tagged 1
    ip address 20.20.20.1 255.255.255.0
    dhcp-server
    exit
    dhcp-server pool "RH"
    authoritative
    default-router "10.10.10.1"
    network 10.10.10.0 255.255.255.0
    range 10.10.10.2 10.10.10.254
    exit
    dhcp-server pool "security"
    authoritative
    default-router "20.20.20.1"
    network 20.20.20.0 255.255.255.0
    range 20.20.20.2 20.20.20.254
    exit
    dhcp-server enable

    //////////////////////////////////////////////////////////////////////////////////////////////////

    switch dlink: screen shot

     

    ////////////////////////////////////////////////////

     

    so what i can edit and configure or chek switch layer 3 or layer 2 that allwo desktop get ip address from switch layer 3 linked switch layer 2

     



  • 31.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 06, 2019 03:46 AM

    my goal : principe switch layer 3 linked to switch layer 2 :

    not pc linked directly switch layer 3 because i try from switch layer  3 and  pc get ip  address from switch layer 3

     

    ==========> desktop linked directly to switch layer 2 ( D-link DES-1210 )  and get ip address from switch layer 3 linked to switch layer 2 

     

    /////////////////////////////////////////////////////////////////

     

    configuration switch layer 3:

     


    Aruba-2930F-24G-4SFP# show running-config

    Running configuration:

    ; JL259A Configuration Editor; Created on release #WC.16.09.0001
    ; Ver #14:27.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:04
    hostname "Aruba-2930F-24G-4SFP"
    module 1 type jl259a
    ip routing
    interface 1
    flow-control
    exit
    snmp-server community "public" unrestricted
    vlan 1
    name "DEFAULT_VLAN"
    untagged 1-28
    ip address dhcp-bootp
    ipv6 enable
    ipv6 address dhcp full
    exit
    vlan 10
    name "RH"
    tagged 1
    ip address 10.10.10.1 255.255.255.0
    dhcp-server
    exit
    vlan 20
    name "office"
    tagged 1
    ip address 20.20.20.1 255.255.255.0
    dhcp-server
    exit
    dhcp-server pool "RH"
    authoritative
    default-router "10.10.10.1"
    network 10.10.10.0 255.255.255.0
    range 10.10.10.2 10.10.10.254
    exit
    dhcp-server pool "security"
    authoritative
    default-router "20.20.20.1"
    network 20.20.20.0 255.255.255.0
    range 20.20.20.2 20.20.20.254
    exit
    dhcp-server enable

    Aruba-2930F-24G-4SFP#
    Aruba-2930F-24G-4SFP# conf terminal
    Aruba-2930F-24G-4SFP(config)# vlan 10
    Aruba-2930F-24G-4SFP(vlan-10)# untagged 3
    Aruba-2930F-24G-4SFP(vlan-10)# quit
    Aruba-2930F-24G-4SFP(config)# quit
    Aruba-2930F-24G-4SFP# write memory
    Aruba-2930F-24G-4SFP# show running-config

    Running configuration:

    ; JL259A Configuration Editor; Created on release #WC.16.09.0001
    ; Ver #14:27.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:04
    hostname "Aruba-2930F-24G-4SFP"
    module 1 type jl259a
    ip routing
    interface 1
    flow-control
    exit
    snmp-server community "public" unrestricted
    vlan 1
    name "DEFAULT_VLAN"
    no untagged 3
    untagged 1-2,4-28
    ip address dhcp-bootp
    ipv6 enable
    ipv6 address dhcp full
    exit
    vlan 10
    name "RH"
    untagged 3
    tagged 1
    ip address 10.10.10.1 255.255.255.0
    dhcp-server
    exit
    vlan 20
    name "office"
    tagged 1
    ip address 20.20.20.1 255.255.255.0
    dhcp-server
    exit
    dhcp-server pool "RH"
    authoritative
    default-router "10.10.10.1"
    network 10.10.10.0 255.255.255.0
    range 10.10.10.2 10.10.10.254
    exit
    dhcp-server pool "security"
    authoritative
    default-router "20.20.20.1"
    network 20.20.20.0 255.255.255.0
    range 20.20.20.2 20.20.20.254
    exit
    dhcp-server enable

    //////////////////////////////////////////////////////////////////////////////////////////////////

    switch dlink: screen shot

     

    ////////////////////////////////////////////////////

     

    so what i can edit and configure or chek switch layer 3 or layer 2 that allwo desktop get ip address from switch layer 3 linked switch layer 2

     

    please 

     



  • 32.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 06, 2019 03:50 AM

    Aruba-2930F-24G-4SFP# show vlans ports 1 detail

    Status and Counters - VLAN Information - for ports 1

    VLAN ID Name | Status Voice Jumbo Mode
    ------- -------------------- + ---------- ----- ----- --------
    1 DEFAULT_VLAN | Port-based No No Untagged
    10 RH | Port-based No No Tagged
    20 office | Port-based No No Tagged

     



  • 33.  RE: Aruba-2930F-24G-4SFP ( Layer 3)
    Best Answer

    Posted Aug 06, 2019 04:09 AM

    I'm not used to work with D-Link Switches (no matter if Layer 2 or 3), said so...what is the port configuration where the PC (set DHCP or Static IP on VLAN 10) you're using for testing (I suspect with desired IP Addressing 10.10.10.40)?

     

    D-Link Switch side that port should be untagged (and only untagged) in VLAN 10.

     

    If you set that PC with temporarily with a Static IP Addressing: 10.10.10.40, Subnet Mask 255.255.255.0 and Default Gateway 10.10.10.1 (which is the IP Address given to VLAN 10 Interface on Aruba 2930F Switch) then you should be able to perform successfully a ping to 10.10.10.1 and also to 20.20.20.1 (because Aruba 2930F if responsible for IPv4 Routing on its VLANs).

     

    Your DHCP issue (which should be, as far as I understood, D-Link access hosts are not receiving IP Addressing from DHCP Server set on Aruba 2930F) shoudl be fixed after the above step is verified...that's essential...why? because you first need to verify and be sure that Switch A (Aruba 2930F) and Switch B (D-Link) have a well formed interconnection and also that an host connected to an access port on Switch A (untagged on VLAN 10 or untagged on VLAN 20) is able to ping a corresponding host connected to an access port on Switch B (untagged on VLAN 10 or untagged on VLAN 20) and vice-versa.



  • 34.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 06, 2019 05:01 AM
      |   view attached

    Hello

     

     from pc vlan 20 , i try to ping 20.20.20.1 and 10.10.10.1 , it not work??????,,!!!! this desktop linked to switch layer 2 -d-link

     

    also from pc vlan 10 , i try to ping 10.10.10.1 and 20.20.20.1 , it not work !!???,

     

    i send you scrennshot about switch layer 2 and please tell me if the configuration switch layer 2 is correct or not !!!???

     



  • 35.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 06, 2019 05:04 AM

    why until now  the ping don't work and aslo dhcp !!??????,,

     

    please help me to find the solution and a thanks a lot 

     



  • 36.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 06, 2019 05:26 AM

    why until now  the ping don't work and aslo dhcp !!??????,,

     

    please help me to find the solution and a thanks a lot



  • 37.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 06, 2019 05:49 AM

    Please i need a reply what i can doing 

    ///////////////////////////////////////////////////////////////////////////////////

    Aruba-2930F-24G-4SFP# show running-config

    Running configuration:

    ; JL259A Configuration Editor; Created on release #WC.16.09.0001
    ; Ver #14:27.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:04
    hostname "Aruba-2930F-24G-4SFP"
    module 1 type jl259a
    ip routing
    interface 1
    flow-control
    exit
    snmp-server community "public" unrestricted
    vlan 1
    name "DEFAULT_VLAN"
    no untagged 3
    untagged 1-2,4-28
    ip address dhcp-bootp
    ipv6 enable
    ipv6 address dhcp full
    exit
    vlan 10
    name "RH"
    untagged 3
    tagged 1
    ip address 10.10.10.1 255.255.255.0
    dhcp-server
    exit
    vlan 20
    name "office"
    tagged 1
    ip address 20.20.20.1 255.255.255.0
    dhcp-server
    exit
    dhcp-server pool "RH"
    authoritative
    default-router "10.10.10.1"
    network 10.10.10.0 255.255.255.0
    range 10.10.10.2 10.10.10.254
    exit
    dhcp-server pool "security"
    authoritative
    default-router "20.20.20.1"
    network 20.20.20.0 255.255.255.0
    range 20.20.20.2 20.20.20.254
    exit
    dhcp-server enable

    Aruba-2930F-24G-4SFP#
    Aruba-2930F-24G-4SFP#
    Aruba-2930F-24G-4SFP# show running-config

    Running configuration:

    ; JL259A Configuration Editor; Created on release #WC.16.09.0001
    ; Ver #14:27.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:04
    hostname "Aruba-2930F-24G-4SFP"
    module 1 type jl259a
    ip routing
    interface 1
    flow-control
    exit
    snmp-server community "public" unrestricted
    vlan 1
    name "DEFAULT_VLAN"
    no untagged 3
    untagged 1-2,4-28
    ip address dhcp-bootp
    ipv6 enable
    ipv6 address dhcp full
    exit
    vlan 10
    name "RH"
    untagged 3
    tagged 1
    ip address 10.10.10.1 255.255.255.0
    dhcp-server
    exit
    vlan 20
    name "office"
    tagged 1
    ip address 20.20.20.1 255.255.255.0
    dhcp-server
    exit
    dhcp-server pool "RH"
    authoritative
    default-router "10.10.10.1"
    network 10.10.10.0 255.255.255.0
    range 10.10.10.2 10.10.10.254
    exit
    dhcp-server pool "security"
    authoritative
    default-router "20.20.20.1"
    network 20.20.20.0 255.255.255.0
    range 20.20.20.2 20.20.20.254
    exit
    dhcp-server enable

    Aruba-2930F-24G-4SFP#

     

     

     



  • 38.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 06, 2019 06:29 AM

    Thanks very much and it work finally

    and desktop get ip address from dhcp 

     

    thanks a lot



  • 39.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 06, 2019 06:45 AM

    thanks vey much and it is resolved and work finally

     

     



  • 40.  RE: Aruba-2930F-24G-4SFP ( Layer 3)
    Best Answer

    Posted Aug 06, 2019 05:45 AM

    Never seen a Network Engineer writing so many "?" and "!" in a thread...by the way...check this D-Link article (I suspect that "Asymmetric VLAN" should be disabled and you should go down the Static VLAN configuration path): https://eu.dlink.com/uk/en/support/faq/switches/layer-2-gigabit/dgs-series/uk_dgs_1210_setup_static_vlans

     

    D-Link Port 1 (interlink) MUST me set to be Untagged on VLAN 1, Tagged on VLAN 10 and Tagged on VLAN 20.

    D-Link Port 3 (example of access port) MUST be Untagged on VLAN 10 (your "RH") ONLY (remove the actual tagging on VLAN 1).

    D-Link Port 4 (example of access port) MUST be Untagged on VLAN 20 (your "office") ONLY (remove the actual tagging on VLAN 1).

     

    Try to connect a PC on Port 3 of D-Link (try first setting a free IP Address compatible with subnet of VLAN 10, as described on my previous post) and verify ping against Aruba 2930 VLAN 10 IP Address 10.10.10.1.

     

    Do the same on Port 4 of D-Link (try first setting a free IP Address compatible with subnet of VLAN 20, as described on my previous post) and verify ping against Aruba 2930 VLAN 20 IP Address 20.20.20.1.

     

    D-Link DGS-1210-28 Manual: https://media.dlink.eu/ftp/products/dgs/dgs-1210/documentation/DGS-1210_man_revF_v6-10_eu_multi_20180110.pdf

     



  • 41.  RE: Aruba-2930F-24G-4SFP ( Layer 3)

    Posted Aug 05, 2019 07:34 AM
      |   view attached

    i changed configuration but desktop don't recive any pool dhcp from vlan 10

     

    this switch is link to switch layer 2 D-LINK 1210-28p

    i give a screenshot switch dlink layer 2

     

    i please i need your chek about two switch !!

     

    urgent 

    thanks in advance