Wired

last person joined: 9 hours ago 

Bring performance and reliability to your network with the Aruba Core, Aggregation, and Access layer switches. Discuss the latest features and functionality of the ArubaOS-Switch and ArubaOS-CX devices, and find ways to improve security across your network to bring together a mobile first solution.
Expand all | Collapse all

2930F trunk to HP switch

Jump to Best Answer
  • 1.  2930F trunk to HP switch

    Posted Jul 02, 2020 08:26 AM

    Hello All,

     

    I try to configure trunk from 2930F switch on two ports connected to HP switch (switch1). I can ping and login to 2930F from switch1 via management vlan. My problem is to ping 2930F from another HP switches connected to switch1. Trunks on all switches are configured in the same way.

     

    On 2930F show arp vlan 100 shows no mac address for other switches (switch1 only).

     

    After running ping from 2930F to other switches its (2930F's) mac address is visible on other routers.

     

    What configuration directives should I check to allow packets from other switches to reach 2930F? Or what other issue couse my problem?

     

    BR,

    Michał Szamocki

    Cirrus


    #2930F


  • 2.  RE: 2930F trunk to HP switch

    Posted Jul 02, 2020 09:26 AM
    Can you share your configuration ?
    Sent from Mail for Windows 10


  • 3.  RE: 2930F trunk to HP switch

    Posted Jul 02, 2020 09:33 AM
    ; JL256A Configuration Editor; Created on release #WC.16.07.0003
    ; Ver #14:01.4f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:02
    hostname "TEST01"
    module 1 type jl256a
    trunk 49,51 trk1 trunk
    radius-server host X.Y.0.32 key "xxxxxx"
    timesync sntp
    sntp unicast
    sntp server priority 1 X.Y.0.17
    no telnet-server
    time daylight-time-rule western-europe
    time timezone 60
    ip default-gateway X.Y.7.1
    ip ssh filetransfer
    snmp-server community "public" unrestricted
    vlan 1
       name "DEFAULT_VLAN"
       no untagged 48
       untagged 1-47,50,52,Trk1
       no ip address
       ipv6 enable
       ipv6 address dhcp full
       exit
    vlan 11
       name "Clients_Printer"
       tagged 48
       no ip address
       exit
    vlan 90
       name "Management"
       tagged 48,Trk1
       ip address X.Y.7.100 255.255.255.0
       exit
    vlan 114
       name "Unauthorized"
       tagged 48
       no ip address
       exit
    spanning-tree
    spanning-tree Trk1 priority 4
    spanning-tree force-version rstp-operation
    no tftp client
    no tftp server
    no autorun
    no dhcp config-file-update
    no dhcp image-file-update
    no dhcp tr69-acs-url
    password manager
    password operator
    


  • 4.  RE: 2930F trunk to HP switch

    Posted Jul 03, 2020 05:38 AM
      |   view attached

    Hello,

     

    config attached.

     

    BR,

    Michał Szamocki

    Cirrus

    Attachment(s)

    txt
    aruba.txt   1K 1 version


  • 5.  RE: 2930F trunk to HP switch

    Posted Jul 06, 2020 07:46 PM

    Hi!

     

    ; JL256A Configuration Editor; Created on release #WC.16.07.0003
    
    trunk 49,51 trk1 trunk
    
    ip default-gateway X.Y.7.1
    
    vlan 1
       name "DEFAULT_VLAN"
       no untagged 48
       untagged 1-47,50,52,Trk1
       no ip address
       ipv6 enable
       ipv6 address dhcp full
       exit
    
    vlan 11
       name "Clients_Printer"
       tagged 48
       no ip address
       exit
    
    vlan 90
       name "Management"
       tagged 48,Trk1
       ip address X.Y.7.100 255.255.255.0
       exit
    
    vlan 114
       name "Unauthorized"
       tagged 48
       no ip address
       exit
    
    spanning-tree
    spanning-tree Trk1 priority 4
    spanning-tree force-version rstp-operation

     

    Looking at relevant portion of published running configuration...it can be said that the Switch hasn't routing enabled (only D.G. is set) and logical interface Trk1 (made of ports 49 and 51) is just Untagged member of VLAN 1 and Tagged member of VLAN 90.

     

    It's supposed that peer LAG/Trunk interface has the same VLAN IDs memberships. Isn't it?



  • 6.  RE: 2930F trunk to HP switch

    Posted Jul 07, 2020 11:45 AM

    Yes, it has, I mean on the switch on the other side of the trunk the trunk is added as untagged to vlan1 and as tagged to vlan 90.



  • 7.  RE: 2930F trunk to HP switch

    Posted Jul 07, 2020 02:50 PM

    You could provide outputs of these commands (and corresponding ones on the peer switch):

     

    show lldp info remote-device

    show lacp | include "Trk1 "

    show trunk | include "Trk1 "

    show vlan port trk1 detail

    show spanning tree



  • 8.  RE: 2930F trunk to HP switch

    Posted Jul 08, 2020 09:02 AM

    This is the situation:

    SWITCH1 and SWITCH2 see each other through trunk trk1:

    SWITCH1(ports L1,L2=trk1)<===>SWITCH2(ports L1,L2=trk1)

     

    SWITCH2 and SWITCH3 see each other through trunk named trk7 from SWITCH2 side and trk1 from SWITCH3 side:

    SWITCH2(ports L7,L8=trk7)<===>SWITCH3(ports 49,51=trk1)

     

    SWITCH1 does not see SWITCH3 (with SWITCH2 acting as man-in-the-middle). When I ping SWITCH1 from SWITCH3 I get timeout and SWITCH3 does not see SWITCH1 and does not have its MAC in ARP table, but ARP address of SWITCH3 appears in SWITCH1 arp table (!?!?).

     

    Enclosed please find shortened configuration files of the three switches together with the results of the commands you asked for (the output is below the configuration dump in each file). Command "show lacp | include "Trk1 "" did not return anything on any of the switches.

     

    Thank you very much for the questions and interest in our problem, parnassus!

    Attachment(s)

    txt
    SWITCH2 short.txt   4K 1 version
    txt
    SWITCH3 short.txt   2K 1 version
    txt
    SWITCH1 short.txt   3K 1 version


  • 9.  RE: 2930F trunk to HP switch
    Best Answer

    Posted Jul 08, 2020 09:25 AM

    On SWITCH2 trk7 L7+L8 was defined as dt-trunk, AKA Distributed-Trunk (Wrong!).

     

    All remaining Port Trunks are of type "trunk" (thus static, non protocol). I strongly (strongly) suggest you to reconfigure all your Port Trunks (trk1, trk7, etc.) as LACP instead...that way Port Trunk will be defined as trunk X,Y trkZ lacp (and the show lacp will show you something...) instead of current trunk X,Y trkZ trunk.



  • 10.  RE: 2930F trunk to HP switch

    Posted Jul 14, 2020 10:17 AM

    parnassus, your advice worked perfectly, thank you very much!