Wired

last person joined: 4 hours ago 

Bring performance and reliability to your network with the Aruba Core, Aggregation, and Access layer switches. Discuss the latest features and functionality of the ArubaOS-Switch and ArubaOS-CX devices, and find ways to improve security across your network to bring together a mobile first solution.
Expand all | Collapse all

Aruba 2530 port cannot ping any Ethernet port that has different IP from the switch

Jump to Best Answer
  • 1.  Aruba 2530 port cannot ping any Ethernet port that has different IP from the switch

    Posted Sep 10, 2020 05:46 AM

    Hi everyone,

    I'm new in Aruba.

    I want to ask about my  problem

    I have Cisco 3750 and Aruba 2530. I can ping to  my 3750 using console cable connected to 2530. And 3750 can ping  my 2530. But I cannot ping any device the ethernet port connected in my Aruba.(Example of my device IP 10.19.1.250)

     

    In my cisco I have

    vlan 10 - 10.11.1.1

    vlan 191 - 10.19.1.1

     

    In my Aruba I have

    vlan 1 - 10.11.1.5

    vlan 191

    All ethernet port in Aruba are set to vlan 191

    Anyone can help me?



  • 2.  RE: Aruba 2530 port cannot ping any Ethernet port that has different IP from the switch

    Posted Sep 14, 2020 08:22 AM

    From what IP connected on which port to what IP connected on which other port are you trying to ping? Is that within the VLAN191?

     

    Would help if you could share the configuration (at lease port, VLAN and IP/routing) for both switches.



  • 3.  RE: Aruba 2530 port cannot ping any Ethernet port that has different IP from the switch

    Posted Sep 15, 2020 09:52 PM

    Hi Herman

    This is my Cisco setting
    !
    aaa new-model
    !
    !
    aaa authentication login default local
    --More--  !
    !
    !
    aaa session-id common
    switch 1 provision ws-c3750v2-24ps
    system mtu routing 1500
    ip routing
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    --More--  vlan internal allocation policy ascending
    !
    !
    !
    interface FastEthernet1/0/1
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/2
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/3
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/4
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    --More--  !
    interface FastEthernet1/0/5
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/6
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/7
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/8
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/9
    switchport access vlan 191
    --More--   switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/10
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/11
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/12
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/13
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    --More--  interface FastEthernet1/0/14
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/15
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/16
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/17
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/18
    switchport access vlan 191
    switchport mode access
    --More--   spanning-tree portfast
    !
    interface FastEthernet1/0/19
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/20
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/21
    switchport access vlan 191
    !
    interface FastEthernet1/0/22
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/23
    switchport access vlan 191
    !
    --More--  interface FastEthernet1/0/24
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/1
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 11
    switchport mode trunk
    !
    interface GigabitEthernet1/0/2
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 11
    switchport mode trunk
    !
    interface Vlan1
    no ip address
    shutdown
    !
    interface Vlan11
    ip address 10.11.1.1 255.255.255.0
    !
    interface Vlan191
    --More--   ip address 10.19.1.1 255.255.255.0
    !
    interface Vlan192
    ip address 10.19.2.1 255.255.255.0
    !
    ip classless
    ip http server
    ip http secure-server
    !
    !
    !
    line con 0
    line vty 5 15
    !

     

     

    And this is my Aruba setting


    ; J9773A Configuration Editor; Created on release #YA.16.06.0006
    ; Ver #13:44.00.04.19.02.13.98.82.34.61.18.28.f3.84.9c.63.ff.37.27:43
    hostname "HP-2530-24G-PoEP"
    time timezone 420
    ip default-gateway 10.11.1.1
    snmp-server community "SadhanaCCTV" unrestricted
    vlan 1
    name "DEFAULT_VLAN"
    no untagged 22
    untagged 1-21,23-28
    ip address 10.11.1.5 255.255.255.0
    exit
    vlan 191
    name "VLAN191"
    tagged 3-28
    no ip address
    exit

     

    I tried to connect a PC to one of the aruba port, I use IP 10.19.1.3 and ping to other IP in the Cisco switch 10.19.1.110 and the result is request time out. I also tried to connect to one of the port in Cisco switch and ping IP 10.19.1.123 which  is connected to one of the Aruba switch port

     

     



  • 4.  RE: Aruba 2530 port cannot ping any Ethernet port that has different IP from the switch

    Posted Sep 16, 2020 05:01 AM

    Hi Herman

     

    This is my setting for Cisco Switch

    :
    aaa session-id common
    switch 1 provision ws-c3750v2-24ps
    system mtu routing 1500
    ip routing
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    --More--  vlan internal allocation policy ascending
    !
    !
    !
    interface FastEthernet1/0/1
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/2
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/3
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/4
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    --More--  !
    interface FastEthernet1/0/5
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/6
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/7
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/8
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/9
    switchport access vlan 191
    --More--   switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/10
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/11
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/12
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/13
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    --More--  interface FastEthernet1/0/14
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/15
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/16
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/17
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/18
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/19
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/20
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/21
    switchport access vlan 191
    !
    interface FastEthernet1/0/22
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet1/0/23
    switchport access vlan 191
    !
    --More--  interface FastEthernet1/0/24
    switchport access vlan 191
    switchport mode access
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/1
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 11
    switchport mode trunk
    !
    interface GigabitEthernet1/0/2
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 11
    switchport mode trunk
    !
    interface Vlan1
    no ip address
    shutdown
    !
    interface Vlan11
    ip address 10.11.1.1 255.255.255.0
    !
    interface Vlan191
    --More--   ip address 10.19.1.1 255.255.255.0
    !
    interface Vlan192
    ip address 10.19.2.1 255.255.255.0
    !
    ip classless
    ip http server
    ip http secure-server
    !
    !
    !
    line con 0
    line vty 5 15
    !
    end

     

    This is my setting for Aruba :

    hostname "HP-2530-24G-PoEP"
    time timezone 420
    ip default-gateway 10.11.1.1
    snmp-server community "SadhanaCCTV" unrestricted
    vlan 1
    name "DEFAULT_VLAN"
    no untagged 22
    untagged 1-21,23-28
    ip address 10.11.1.5 255.255.255.0
    exit
    vlan 191
    name "VLAN191"
    tagged 3-28
    no ip address
    exit

     

     

    I have tried to connect using PC connected in Aruba switch using IP 10.19.1.3 and tried to ping 10.19.1.137 located in Cisco Switch.

    I also tried to connect in Cisco Switch and ping to 10.19.1.123 located in Aruba Switch

    But both resulted in request time out

     



  • 5.  RE: Aruba 2530 port cannot ping any Ethernet port that has different IP from the switch

    Posted Sep 16, 2020 08:27 AM

    Have you tried making your management VLAN on the Aruba switch VLAN 11 instead of VLAN 1? Status of spanning tree of each VLAN on those ports?

     

     



  • 6.  RE: Aruba 2530 port cannot ping any Ethernet port that has different IP from the switch

    Posted Sep 17, 2020 04:34 AM

    Sorry ,I saw someone use vlan 1 as default vlan and don't change it and it doesn't matter. I will try to change that to vlan 11. But from console cable connected to Aruba I can ping to any port in Cisco, but I can't ping to port in Aruba.

    How to check the spanning tree for each vlan? And how to change them?



  • 7.  RE: Aruba 2530 port cannot ping any Ethernet port that has different IP from the switch
    Best Answer

    Posted Sep 16, 2020 12:41 PM

    Also if PCs on the Aruba switch are supposed to be in VLAN 191, you need to change VLAN 191 to be untagged on the aruba ports, not tagged.

     

     



  • 8.  RE: Aruba 2530 port cannot ping any Ethernet port that has different IP from the switch

    Posted Sep 17, 2020 04:35 AM

    I thought untagged is used for trunk port in Cisco, and tagged is used for access port. Can you explain what's the difference in Aruba? 



  • 9.  RE: Aruba 2530 port cannot ping any Ethernet port that has different IP from the switch

    Posted Sep 17, 2020 07:48 AM

    Untagged means that it does not put a dot1Q VLAN tag on the frame. PCs, and other end user devices usually need an untagged frame. In the Cisco world an untagged vlan on a port would be an "access port".

     

    If you have a "trunk port" in Cisco, you have a native (untagged VLAN, and whatever other VLANs (tagged). Your untagged VLAN should be the same on both sides, and any tagged vlans you need between them.

     

     



  • 10.  RE: Aruba 2530 port cannot ping any Ethernet port that has different IP from the switch

    Posted Sep 17, 2020 10:56 PM

    So tagged ports are used only on port which I want  to let the vlan to get through like in port for trunk (where I untagged vlan for trunk and tagged vlan for any vlan to let them pass)

    Untagged ports are used usually for trunk and any end user device like PC, camera, etc

     

    Am I correct ?



  • 11.  RE: Aruba 2530 port cannot ping any Ethernet port that has different IP from the switch

    Posted Sep 18, 2020 08:01 AM

    I agree it can be confusing, and that has mostly to do with trunk/access port on other products.

     

    If you need to pass multiple VLANs on a port, you will need to add VLAN tags to the traffic, and the other side needs the take the tags off again and process it for the different VLANs.

     

    On a port you can have multiple tagged VLANs, and/or one untagged VLAN. In most products for a link between switches to carry VLAN 10-19, you would do something like:

    interface gigabit 48
      switchport mode trunk
      trunk allowed-vlan 10-19

    If you have port 10 to connect a printer in vlan 12, that would be:

    interface gigabit 10
      switchport mode access
      access vlan 12

    The first will apply VLAN tags to the vlans 10-19, so the AOS Switch configuration to put the vlans on port 48 would be:

    vlan 10-19
      tagged 48

    The second, to connect a device that needs to be in vlan 12 on port 10:

    vlan 12 untagged 10

    Technically there is not really a difference in mode between access ports and trunk ports, so thinking in tagged (to other switches) and untagged (to computers, printers, etc.) is more accurate. But most important is that the terminology is just different.

     

    Then if you have the 'native vlan' on a switch that works with 'mode trunk', it will put the native vlan traffic as untagged on the wire. See the following configuration equivalents:

     

    interface gigabit 48
      switchport mode trunk
      trunk native vlan 5
      trunk allowed-vlan 10-19

     

     

    vlan 5
      untagged 48
    vlan 10-19
      tagged 48

     

     



  • 12.  RE: Aruba 2530 port cannot ping any Ethernet port that has different IP from the switch

    Posted Sep 21, 2020 03:01 AM

    Thank you Herman for your explaination