Security

last person joined: 9 hours ago 

Enterprise security using ClearPass Policy Management, ClearPass Security Exchange, IntroSpect, VIA, 360 Security Exchange, Extensions and Policy Enforcement Firewall (PEF).
Expand all | Collapse all

Problem with special type in SMS

  • 1.  Problem with special type in SMS

    Posted Mar 18, 2013 09:19 AM

    Hi,

     

    I have a problem with the SMS service in ClearPass. I would like to send a SMS with usernames that contain a "+" (usernames are phonenumbers). The issue is that the "+" is deleted from the SMS. It's not coming from my SMS provider (I have tested it, works well).

     

    Any idea ?


    Thanks

     

    Dimitri



  • 2.  RE: Problem with special type in SMS

    Posted Mar 18, 2013 10:20 AM

    Hmm - seems the reply by email doesn't work anymore - as my reply by email landed in a different post..

     

    Anyways:

     

    I have a self-registration that allows +<countrycode><phonenumber> and registers that as username. The sms receipt shows the + just fine. I’m using this code {$u.username|escape} in the sms receipt.

     



  • 3.  RE: Problem with special type in SMS

    Posted Mar 18, 2013 10:28 AM

    Thanks.

     

    I don't understand because I have the same code and the + is still escaped.

     

    Regards

    Dimitri



  • 4.  RE: Problem with special type in SMS

    Posted Mar 18, 2013 10:32 AM

    Is this through the self-registration? What happens if you go to the SMS gateway in Administration and Send SMS directly from there.

    Just type in various letters and see what arrives at your phone.



  • 5.  RE: Problem with special type in SMS

    Posted Mar 18, 2013 10:35 AM

    If I do it thru the SMS gateway, it's the same. The + is escaped.

     

    But if I send a SMS thru the SMS provider (directly by its website), no problem, I can see all types.

     

    Thanks for your help.

     

    Dimitri



  • 6.  RE: Problem with special type in SMS

    Posted Mar 18, 2013 10:41 AM

    Try this..

     

    Edit the SMS Gateway

    Check the box for "Convert text to hex-encoded UTF-16"

     

    It really shouldn't be a problem with + sign tho..



  • 7.  RE: Problem with special type in SMS

    Posted Mar 18, 2013 10:44 AM

    As I am using SMS Global, there isn't this option.

     

    Edit : I have tried to configure a custom http handler, it seems that SMS Global doesn't support utf-16.

     

    Dimitri



  • 8.  RE: Problem with special type in SMS

    Posted Mar 19, 2013 04:41 AM

     

    Are you saying the + is removed or escaped to some other character?

     

    You are certain the + is saved in the username? (just checking :))

     

    You could try to use the ClearPass Guest SMS Service gateway and see if the same happens. Won't help you much, but you might be able to narrow down where the issue might be. 

     

     



  • 9.  RE: Problem with special type in SMS

    Posted Mar 20, 2013 03:14 AM

    The + is removed.

     

    Yes the + is saved in the username.

     

    Ok I will try with ClearPass Guest SMS Service gateway and give feedback.

     

    Dimitri



  • 10.  RE: Problem with special type in SMS

    Posted Mar 21, 2013 08:46 AM

    So I can't try the ClearPass Guest SMS Service gateway, can you do it in your lab ?

     

    Thanks

     

    Dimitri



  • 11.  RE: Problem with special type in SMS

    Posted Jun 19, 2013 11:26 AM

    I am back with my problem that is not solved. Anyone has the same issue or I am alone ?

     

    Thanks

     

    Regards

     

    Dimitri



  • 12.  RE: Problem with special type in SMS

    Posted Jun 24, 2013 11:20 AM

    I had the exact same issue when using SMS Global. 

    They seem to strip the '+'-sign from any SMS we sent with them. We did open a ticket with them but this never got resolved.



  • 13.  RE: Problem with special type in SMS

    Posted Jun 24, 2013 11:23 AM

    Thanks for this comment.

     

    The strange thing is that you can send a SMS with a + in the message by their webpage. But thru CP, + is stripped yes.



  • 14.  RE: Problem with special type in SMS

    Posted Jul 15, 2014 08:02 AM

    I ran into this issue again. So if you got this fixed, let me know.

     

    If not, here's what I found...

     

    The predefined sms gateway uses the following service url:

    https://www.smsglobal.com.au/http-api.php?action=sendsms&user=@USERNAME@&password=@PASSWORD@&from=@FROM@&to=@TO@&text=@MESSAGE@

      

    To troubleshoot further I created a custom SMS gateway and configured the following service url:

    https://www.smsglobal.com.au/http-api.php?action=sendsms&user=@USERNAME@&password=@PASSWORD@&from=@FROM@&to=@TO@&text=+3245678

      

    So basically all I changed was the message from the variable to a fixed value. When sending this the +-sign still gets removed.

    I’m guessing this is exactly how the predefined SMSGLOBAL gateway stuff is sent.

     

    Some research gave this on the smsglobal website: http://support.smsglobal.com/customer/portal/articles/1120743-troubleshooting-the-http-api---character-encoding.

    So my best guess is Clearpass does not do the proper (for SMSglobal) character encoding of the special symbols.

     

    So apparently triple encoding a "+" gives %25252B.

    https://www.smsglobal.com.au/http-api.php?action=sendsms&user=@USERNAME@&password=@PASSWORD@&from=@FROM@&to=@TO@&text=+3245678 

     

     

    When I sent the above url with this I actualy do get the +-sign in my sms body. So this 

     

    I have now opened a ticket for this with Aruba and will update with the results.