Wireless Access

last person joined: 7 hours ago 

Access network design for branch, remote, outdoor and campus locations with Aruba access points, and mobility controllers.
Expand all | Collapse all

Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

Jump to Best Answer
This thread has been viewed 0 times
  • 1.  Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

    Posted Apr 19, 2012 01:31 PM

    Hello. The issue I am having is when I put one port of an Aruba controller in a Port channel I can't ping the default gateway. I only have this one port connected to the switch to try and rule out any other issues. Once I take the one port out of the Aruba port channel and put it just pure trunked I can ping the default gateway. My laptop on the same network can ping the controller in both scenarios. Also once I do this, I lose all remote access to the controller (web/ssh).

    Cisco Port Config:

     

    description Wireless Controller Port 1

    switchport trunk encapsulation dot1q

    switchport mode trunk

    switchport nonegotiate

    flowcontrol receive on

    channel-group 30 mode on

     

    interface Port-channel30

    description Port Channel for Wireless Controller

    switchport trunk encapsulation dot1q

    switchport mode trunk

    switchport nonegotiate

    flowcontrol receive on

    spanning-tree portfast trunk

     

    Aruba Side

    interface gigabitethernet 1/1

    description "GE1/1" trusted trusted vlan 1-4094

    switchport mode trunk

    switchport trunk allowed vlan 1-4094

     

    interface port-channel 0

    add gigabitethernet 1/1

    trusted vlan 1-4093

    switchport mode trunk

    switchport trunk native vlan 70

    switchport trunk allowed vlan 1-4094

    spanning-tree portfast

     

    ArubaOS 6.1.3.1


    #3400


  • 2.  RE: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

    Posted Apr 19, 2012 04:03 PM

     Try this on the Aruba Controller:

     

    interface port-channel 0

    trusted.

     



  • 3.  RE: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

    Posted Apr 19, 2012 04:13 PM

    Adding the trusted to the port channel now allowes me to remotely get into the controller, but I still can't ping the default gateway.



  • 4.  RE: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

    Posted Apr 19, 2012 04:14 PM

    What is the default gateway?  Can you see it in your ARP table?

     



  • 5.  RE: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

    Posted Apr 19, 2012 04:18 PM

    Nothing in arp. 



  • 6.  RE: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

    Posted Apr 19, 2012 04:20 PM

    Are you pinging From:

     

    A client on the LAN, the controller or a router?

    What device is the default gateway in this situation?

     

     



  • 7.  RE: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

    Posted Apr 19, 2012 04:25 PM

    When in port channel:

      Pinging from Cisco switch to controller = fail

      Pinging from controller to cisco switch = fail.

      Pinging from laptop in same subnet = is good

     

    When in plain trunked port:

      everything works.

     

    Cisco switch provides the default gateway.



  • 8.  RE: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

    Posted Apr 19, 2012 04:28 PM

    @bettism wrote:

    When in port channel:

      Pinging from Cisco switch to controller = fail

      Pinging from controller to cisco switch = fail.

      Pinging from laptop in same subnet = is good

     

    When in plain trunked port:

      everything works.

     

    Cisco switch provides the default gateway.


    Can you clear the ARP table on all devices and try again?

     



  • 9.  RE: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

    Posted Apr 19, 2012 04:42 PM

    A suggestion.

     

    On the Cisco side:

     

    interface xxxxx

     channel-protocol lacp
     channel-group 30 mode active

     

    On the Aruba side:

     

    interface gigabitethernet  1/1

     lacp group 0 mode passive



  • 10.  RE: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

    Posted Apr 20, 2012 10:02 AM

    Still no luck.  I have clear arp tables on both devices and no avail.

     

    I did change everything over to LACP and still no luck.

     

    interface gigabitethernet  1/1        

    description "GE1/1"        

    trusted        

    trusted vlan 1-4094        

    speed 1000        

    duplex full        

    lacp group 0 mode passive

     

    interface port-channel 7        

    trusted        

    trusted vlan 1-4094        

    switchport mode trunk        

    switchport access vlan 70        

    switchport trunk native vlan 70

     

    Cisco:

     

    sh eth sum

    30     Po30(SU)        LACP      Gi1/0/39(P)

     

     

    interface GigabitEthernet1/0/39  

    description Wireless Controller Port 1

    switchport trunk encapsulation dot1q  

    switchport mode trunk  

    switchport nonegotiate  

    speed 1000  

    duplex full  

    channel-group 30 mode active

    end

     

     

     

     



  • 11.  RE: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

    Posted Apr 20, 2012 10:13 AM

    Please open a support case so that they can look into the details of this.

     



  • 12.  RE: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

    Posted Apr 20, 2012 02:06 PM

    Looks like you changed port-channel interfaces.  If you're using int port-channel 7, but gig 1/1 in lacp group 7.

     

    interface gigabitethernet  1/1        

     

    lacp group 7 mode passive

     

    interface port-channel 7        

    trusted        

    trusted vlan 1-4094        

    switchport mode trunk        

    switchport access vlan 70        

    switchport trunk native vlan 70

     



  • 13.  RE: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

    Posted Apr 20, 2012 04:14 PM

    Yes I was pulling straws out of the hat.

     

    One issue was that one of the interfaces was set to access instead of trunk on the aruba side.  The other issue is when configuring a cisco port channel and putting the native vlan in there as I was just trying to put it in the interface side.  I can ping the gateway.  Now adding additional ports and they don't seem to be coming up correctly.

     

    Aruba Side:

     

     

    interface gigabitethernet  1/0

            description "GE1/0"

            trusted

            trusted vlan 1-4094

            speed 1000

            duplex full

            switchport mode trunk

            switchport trunk native vlan 70

            switchport trunk allowed vlan 1-4094

            no spanning-tree

            lacp port-priority 1

            lacp timeout short

            lacp group 7 mode active

    !

     

    interface gigabitethernet  1/1

            description "GE1/1"

            trusted

            trusted vlan 1-4094

            speed 1000

            duplex full

            switchport mode trunk

            switchport trunk native vlan 70

            lacp port-priority 1

            lacp timeout short

            lacp group 7 mode active

    !

     

    interface gigabitethernet  1/2

            description "GE1/2"

            trusted

            trusted vlan 1-4094

            speed 1000

            duplex full

            switchport mode trunk

            switchport trunk native vlan 70

            lacp port-priority 1

            lacp timeout short

            lacp group 7 mode active

    !

     

    interface gigabitethernet  1/3

            description "GE1/3"

            trusted

            trusted vlan 1-4094

            speed 1000

            duplex full

            switchport mode trunk

            switchport trunk native vlan 70

            lacp port-priority 1

            lacp timeout short

            lacp group 7 mode active

    !

     

    interface port-channel 7

                    trusted

            trusted vlan 1-4094

            switchport mode trunk

            switchport access vlan 70

            switchport trunk native vlan 70

            no spanning-tree

    !

     

    Cisco Side:

     

    interface Port-channel7

     switchport trunk encapsulation dot1q

     switchport trunk native vlan 70

     switchport trunk allowed vlan 1,70,211

     switchport mode trunk

     switchport nonegotiate

    end

    

     

    interface GigabitEthernet1/0/39

     description Wireless Controller Port 1

     switchport trunk encapsulation dot1q

     switchport trunk native vlan 70

     switchport trunk allowed vlan 1,70,211

     switchport mode trunk

     switchport nonegotiate

     speed 1000

     duplex full

     channel-group 7 mode active

    end



  • 14.  RE: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

    Posted Apr 27, 2012 11:22 AM

    I'm at a bit of a loss on this one.  Did you ever get it working?

     

    The only thing I find odd is that "channel-protocol lacp" isn't showing up in your Cisco interface config.



  • 15.  RE: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

    Posted Apr 27, 2012 12:45 PM

    I have it all working now. 



  • 16.  RE: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

    Posted Apr 27, 2012 12:46 PM

    Please let us know the solution and mark it solved, if it is not too much trouble.

     



  • 17.  RE: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue
    Best Answer

    Posted Apr 30, 2012 04:55 PM

    The above configuration will work.  Items to make sure:

     

    Aruba side:

     

      Make sure you set your network interfaces to trunking before adding them into the port channel.  Once you do it won't let you change it until you take it out of the group.  Also the port group does not take precedence over what is configured on the interface.  So configure everything to work on each interface and then add to a port channel.

     

    Cisco side:

     

    Make sure you know how the port channel was orginally setup as this will affect how you can configure the port channel and then what takes precedence over needing to configure the port channel and interface or just port channel.



  • 18.  RE: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

    Posted May 03, 2012 12:15 PM

    The following works for me going to a set of Cisco switches. I use LACP for each pair of ports servicing different vlans. I've simplified it and stripped off the other vlans but you get idea:

     

     

    vlan 2 "corp"
    vlan 3 "guest"

     

    interface gigabitethernet  1/0
            description "uplink to sw1 port 13 pc1"
            trusted
            trusted vlan 2
            switchport mode trunk
            switchport trunk allowed vlan 2
            no spanning-tree
            lacp port-priority 32768
            lacp group 0 mode active
    !

    interface gigabitethernet  1/1
            description "uplink to sw2 port 13 pc1"
            trusted
            trusted vlan 2
            switchport mode trunk
            switchport trunk allowed vlan 2
            no spanning-tree
            lacp port-priority 32768
            lacp group 0 mode active
    !

    interface gigabitethernet  1/2
            description "uplink to sw1 port 14 pc2"
            trusted
            trusted vlan 3
            switchport mode trunk
            switchport trunk allowed vlan 3
            no spanning-tree
            lacp port-priority 32768
            lacp group 1 mode active
    !

    interface gigabitethernet  1/3
            description "uplink to sw2 port 14 pc2"
            trusted
            trusted vlan 3
            switchport mode trunk
            switchport trunk allowed vlan 3
            no spanning-tree
            lacp port-priority 32768
            lacp group 1 mode active
    !

    interface port-channel 0
            trusted
            trusted vlan 2
            switchport mode trunk
            switchport trunk allowed vlan 2
    !

    interface port-channel 1
            trusted
            trusted vlan 3
            switchport mode trunk
            switchport trunk allowed vlan 3
    !

    interface vlan 1
            shutdown
    !

    interface vlan 2
            ip address 1.2.3.4 255.255.254.0
            ip helper-address 1.2.3.10
    !

    interface vlan 3
            ip address 2.3.4.5 255.255.255.0
    !

    !

    master-redundancy
      master-vrrp 2
      peer-ip-address 1.2.3.5 ipsec blah
    !
    vrrp 2
      priority 110
      authentication password
      ip address 1.2.3.2
      description "preferred-master"
      vlan 102
      preempt
      tracking master-up-time 30 add 20
      no shutdown
    !
    ip default-gateway 1.2.3.1

     



  • 19.  RE: Cisco 3750E Stack & Aruba 3400 Controller -- Port Channel Issue

    Posted May 07, 2012 09:26 AM

    I had a simular issue a couple of months ago and what I ended up doing was putting the switch ports on speed auto and duplex auto. The ports came up after those changes. I hope that this helps.

     

    Thanks,

     

    Winston Jordan