Network Management

last person joined: yesterday 

Keep an informative eye on your network with IMC and AirWave network management solutions.
Expand all | Collapse all

AirWave 8.2.3 won't talk to 172.17.0.0/16 addresses.

  • 1.  AirWave 8.2.3 won't talk to 172.17.0.0/16 addresses.

    Posted Jan 03, 2017 11:59 PM

    Ran into a bit of an issue today with upgrading to AirWave 8.2.3.

    Seems the docker service was added in with the default network bridge.

     

    The default bridge is 172.17.0.0/16 and is connected so all traffic going to 172.17.0.0-172.17.255.255 will go to the docker0 interface rather than eth0. 

     

    Waiting to hear back from TAC, but using the Docker documentation this seems to work. 

    https://docs.docker.com/v1.7/articles/networking/#docker0 

     

    Login as root on the console/ssh:

    Commands:

    Stop the service

    • service docker stop

    Bring the interface down

    • ip link set dev docker0 down

    Delete the interface

    • brctl delbr docker0

    Modify the configuration to use the new IP address

    • vi /etc/sysconfig/docker
    • add: --bip=x.x.x.x/xx to the other_args=”” line so it looks like this now:
      other_args="--bip=10.1.1.1/24"

    Start the service

    • service docker start

    ifconfig to confirm docker0 has been changed.

     

     



  • 2.  RE: AirWave 8.2.3 won't talk to 172.17.0.0/16 addresses.

    Posted Jan 09, 2017 09:19 PM

    Would you mind sharing the TAC case / ticket number?



  • 3.  RE: AirWave 8.2.3 won't talk to 172.17.0.0/16 addresses.

    Posted Jan 10, 2017 12:36 PM

    5316172332



  • 4.  RE: AirWave 8.2.3 won't talk to 172.17.0.0/16 addresses.

    Posted Jan 20, 2017 08:50 PM

    Here is what our engineering team came back with:

     

    To delete the interface, we can execute the below commands:

     

    [root@localhost mercury]# sudo ip link delete docker0 type bridge

    [root@localhost mercury]# service network restart

     

    To change the IP Address of the docker interface, we can execute the below commands:

     

    [root@localhost mercury]# ip addr add 127.0.0.2/16 dev docker0

    [root@localhost mercury]# service network restart

     

    Let us know if this works or if you need more assistance.  



  • 5.  RE: AirWave 8.2.3 won't talk to 172.17.0.0/16 addresses.

    Posted Jul 11, 2017 04:38 PM

    Just a heads up if this hit you it looks like HPE did the same thing for ClearPass with 6.6.7

     

    HPE didn't changing this to something more approperate like a 169 address and then allow us to configure the docker bridge, or use a smaller netmask to reduce the blast radius.

     

    I'm sure we will need all 65,534 address to run ClearPass Exchange, or AirWave Glass. At least it was in the release notes for ClearPass.  



  • 6.  RE: AirWave 8.2.3 won't talk to 172.17.0.0/16 addresses.

    Posted Mar 23, 2017 09:00 AM

    Looks like an upgrade to 8.2.3.1 restores the configuration.

     

    From the CLI to disable the service from start up.

    SSH in as root, and run the following commands:

    chkconfig docker off
    chkconfig docker --del

     

    To restore:

    chkconfig docker --add

    chkconfig docker off 2,3,4,5