Wireless Access

last person joined: 2 hours ago 

Access network design for branch, remote, outdoor and campus locations with Aruba access points, and mobility controllers.
Expand all | Collapse all

AP 105's are unable to be provisioned anymore

  • 1.  AP 105's are unable to be provisioned anymore

    Posted May 11, 2012 04:02 PM

    Ran into a weird issue where I can't provision my AP105's anymore.  The 105's will still be able to lease network info via dhcp (I can ping our master controller after boot), but ADP appears to fail.  Even if I manually set the master controller IP (and the rest of the network stats), a 'show summary' on the AP after boot shows itself as the master controller.  I've done multiple purgeenv's, saves, factory_resets to no avail.  This happens with all the AP105's I've tested (three).  AP125's work just fine (a factory reset 125 can be seen on the master controller webUI right after boot). 

     

    Any ideas?  I'm a bit clueless now..



  • 2.  RE: AP 105's are unable to be provisioned anymore

    Posted May 11, 2012 07:31 PM

    type "show log system 50" to get an idea of what is going on.

     



  • 3.  RE: AP 105's are unable to be provisioned anymore

    Posted May 13, 2012 12:56 PM

    Can you give output of "printenv" from apboot prompt & also boot-log , i.e. console log while AP is booting up?



  • 4.  RE: AP 105's are unable to be provisioned anymore

    Posted May 14, 2012 02:24 PM

    "show system log 50" wasn't available from the console.. here's output (I had to snip the IP addresses):

     

    Hit <Enter> to stop autoboot: 0
    apboot>
    apboot> printenv
    bootdelay=2
    baudrate=9600
    autoload=n
    boardname=Talisker
    servername=aruba-master
    bootcmd=boot ap
    autostart=yes
    bootfile=mips32.ari
    ethaddr=d8:c7:c8:ca:f7:c7
    stdin=serial
    stdout=serial
    stderr=serial
    ethact=eth0

    Environment size: 209/65532 bytes
    apboot> boot
    Checking image @ 0xbf100000
    Invalid image format version: 0xffffffff
    Checking image @ 0xbf800000

    Image is signed; verifying checksum... passed
    Signer Cert OK
    Policy Cert OK
    RSA signature verified.
    ELF file is 32 bit
    Loading .text @ 0x80e00000 (4508696 bytes)
    Clearing .bss @ 0x8124cc20 (16 bytes)
    Loading .data @ 0x8124cc30 (32 bytes)
    ## Starting application at 0x80e00000 ...
    Uncompressing..........................................
    ?
    Aruba Networks
    ArubaOS Version 5.0.3.0-1.1.0.1 (build 29974 / label #29974)
    Built by p4build@stan on 2011-08-26 at 09:52:58 PDT (gcc version 3.4.3)
    CPU Rev: aa
    71x CPU
    Flash variant: default
    Cache parity protection disabled
    Using 340.000 MHz high precision timer. cycles_per_jiffy=680000
    Memory: 122240k/131072k available (1639k kernel code, 8676k reserved, 716k data, 3740k init, 0k highmem)
    available.
    detected lzma initramfs
    initramfs: LZMA lc=3,lp=0,pb=2,dictSize=8388608,origSize=19740672
    LZMA initramfs by Ming-Ching Tiew <mctiew@yahoo.com> .........................................................................................................................................................................................................................
    AR7100 GPIOC major 0
    wdt: registered with refresh
    Enabling Watchdog
    Talisker RSSI LED initialization
    Creating 1 MTD partitions on "ar7100-nor0":
    0x00000000-0x01000000 : "flash"
    i2c /dev entries driver
    i2c-talisker: using default base 0x18040000
    AD7416 driver probing for devices on AR7100 I2C
    .
    Starting Kernel SHA1 KAT ...Completed Kernel SHA1 KAT
    Starting Kernel HMAC-SHA1 KAT ...Completed Kernel HMAC-SHA1 KAT
    Starting Kernel DES KAT ...Completed Kernel DES KAT
    Starting Kernel AES KAT ...Completed Kernel AES KAT

    Domain Name: arubanetworks.com
    No panic info available
    Testing TPM... Passed
    <4>ag7100_mod: module license 'unspecified' taints kernel.
    AG7100: Length per segment 512
    AG7100: Max segments per packet 4
    AG7100: Max tx descriptor count 400
    AG7100: Max rx descriptor count 252
    AG7100: fifo cfg 3 018001ff
    AG7100CHH: Mac address for unit 0
    AG7100CHH: d8:c7:c8:ca:f7:c7
    ATHRF1: Port 0, Neg Success
    ATHRF1: unit 0 phy addr 0 ATHRF1: reg0 0
    ag7100_ring_alloc Allocated 4800 at 0x80372000
    ag7100_ring_alloc Allocated 3024 at 0x806b2000
    AG7100: cfg1 0xf cfg2 0x7014
    ATHRF1: Port 0, Neg Success
    ATHRF1: unit 0 phy addr 0 ATHRF1: reg0 3100
    AG7100: unit 0: phy not up carrier 1
    Writing 4
    Ethernet uplink not active yet
    Ethernet uplink not active yet
    Ethernet uplink not active yet
    Ethernet uplink not active yet
    Ethernet uplink not active yet
    AG7100: unit 0 phy is up...RGMii 100Mbps full duplex
    AG7100: pll reg 0x18050010: 0x1099 AG7100: cfg_1: 0x1ff0000
    AG7100: cfg_2: 0x3ff
    AG7100: cfg_3: 0x18001ff
    AG7100: cfg_4: 0xffff
    AG7100: cfg_5: 0x7ffef
    AG7100: done cfg2 0x7115 ifctl 0x10000 miictrl 0x12
    Ethernet uplink active. Becoming Mesh Portal
    AP xml model 39, num_radios 2 (jiffies 13434)
    init_asap_mod: installation:0
    radio 0: band 1 ant 0 max_ssid 8
    radio 1: band 0 ant 0 max_ssid 8
    election init: rand=1c HZ=500
    asap_gre_init: ADDED GRE protocol c00b01fc
    setting bond0 as bridge child
    USB not provisioned
    Starting watchdog process...
    Getting an IP address...
    Dec 31 16:00:27 udhcpc[180]: udhcpc (v0.9.9-pre) started
    Dec 31 16:00:27 udhcpc[180]: Sending discover...
    Kernel watchdog refresh ended.
    Dec 31 16:00:29 udhcpc[180]: Sending discover...
    Dec 31 16:00:29 udhcpc[180]: Sending select for <snip>
    Dec 31 16:00:29 udhcpc[180]: Lease of <snip> obtained, lease time 1800
    Dec 31 16:00:29 udhcpc[180]: DHCP OPT 43 deleted airwave config

    <snip> 255.255.255.0 <snip>.1
    Starting Webserver
    NTP Server not saved in flash... using default
    ath_hal: 0.9.17.1 (AR5416, REGOPS_FUNC, PRIVATE_DIAG, WRITE_EEPROM, 11D)
    ath_rate_atheros: Copyright (c) 2001-2005 Atheros Communications, Inc, All Rights Reserved
    ath_rate_atheros: Aruba Networks Rate Control Algorithm
    ath_dfs: Version 2.0.0
    Copyright (c) 2005-2006 Atheros Communications, Inc. All Rights Reserved
    ath_dev: Copyright (c) 2001-2007 Atheros Communications, Inc, All Rights Reserved
    ath_pci: 0.9.4.5 (Atheros/multi-bss)
    wifi0: Base BSSID d8:c7:c8:2f:7c:78, 8 available BSSID(s)
    edev->dev_addr=d8:c7:c8:ca:f7:c7
    edev->dev_addr=d8:c7:c8:ca:f7:c7
    wifi0: AP type AP-105, radio 0, max_bssids 8
    wifi0: Atheros 9280: mem=0x10010000, irq=49 hw_base=0xb0010000
    ip_time_handler: Got ip and packets on bond0 Started master election 30-0
    wifi1: Base BSSID d8:c7:c8:2f:7c:70, 8 available BSSID(s)
    edev->dev_addr=d8:c7:c8:ca:f7:c7
    edev->dev_addr=d8:c7:c8:ca:f7:c7
    wifi1: AP type AP-105, radio 1, max_bssids 8
    wifi1: Atheros 9280: mem=0x10000000, irq=48 hw_base=0xb0000000
    cat: /tmp/master: No such file or directory
    shutting down watchdog process (nanny will restart it)...

    <<<<< Welcome to the Access Point >>>>>

    process `snmpd' is using obsolete setsockopt SO_BSDCOMPAT
    dns domain - arc.nasa.gov
    User: i am master now
    asap_send_elected_master: sent successfully
    vap aruba000 vlan is 0. fwd-mode:0 mesh

    User: admin
    Password:

    d8:c7:c8:ca:f7:c7# show sum

    Name :Instant-CA:F7:C7
    Domain :US
    Address :0.0.0.0
    Content Filtering :disable
    Terminal Access :disable
    Organization :
    Airwave Address :0.0.0.0
    Airwave Shared Key :
    Airwave Config Via :DHCP
    Syslog Server :0.0.0.0
    Syslog Level :notice
    Band :all
    Master *: <snip> (IP address of itself)
    Master Key :a705173a010f39868c5a881852000f06341b1455e3d91888bd
    Elected Time :15m:43s
    Mesh :enable
    Dynamic Radius Proxy :disable
    NTP Server :
    Configuration Dirty :disable
    Allow New APs :enable
    Classification :disable
    Wireless Containment :disable
    Wired Containment :disable
    Rogue Containment :disable
    LED Off :disable
    Airwave :Not Set Up
    Image Server State :success
    Image Server Message :Success
    New Image Version :6.1.2.3-2.0.0.4_32946
    New Image URL :http://s3.amazonaws.com/firmwareupdate.arubanetworks.com/ArubaInstant_Orion_6.1.2.3-2.0.0.4_32946
    Factory SSID :instant
    Image Sync Via :Master
    Client Alerts :0
    0 Clients
    ---------
    MAC Name IP Address Network Access Point
    --- ---- ---------- ------- ------------
    1 Network
    ---------
    Key Name Clients
    --- ---- -------
    instant instant 0
    1 Access Point
    --------------
    MAC IP Address Name Clients
    --- ---------- ---- -------
    d8:c7:c8:ca:f7:c7 <snip> d8:c7:c8:ca:f7:c7 0
    RADIUS Servers
    --------------
    Name IP Address Port Key NAS IP Address NAS Identifier
    ---- ---------- ---- --- -------------- --------------
    InternalServer 127.0.0.1 1616 b495737c013086fb940a42b79f1e524f
    RTLS Servers
    ------------
    Type IP Address Port Key Frequency
    ---- ---------- ---- --- ---------
    Aeroscout 0.0.0.0 0
    Airwave 0.0.0.0 0 0

     

     

    I can get output from an AP-125 (which works), if necessary, as well.



  • 5.  RE: AP 105's are unable to be provisioned anymore

    Posted May 15, 2012 06:27 AM

    Looking at the AP bootup logs, I find that this is coming up as an IAP, rather than an regular campus AP. If this is a IAP105 (as compared to AP105), then ADP, master discovery, etc is not expected to work, since the AP acts as a Virtual controller by itself.

     

    Can you please confirm that, you were indeed supposed to have an AP105, but ended up with an IAP105?



  • 6.  RE: AP 105's are unable to be provisioned anymore

    Posted May 15, 2012 11:39 AM

    oh my lord.  Looks like our vendor sent us a mess of IAP105's instead of AP105's (I didn't even know the "instant" series of APs existed).  Well, that explains it.  Thanks a bunch for your help.  



  • 7.  RE: AP 105's are unable to be provisioned anymore

    Posted May 15, 2012 12:40 PM

    Ah, apparently you can change IAPs to function regular via the console.  Looks like I'm good now.  Crisis averted.  Thanks everyone!