Wireless Access

last person joined: 4 hours ago 

Access network design for branch, remote, outdoor and campus locations with Aruba access points, and mobility controllers.
Expand all | Collapse all

6.1.3.7 Upgrade from 3.4.5.1

  • 1.  6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 27, 2013 09:43 AM

    Hi guys, new to the forum, though I have read quite a few posts on here. 

     

    I am needing some help with my Aruba 3200XM controller.  I have been trying to upgrade our controller from 3.4.5.1 to 6.1.3.7.  The problem I keep having is that after the upgrade, any device that connects will not get a DHCP address.  I have turned of control plane security.  I have the radios set up in tunnel mode.  I have tried it with control plane security on, and in bridge mode, and control plane security off, and in split tunnel mode.  I have made sure that users and radios are on the VLAN 1 (we use just the standard VLan).  If I restart the controller back to 3.4.5.1, everything works fine again.  Any thoughts on this?  Thanks!


    #3200


  • 2.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 27, 2013 09:51 AM

    Hi,

    *You dont need to mess up your configuration too much - leave everyting like it's working in 3.4.5.X.

    NOW..

    Uour DHCP is internal or extrnal?

    It's sound like u got a PEF/PEFNG issue.

    What is the user-role that your usersgetting in version 3.4.5.1 when connecting to SSID

    And on what access roles it's based.

    Can u please print screen of amount of licesnse installed on your controller in version 3.4.5.1 - and then on version 6.1.3.7

     

    update me in needed details - and i will be able to help you.

     

     

     



  • 3.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 27, 2013 10:00 AM

    DHCP is external to the Aruba system (disabled on controller).  All users are just using the standard logon user.  There are two pics attached.  I will have to wait to do the upgrade again until tonight since we only have one controller and it is our production unit.  Our system is very simple.  Basically it just needs to be an extension of the wired network to wireless clients.



  • 4.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 27, 2013 10:03 AM

    I should also add that after the 6.1.3.7 upgrade, the AP's show the "a" flag for "a = Reduce ARP packets in the air".  Not sure if that matters or not.

     

    Oh yeah, and with the licenses, it says in 3.4.5.1 the PEF is disabled, but in 6.1.3.7 after the upgrade it is enabled.  I can't find where to disable it.



  • 5.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 27, 2013 10:09 AM

    kdisc98 is right .

     

    You don't have a PEF license according to the screen shot you provided.

     

     



  • 6.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 27, 2013 10:12 AM

    mmm..

    if u didnt had pef |  after moving from 3.4.5.1 to 6.1.3.7 You cant suddenly have PEFNG installed.

    can u please screenshot me the licesnse page in the 6.1.3.7 page (like u did in the 3.4.5.1)

     

    *Dont forget to disable the control-plane secutiry after upgrading (in order to allow your ap to boot up and provision)

    *ALSO - after upgrading - check that u still have VLAN/IP connectiviy to the extranl DHCP (By doing ping)

    *ALSO - after upgrading - check your AP/VAP settings - check that u are using the same working mode as in 3.4.5.1 and also - make sure that there is a vlan tagging

     

    update us.

     

     



  • 7.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 27, 2013 10:17 AM

    I have 24 licenses on the Aruba licensing site for PEFNG.  And after I upgrade to 6.1.3.7 it shows that PEF is enabled.  I will have to upgrade again tonight and take some screen shots for you.



  • 8.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 27, 2013 10:28 AM

    I will be here also in the evening.

     

    feel free to post a new screenshots.

    and also check if u have red flag in the gui (in 6.1.3.7 after upgraindg)



  • 9.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 27, 2013 10:35 AM

     

    What's the sequece you are taking to upgrade from 3.4 to  6x ?



  • 10.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 27, 2013 10:57 AM

    Basically, I have the 6.1.3.7 system on partition 1, and 3.4.5.1 on partiton 2.  I backup up the settings to the flashbackup.tar.gz file, and then reboot to partition 1.  It updates the AP's and they all show "up" and the SSID information is correct, they just no longer get a DHCP address from my server.  I also turn off control plane security after the upgrade.



  • 11.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 27, 2013 11:20 AM

    So again like i wrote earlier - please print screen your 6.1.3.7 GUI

    look for a red flag (at the top in the configuration)

    also - printout user roles / fw roles that u assigning to this VAP

    also - printout the VAP settings.

     

    Thanks - when we will see all of those - i might find the problematic issue - that making your DHCP stop working.

     

    Me



  • 12.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 27, 2013 11:42 AM

     

    I would try going to 5.x first and then to 6.x 



  • 13.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 27, 2013 12:23 PM

    The path he's attempting is permitted in the documentation, and will probably work fine - he's described a very simple setup.

    It sounds like something in licensing or control-plane-securtiy is the issue.

     

    A running-config from before and after may just show a setting change which is causing the problem.



  • 14.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 27, 2013 02:25 PM

    I am really beginning to think it might be the PEFNG license.  Neither of them are showing up in my list of licenses on 3.4.5.1.  I still think it is weird that it shows PEF is enabled though when I upgrade to 6.1.3.7, but it shows disabled in 3.4.5.1, and the two licenses I have aren't listed.



  • 15.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 27, 2013 05:02 PM

    I just tried to re-add the PEF licenses in 3.4.5.1, but it says that "Key contains limits that are not valid for ArubaOS".  I am going to reboot to 6.1.3.7 here in just a minute.



  • 16.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 27, 2013 05:14 PM

    I just updated back to 6.1.3.7, and here is what I have.  This is the licenses page on 6.1.3.7.  It shows the licenses at the bottom are all there that I should have.  16 AP licenses (8 are built in from what I am told), 24 PEFNG licenses (that seem to be missing after downgrading back to 3.4.5.1), and 24 RF protect licenses.

     

    As for the red flag at the top, I have an error that says role 'authenticated' is unknown.  That is listed twice, and it takes me to the system settings page if I click on the error.



  • 17.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 27, 2013 05:23 PM

    I did try the 5.0 path to 6.1 in the past, and that did the same thing in 5.0.



  • 18.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 27, 2013 05:37 PM

    I just rebooted back to 3.4.5.1.  If you need anything later on, let me know.  They have a meeting here after a while, so it had to be functional again.  I am beginning to wonder if a factory reset might be the way to go.  I did move some of this config from an older 2400 controller about a year ago, so it's possible maybe that is where the problem may lie?



  • 19.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 27, 2013 10:30 PM

    Any thoughts guys?



  • 20.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 27, 2013 11:11 PM

    Ok guys, here is the next step I took.  I upgraded again tonight to 6.1.3.7.  Thinking of messing with licenses, I actually went and turned off Control Plane Security, then removed the PEFNG licenses.  After rebooting the controller, DHCP is now passing through and things seem to work fine.  I have no idea why those licenses were causing issues, but at least things are working now.  Now I just need to figure out what to do about the fixing that issue when I have time.  Thanks for the thoughts and ideas guys.



  • 21.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 28, 2013 10:05 AM
    I have found 1 more issue. When we download from wireless, I am only getting about 18 mb throughput. If i am plugged in I get our full 50 from the net. I am using ap-65's if that helps.


  • 22.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Feb 28, 2013 04:04 PM

    cant say much about the speed, could be lots of things, do you get the 50mb when on version 3.x?

     

    as for "I have an error that says role 'authenticated' is unknown." that usually points to the PEFNG config missing, haven't found a nice way to correct that except for just pasting stuff from another controller.

     

    perhaps wiping config and starting over is an option?



  • 23.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Mar 01, 2013 09:00 AM

    Ok, next step.  Last night I added the PEFNG licenses back.  Things seem to be getting IP addresses now.  But, now the issue is that when you try to go to a website, all you get is a message saying that web authentication  is not enabled (or something close to that).  Any ideas? 



  • 24.  RE: 6.1.3.7 Upgrade from 3.4.5.1

    Posted Mar 02, 2013 02:24 PM

    yes, you have the license but you lost some of your default pefng configuration, like the default roles and such. the role you get in probably has web auth configured, but missing parts of the config.

     

    like i said, havent found a clear way to solve this, contacting TAC might be a good step by now. or if you have another controller you could pick up the config there. another way would be to save the config, reset to factory default and add the sections you configured in the past.