Wireless Access

last person joined: 4 hours ago 

Access network design for branch, remote, outdoor and campus locations with Aruba access points, and mobility controllers.
Expand all | Collapse all

Chromecast AirGrouping not working

Jump to Best Answer
  • 1.  Chromecast AirGrouping not working

    Posted Oct 14, 2016 12:06 PM

    Info:

    Campus based APs with Controllers running 6.4.3.7

    ClearPass based role assignment

    Chromecast ver2

    We have gazillions of AppleTV's that work fine

     

    The Issue:

    We have two SSID's, one using 802.1x and the other is open and controlled by CPPM Guest, each with separate VLANs. I have joined AppleTV's to both the 802.1x and open network and sucessfully shared them using AirGroup configuration in CPPM.

     

    The Chromecast however....not so much! The controller AirGroup config has all services enabled, I can see that the device has the correct roles assigned and is showing up in the AirGroup server list.

     

    Both Android and iOS devices running the Google Cast app can see and configure and it SAYS that's ready to cast to.

     

    However, you cannot actually cast any media to it on ANY platform (iOS, Chromebook, Chrome Browser, Android), it just doesn't show up. I have read a few threads (mostly about earlier AOS versions) and tried everything in them but it simply refuses to show up.



  • 2.  RE: Chromecast AirGrouping not working

    Posted Oct 14, 2016 12:11 PM
    If it is showing up on the devices as available, AirGroup is working correctly. That's all AirGroup does is handle discovery. If after selecting a Chromecast and the device can't connect to the Chromecast, it's likely a firewall issue.

    Are any ports being blocked? Do you have deny inter-user bridging enabled?


  • 3.  RE: Chromecast AirGrouping not working

    Posted Oct 14, 2016 01:58 PM

    Thanks for the reply.

     

    Only the Chrome Cast configuration app can see the device, any other app (i.e. YouTube, or Chrome Browser) on any OS cannot see it at all.

     

    I've checked (and rechecked) the ACLs for the roles that are supposed to be able to access it as well as the role that the ChromeCast is being assigned. They're actually 'allow-all' (shudder)

     

    Deny Inter User traffic is not enabled on either VAP.

     

    I have used this exact same configuration with AppleTV's and it works fine, which is why this is confusing me so much.

    Thanks



  • 4.  RE: Chromecast AirGrouping not working

    Posted Oct 14, 2016 04:28 PM
    Do you see any blocked service IDs or blocked queries?


  • 5.  RE: Chromecast AirGrouping not working

    Posted Oct 17, 2016 01:18 PM

    There are no blocked service ID's (show airgroup blocked-service-id)

     

    There are a lot of blocked queries. I looked through the list and didn't see anything that jumped out (like _GoogleChrome._tcp or something obvious like that)

     

    this is what 'show airgroup servers' looks like:

    a4:77:33:7e:4e:58  172.16.1.242  mDNS,DLNA  CHS-Library-ChromeCast            googlecast  3000  wireless        MEDIA-PLAYER-ROLE         chs library chromecast  SAU-ConferenceRoom

     

    And this is what 'show airgroup users' looks like for my phone and laptop respectively.

    (CONCORD-MASTER) # show airgroup users | include 90:60:f1:75:97:6b
    90:60:f1:75:97:6b  10.10.112.43  mDNS,DLNA                                    2222  IT-ROLE                 blambert       SAU-IT-AP2

    (CONCORD-MASTER) # show airgroup users | include 34:13:e8:10:93:2f

    (CONCORD-MASTER)#



  • 6.  RE: Chromecast AirGrouping not working

    Posted Oct 18, 2016 01:25 PM

    Here's something interesting.

     

    I took my Windows 10 laptop and started a packet capture while attempting to cast via Chrome.

     

    There is actual traffic to and from the Chromecast IP address.

     

    So....it looks like it's able to discover it, attempts to communicate, goes back and forth a bit....then fails for no discernable reason. As I watch the capture, it looks like the browser attempts a discovery again, goes through the process over again every two minutes.

     

    I have checked and re-checked the ACLs on the controller, and the two roles involved both have allow-all ipv4/ipv6



  • 7.  RE: Chromecast AirGrouping not working

    Posted Oct 18, 2016 03:20 PM

    Hi Ben,

     

    In the Guest Device Repository , Are you sharing the necessary controller user-roles ?

     

     



  • 8.  RE: Chromecast AirGrouping not working

    Posted Oct 19, 2016 08:39 AM

    Hi Victor!

     

    I have tried it several different ways and none have made a difference.

     

    I've tried it via usernames, shared locations (which work great for the AppleTVs), and shared roles, as well as various combonation of the three.

     

    Glad I'm not the only one who is confused here!



  • 9.  RE: Chromecast AirGrouping not working

    Posted Oct 22, 2016 11:24 AM

    At this point am I better off opening a case with TAC?

    Thanks,

    --Ben



  • 10.  RE: Chromecast AirGrouping not working

    Posted Oct 22, 2016 11:25 AM
    Hey Ben please open a TAC case

    Get Outlook for iOS


  • 11.  RE: Chromecast AirGrouping not working
    Best Answer

    Posted Nov 18, 2016 03:27 PM

    It took a while to figure out as everything was configured correctly. However, due to a misunderstanding on my part I had to change things around a little bit.

     

    The controller will happily pass along the 'discovery' traffic so that the devices can find each other...but the actual communication is unicast which the controller does not redirect (I was under the impression that it did). In this case the two VLANs were completely separate and not routable at all.

     

    I ended up making a new CPPM role that finds these devices (IF GuestUser role = X AND is connecting from Guest) and puts them on a routable VLAN.

     

    Annoyingly it took several hours on the phone with TAC to get to this point of understanding.



  • 12.  RE: Chromecast AirGrouping not working

    Posted Jun 08, 2017 06:14 AM

    I'm also having some Airgroups issue.

    Android to chromecast ( same ssid same vlan) works just fine, can stream audio o.k.

    ios apps can;t even see the chromecast device ... can see apple TV on same network though

    With Chromecast Ultra same thing.. anroid streams o.k. ios can;t even see it. 

    User policy set to allow all 

    all airgroups services set to all apart from the default "any"