Controllerless Networks

last person joined: 6 hours ago 

Aruba Instant Wi-Fi: Meet the controllerless Wi-Fi solution that's easy to set-up, is loaded with security and smarts, and won't break your budget.
Expand all | Collapse all

IAP-225 Radios not turning on

Jump to Best Answer
This thread has been viewed 0 times
  • 1.  IAP-225 Radios not turning on

    Posted Jan 04, 2016 01:27 PM

    I have an IAP-225 running in Standalone mode and the Instant SSID isn't coming up. Both radio LEDs are staying amber as well. 

     

    I'm setting it up for a site survey.

     

    Also have the exact same issue on an IAP-224 that has a valid SSID configured.

     

    Boot and config are attached. 

     

    Any ideas?

    Attachment(s)

    txt
    iap-225 config.txt   2 KB 1 version
    txt
    iap-225 boot.txt   8 KB 1 version


  • 2.  RE: IAP-225 Radios not turning on

    Posted Jan 04, 2016 01:33 PM

    It is not getting an ip address from the DHCP server.



  • 3.  RE: IAP-225 Radios not turning on

    Posted Jan 04, 2016 01:36 PM
    It is saying that in the log, but I gave it a static address in the apboot menu, saved it, verified and booted.


  • 4.  RE: IAP-225 Radios not turning on

    Posted Jan 04, 2016 01:41 PM

    apboot> print
    bootdelay=2
    baudrate=9600
    autoload=n
    boardname=Ardmore
    servername=aruba-master
    bootcmd=boot ap
    autostart=yes
    bootfile=e500.ari
    ethaddr=84:d4:7e:c5:e3:d2
    ethact=eth0
    subnetmask=255.255.255.0
    standalone_mode=1
    stdin=serial
    stdout=serial
    stderr=serial
    ipaddr=192.168.1.2

    Environment size: 268/131068 bytes
    apboot> save
    Saving Environment to Flash...
    Un-Protected 1 sectors
    . done
    Erased 1 sectors
    Writing 9....8....7....6....5....4....3....2....1....
    apboot> boot



  • 5.  RE: IAP-225 Radios not turning on

    Posted Jan 04, 2016 01:47 PM

    @Matt Frederick wrote:

    apboot> print
    bootdelay=2
    baudrate=9600
    autoload=n
    boardname=Ardmore
    servername=aruba-master
    bootcmd=boot ap
    autostart=yes
    bootfile=e500.ari
    ethaddr=84:d4:7e:c5:e3:d2
    ethact=eth0
    subnetmask=255.255.255.0
    standalone_mode=1
    stdin=serial
    stdout=serial
    stderr=serial
    ipaddr=192.168.1.2

    Environment size: 268/131068 bytes
    apboot> save
    Saving Environment to Flash...
    Un-Protected 1 sectors
    . done
    Erased 1 sectors
    Writing 9....8....7....6....5....4....3....2....1....
    apboot> boot


    You need to configure a subnet mask and a default gateway, as well.



  • 6.  RE: IAP-225 Radios not turning on

    Posted Jan 04, 2016 01:45 PM

     Did you configure "work without uplink" on the SSID?  Please look at the thread here: http://community.arubanetworks.com/t5/Unified-Wired-Wireless-Access/Site-Survey-with-IAP-Manual/td-p/57274/page/2



  • 7.  RE: IAP-225 Radios not turning on

    Posted Jan 04, 2016 01:56 PM

    I did. Will try setting a default gateway.



  • 8.  RE: IAP-225 Radios not turning on

    Posted Jan 04, 2016 02:12 PM

    Added default gateway and still same results:

     

    apboot> print
    bootdelay=2
    baudrate=9600
    autoload=n
    boardname=Ardmore
    servername=aruba-master
    bootcmd=boot ap
    autostart=yes
    bootfile=e500.ari
    ethaddr=84:d4:7e:c5:e3:d2
    ipaddr=192.168.1.2
    subnetmask=255.255.255.0
    defaultgw=192.168.1.1
    standalone_mode=1
    stdin=serial
    stdout=serial
    stderr=serial
    ethact=eth0

    Environment size: 290/131068 bytes
    apboot> boot
    Checking image @ 0xee000000
    Copying image from 0xee000000

    Image is signed; verifying checksum... passed
    Signer Cert OK
    Policy Cert OK
    RSA signature verified.
    [ 0.000000] Flash variant: default
    [ 0.000000]
    [ 0.000000] Aruba Networks
    [ 0.000000] ArubaOS Version 6.4.2.6-4.1.1.6 (build 50009 / label #50009)
    [ 0.000000] Built by p4build@tortuga on 2015-05-12 at 10:54:20 PDT (gcc version 4.5.1)
    [ 0.000000]
    [ 0.000000] Memory: 506148k/524288k available (12480k kernel code, 18140k reserved, 504k data, 456k bss, 9040k init)
    [ 0.002949] Processor 1 found.
    [ 0.156865] Brought up 2 CPUs
    [ 0.233377] PCI: Probing PCI hardware
    [ 0.276103] PCI: Resetting PCI bus
    [ 0.477124] pci 0000:00:00.0: PCI bridge to [bus 01-ff]
    [ 0.539366] pci 0001:02:00.0: PCI bridge to [bus 03-ff]
    [ 0.601652] pci 0000:01:00.0: BAR 2: assigned [mem 0x80000000-0x801fffff 64bit]
    [ 0.688633] pci 0000:01:00.0: BAR 2: set to [mem 0x80000000-0x801fffff 64bit] (PCI address [0x80000000-0x801fffff]
    [ 0.812542] pci 0000:01:00.0: BAR 0: assigned [mem 0x80200000-0x80207fff 64bit]
    [ 0.900039] pci 0000:01:00.0: BAR 0: set to [mem 0x80200000-0x80207fff 64bit] (PCI address [0x80200000-0x80207fff]
    [ 1.023993] pci 0000:00:00.0: enabling device (0106 -> 0107)
    [ 1.091694] pci 0001:03:00.0: BAR 2: assigned [mem 0xa0000000-0xa01fffff 64bit]
    [ 1.179189] pci 0001:03:00.0: BAR 2: set to [mem 0xa0000000-0xa01fffff 64bit] (PCI address [0xa0000000-0xa01fffff]
    [ 1.303134] pci 0001:03:00.0: BAR 0: assigned [mem 0xa0200000-0xa0207fff 64bit]
    [ 1.390632] pci 0001:03:00.0: BAR 0: set to [mem 0xa0200000-0xa0207fff 64bit] (PCI address [0xa0200000-0xa0207fff]
    [ 1.514584] pci 0001:02:00.0: enabling device (0106 -> 0107)
    [ 7.718574] Kprobe smoke test started
    [ 7.793544] Kprobe smoke test passed successfully
    [ 7.965466] ee000000.nor: Found 1 x16 devices at 0x0 in 16-bit bank
    [ 8.040508] Amd/Fujitsu Extended Query Table at 0x0040
    [ 8.102036] number of CFI chips: 1
    [ 8.146760] fsl-gianfar ethernet.2: enabled errata workarounds, flags: 0x4
    [ 8.229571] /proc/gfar_eth0_stats created
    [ 8.279832] fsl-gianfar ethernet.3: enabled errata workarounds, flags: 0x4
    [ 8.362597] /proc/gfar_eth1_stats created
    [ 8.426734] Enabling watchdog on CPU 1
    [ 8.426742] Enabling watchdog on CPU 0
    [ 8.523269]
    [ 8.523274] Starting Kernel SHA1 KAT ...Completed Kernel SHA1 KAT
    [ 8.615052] Starting Kernel HMAC-SHA1 KAT ...Completed Kernel HMAC-SHA1 KAT
    [ 8.704726] Starting Kernel DES KAT ...Completed Kernel DES KAT
    [ 8.776676] Starting Kernel AES KAT ...Completed Kernel AES KAT
    [ 8.820477]
    [ 8.866342] Starting Kernel HMAC SHA1 FIPS KAT ...Completed Kernel HMAC SHA1 FIPS KAT
    [ 8.961751] Starting Kernel HMAC SHA256 FIPS KAT ...Completed Kernel HMAC SHA256 FIPS KAT
    [ 9.061485] Starting Kernel HMAC SHA384 FIPS KAT ...Completed Kernel HMAC SHA384 FIPS KAT
    [ 9.160916] Starting Kernel HMAC SHA512 FIPS KAT ...Completed Kernel HMAC SHA512 FIPS KAT
    [ 9.260353] Starting Kernel AES-CBC FIPS KAT ...Completed Kernel AES-CBC FIPS KAT
    [ 9.354873] Starting Kernel AES-CCM FIPS KAT ...Completed Kernel AES-CCM FIPS KAT
    [ 9.445998] Starting Kernel 3DES-CBC FIPS KAT ...Completed Kernel 3DES-CBC FIPS KAT
    Domain Name: instant.arubanetworks.com
    No panic info available
    Backup ENV.
    [ 14.594068] p1020_soc: P1020 Misc Utils Driver version 1
    Ethernet port 1 mode: active-standby
    [ 14.858333] ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 14.925834] ADDRCONF(NETDEV_UP): bond0: link is not ready
    [ 15.005325] bonding: bond0: enslaving eth0 as a backup interface with a down link.
    [ 15.112350] ADDRCONF(NETDEV_UP): eth1: link is not ready
    [ 15.199214] bonding: bond0: enslaving eth1 as a backup interface with a down link.
    Cfg len is 2.5k
    Loading configuration file of length 2.5k...
    wifi uplink not present...
    extended ssid config detected...
    Terminal access enabled...
    factory default SSID detected...
    extended ssid activate due to no valid ssid ...
    do ethtool autoneg on for eth0
    Starting up in standalone mode
    Disabling wpa_supplicant for this paltform
    [ 18.594167] AP xml model 66, num_radios 2 (jiffies 8646)
    [ 18.657768] init_asap_mod: installation:0
    [ 18.705714] radio 0: band 1 ant 0 max_ssid 16
    [ 18.757820] radio 1: band 0 ant 0 max_ssid 16
    [ 18.809937] election init: rand=12 HZ=500
    [ 18.857873] IAP client match init
    [ 18.897547] ethernet_device_event: dev eth0 is up
    [ 18.953828] ethernet_device_event: dev eth1 is up
    notify asap_mod 3g no present...
    notify asap standalone ap...
    Starting watchdog process...
    [ 19.150191] bonding: bond0: Could not set eth0 as active slave; either eth0 is down or the link is down.
    Getting an IP address...
    Dec 31 16:00:17 udhcpc[2195]: udhcpc (v0.9.9-pre) started
    Dec 31 16:00:18 udhcpc[2195]: send_discover: pkt num 0, secs 0
    Dec 31 16:00:18 udhcpc[2195]: Sending discover...
    Dec 31 16:00:19 udhcpc[2195]: send_discover: pkt num 1, secs 1
    Dec 31 16:00:19 udhcpc[2195]: Sending discover...
    Dec 31 16:00:21 udhcpc[2195]: send_discover: pkt num 2, secs 3
    Dec 31 16:00:21 udhcpc[2195]: Sending discover...
    Dec 31 16:00:23 udhcpc[2195]: No lease, forking to background.
    Dec 31 16:00:43 udhcpc[2313]: send_discover: pkt num 0, secs 25
    Dec 31 16:00:43 udhcpc[2313]: Sending discover...
    Dec 31 16:00:45 udhcpc[2313]: send_discover: pkt num 1, secs 27
    Dec 31 16:00:45 udhcpc[2313]: Sending discover...
    Dec 31 16:00:47 udhcpc[2313]: send_discover: pkt num 2, secs 29
    Dec 31 16:00:47 udhcpc[2313]: Sending discover...
    Dec 31 16:01:09 udhcpc[2313]: send_discover: pkt num 0, secs 51
    Dec 31 16:01:09 udhcpc[2313]: Sending discover...
    Dec 31 16:01:11 udhcpc[2313]: send_discover: pkt num 1, secs 53
    Dec 31 16:01:11 udhcpc[2313]: Sending discover...
    Dec 31 16:01:13 udhcpc[2313]: send_discover: pkt num 2, secs 55
    Dec 31 16:01:13 udhcpc[2313]: Sending discover...
    Dec 31 16:01:35 udhcpc[2313]: send_discover: pkt num 0, secs 77
    Dec 31 16:01:35 udhcpc[2313]: Sending discover...
    Dec 31 16:01:37 udhcpc[2313]: send_discover: pkt num 1, secs 79
    Dec 31 16:01:37 udhcpc[2313]: Sending discover...
    Dec 31 16:01:39 udhcpc[2313]: send_discover: pkt num 2, secs 81
    Dec 31 16:01:39 udhcpc[2313]: Sending discover...
    [ 109.031533] Picked up default IP a9fe756f, rand 756f
    [ 115.043529] Default IP is ready
    Dec 31 16:02:01 udhcpc[2313]: send_discover: pkt num 0, secs 103
    Dec 31 16:02:01 udhcpc[2313]: Sending discover...
    Dec 31 16:02:03 udhcpc[2313]: send_discover: pkt num 1, secs 105
    Dec 31 16:02:03 udhcpc[2313]: Sending discover...
    Dec 31 16:02:05 udhcpc[2313]: send_discover: pkt num 2, secs 107
    Dec 31 16:02:05 udhcpc[2313]: Sending discover...
    DHCP timed out.
    Installing default ip.
    Default IP comes up.
    [ 147.107548] ip_time_handler: Got ip and packets on bond0 Started master election 124-0, rand 21
    DHCP timed out.
    DHCP got ip address.
    [ 147.527122] bonding: bond0: releasing backup interface eth1
    [ 147.621004] ethernet_device_event: dev eth1 is down
    [ 147.686538] ADDRCONF(NETDEV_UP): eth1: link is not ready
    [ 147.750136] ethernet_device_event: dev eth1 is up
    169.254.117.111 255.255.0.0
    Compressing all files in the /etc/httpd directory...
    Dec 31 16:02:27 udhcpc[2313]: send_discover: pkt num 0, secs 129
    Dec 31 16:02:27 udhcpc[2313]: Sending discover...
    Dec 31 16:02:29 udhcpc[2313]: send_discover: pkt num 1, secs 131
    Dec 31 16:02:29 udhcpc[2313]: Sending discover...
    Done.
    Starting Webserver
    bind: Transport endpoint is not connected
    bind: Transport endpoint is not connected
    bind: Transport endpoint is not connected
    Launching NTP Client on pool.ntp.org
    [ 152.027143] wl 0000:01:00.0: enabling device (0000 -> 0002)
    [ 152.121383] wifi0: AP type AP-225, radio 0, max_bssids 16
    [ 152.466372] Enabling eth1 due to power change [power profile 1]
    [ 152.539421] wl 0001:03:00.0: enabling device (0000 -> 0002)
    [ 152.767105] wifi1: AP type AP-225, radio 1, max_bssids 16
    Jan 1 00:02:31 udhcpc[2313]: send_discover: pkt num 2, secs 133
    Jan 1 00:02:31 udhcpc[2313]: Sending discover...
    Clearing P1020 PCIe Error Status
    AP rebooted Thu Jan 1 00:05:45 UTC 1970; CLI cmd at uptime 0D 0H 5M 45S: reload
    shutting down watchdog process (nanny will restart it)...
    Completed SW FIPS KAT test

    <<<<< Welcome to the Access Point >>>>>

    User: [ 178.375296] process `snmpd_sap' is using obsolete setsockopt SO_BSDCOMPAT
    [ 179.215034] i am master now
    [ 179.248420] (00:02:57) !!! Init ---> Master
    [ 179.298472] asap_send_elected_master: sent successfully



  • 9.  RE: IAP-225 Radios not turning on

    Posted Jan 04, 2016 02:14 PM

    However, when I purged it, set the ip/subnet/gw and booted - it did not search for an ip. 

     

    Though when I configured it for Standalone, "work-without-uplink", and rebooted it went back to searching for an ip on the boot. 



  • 10.  RE: IAP-225 Radios not turning on

    Posted Jan 04, 2016 03:13 PM

    Hi, 

     

    subnetmask=255.255.255.0
    defaultgw=192.168.1.1 

     

    The static subnetmask and default GW are not set with proper commands. Please try the commands in the below link, 

    http://www.arubanetworks.com/techdocs/InstantHTML/Content/Chapter2%20InitialConfiguration/AssigninganIP.htm 

     

    Thanks, 

    Rajaguru Vincent 



  • 11.  RE: IAP-225 Radios not turning on
    Best Answer

    Posted Jan 04, 2016 07:11 PM

    Fixing the subnet mask and default gateway commands didn't fix it. 

     

    However, I was able to fix it. Even though I went in and booted in Standalone AND added the "work-without-uplink" command, it still wouldn't broadcast instant without an uplink. Once I plugged my laptop into the "Data In" port of the PoE injector - voila, it starts broadcasting instant. 

     

    Went ahead and configured my new WLAN, uncecked the "Disable if no uplink" box, and rebooted without the uplink. Working as it should.

     

    Thanks for the help!