Controllerless Networks

last person joined: an hour ago 

Aruba Instant Wi-Fi: Meet the controllerless Wi-Fi solution that's easy to set-up, is loaded with security and smarts, and won't break your budget.
Expand all | Collapse all

"SSL connect error" when AP trying to connect to Aruba Central

  • 1.  "SSL connect error" when AP trying to connect to Aruba Central

    Posted Aug 31, 2016 02:38 PM

    My 215 AP is managed by Aruba Central.  I got it connected to AC once before when i configured it initially.  I then boxed and shipped it to a branch and now it will not connect.  I run show activate status and get:

     

    Activate Server: device.arubanetworks.com

    Activate status: connection-failed

    Activate fail reason: SSL connect error

     

    What would be causing this and how do i get it fixed?



  • 2.  RE: "SSL connect error" when AP trying to connect to Aruba Central

    Posted Oct 05, 2016 10:21 PM

    Hi ,

    Can you please share ' show tech support " outputs so i can look at this?



  • 3.  RE: "SSL connect error" when AP trying to connect to Aruba Central

    Posted Feb 22, 2017 11:19 PM
    please provide output below;

    show clock
    show log ap-debug | include awc
    show summary | include mage

    Check if iap is able to resolve device.arubanetworks.com and reach it on Https port 443
    Clock need to be accurate as iap forms Ssl tunnel which involves verify server certificate


  • 4.  RE: "SSL connect error" when AP trying to connect to Aruba Central

    Posted Feb 23, 2017 12:24 PM

    Thanks for responding. Here's my output:

     

    7011iap01# sh clock
    Current Time     :2017-02-23 17:21:09

     

    7011iap01# sh log ap-debug | include awc
    Feb 23 16:33:06  awc[1841]: awc_init_connection: 2222: connecting to device.arubanetworks.com:443
    Feb 23 16:33:06  awc[1841]: tcp_connect: 168: recv timeout set to 5
    Feb 23 16:33:06  awc[1841]: tcp_connect: 175: send timeout set to 5
    Feb 23 16:33:06  awc[1841]: awc_init_connection: 2264: connected to device.arubanetworks.com:443
    Feb 23 16:33:06  awc[1841]: awc_init_connection: 2306: Loading local CA certificates
    Feb 23 16:33:07  awc[1841]: Failed to establish SSL connection: Error code is -1:unknown error number
    Feb 23 16:33:07  awc[1841]: isc_init failed
    Feb 23 16:38:09  awc[1841]: awc_init_connection: 2222: connecting to device.arubanetworks.com:443
    Feb 23 16:38:09  awc[1841]: tcp_connect: 168: recv timeout set to 5
    Feb 23 16:38:09  awc[1841]: tcp_connect: 175: send timeout set to 5
    Feb 23 16:38:09  awc[1841]: awc_init_connection: 2264: connected to device.arubanetworks.com:443
    Feb 23 16:38:09  awc[1841]: awc_init_connection: 2306: Loading local CA certificates
    Feb 23 16:38:09  awc[1841]: Failed to establish SSL connection: Error code is -1:unknown error number
    Feb 23 16:38:09  awc[1841]: isc_init failed
    Feb 23 16:43:11  awc[1841]: awc_init_connection: 2222: connecting to device.arubanetworks.com:443
    Feb 23 16:43:11  awc[1841]: tcp_connect: 168: recv timeout set to 5
    Feb 23 16:43:11  awc[1841]: tcp_connect: 175: send timeout set to 5
    Feb 23 16:43:11  awc[1841]: awc_init_connection: 2264: connected to device.arubanetworks.com:443
    Feb 23 16:43:11  awc[1841]: awc_init_connection: 2306: Loading local CA certificates
    Feb 23 16:43:12  awc[1841]: Failed to establish SSL connection: Error code is -1:unknown error number
    Feb 23 16:43:12  awc[1841]: isc_init failed
    Feb 23 16:48:14  awc[1841]: awc_init_connection: 2222: connecting to device.arubanetworks.com:443
    Feb 23 16:48:14  awc[1841]: tcp_connect: 168: recv timeout set to 5
    Feb 23 16:48:14  awc[1841]: tcp_connect: 175: send timeout set to 5
    Feb 23 16:48:14  awc[1841]: awc_init_connection: 2264: connected to device.arubanetworks.com:443
    Feb 23 16:48:14  awc[1841]: awc_init_connection: 2306: Loading local CA certificates
    Feb 23 16:48:15  awc[1841]: Failed to establish SSL connection: Error code is -1:unknown error number
    Feb 23 16:48:15  awc[1841]: isc_init failed
    Feb 23 16:53:21  awc[1841]: awc_init_connection: 2222: connecting to device.arubanetworks.com:443
    Feb 23 16:53:21  awc[1841]: tcp_connect: 168: recv timeout set to 5
    Feb 23 16:53:21  awc[1841]: tcp_connect: 175: send timeout set to 5
    Feb 23 16:53:21  awc[1841]: awc_init_connection: 2264: connected to device.arubanetworks.com:443
    Feb 23 16:53:21  awc[1841]: awc_init_connection: 2306: Loading local CA certificates
    Feb 23 16:53:21  awc[1841]: Failed to establish SSL connection: Error code is -1:unknown error number
    Feb 23 16:53:21  awc[1841]: isc_init failed
    Feb 23 16:58:23  awc[1841]: awc_init_connection: 2222: connecting to device.arubanetworks.com:443
    Feb 23 16:58:23  awc[1841]: tcp_connect: 168: recv timeout set to 5
    Feb 23 16:58:23  awc[1841]: tcp_connect: 175: send timeout set to 5
    Feb 23 16:58:23  awc[1841]: awc_init_connection: 2264: connected to device.arubanetworks.com:443
    Feb 23 16:58:23  awc[1841]: awc_init_connection: 2306: Loading local CA certificates
    Feb 23 16:58:24  awc[1841]: Failed to establish SSL connection: Error code is -1:unknown error number
    Feb 23 16:58:24  awc[1841]: isc_init failed
    Feb 23 17:03:25  awc[1841]: awc_init_connection: 2222: connecting to device.arubanetworks.com:443
    Feb 23 17:03:26  awc[1841]: tcp_connect: 168: recv timeout set to 5
    Feb 23 17:03:26  awc[1841]: tcp_connect: 175: send timeout set to 5
    Feb 23 17:03:26  awc[1841]: awc_init_connection: 2264: connected to device.arubanetworks.com:443
    Feb 23 17:03:26  awc[1841]: awc_init_connection: 2306: Loading local CA certificates
    Feb 23 17:03:26  awc[1841]: Failed to establish SSL connection: Error code is -1:unknown error number
    Feb 23 17:03:26  awc[1841]: isc_init failed
    Feb 23 17:08:28  awc[1841]: awc_init_connection: 2222: connecting to device.arubanetworks.com:443
    Feb 23 17:08:28  awc[1841]: tcp_connect: 168: recv timeout set to 5
    Feb 23 17:08:28  awc[1841]: tcp_connect: 175: send timeout set to 5
    Feb 23 17:08:28  awc[1841]: awc_init_connection: 2264: connected to device.arubanetworks.com:443
    Feb 23 17:08:28  awc[1841]: awc_init_connection: 2306: Loading local CA certificates
    Feb 23 17:08:28  awc[1841]: Failed to establish SSL connection: Error code is -1:unknown error number
    Feb 23 17:08:28  awc[1841]: isc_init failed
    Feb 23 17:13:32  awc[1841]: awc_init_connection: 2222: connecting to device.arubanetworks.com:443
    Feb 23 17:13:32  awc[1841]: tcp_connect: 168: recv timeout set to 5
    Feb 23 17:13:32  awc[1841]: tcp_connect: 175: send timeout set to 5
    Feb 23 17:13:32  awc[1841]: awc_init_connection: 2264: connected to device.arubanetworks.com:443
    Feb 23 17:13:32  awc[1841]: awc_init_connection: 2306: Loading local CA certificates
    Feb 23 17:13:32  awc[1841]: Failed to establish SSL connection: Error code is -1:unknown error number
    Feb 23 17:13:32  awc[1841]: isc_init failed
    Feb 23 17:18:37  awc[1841]: awc_init_connection: 2222: connecting to device.arubanetworks.com:443
    Feb 23 17:18:37  awc[1841]: tcp_connect: 168: recv timeout set to 5
    Feb 23 17:18:37  awc[1841]: tcp_connect: 175: send timeout set to 5
    Feb 23 17:18:37  awc[1841]: awc_init_connection: 2264: connected to device.arubanetworks.com:443
    Feb 23 17:18:37  awc[1841]: awc_init_connection: 2306: Loading local CA certificates
    Feb 23 17:18:38  awc[1841]: isc_init failed

     

    7011iap01# sh summary | include mage
    Image Server State   :error
    Image Server Message :payload_empty
    New Image Version    :
    New Image URL        :
    Image Sync Via       :Master



  • 5.  RE: "SSL connect error" when AP trying to connect to Aruba Central

    Posted Mar 11, 2017 07:41 PM
    From logs, it shows the iap doesn't have reachability to device.arubanetworks.com over Https.

    Points to check :

    > Ping device.arubanetworks.com
    > check if dns is configured in iap as it needs to resolve url
    > check if TCP 443 is allowed if there is a firewall between iap and internet


  • 6.  RE: "SSL connect error" when AP trying to connect to Aruba Central

    Posted Aug 08, 2018 01:09 PM

    I have exactly same issue with my IAP 215 !

    Did you open one TAC case ?

    Regards



  • 7.  RE: "SSL connect error" when AP trying to connect to Aruba Central

    Posted Aug 08, 2018 01:41 PM

    Indeed, it was my firewall configuration issue. Wrong position of "captiveportal" acl with "central acl (443)" in my FW rules..