Controllerless Networks

last person joined: 17 hours ago 

Aruba Instant Wi-Fi: Meet the controllerless Wi-Fi solution that's easy to set-up, is loaded with security and smarts, and won't break your budget.
Expand all | Collapse all

one iap can't join VC

Jump to Best Answer
  • 1.  one iap can't join VC

    Posted Mar 11, 2015 11:22 PM

    Hi expert,

     

    Currently ,two iap (i274,i134) have joined the VC and configure static ap ip address . Allow automatic join is enable. new iap i92 has same version as other two iap ,when the iap92 tried to join vc ,some error message shows up :

    Rebooting AP due to default-ip is denied in this network (ac:a3:1e:c0:38:ec 10.75.156.83)

    and 10.75.156.83 is ap address which selected as VC .

    Should I must confiugre static ip for iap92 before it could join vc?



  • 2.  RE: one iap can't join VC

    Posted Mar 11, 2015 11:27 PM


  • 3.  RE: one iap can't join VC

    Posted Mar 11, 2015 11:50 PM
    Thanks for reply,but that post is about compass ap ,I am using iap.


  • 4.  RE: one iap can't join VC

    Posted Mar 12, 2015 01:53 AM

    Hi Wang,

     

    let me understand couple of things here.

     

    1. Do you have DHCP in the subnet to provide IP address to IAPs ?

    2. Have factory reset the IAP 92 .

     

    Please share the outut of "show log system" it wil give some more idea.

     

    Feel free for any further help on this.



  • 5.  RE: one iap can't join VC

    Posted Mar 12, 2015 01:55 AM

    Hi Wang,

     

    let me understand couple of things here.

     

    1. Do you have DHCP in the subnet to provide IP address to IAPs ?

    2. Have factory reset the IAP 92 .

     

    Please share the outut of "show log system" it wil give some more idea.

     

    Feel free for any further help on this.



  • 6.  RE: one iap can't join VC

    Posted Mar 12, 2015 03:10 AM

    1.I have tried both enable and disable dhcp ,result is same.

    2.yes ,has reset iap92

    Aos version is 4.1.1.2 which was thought has tons problem,just tried downgrade AOS.

    *********************************************************************************************************
     3/12/2015 15:07:04 PM    Target: colin_i274    Command: show log system 
    *********************************************************************************************************
    
    Jan  1 00:00:50  syslog: <341005> <ERRS> |AP colin_i274: |  terminal access is enabled but dropbear is not running, starting
    Jan  1 00:00:53  nanny[2445]: <303022> <WARN> |AP colin_i274: |  Reboot Reason: No reboot message found.
    Jan  1 00:01:05  cli[2521]: <341317> <WARN> |AP colin_i274@10.75.156.83 cli|  Regulatory table file init at version 1.0_48019, build 9/1/2015.
    Jan  1 00:01:05  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  Extended ssid enabled
    Jan  1 00:01:05  cli[2521]: <341207> <WARN> |AP colin_i274@10.75.156.83 cli|  AP support up to 16 SSID.
    Jan  1 00:01:06  cli[2521]: <341172> <WARN> |AP colin_i274@10.75.156.83 cli|  Find enet0 name eth0.
    Jan  1 00:01:06  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  cli starting, clearing any dpimgr
    Jan  1 00:01:07  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  cli_choose_eth_uplink:eth current uplink set to DHCP
    Jan  1 00:01:07  cli[2521]: <341169> <WARN> |AP colin_i274@10.75.156.83 cli|  Add uplink Ethernet 0.
    Jan  1 00:01:07  cli[2521]: <341167> <WARN> |AP colin_i274@10.75.156.83 cli|  Uplink eth0 type Ethernet, state INIT->LOAD.
    Jan  1 00:01:07  cli[2521]: <341169> <WARN> |AP colin_i274@10.75.156.83 cli|  Add uplink Wifi-sta 6.
    Jan  1 00:01:07  cli[2521]: <341169> <WARN> |AP colin_i274@10.75.156.83 cli|  Add uplink 3G/4G 7.
    Jan  1 00:01:07  cli[2521]: <341167> <WARN> |AP colin_i274@10.75.156.83 cli|  Uplink  type Dummy, state INIT->LOAD.
    Jan  1 00:01:07  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  receive sapd hello for process recovery
    Jan  1 00:01:08  cli[2521]: <341174> <WARN> |AP colin_i274@10.75.156.83 cli|  No current uplink, pick the highest one - Ethernet eth0.
    Jan  1 00:01:08  cli[2521]: <341263> <WARN> |AP colin_i274@10.75.156.83 cli|  enable uplink eth0.
    Jan  1 00:01:08  cli[2521]: <341167> <WARN> |AP colin_i274@10.75.156.83 cli|  Uplink eth0 type Ethernet, state LOAD->PROBE.
    Jan  1 00:01:08  cli[2521]: <341265> <WARN> |AP colin_i274@10.75.156.83 cli|  enable ethernet uplink eth0.
    Jan  1 00:01:08  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  the ethernet uplink inuse in first time, get ip address.
    Jan  1 00:01:08  cli[2521]: <341167> <WARN> |AP colin_i274@10.75.156.83 cli|  Uplink eth0 type Ethernet, state PROBE->UP.
    Jan  1 00:01:08  cli[2521]: <341185> <WARN> |AP colin_i274@10.75.156.83 cli|  Retrieving ip address from br0, ip 10.75.156.83, mask 255.255.255.0.
    Jan  1 00:01:08  cli[2521]: <341274> <WARN> |AP colin_i274@10.75.156.83 cli|  Update election ip from br0, election ip 10.75.156.83/255.255.255.0.
    Jan  1 00:01:08  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  build_my_ip_address: old ip and new ip same; skipping
    Jan  1 00:01:08  cli[2521]: <341006> <CRIT> |AP colin_i274@10.75.156.83 cli|  Sending uplink_up msg to sapd
    Jan  1 00:01:08  cli[2521]: <341006> <CRIT> |AP colin_i274@10.75.156.83 cli|  trap uplink info.
    Jan  1 00:01:08  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  last uplink is null, it's the first uplink, ignore this trap.
    Jan  1 00:01:08  cli[2521]: <341173> <WARN> |AP colin_i274@10.75.156.83 cli|  Current uplink set to Ethernet, state UP.
    Jan  1 00:01:08  cli[2521]: <341135> <WARN> |AP colin_i274@10.75.156.83 cli|  Master Changed - new 127.0.0.1 old 0.0.0.0 current swarm state 0.
    Jan  1 00:01:09  cli[2521]: <341135> <WARN> |AP colin_i274@10.75.156.83 cli|  Master Changed - new 127.0.0.1 old 0.0.0.0 current swarm state 1.
    Jan  1 00:01:11  cli[2521]: <341097> <WARN> |AP colin_i274@10.75.156.83 cli|  recv_image_check: mac-9c:1c:12:c6:37:ca, version-6.4.2.3-4.1.1.2_48114, ccode_idx-156.
    Jan  1 00:01:11  cli[2521]: <341005> <ERRS> |AP colin_i274@10.75.156.83 cli|  Drop image check since i am not the Master
    Jan  1 00:01:12  cli[2521]: <341135> <WARN> |AP colin_i274@10.75.156.83 cli|  Master Changed - new 127.0.0.1 old 0.0.0.0 current swarm state 1.
    Jan  1 00:01:12  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  Swarm State Change from Found to Image-ok
    
    
    Jan  1 00:01:16  cli[2521]: <341097> <WARN> |AP colin_i274@10.75.156.83 cli|  recv_image_check: mac-9c:1c:12:c6:37:ca, version-6.4.2.3-4.1.1.2_48114, ccode_idx-156.
    Jan  1 00:01:17  cli[2521]: <341194> <WARN> |AP colin_i274@10.75.156.83 cli|  Loading configuration, func swarm_timer_handler, line 8081.
    Jan  1 00:01:22  cli[2521]: <341205> <WARN> |AP colin_i274@10.75.156.83 cli|  Applying enet config : port eth1.
    Jan  1 00:01:30  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  Swarm State Change from Image-ok to Complete
    Jan  1 00:01:31  cli[2521]: <341097> <WARN> |AP colin_i274@10.75.156.83 cli|  recv_image_check: mac-9c:1c:12:c6:37:ca, version-6.4.2.3-4.1.1.2_48114, ccode_idx-156.
    Jan  1 00:01:31  cli[2521]: <341165> <WARN> |AP colin_i274@10.75.156.83 cli|  send image match to 10.75.156.81.
    Jan  1 00:01:31  cli[2521]: <341097> <WARN> |AP colin_i274@10.75.156.83 cli|  recv_image_check: mac-9c:1c:12:c6:37:ca, version-6.4.2.3-4.1.1.2_48114, ccode_idx-156.
    Jan  1 00:01:31  cli[2521]: <341165> <WARN> |AP colin_i274@10.75.156.83 cli|  send image match to 10.75.156.81.
    Jan  1 00:01:31  cli[2521]: <341097> <WARN> |AP colin_i274@10.75.156.83 cli|  recv_image_check: mac-9c:1c:12:c6:37:ca, version-6.4.2.3-4.1.1.2_48114, ccode_idx-156.
    Jan  1 00:01:31  cli[2521]: <341165> <WARN> |AP colin_i274@10.75.156.83 cli|  send image match to 10.75.156.81.
    Jan  1 00:01:42  cli[2521]: <341199> <WARN> |AP colin_i274@10.75.156.83 cli|  send_config_init: send config to slave 10.75.156.81, using url 0, auto save disable 0.
    Jan  1 00:51:11  cli[2521]: <341108> <ERRS> |AP colin_i274@10.75.156.83 cli|  sess_validate_sid: 179 invalid session client-10.75.56.3 sid-RLHAQQwsKCRmKEG5G27e.
    Jan  1 16:42:26  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  Invalid backup image version
    Jan  1 16:42:26  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  Get backup image info error
    Jan  1 16:43:45  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  Invalid backup image version
    Jan  1 16:43:45  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  Get backup image info error
    Jan  1 16:55:44  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  Invalid backup image version
    Jan  1 16:55:44  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  Get backup image info error
    Jan  1 17:09:11  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  Invalid backup image version
    Jan  1 17:09:11  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  Get backup image info error
    Jan  1 17:31:48  cli[2521]: <341108> <ERRS> |AP colin_i274@10.75.156.83 cli|  sess_validate_sid: 179 invalid session client-10.75.56.3 sid-ZTEC3D8HS87iJEiYTSGd.
    Jan  1 17:42:11  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  Invalid backup image version
    Jan  1 17:42:11  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  Get backup image info error
    Jan  1 17:44:36  cli[2521]: <341132> <WARN> |AP colin_i274@10.75.156.83 cli|  Check sum error for AP-10.75.156.81, slave 50540 vs master 18472, error_cnt 1, recover_sent 0.
    Jan  1 17:57:27  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  Invalid backup image version
    Jan  1 17:57:27  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  Get backup image info error
    Jan  1 18:14:34  cli[2521]: <341108> <ERRS> |AP colin_i274@10.75.156.83 cli|  sess_validate_sid: 179 invalid session client-10.75.56.3 sid-SVDcZJVgAT8ZmCZeEXjU.
    Jan  1 21:21:25  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  Invalid backup image version
    Jan  1 21:21:25  cli[2521]: <341004> <WARN> |AP colin_i274@10.75.156.83 cli|  Get backup image info error
    Jan  1 21:44:57  cli[2521]: <341097> <WARN> |AP colin_i274@10.75.156.83 cli|  recv_image_check: mac-9c:1c:12:cf:f5:d7, version-6.4.2.3-4.1.1.2_48114, ccode_idx-156.
    Jan  1 21:44:57  cli[2521]: <341165> <WARN> |AP colin_i274@10.75.156.83 cli|  send image match to 10.75.156.80.
    
    
    Jan  1 21:50:25  cli[2521]: <341108> <ERRS> |AP colin_i274@10.75.156.83 cli|  sess_validate_sid: 179 invalid session client-10.75.56.3 sid-Wg2dia11s6SBRUbpdxJb.


  • 7.  RE: one iap can't join VC

    Posted Mar 12, 2015 06:28 AM

    Hi Wang,

     

    To form a cluster the following point need to be ful filled,

     

    1. All IAPs should be in the same VLAN and should have IP address( DHCP or Static) from the same subnet

    2. All IAPs should have same Image version.

     

    In your case, are you satisfying above points ?

     

    As a work around, console the IAP 92 and observer the boot messages and confirm whether is able to get a valid IP and also receiving a Master beacon.

     

    Please feel free for any further help on this

     

     



  • 8.  RE: one iap can't join VC

    Posted Mar 13, 2015 04:13 AM

    Yes ,I think I got the reason. When I initial one iap and add to vlan ,it only could get ip address from 169 subnet which is diffirence from other ap.



  • 9.  RE: one iap can't join VC
    Best Answer

    Posted Mar 13, 2015 04:26 AM

    Hi Wang,

     

    I believe in your setup either there is no DHCP available or IAP not able to get IP , coz as you said, new IAP is getting IP from 169.254.X.X which is APIPA ( Default IP) IAP will not join with default IP hence you configure a static IP or configure a DHCP so that new IAP gets a valid IP ( same subnet as the VC) and join the cluster.

     

    Hope your issue is resolved,

     

    Please feel free to seek any further help on Aruba.



  • 10.  RE: one iap can't join VC

    Posted Mar 13, 2015 04:37 AM
    yes,and one kudous for you to support:)