Cloud Managed Networks

last person joined: yesterday 

Forum to discuss all things Aruba Central and UXI Network Management, this includes Aruba Central managed networks, Central configuration, best practices, Central APIs, Cloud Guest, AIOps, Presence Analytics and Other Central Applications
Expand all | Collapse all

Streaming API - no data received

This thread has been viewed 8 times
  • 1.  Streaming API - no data received

    Posted Jul 06, 2021 07:58 AM

    Hi,
    We are trying to build a monitoring tool using Central streaming.
    I was able to successfully follow the documentation and connect to the webhooks endpoint via websocket
    (Streaming API)

    However,
    1. Almost no data is coming, initially there is a single audit message right after opening connection and then, nothing, and I was waiting for hours.
    2. After starting the websocket client, turning it down and the again up, we are always getting the same audit message. Now, we were expecting to get streaming events and not the same data again and again. Seems like the topic is read always from the start, we need to be able to read it from the last place the client stopped.




    ------------------------------
    Evgeny Tsirkin
    ------------------------------


  • 2.  RE: Streaming API - no data received

    Posted Jul 16, 2021 03:43 AM
    Can you work with Aruba support on this? It's hard without knowing the API calls, code and purpose if it works or not. It could also be that the Streaming API might need to be enabled for your account (not sure if it still has, that was needed in the past).

    ------------------------------
    Herman Robers
    ------------------------
    If you have urgent issues, always contact your Aruba partner, distributor, or Aruba TAC Support. Check https://www.arubanetworks.com/support-services/contact-support/ for how to contact Aruba TAC. Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba Networks.

    In case your problem is solved, please invest the time to post a follow-up with the information on how you solved it. Others can benefit from that.
    ------------------------------