Wireless Access

last person joined: an hour ago 

Access network design for branch, remote, outdoor and campus locations with Aruba access points, and mobility controllers.
Expand all | Collapse all

Aruba 305 from 20 AP left 4 online

This thread has been viewed 5 times
  • 1.  Aruba 305 from 20 AP left 4 online

    Posted Jan 05, 2019 05:42 PM

    Good Day.

    I have following problem.

    20 PC Aruba 305 connected through POE to managed switch. Everything was working fine until I have disconnected one AP, after that I was not able to get back to cluster. For now, I have only 4 left keeping system live.

    Can somebody assist me in this matter...:(?

    I have attached log files which I was able to get from SSH “show log iap-bootup” and “show log system”. Also, config file.

    As I can see it, when I am connecting AP, for some reason in is not connecting back to the network. It assigns IP, but not getting in the cluster.

    Aruba 305

    6.5.1.0-4.3.1.0_57305

     

    Attachment(s)

    txt
    instant.txt   3 KB 1 version
    txt
    Boot.txt   7 KB 1 version
    txt
    2.txt   11 KB 1 version
    txt
    1.txt   18 KB 1 version
    txt
    Failed.txt   7 KB 1 version


  • 2.  RE: Aruba 305 from 20 AP left 4 online

    Posted Jan 06, 2019 05:32 AM

    Hi

     

    Are all AP's in the same vlan? I am seeing different IP subnets in your logs. 172.20.x.x and 192.168.x.x.

     

    Can you tell which AP's are working as the should be (IP addresses)?

     

    My idea to try to solve it would be to upgrade the software to a newer version. Your version 6.5.1.0-4.3.1.0 is the first version supporting the AP-305 and it is dated dec-2016. It would for now stick to 6.x version so upgrade to 6.5.4.10.

    You could also contact TAC for advise.

     

    Hope this helps.



  • 3.  RE: Aruba 305 from 20 AP left 4 online

    Posted May 10, 2019 03:38 AM

    Which solution? 

     

    Controller based or instant?

     

     



  • 4.  RE: Aruba 305 from 20 AP left 4 online

    Posted May 10, 2019 03:35 AM

    An AP will obtain its image from which ever controller it is connected to. So if you upgrade the controller, any attached APs will also be upgraded.



  • 5.  RE: Aruba 305 from 20 AP left 4 online

    Posted May 10, 2019 05:46 AM
    what is the current Aruba OS version ?

    --
    Best Regards,
    Minesh patel |


  • 6.  RE: Aruba 305 from 20 AP left 4 online

    Posted Jan 06, 2019 06:32 AM

    Main Network is 172.20.x.x.

    But let me explain, from where 192.168 appeared.

    So, I have two scenarios when I am connecting Aruba AP to network.

    1. I am just plug it in, it is powers up (it powers up with the main network connected). So as far I am understanding, that for some reason, AP is not getting settings from Master AP.

     

    Highlight from the log:

    [   18.923346] sps:Pipe 3 already allocated on BAM 0x08e04000
    [   18.982901] sps:Failed to allocate connection
    [   19.032922] sps:Fail to allocate resource for BAM 0x  (null) pipe 0.
    [   19.111007] QCE50: qce_sps_init_ep_conn: sps_connect() fail pipe_handle=0xdbca8a00, rc = -1
    [   19.211125] qcrypto: probe of 8e20000.qcrypto failed with error -1

    and

    Jan  1 08:00:46  KERNEL(20:a6:cd:c1:02:46@172.20.37.179): [    0.000000]

    Jan  1 08:00:46  KERNEL(20:a6:cd:c1:02:46@172.20.37.179): [    0.000000] Aruba Networks

    Jan  1 08:00:46  KERNEL(20:a6:cd:c1:02:46@172.20.37.179): [    0.000000] ArubaOS Version 6.5.1.0-4.3.1.0 (build 57305 / label #57305)

    Jan  1 08:00:46  KERNEL(20:a6:cd:c1:02:46@172.20.37.179): [    0.000000] Built by p4build@lemnos on 2016-11-14 at 01:13:48 PST (gcc version 4.6.3)

    Jan  1 08:00:46  KERNEL(20:a6:cd:c1:02:46@172.20.37.179): [   18.854420] bus_scale_table is NULL

    Jan  1 08:00:46  KERNEL(20:a6:cd:c1:02:46@172.20.37.179): [   18.889470] sps:Pipe 3 already allocated on BAM 0x08e04000

    Jan  1 08:00:46  KERNEL(20:a6:cd:c1:02:46@172.20.37.179): [   18.949267] sps:Failed to allocate connection

    Jan  1 08:00:46  KERNEL(20:a6:cd:c1:02:46@172.20.37.179): [   18.999259] sps:Fail to allocate resource for BAM 0x  (null) pipe 0.

    Jan  1 08:00:46  KERNEL(20:a6:cd:c1:02:46@172.20.37.179): [   19.077423] QCE50: qce_sps_init_ep_conn: sps_connect() fail pipe_handle=0xddf2c400, rc = -1

    Jan  1 08:00:46  syslog: <341005> <ERRS> |AP 20:a6:cd:c1:02:46: |  terminal access is enabled but sshd is not running, starting

    Jan  1 08:00:47  sapd[2165]: <311020> <ERRS> |AP 20:a6:cd:c1:02:46: |  An internal system error has occurred at file sapd_main.c function main line 3102 error Unable to initialize Factory Certificates or Field Certificates.

    Jan  1 08:00:49  nanny[2072]: <303022> <WARN> |AP 20:a6:cd:c1:02:46: |  Reboot Reason: AP rebooted caused by cold HW reset(power loss)

    Jan  1 08:00:58  cli[2148]: <341317> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  Regulatory table file init at version 1.0_57023, build Oct 25,2016.

    Jan  1 08:00:58  cli[2148]: <341004> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  Extended ssid enabled

    Jan  1 08:00:58  cli[2148]: <341207> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  AP support up to 16 SSID.

    Jan  1 08:00:58  cli[2148]: <341172> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  Find enet0 name bond0.

    Jan  1 08:00:59  cli[2148]: <341004> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  cli_choose_eth_uplink:eth current uplink set to DHCP

    Jan  1 08:00:59  cli[2148]: <341169> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  Add uplink Ethernet 0.

    Jan  1 08:00:59  cli[2148]: <341167> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  Uplink bond0 type Ethernet, state INIT->LOAD.

    Jan  1 08:00:59  cli[2148]: <341169> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  Add uplink Wifi-sta 6.

    Jan  1 08:00:59  cli[2148]: <341169> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  Add uplink 3G/4G 7.

    Jan  1 08:00:59  cli[2148]: <341167> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  Uplink  type Dummy, state INIT->LOAD.

    Jan  1 08:00:59  cli[2148]: <341004> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  receive sapd hello for process recovery

    Jan  1 08:00:59  nanny[2072]: <303074> <ERRS> |AP 20:a6:cd:c1:02:46@172.20.37.179 nanny|  Process /aruba/bin/radiusd [pid 2195] died: exited with 0x1

    Jan  1 08:00:59  nanny[2072]: <303079> <ERRS> |AP 20:a6:cd:c1:02:46@172.20.37.179 nanny|  Restarted process /aruba/bin/radiusd, new pid 2516

    Jan  1 08:01:00  cli[2148]: <341167> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  Uplink bond0 type Ethernet, state LOAD->PROBE.

    Jan  1 08:01:00  cli[2148]: <341265> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  enable ethernet uplink bond0.

    Jan  1 08:01:00  cli[2148]: <341004> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  the ethernet uplink inuse in first time, get ip address.

    Jan  1 08:01:00  cli[2148]: <341167> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  Uplink bond0 type Ethernet, state PROBE->UP.

    Jan  1 08:01:00  cli[2148]: <341185> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  Retrieving ip address from br0, ip 172.20.37.179, mask 255.255.254.0.

    Jan  1 08:01:00  cli[2148]: <341274> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  Update election ip from br0, election ip 172.20.37.179/255.255.254.0.

    Jan  1 08:01:00  cli[2148]: <341004> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  build_my_ip_address: old ip and new ip same; skipping

    Jan  1 08:01:00  cli[2148]: <341006> <CRIT> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  Sending uplink_up msg to sapd

    Jan  1 08:01:00  cli[2148]: <341006> <CRIT> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  trap uplink info.

    Jan  1 08:01:00  cli[2148]: <341004> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  last uplink is null, it's the first uplink, ignore this trap.

    Jan  1 08:01:00  cli[2148]: <341173> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  Current uplink set to Ethernet, state UP.

    Jan  1 08:01:00  cli[2148]: <341135> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  Master Changed - new 172.20.37.77 old 0.0.0.0 current swarm state 0.

    Jan  1 08:01:01  cli[2148]: <341135> <WARN> |AP 20:a6:cd:c1:02:46@172.20.37.179 cli|  Master Changed - new 172.20.37.77 old 0.0.0.0 current swarm state 1.

    Jan  1 08:01:19  nanny[2072]: <303073> <ERRS> |AP 20:a6:cd:c1:02:46@172.20.37.179 nanny|  Process /usr/sbin/dhcp-helper [pid 2684] died: got signal SIGTERM

    Jan  1 08:01:19  nanny[2072]: <303079> <ERRS> |AP 20:a6:cd:c1:02:46@172.20.37.179 nanny|  Restarted process /usr/sbin/dhcp-helper, new pid 2745

    Jan  1 08:01:29  nanny[2072]: <303073> <ERRS> |AP 20:a6:cd:c1:02:46@172.20.37.179 nanny|  Process /usr/sbin/dhcp-helper [pid 2745] died: got signal SIGTERM

     

    And following massage.

    Warning: CLI module is running in a degraded state.  Configuration, write memory                                                                              , and support command are disabled; please debug with caution.

     

    1. Second way I am trying another way. I power up AP without connecting to network, wait until it boots up and then trying to connect. In this case Master IP is kicked off from the network and then another AP becoming Master in existing network and in total I am getting "minus" one AP...:)

     

    Hope this clarifies... you support is appreciating very much...:)



  • 7.  RE: Aruba 305 from 20 AP left 4 online

    Posted May 10, 2019 03:11 AM

    How to check the that Aruba 305 working on which version ???

    How to update the firmware version ap ??



  • 8.  RE: Aruba 305 from 20 AP left 4 online

    Posted May 10, 2019 05:00 AM
    Controller based

    --
    Best Regards,
    Minesh patel | Network Engineer


  • 9.  RE: Aruba 305 from 20 AP left 4 online

    Posted Jan 06, 2019 06:40 AM

    Hi

     

    There could be something wrong with their build in certs.

     

    I would or contact TAC is you can (support and stuff)

     

    1. Upgrade the instant cluster to 6.5.4.10.

    2. factory reset one of the not working AP's and reconnect is to the main network. The instant cluster should upgrade it and push the config

    3. If that works continue with step 2 for the other not working AP's

     

    Hope this helps.

     

     



  • 10.  RE: Aruba 305 from 20 AP left 4 online

    Posted May 10, 2019 05:42 AM

    Then follow