Wired Intelligent Edge

last person joined: 9 hours ago 

Bring performance and reliability to your network with the Aruba Core, Aggregation, and Access layer switches. Discuss the latest features and functionality of the ArubaOS-Switch and ArubaOS-CX devices, and find ways to improve security across your network to bring together a mobile first solution.
Expand all | Collapse all

OSPF configuration and routing

This thread has been viewed 49 times
  • 1.  OSPF configuration and routing

    Posted Jul 18, 2021 05:32 PM
    Hello, 

    I know i need to add more info, but i am inherenting a few networks. They were built about 20 yrs ago and then all kinds of network gear was thrown on it. I had no diagrams or anything when i started, i think i have a good one now and a good idea of what im getting into…

    we are running ospf. We have it configured on an HPE 5900. I am much more familiar with Cisco and working in Aruba, but there is no other switch in the entire network with any kind of ospf config on it. From what i have been reading and from cisco, there should be router IDs and such?

    Also, the HPE 5900 is the main switch and thats where our backbone starts. The plan was to use a /29 subnet when they installed this equipment which gives a range of 6 IPs and they are trying to use them for the backbone switches (that was what they planned, not what happened) and another subnet for the switches coming off the backbone.

    Im trying to figure out where to start here. I have my diagram so i have a good idea of whats out there, but im not very familiar with Aruba routing yet. From what i know and read, i need to configure OSPF on other switches not just the main one right? There are lots of switches that are up and running, but i cannot ping or putty into them, i can only telnet from other switches… I think getting uplinks set up properly first is where i should start, but any help or suggestions would be great

    on a side note, i do have some cx series switches i am going to use to replace a chassis switch that is failing then i want to make the cx switches the main switch and branch out from there. So maybe i should just give up with what i am trying to do now and focus on reconfiguring all the routing? I kind of want to get things working properly first in case i need to get and replace anything else…

    ------------------------------
    rford1219
    ------------------------------


  • 2.  RE: OSPF configuration and routing

    Posted Jul 19, 2021 04:06 AM
    Hi, simple question: how many Routers are running in your internal network? if just one (your Layer 3 Switch acting as your "Core" for your internal VLANs) then the question is: why OSPF should be used at all?

    A network diagram of what you have and a network diagram of what you want (topologically speaking) would be of help in order to help you understanding in what direction you could move.

    ------------------------------
    Davide Poletto
    ------------------------------



  • 3.  RE: OSPF configuration and routing

    Posted Jul 19, 2021 10:53 PM
    Ok, give me a little bit and I will get one put together and post it.

    ------------------------------
    rford1219
    ------------------------------



  • 4.  RE: OSPF configuration and routing

    Posted Jul 24, 2021 04:11 PM
    After some long talks and thinking, I am going to start over with everything. I have 3 8320s I am going to use as my Core (I am going to with OSPF).

    I am going to configure it all and test it first before I deploy it, I currently have them configured just running OSPFv2. My Main switch (switch A) can ping both switch B and C. Switch C can ping Switch A (both IP addresses I am using, but not Switch B. Switch B can ping one IP on Switch A, but not the second or Switch C. Below are my configs ( I am sure it is something simple I am missing)...

    Switch B <--> Switch A <--> Switch C

    -----------------------------------------------------------------------------------------------------
    Switch B

    configure terminal
    interface loopback 0
    ip address 1.1.1.2/32
    exit

    interface 1/1/48
    description Switch B <--> Switch A
    routing
    ip address 192.168.5.0/31
    router ospf 1
    router-id 1.1.1.2
    area 0
    passive interface default
    exit
    interface loopback 0
    ip ospf 1 area 0
    exit
    int 1/1/48
    ip ospf 1 area 0
    ip ospf messagde-digest-key 1 md5 plaintext password
    ip ospf authentication message-digest
    no ip ospf passive
    ip ospf network point-to-point
    no shut
    exit
    wr mem
    -----------------------------------------------------------------------------------------------------

    Switch A
    config
    int l0
    ip add 1.1.1.1/32
    exit
    int 1/1/1
    descrition Switch A <--> Switch B
    routing
    ip address 192.168.5.1/31
    router ospf 1
    router-id 1.1.1.1
    passive-interface default
    area 0
    exit
    int l0
    ip ospf 1 area 0
    exit
    int 1/1/1
    ip ospf 1 area 0
    ip ospf message-digest-key 1 md5 plaintext password
    ip ospf 1 area 0.0.0.0
    no ip ospf passive
    ip ospf network point-to-point
    ip ospf authentication message-digest
    no shut

    int 1/1/48
    description Switch A <--> Switch C
    routing
    ip add 192.168.5.2/31
    ip ospf 1 area 0
    no ip ospf passive
    ip ospf network point-to-point
    ip ospf message-digest-key 1 md5 plaintext password
    ip ospf authentication message-digest

    -----------------------------------------------------------------------------------------------------
    Switch C

    configure terminal
    interface loopback 0
    ip address 1.1.1.3/32
    exit

    interface 1/1/1
    description Switch C <--> Switch A
    routing
    ip address 192.168.5.3/31
    router ospf 1
    router-id 1.1.1.3
    area 0
    passive interface default
    exit
    interface loopback 0
    ip ospf 1 area 0
    exit
    int 1/1/1
    ip ospf 1 area 0
    ip ospf messagde-digest-key 1 md5 plaintext password
    ip ospf authentication message-digest
    no ip ospf passive
    ip ospf network point-to-point
    no shut
    exit
    wr mem


    ------------------------------
    rford1219
    ------------------------------



  • 5.  RE: OSPF configuration and routing

    Posted Jul 27, 2021 05:44 AM
    Hello,

    I have copied your config into a lab and I can ping everyone.
    Your route table should have 6 routes on switches B and C, 7 routes on A :

    B# show ip route
    ---------------------------------------------------------------------------------------------------------
    1.1.1.1/32 192.168.5.1 1/1/1 - O [110/100] 00h:09m:40s
    1.1.1.2/32 - loopback0 - L [0/0] -
    1.1.1.3/32 192.168.5.1 1/1/1 - O [110/200] 00h:03m:30s
    192.168.5.0/31 - 1/1/1 - C [0/0] -
    192.168.5.0/32 - 1/1/1 - L [0/0] -
    192.168.5.2/31 192.168.5.1 1/1/1 - O [110/200] 00h:03m:39s



    ------------------------------
    Laurent from Brest / France
    Network Engineer
    ------------------------------



  • 6.  RE: OSPF configuration and routing

    Posted Jul 29, 2021 01:07 AM
    Thank you for the reply... I went back and zeroized everything and changed out all my cables then tried again and now I am good... I might have had some part of a config or might have fat fingered something, but I am able to talk to all of the devices now.

    ------------------------------
    Richard Ford
    ------------------------------



  • 7.  RE: OSPF configuration and routing

    Posted 21 days ago
      |   view attached
    Hello, so I have a question and I know it is probably a simple answer...

    The attached is a basic OSPF diagram of what I am trying to do (There are more devices, but basic idea).

    I have OSPF running between switch A, B and C, that is my Area 0.

    What is the best or preferred way to connect the 2930Fs to Area 0 (the 3 8320s)?

    Should I just untag/ tag on the VLANs or is there a better way to do this?