Comware

 View Only
  • 1.  Adding new VLAN to LACP link between HP A5800-48G and Cisco 3750 stack

    Posted Jul 27, 2016 11:31 AM

    Hello all,

     

    My name is Luke. I'm new to HP networking field, but have experience working with Cisco and Juniper gear.

    I was wondering if you could help me to establish proper way of allowing new VLAN over LACP link between HP and Cisco stack. Please see below for details:

    1. on HP end, I got the following production config:

    interface Bridge-Aggregation3
    port link-type trunk
    undo port trunk permit vlan 1
    port trunk permit vlan 30 to 31 60 70 80 900
    link-aggregation mode dynamic

    interface Ten-GigabitEthernet1/0/51
    port link-mode bridge
    port link-type trunk
    undo port trunk permit vlan 1
    port trunk permit vlan 30 to 31 60 70 80 900
    port link-aggregation group 3


    interface Ten-GigabitEthernet2/0/51
    port link-mode bridge
    port link-type trunk
    undo port trunk permit vlan 1
    port trunk permit vlan 30 to 31 60 70 80 900
    port link-aggregation group 3

    2. On Cisco end, I have the following:

    interface TenGigabitEthernet1/1/1
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 30 to 31 60 70 80 900
    switchport mode trunk
    switchport nonegotiate
    channel-protocol lacp
    channel-group 2 mode active


    interface TenGigabitEthernet2/1/1
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 30 to 31 60 70 80 900
    switchport mode trunk
    switchport nonegotiate
    channel-protocol lacp
    channel-group 2 mode active


    interface Port-channel2
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 30 to 31 60 70 80 900
    switchport mode trunk
    switchport nonegotiate

    This is production envirement. Now, i need to create a new VLAN and add allow it over the LACP link.

    Could you please advice how this should be handled on HP switch?

    My steps are as follows:

    1. HP end - create new VLAN and SVI

    system-view

    vlan 700

    interface Vlan-interface 700
    ip address 10.25.25.1 255.255.255.0

    Not sure how to add that VLAN to bridge aggregation? Is there a similar command to Cisco IOS:

    SWITCHPORT TRUNK ALLOWED VLAN ADD

    Also, does such change have impact on the bridge group itself?

     

    2. Cisco end is rather easy for me:

    (create new VLAN and add it to the port channel)

    config t

    vlan 700

    INTERFACE Port-channel2
    SWITCHPORT TRUNK ALLOWED VLAN ADD 700

    Any help is appreciated.

     

    Regards,

     

    luke



  • 2.  RE: Adding new VLAN to LACP link between HP A5800-48G and Cisco 3750 stack

    Posted Jul 27, 2016 08:06 PM

    You seem to be on the right track.

    Have you used this to refre to?
    http://networktest.com/hpiop/hpiopcookbook.pdf

     

     



  • 3.  RE: Adding new VLAN to LACP link between HP A5800-48G and Cisco 3750 stack

    Posted Jul 28, 2016 03:54 AM

    Hi

    If you want to add a vlan to an interface you just have to add it like this:

     port trunk permit vlan 700

    It will not overwrite the other vlans, it will simply be added. I dont think this will interrupt the link.

    When you are not sure, you can test it on a down link.

     

    Kind regards

     



  • 4.  RE: Adding new VLAN to LACP link between HP A5800-48G and Cisco 3750 stack

    Posted Jul 28, 2016 04:18 AM

    Since VLAN(s) and Bridge-Aggregation group have been yet defined, have you tried (port trunk permit vlan as per HP 5820X&5800 Switch Series Layer 2 - LAN Switching Command Reference R18xx manual) something like:

    <hpswitch> system-view
    [hpswitch] interface bridge-aggregation 3
    [hpswitch-Bridge-Aggregation3] port trunk permit vlan 30 31 60 70 80 700 900

    or just:

    <hpswitch> system-view
    [hpswitch] interface bridge-aggregation 3
    [hpswitch-Bridge-Aggregation3] port trunk permit vlan 700

    remembering that:

      • If you use the port trunk permit vlan command multiple times, the trunk port carries the set of VLANs specified by vlan-list in each execution.
      • The configuration made in Layer 2 aggregate interface view applies to the aggregate interface and its aggregation member ports (your Ten-GigabitEthernet1/0/51 and Ten-GigabitEthernet2/0/51).


  • 5.  RE: Adding new VLAN to LACP link between HP A5800-48G and Cisco 3750 stack

    Posted Jul 29, 2016 05:47 AM

    Thank you all for the support. Adding new VLAN to the trunk/LACP agg is as simple as mentioned above:

     

    port trunk permit vlan 700

    Indeed, the vlan will be added to the existing trunk with no impact on it.

    I can also confirm there's no impact on the bridge-agg/port channel. It remains stable...still I'd recommend making change within the maintenance window.

     

    Thanks again.

     

    luke



  • 6.  RE: Adding new VLAN to LACP link between HP A5800-48G and Cisco 3750 stack

    Posted Jul 24, 2019 10:29 AM

    Hi,

    How does this command know what trunk the VLAN should be added to?

    If i have trk1 configured on the switch and want to add vlan 100 to that trunk what command could I use?

    i.e 

    port trunk trk1 permitt vlan 100

    Im also confused on how to do the reverse, so add a trunk to an existing VLAN - is that the same thing?

    Thanks for your help,

    Andy

     


    #Trunk
    #LACP
    #VLAN