Wireless Access

 View Only
last person joined: 23 hours ago 

Access network design for branch, remote, outdoor, and campus locations with HPE Aruba Networking access points and mobility controllers.
Expand all | Collapse all

Airwave 8.3.0.1 > 8.3.0.3 aborted and cant upgrade

This thread has been viewed 39 times
  • 1.  Airwave 8.3.0.1 > 8.3.0.3 aborted and cant upgrade

    Posted 15 days ago

    hi 

    were trying to upgrade our Airwave VM from 8.3.0.1 to 8.3.0.3. we are upgrading it manually but it always seems to get aborted and doesnt want to upgrade.

    the server itself has sufficient disk space and release notes for 0.3 doesnt have anything dodgy or iffy written so i dont know why its not upgrading.

    the below is what i get when i go to upgrade it manaully via CLI

    ***Please Don't Interrupt. Upgrade in Progress***
    Upgrading AMP to version 8.3.0.3 from version 8.3.0.1...
    Detailed log will be written to /var/log/upgrade/AMP-8.3.0.3-upgrade.log
     
    STEP 1: Moving old version aside.
     
    STEP 2: Unpacking upgrade package.
     
    STEP 3: Checking for compatibility.
     
    STEP 4: Stopping AMP services.
     
    STEP 5: Installing upgrade.
    sh: stop_amp_services: command not found
    Stopping logging:
    Redirecting start to /bin/systemctl start auditd.service
            main::go() called at ./upgrade_postgres line 60
    make[3]: *** [Makefile:18: force_postgresql] Error 1
    make[3]: Leaving directory '/var/airwave/git/mercury/src'
    make[2]: *** [Makefile:79: localrepo_update] Error 2
    make[2]: Leaving directory '/var/airwave/git/mercury/src'
    make[1]: *** [Makefile:200: localrepo_update] Error 2
    make[1]: Leaving directory '/var/airwave/git/mercury'
    make: *** [Makefile:47: upgrade] Error 2
    make: Leaving directory '/var/airwave/git/mercury'
    sh: stop_amp_services: command not found

    has anyone come across similar error? any help is much appreciated!



  • 2.  RE: Airwave 8.3.0.1 > 8.3.0.3 aborted and cant upgrade

    Posted 13 days ago

    We have the exact same issue on the same upgrade path, waiting for TAC to fix a different issue on Airwave / CPPM relating to TACACS auth before i log this with them.

    STEP 5: Installing upgrade.
    sh: stop_amp_services: command not found
    Stopping logging:
    Redirecting start to /bin/systemctl start auditd.service
            main::go() called at ./upgrade_postgres line 60
    make[3]: *** [Makefile:18: force_postgresql] Error 1
    make[3]: Leaving directory '/var/airwave/git/mercury/src'
    make[2]: *** [Makefile:79: localrepo_update] Error 2
    make[2]: Leaving directory '/var/airwave/git/mercury/src'
    make[1]: *** [Makefile:200: localrepo_update] Error 2
    make[1]: Leaving directory '/var/airwave/git/mercury'
    make: *** [Makefile:47: upgrade] Error 2
    make: Leaving directory '/var/airwave/git/mercury'
    sh: stop_amp_services: command not found


    Upgrade aborted.
    Please contact Aruba Support at
    1-800-WiFi-LAN (US & Canada) or 1-408-754-1200 (International Toll) or http://www.hpe.com/networking/mynetworking
    Hit <enter> to continue




  • 3.  RE: Airwave 8.3.0.1 > 8.3.0.3 aborted and cant upgrade

    Posted 7 days ago

    When i spoke to TAC they said this isn't the only install failure they have seen from 8.3.0.1 to 8.3.0.3. They recommended the quickest way was to build a fresh 8.3.0.1 and restore. the Database. There is a new backup of the database as part of the upgrade process.

    As my environment is VMWARE and i was locked out of the CLI in both ampadmin and amprecovery, I had to build a Ubuntu VM and attach the Airwave Disk to the ubuntu device as a second disk. Then i could SCP the files I needed from the failed Airwave disk and restore them back to a fresh built 8.3.0.1 install from ISO.   You cant restore 8.3.0.1 database to 8.3.0.3 new install.

    And yes before anyone thinks it, I should have hit snapshot before i did the upgrade, it was a mistake, i wont do it again.

    Not sure whether this will be helpful to anyone or not, but it was the quickest way to fix my issue.




  • 4.  RE: Airwave 8.3.0.1 > 8.3.0.3 aborted and cant upgrade

    Posted 6 days ago

    Hello,

    Hit the same yesterday when trying to upgrade Airwave from 8.3.0.1 to 8.3.0.3.

    As I took a VM Snapshot before I could easily go back to a 8.3.0.1 running system then try to upgrade to 8.3.0.2 with same result !!!

    It is a pain that we cannot restore 8.3.0.1 backups directly to a newly build 8.3.0.3 :-(

    Does TAC say anything about a fix for this problem ?

    Will update thread after next week operation (rebuild 8.3.0.1 > restore > upgrade to 8.3.0.3)

    Kind regards

    Christian Chautems




  • 5.  RE: Airwave 8.3.0.1 > 8.3.0.3 aborted and cant upgrade

    Posted 6 days ago

    I had advice from TAC who said that upgrade to 8.3.0.3 directly was the likely cause and to try 8.3.0.2 first.  this worked in the end and then from 8.3.0.2 to 8.3.0.3 worked fine also, so for me it was just the direct upgrade that was the issue.

    Hope you get your issues sorted.




  • 6.  RE: Airwave 8.3.0.1 > 8.3.0.3 aborted and cant upgrade

    EMPLOYEE
    Posted 6 days ago

    I see some recent issues where upgrading to 8.3.0.3 fails, where reinstall/restore backup works, where sometimes reinstalling in BIOS mode (vs UEFI) works, in some cases adding some database tables resolved the issue.

    Let's assume TAC and Engineering are working on this, and can get a fix included in 8.3.0.4, but if people have issues with the upgrade please work with TAC.



    ------------------------------
    Herman Robers
    ------------------------
    If you have urgent issues, always contact your Aruba partner, distributor, or Aruba TAC Support. Check https://www.arubanetworks.com/support-services/contact-support/ for how to contact Aruba TAC. Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba Networks.

    In case your problem is solved, please invest the time to post a follow-up with the information on how you solved it. Others can benefit from that.
    ------------------------------



  • 7.  RE: Airwave 8.3.0.1 > 8.3.0.3 aborted and cant upgrade

    Posted yesterday

    I had the upgrade from 8.3.0.2 to 8.3.0.3 fail as well.

    TAC performed the upgrade in a support shell, and there the upgrade worked without additional modification. What was very noticable though is, that the upgrade took a very long time, significantly longer than any i did before. My suspicion would be a timeout issue, with the upgrade process failing once the session timeout for the ampadmin login hits.

    The support session seems to not have a timeout, so the upgrade worked.




  • 8.  RE: Airwave 8.3.0.1 > 8.3.0.3 aborted and cant upgrade

    Posted 13 hours ago
    Hello,
     
    This time upgrade successful but not that easy:
     
    1 - rebuild new VM on 8.3.0.1
     
    2 - restore backup
     
    3 - Snapshot VM
     
    4 - Try upgrade directly from newly rebuilded VM 8.3.0.1 > 8.3.0.3 FAILED !!!
     
         ***Please Don't Interrupt. Upgrade in Progress***
         Upgrading AMP to version 8.3.0.3 from version 8.3.0.1...
         Detailed log will be written to /var/log/upgrade/AMP-8.3.0.3-upgrade.log
         
         STEP 1: Moving old version aside.
         
         STEP 2: Unpacking upgrade package.
         
         STEP 3: Checking for compatibility.
         
         STEP 4: Stopping AMP services.
         
         STEP 5: Installing upgrade.
         sh: stop_amp_services: command not found
         Stopping logging: 
         Redirecting start to /bin/systemctl start auditd.service
         Error opening /root/git/mercury/src/repo/rhel8/aw-perl-libapreq2-2.13-510.el7.x86_64.rpm: No such file or directory
         Package "aw-perl-libapreq2-2.13-510.el7.x86_64" from local repository "airwave" has incorrect checksum
         Error: Some packages from local repository have incorrect checksum
         make[2]: *** [Makefile:132: do_repo_update] Error 1
         make[2]: Leaving directory '/var/airwave/git/mercury/src'
         make[1]: *** [Makefile:200: localrepo_update] Error 2
         make[1]: Leaving directory '/var/airwave/git/mercury'
         make: *** [Makefile:47: upgrade] Error 2
         make: Leaving directory '/var/airwave/git/mercury'
         sh: stop_amp_services: command not found
         
         Upgrade aborted.
     
     
    5 - Revert to Snapshot before upgrade
     
    6 - Upgrade newly rebuilded VM from 8.3.0.1 > 8.3.0.2   OK
     
    7 - Upgrade from 8.3.0.2 > 8.3.0.3   OK
     
    Please note that phases 6 & 7 were executed from the VMware Console NOT via SSH


    Kind regards

    Christian Chautems