Wireless Access

 View Only
last person joined: 11 hours ago 

Access network design for branch, remote, outdoor, and campus locations with HPE Aruba Networking access points and mobility controllers.
Expand all | Collapse all

Help Troubleshooting AP 325 constant rebootstap

This thread has been viewed 32 times
  • 1.  Help Troubleshooting AP 325 constant rebootstap

    Posted Oct 12, 2021 11:55 AM
    I have built a home lab to test out clustering and have a mixture of physical and virtual appliances, I have an AP 325 which was working when used just with the 7002 in standalone, but now I am unable to get past the provisioning stage. I am trying to troubleshoot and can figure out why its not working. 

    LAB Environment

    VMCr - 8.9
    Managed Network
             7005 - Version
             VMC 1 - Version
             VMC 2 - Version

    AP is a AP-325 (pervious working in standalone)

    Console on the AP has 

    Running ADP...Done. Master is
    [ 60.574258] Initializing Pktlogs for 11ac
    [ 60.574289] Initializing Pktlogs for 11ac
    AP rebooted Wed Dec 31 16:01:49 PST 1969; SAPD: Reboot after image upgrade failed: 65280
    shutting down watchdog process (nanny will restart it)...

    <<<<< Welcome to the Access Point >>>>>

    ~ # [ 66.106747] Kernel watchdog refresh ended on core 1.
    [ 66.113027] Kernel watchdog refresh ended on core 0.
    The system is going down NOW !!
    Sending SIGTERM to all processes.
    Please stand by while rebooting the system.
    [ 118.937706] Restarting system.
    [ 118.961699] Going down for restart now

    (VMM-01-LAB) [mynode] #show switches

    All Switches
    IP Address IPv6 Address Name Location Type Model Version Status Configuration State Config Sync Time (sec) Config ID
    ---------- ------------ ---- -------- ---- ----- ------- ------ ------------------- ---------------------- --------- None VMM-01-LAB Building1.floor1 conductor ArubaMM-VA up UPDATE SUCCESSFUL 0 46 None VMC-01-LAB Building1.floor1 MD ArubaMC-VA up UPDATE SUCCESSFUL 0 46 None VMC-02-LAB Building1.floor1 MD ArubaMC-VA up UPDATE SUCCESSFUL 0 46 None WLC-01-LAB Building1.floor1 MD Aruba7005 up UPDATE SUCCESSFUL 0 46

    VMM-01-LAB) [mynode] #show ap database long

    AP Database
    Name Group AP Type IP Address Status Flags Switch IP Standby IP Wired MAC Address Serial # Port FQLN Outer IP User
    ---- ----- ------- ---------- ------ ----- --------- ---------- ----------------- -------- ---- ---- -------- ----
    f0:5c:19:cb:53:64 default 325 Down f0:5c:19:cb:53:64 CNBJHN70BF N/A N/A

    I have checked power (it was working with this switch before) - drawing 7w as expected
    AP is getting a DHCP IP address

    The firmware was on 8.9 but I have reverted to the original firmware to troubleshoot. 
    I have also factory reset the AP, but it make no difference. 
    I've tried factory reset the AP.

    What can i do to find out what the issue is. 

    Andrew Partridge

  • 2.  RE: Help Troubleshooting AP 325 constant rebootstap

    Posted Oct 13, 2021 06:01 AM
    What is the current version on the AP (after the factory reset)? You can see that at the beginning of the console log. The AP325 (and some other APs) can have issues making a really big step, like 6.x to 8.4+, and a workaround is to bring up a controller on 8.3 and upgrade to 8.3 first, then make the jump up.

    Not fully sure if this is the case, as you came from 8.7 on the 7005. Please work with Aruba Support if the current firmware on the AP is already higher than 8.3.

    Herman Robers
    If you have urgent issues, always contact your Aruba partner, distributor, or Aruba TAC Support. Check https://www.arubanetworks.com/support-services/contact-support/ for how to contact Aruba TAC. Any opinions expressed here are solely my own and not necessarily that of Hewlett Packard Enterprise or Aruba Networks.

    In case your problem is solved, please invest the time to post a follow-up with the information on how you solved it. Others can benefit from that.

  • 3.  RE: Help Troubleshooting AP 325 constant rebootstap

    Posted Oct 13, 2021 09:10 AM
    So I carried on troubleshooting (my post was delayed for 24 hours as a newbie) and looked a little more into 

    AP rebooted Wed Dec 31 16:01:49 PST 1969; SAPD: Reboot after image upgrade failed: 65280

    When I viewed the images on the AP the First partition was empty and the secondary had 6.4

    I issues the command to boot from tftp and because the conductor IP address was in the settings (found via ADP), it downloaded and installed the image before booting correctly.

    So its all fixed with a tftpboot

    Andrew Partridge

  • 4.  RE: Help Troubleshooting AP 325 constant rebootstap

    Posted Sep 21, 2023 11:01 AM
      |   view attached

    Hello All,

    I don't know if my issue is related to your AP issue or not.

    However, I face a problem in Ap-325 which is continuously reloading again and again, even after doing the factory reset and assigning a Correct AP name, Master Controller Ip & AP group. Ip it will take automatically from DHCP.

    Then I logged a case with Aruba and they told me there was one Bug in the Ap-325 model. I have attached the advisory from Aruba.

    Now we take the console and change the AP boot partition from 0 to 1 for quick boot since partition 0 was the IAP firmware version.

    • on New AP  default firmware version will be 6.4 or 6.5 and the current controller version is 8.6. 
    • So the AP did not download the new image due to AP image space constraints. 
    • So suggested to upgrade to or as per Aruba advisory for 325 series Aps (shared advisory over attachment) then upgrade to 8.10 or higher to avoid losing 325Aps from the network.

    If not then,

    The command I used to manually push the OS from the Controller is.

    apboot> setenv group XXXX

    apboot> setenv name XXXX

    apboot> setenv master X.X.X.X

    apboot> saveenv

    used to boot from the Controller on different partitions. 

    apboot>  upgrade os 1 (Controler Master ip):ipq806x 

    apboot> saveenv

    apboot> setenv os_partition 1
    apboot> saveenv

    apboot> boot

    after that, it reloads 2 or 3 times and then stable.

            <<<<<       Welcome to the Access Point     >>>>>

    ~ #