Wired Intelligent Edge

 View Only
  • 1.  No Switchport - HP Equivalent

    Posted Aug 29, 2017 11:22 AM

    Hi,

    I am trying to convert a Cisco 1900 router config into a working config for a HP 2920. 

    We have Site A Router 192.168.104.25  and Site B Router 192.9.200.25 connected via P2P Fibre Link on 192.168.1.1 and 192.168.1.2. The customer would like to remove the routers and implement a Layer 3 stack. 

    The issue I am having is configuring multiple interfaces to act as gateways. On Cisco L3 I just run no switchport, assign an IP and it works but I cannot seem to figure out the HP Way.

    Any assistance on setting the ip address for each gateway please?

    Thanks in advance

     

    interface GigabitEthernet0/0
     ip address 192.168.118.254 255.255.255.0 secondary
     ip address 192.9.200.25 255.255.254.0
     ip virtual-reassembly in
     duplex auto
     speed auto
     no cdp enable
     no mop enabled
    !
    interface GigabitEthernet0/1
     ip address 192.1.1.2 255.255.255.0
     ip virtual-reassembly in
     duplex auto
     speed auto
     no cdp enable
     no mop enabled
    !
    router ospf 10
     network 192.168.118.0 0.0.0.255 area 0
    !
    ip forward-protocol nd
    !
    ip http server
    ip http secure-server
    !
    ip route 0.0.0.0 0.0.0.0 192.9.200.20
    ip route 192.9.200.0 255.255.254.0 192.1.1.1
    ip route 192.168.101.0 255.255.255.0 192.1.1.1
    ip route 192.168.102.0 255.255.255.0 192.9.200.201
    ip route 192.168.104.0 255.255.254.0 192.1.1.1
    ip route 192.168.108.0 255.255.255.0 192.9.200.104
    ip route 192.168.117.0 255.255.255.0 192.1.1.1
    ip route 192.168.118.0 255.255.255.0 192.168.118.1
    interface GigabitEthernet0/0
     description $ETH-LAN$
     ip address 192.168.104.25 255.255.254.0
     ip virtual-reassembly
     duplex auto
     speed auto
     no cdp enable
     no mop enabled
    !
    interface GigabitEthernet0/1
     description $ETH-WAN$
     ip address 192.1.1.1 255.255.255.0
     ip virtual-reassembly
     duplex auto
     speed auto
     no cdp enable
     no mop enabled
    
    !
    router ospf 10
     log-adjacency-changes
     network 192.168.117.0 0.0.0.255 area 0
    !
    ip forward-protocol nd
    !
    ip http server
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    ip route 0.0.0.0 0.0.0.0 192.1.1.2
    ip route 192.168.101.0 255.255.255.0 192.168.104.27
    ip route 192.168.117.0 255.255.255.0 192.168.104.27

     



  • 2.  RE: No Switchport - HP Equivalent

    Posted Sep 01, 2017 12:44 PM

    You can assign the IP addresses to VLAN interfaces, which you then untag on the different physical interfaces. You then have to enable routing and configure ospf.

    F.e. the physical interface on your Cisco G0/0 with 192.168.118.254 /24 would turn into something like the following for the interface 1 (no guarantee it is all correct ;D )

    vlan 200
    ip address 192.168.118.254 255.255.255.0
    untagged g1
    exit
    
    router ospf
    enable
    area 0
    vlan 200
    ip ospf area 0
    exit
    router ospf
    redistribute connected

     

    There is also a handy cheating sheet for HP and Cisco:

    https://h20565.www2.hpe.com/hpsc/doc/public/display?sp4ts.oid=4177453&docLocale=en_US&docId=emr_na-c04793912